Autor Wątek:  MaSzyna 20.01 - problemy  (Przeczytany 72708 razy)

0 użytkowników i 2 Gości przegląda ten wątek.

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 10106
    • Zobacz profil
  • Otrzymane polubienia: 2592
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #240 dnia: 07 Lutego 2020, 11:22:10 »
Albo ktoś przeniesie na nowsze rozwiązania, albo kiedyś wylecą, tak jak stare całkowa. Stary Bałtyk i stara l053 są trzymane w sumie tylko z myślą o słabych komputerach, którym transkeiowe scenariusze nie wydolą z nawałą taboru.
Mój kanał youtube

Offline AIR

  • Deweloper
  • Wiadomości: 646
    • Zobacz profil
  • Otrzymane polubienia: 497
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #241 dnia: 07 Lutego 2020, 12:28:37 »
Mam problem z wyświetlaniem się niektórych tekstur budynków w rejonie Częstochowy Osobowej i Stradom. Czy tak jest tylko u mnie czy jest to po prostu na etapie rozwojowym?

Przekroczona waga załącznika
Matek123


Zał. usunięty.
@MaciejM
« Ostatnia zmiana: 13 Lutego 2020, 22:28:12 wysłana przez MaciejM »
Niebo jest Bogiem, a skoki nałogiem...->
http://www.youtube.com/watch?v=nE9G-qiZqSU

Offline Miłosz Dorsz

  • Wydział Repozytorium
  • Wiadomości: 1146
    • Zobacz profil
  • Otrzymane polubienia: 2873
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #242 dnia: 07 Lutego 2020, 12:34:51 »
Tak jest u wszystkich, nie ma zrobionych tekstur dla tych budynków.
Aktualne projekty: KLIK

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 10106
    • Zobacz profil
  • Otrzymane polubienia: 2592
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #243 dnia: 07 Lutego 2020, 12:43:01 »
Domy w mieście są automatycznie generowane z danych numerycznych, przez co nie posiadają mapowania o teksturach nie wspominając.
Na dworzec mam komplet obrobionych zdjęć, ale z braku czasu leży od lat. Jakby ktoś chciał przejąć, chętnie oddam wraz z całością praw majątkowych.
Mój kanał youtube

Offline Paweł Grzejszczak

  • Wiadomości: 29
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #244 dnia: 09 Lutego 2020, 21:04:03 »
Witam, mam taki o to komunikat (instalowałem symulatora 3x i nie pomogło)

Mo być rozumisz

Offline rysiekchaszcz

  • Wiadomości: 57
    • Zobacz profil
    • Galeria Miłośników Fotografii Kolejowej
  • Otrzymane polubienia: 20
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #245 dnia: 15 Lutego 2020, 20:25:36 »
Sciągnełem MaSzyna2001.zip ma 4,129 Gb i niestety nie mozna otworzyć folderu żeby zainstalować. Komunikat : "Błąd w pliku archiwum *******\Maszyna2001.zip"  Może jak coś udostępniacie to niech to będzie dostępne. Ja akurat płacę za każdy bajt przesyłanych danych i jestem w dupie.

Offline Siecool

  • Deweloper
  • Wiadomości: 973
    • Zobacz profil
  • Otrzymane polubienia: 227
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #246 dnia: 15 Lutego 2020, 20:48:53 »
Czy SU45 ma zaimplementowany podgrzewacz wody? Naciskam SHIFT+W i nie dzieje się nic, w SU46 działa. Wygląda na to, że nie idzie uruchomić zimnej SU45.

Offline Joachimowicz

  • ZbanowanyZbanowany
  • Zasłużony dla Symulatora
  • Wiadomości: 1598
  • Nazywam się N'Avoie
    • Zobacz profil
  • Otrzymane polubienia: 1678
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #247 dnia: 15 Lutego 2020, 21:02:07 »
Otwórz zakładkę vehicles w panelu pod F12. Żeby załączyć podgrzewacz wody, trzeba najpierw załączyć pompę wody. W przeciwnym razie podgrzewacz się przepali i nie będzie działał.
| Z maszyną od 20 Kwietnia 2010! |

Offline Siecool

  • Deweloper
  • Wiadomości: 973
    • Zobacz profil
  • Otrzymane polubienia: 227
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #248 dnia: 15 Lutego 2020, 21:14:31 »
Pompa wody jest włączona, zakładkę mam uruchomioną. Po naciśnięciu SHIFT+W w SU46 pojawia się "H" w panelu urządzeń i temperatura wody zaczyna rosnąć, w SU45 w tych samych warunkach nie dzieje się absolutnie nic. Stąd moje podejrzenie, że coś jest sknocone w charakterystykach.

Offline Joachimowicz

  • ZbanowanyZbanowany
  • Zasłużony dla Symulatora
  • Wiadomości: 1598
  • Nazywam się N'Avoie
    • Zobacz profil
  • Otrzymane polubienia: 1678
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #249 dnia: 15 Lutego 2020, 21:32:39 »
Zarówno na paczce 20_01 jak i svn wszystko działa prawidłowo. Pokaż log.
| Z maszyną od 20 Kwietnia 2010! |

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 10106
    • Zobacz profil
  • Otrzymane polubienia: 2592
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #250 dnia: 15 Lutego 2020, 21:37:01 »
Nie ma wklepanego termostatu grzałki, ale sama grzałka działa, jak Joachimowicz mówi. Zachęcam do uzupełniania fizyk. Dostęp do svn masz.
Mój kanał youtube

Offline Siecool

  • Deweloper
  • Wiadomości: 973
    • Zobacz profil
  • Otrzymane polubienia: 227
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #251 dnia: 15 Lutego 2020, 23:28:42 »
OK, zwracam honor. Prawdopodobnie włączałem w odwrotnej kolejności - najpierw podgrzewacz, a potem pompę, co sprawiało niedziałanie podgrzewacza - tak jak pisał Joachimowicz. Jak się za pierwszym razem źle wciśnie to potem już się nie da tego odkręcić.

A teraz z innej beczki - czy ktoś ma podobny problem, że poświata świateł nie jest zakrywana przez teren lub inne pojazdy? Przykłady w załącznikach.

Offline KrisMK

  • Wydział Promocji
  • Wiadomości: 12
    • Zobacz profil
  • Otrzymane polubienia: 24
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #252 dnia: 16 Lutego 2020, 23:50:51 »
Traxx spalinowy - nie działa ekran

Offline Miłosz Dorsz

  • Wydział Repozytorium
  • Wiadomości: 1146
    • Zobacz profil
  • Otrzymane polubienia: 2873
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #253 dnia: 16 Lutego 2020, 23:51:46 »
0 na klawiaturze nienumerycznej ponoc pomaga.
Aktualne projekty: KLIK

Offline AntoniS

  • Wiadomości: 79
    • Zobacz profil
  • Otrzymane polubienia: 10
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #254 dnia: 17 Lutego 2020, 19:23:35 »
Wyprobuj moze taki zestaw wpisow:
gfxrenderer simple
maxtexturesize 512
maxcabtexturesize 1024
Część scenariuszy takich jak nowsze l053 mogą i tak mieć problem z wersja 32-bitowa -- różnorodność użytego tam taboru prowadzi do zużycia pamięci na poziomie 6-8 GB czyli grubo powyżej tego, co może zaadresować 32-bitowy Windows.

Przepraszam, że powracam do tematu, który w tej dyskusji zszedł już trochę na bok, jednak problem cały czas mnie dręczy - praktycznie 97,5% :-) uruchomień kończy się zakończeniem zaraz po załadowaniu misji i przystąpieniu do uruchamiania lokomotywy. Problem zawsze ten sam tzn.: "...memory bad allocation". Ustawienie simple niestety nic nie zmienia (w zużyciu pamięci widocznym w menedżerze zadań. Wczoraj natomiast, gdy włączyłem plik stronicowania pamięci na dysku, na którym mam maszynę (na systemowym mam włączone cały czas w zakresie 4000-6000 MB) z zakresem 16-2705 MB raz, czy dwa razy z rzędu udało mi się uruchomić i mnie nie wywaliło (sam po chwili zakończyłem symulację) przy czym menedżer zadań pokazał ponad 3,6 GB przydzielonej pamięci i jednocześnie określił jako ok. 50% zajętości (zwykle po uruchomieniu symulacji jest przydzielone między 3,1-3,4 GB, symulacja się zawiesza i kończy w/wym. błędem, a poziom zajętości pamięci menedżer zadań pokazuje w granicach 80-90%... Niestety, gdy następnie zmieniłem ustawienia rozmiaru na 2048 - 2048 problem powrócił, podobnie i nawet po ustawieniu opcji, by system sam decydował o wielkości pliku stronicowania nic nie pomaga. W związku z powyższym mam kilka pytań i bardzo proszę o odpowiedź oraz pomoc tych, którzy się bardziej na tym znają ode mnie, otóż:
1. Czy zakładając, że systemowe 4GB fizycznie zainstalowanego RAMu jest za mało, to system ładując/wykonując symulację nie powinien skorzystać z pliku stronicowania?
2. Jak ewentualnie go do tego zmusić lub co może być nie tak, że przeważnie tak się nie dzieje?
3. Czy rzeczywiście jedyny możliwy sposób rozwiązania tego problemu, to przejście na system 64bit-owy, czyli wymiana komputera (w obecnym musiałbym co najmniej wymienić procesor i dokupić pamięci RAM, czy coś jeszcze?).

Powiem szczerze nie bardzo rozumiem, czemu raz (choć rzadko) działa, a raz nie. Robiłem windowsowy test pamięci, ale nic nie wykazał. Będę wdzięczny za jakąś pomocną informację lub poradę. Szczerze mówiąc to wymiany sprzętu wolałbym raczej uniknąć, bo choć obecny nie jest może super, ale też nie jest jakiś tragiczny wydaje mi się. Dodam, że FPS-y mam po uruchomieniu rzędu 20-30, gfxrenderer legacy (stawienie na simple nic nie zmienia), a testowany scenariusz to l053_noc. W razie potrzeby oczywiście służę logiem i errorem. Pamięć vRam na karcie graficznej to bodajże 1 GB.
« Ostatnia zmiana: 17 Lutego 2020, 19:25:38 wysłana przez AntoniS »
Pozdrawiam,

Antoni Ślebodziński

Offline AntoniS

  • Wiadomości: 79
    • Zobacz profil
  • Otrzymane polubienia: 10
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #255 dnia: 17 Lutego 2020, 22:05:30 »
Jeszcze jedno: czy możliwe jest, że coś w plikach maszyny albo innych zasobach, z których korzysta się przestawiło/przestało działać? Pytam, bo obecnie uruchomiłem symulację na "pustym" tj. świeżo uruchomionym systemie, zużycie pamięci RAM na poziomie 2,66 GB (po za ładowaniu symulacji), tj. 65% wykorzystania pamięci fizycznej, z czego zadeklarowane przez eu07 - ok. 1,6 GB  efekt jak wcześniej tj. wywalenie symulacji nie długo po starcie. W załączeniu log, error, ustawienia oraz screen z menedżera zadań (po załadowaniu symulacji, gdy jeszcze działała - tuż przed wywaleniem...)? Szczerze mówiąc nic już z tego nie rozumiem...

Innymi słówy, czy jest sens ponownie instalować maszynę, czy tylko przeinstalować któreś pliki, czy w ogóle to nie tu jest problem?

Usuwam załączony screen - masa zbędnego białego miejsca. Do robienia screenów zamiast Painta użyj lepiej narzędzia wycinania, w Win10 jest pod skrótem klawiszowym WIN+Shift+S i wytnij tylko potrzebne informacje.
« Ostatnia zmiana: 01 Marca 2020, 17:59:28 wysłana przez adsim »
Pozdrawiam,

Antoni Ślebodziński

Offline AntoniS

  • Wiadomości: 79
    • Zobacz profil
  • Otrzymane polubienia: 10
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #256 dnia: 17 Lutego 2020, 23:11:55 »
Jeszcze w załączeniu okno informacyjne z Windowsa z zamknięciu eu07 - problem dotyczy ucrtbase.dll.
Pozdrawiam,

Antoni Ślebodziński

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #257 dnia: 21 Lutego 2020, 04:38:53 »
1. Czy zakładając, że systemowe 4GB fizycznie zainstalowanego RAMu jest za mało, to system ładując/wykonując symulację nie powinien skorzystać z pliku stronicowania?
(..)
3. Czy rzeczywiście jedyny możliwy sposób rozwiązania tego problemu, to przejście na system 64bit-owy, czyli wymiana komputera (w obecnym musiałbym co najmniej wymienić procesor i dokupić pamięci RAM, czy coś jeszcze?).
W przypadku systemu 32-bitowego maksymalny rozmiar obszaru pamieci jaki moze otrzymac pojedynczy program to 2-3 GB (symulator uzywa ustawienia pozwalajacego na skorzystanie z 3 GB). Plik pamieci wirtualnej nie umozliwi przekroczenia tego limitu, jest to cos z czym poradzi sobie tylko system 64-bit.

Przy takiej ilosci pamieci dla symulatora obawiam sie moze sie on faktycznie wywalic przy "byle czym". Potencjalnie mozna sprobowac jeszcze ustawienia w ini przelacznika
gfx.resource.move no
ktory moze ograniczyc nieco ilosc pamieci zuzywanej na przechowywanie danych tekstur, ale nie kazda karta graficzna/sterowniki potrafia ten tryb obsluzyc.

edit: jako ciekawostka, wspomniany scenariusz l053_noc zajmuje na ustawieniach domyslnych swiezo po zaladowaniu ~3.3 GB, a rozmiar uzytych w nim tekstur to ~1.6 GB
« Ostatnia zmiana: 21 Lutego 2020, 04:48:57 wysłana przez tmj »

Offline AntoniS

  • Wiadomości: 79
    • Zobacz profil
  • Otrzymane polubienia: 10
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #258 dnia: 23 Lutego 2020, 00:23:53 »
Dzięki za informację - spróbuję z tym move jeszcze. Co do ilości pamięci, to wg menedżera zadań eu07.exe z załadowaną scenerią l053_noc zajmuje ok. 1,6 GB pamięci, także nie przekraczam tutaj żadnych limitów. Mało tego według menedżera zadań zajętość pamięci jest na poziomie ok. 75% a symulator kończy przedwcześnie swoje działanie z komunikatami, jak opisywałem wcześniej - i tego za bardzo nie mogę zrozumieć. Bo gdybym miał 1005 zajętej pamięci i symulacja zostałaby przerwana przy próbie zapisu jakiejś kolejnej rzeczy w pamięci, to ok. rozumiem - brakło miejsca, ale tak, to albo informacje pokazywane w menedżerze zadań nie są rzeczywiste, albo coś jeszcze jest nie tak. A co do pliku stronicowania, to zawsze wydawało mi się, że właśnie służy on temu, by umożliwić pracę systemu i innych programów w momencie, gdy w pamięci fizycznej brakuje dla nich miejsca. Czy z tego co napisałeś wynika, że jeżeli mam system 32-bit i 4 GB RAMu, to włączenie stronicowania pamięci RAM na dysku nie ma sensu, bo i tak system tego zasobu nie użyje?

W między czasie doszedłem do tego, że w dużej mierze problemy powodowało podanie w pliku ini większej rozdzielczości obrazu niż ustawiona jednocześnie maksymalna możliwa rozdzielczość monitora - po skorygowaniu tego wpisu symulator zaczął o wiele lepiej na tej scenerii działać, jednak nadal maksymalnie, co pozwala na jego używanie to rozmiar tekstur zmniejszony do 256 a tekstur kabiny do 1024.
Pozdrawiam,

Antoni Ślebodziński

Offline Michal1983

  • Wiadomości: 66
    • Zobacz profil
  • Otrzymane polubienia: 1
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #259 dnia: 07 Marca 2020, 22:19:58 »
Rainsted 20.2.148.15459
EU07 20.120.64.0
Lenovo ThinkPad X240 i5-4300U 8GB
Ogólnie wszystkie scenerie działają wolniej niż w poprzedniej wersji. Chciałem się przejechać po scenerii Jawor. Niestety po chwili od uruchomienia symulacji zawiesza się ona.
« Ostatnia zmiana: 07 Marca 2020, 22:24:40 wysłana przez Michal1983 »
Używam Rainsted 17.2.124.12566

Offline Turbokibel

  • Wydział Repozytorium
  • Wiadomości: 1472
    • Zobacz profil
  • Otrzymane polubienia: 1197
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #260 dnia: 07 Marca 2020, 22:22:41 »
Zapewne to jest problemem: Gfx Renderer: Intel(R) HD Graphics 4400 nie ma ten laptop może jakiegoś GTXa lub Radeona?
Edit: sprawdziłem, nie ma, więc na gfxrendererze ustawionym na full raczej nie pojedziesz, ustaw na legacy, powinien ruszyć.
« Ostatnia zmiana: 07 Marca 2020, 22:25:19 wysłana przez Turbokibel »

Offline Michal1983

  • Wiadomości: 66
    • Zobacz profil
  • Otrzymane polubienia: 1
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #261 dnia: 07 Marca 2020, 22:28:09 »
na gfxrendererze ustawionym na full raczej nie pojedziesz, ustaw na legacy, powinien ruszyć.
Gdzie to ustawienie się znajduje?
Używam Rainsted 17.2.124.12566

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 10106
    • Zobacz profil
  • Otrzymane polubienia: 2592
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #262 dnia: 07 Marca 2020, 22:30:13 »
W eu07.ini masz wszystkie ustawienia wraz z opisem. Próba odpalenia gry na wysokich detalach na notebooku to średnio dobry pomysł tak ogólnie. Może większość współczesnych diagnozuje sprzęt i sama skręca się do niskich, ale dobrym nawykiem jest przejrzeć opcje i samemu zmniejszyć w przypadku problemów.
W dalszej kolejności zmniejszaj:
-antyaliasing (suwak w starterze)
-jakość cieni
-jakość tekstur

Wysyp spowodowany jest przeładowaniem pamięci. Serio masz 8GB ramu i połowa nie jest zajęta procesami w tle?
« Ostatnia zmiana: 07 Marca 2020, 22:32:01 wysłana przez Stele »
Mój kanał youtube

Offline Michal1983

  • Wiadomości: 66
    • Zobacz profil
  • Otrzymane polubienia: 1
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #263 dnia: 07 Marca 2020, 22:51:26 »
Podczas uruchomionej symulacji:
Procesor graficzny 97%
RAM zajęty 5,3 GB / 7,7 GB
CPU 1,8 GHz
Mam prosty Panel sterowniczy grafiki HD intel.
Używam Rainsted 17.2.124.12566

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 10106
    • Zobacz profil
  • Otrzymane polubienia: 2592
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #264 dnia: 07 Marca 2020, 23:23:36 »
No to niby ramu mu trochę zostało. Czytam, że ten układ alokuje domyślnie 128MB ramu na vram i da się to podkręcić do 512MB. Musisz już sam doczytać w jaki sposób. Może mu mało na pojedynczy bufor.
Mój kanał youtube

Offline Michal1983

  • Wiadomości: 66
    • Zobacz profil
  • Otrzymane polubienia: 1
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #265 dnia: 08 Marca 2020, 14:03:40 »
Zmieniłem rozmiar pamięci graficznej w BIOS z 256 na 512 MB, ale bez zmian.
Używam Rainsted 17.2.124.12566

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 10106
    • Zobacz profil
  • Otrzymane polubienia: 2592
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #266 dnia: 08 Marca 2020, 14:36:57 »
No to skręcaj detale zgodnie z podaną kolejnością i sprawdzaj stan.
Mój kanał youtube

Offline Siecool

  • Deweloper
  • Wiadomości: 973
    • Zobacz profil
  • Otrzymane polubienia: 227
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #267 dnia: 08 Marca 2020, 19:01:29 »
Wagon slmmps_v1, na którym przewozi się czołgi, ma wpisany MaxLoad = 1.

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 10106
    • Zobacz profil
  • Otrzymane polubienia: 2592
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #268 dnia: 08 Marca 2020, 19:03:25 »
No bo mieści jeden czołg. Wszystkie pojazdy są ładunkami sztukowymi.
Mój kanał youtube

Offline Siecool

  • Deweloper
  • Wiadomości: 973
    • Zobacz profil
  • Otrzymane polubienia: 227
Odp: MaSzyna 20.01 - problemy
« Odpowiedź #269 dnia: 08 Marca 2020, 19:07:23 »
To skąd symulator wie, ile waży czołg?