Autor Wątek:  Blad too many iterations  (Przeczytany 4933 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Grand

  • Wiadomości: 382
    • Zobacz profil
  • Otrzymane polubienia: 0
Blad too many iterations
« dnia: 14 Listopada 2005, 18:18:01 »
Czy ktos wie w czym jest problem ?



/ \  / \  / \

Offline youBy

  • Deweloper
  • Wiadomości: 6163
  • Co tam?
    • Zobacz profil
    • Automat Weryfikujący Regulację i Lambdę
  • Otrzymane polubienia: 865
Blad too many iterations
« Odpowiedź #1 dnia: 14 Listopada 2005, 18:32:51 »
któryś flex jest źle zrobiony, np. jego początek i koniec są w tym samym miejscu
Xoov
Powyższy post wyraża jedynie opinię autora w chwili publikacji. Autor zastrzega sobie prawo do zmiany poglądów bez podawania przyczyny, jak również informowania o tym.

Offline wasyl

  • Wiadomości: 276
  • Permanentny Inwigilator Sieciowy
    • Zobacz profil
  • Otrzymane polubienia: 0
Blad too many iterations
« Odpowiedź #2 dnia: 14 Listopada 2005, 18:58:38 »
Witam!!!
Albo 2 flexy z jednego toru (z tego samego końca) odchodzą.
Przygarnę fotki na tekstury obiektów!

Offline eu43

  • Wiadomości: 239
    • Zobacz profil
    • http://www.eu43.fora.pl/
  • Otrzymane polubienia: 0
Blad too many iterations
« Odpowiedź #3 dnia: 14 Listopada 2005, 19:23:10 »
Witam ;)

Moim zdaniem, gdyby flex zaczynał się i kończył, to by scenerii wogóle nie szło odpalić. Zrobiłem na próbe scenerię, w której z jednego toru wychodzą 2 flexy. Żadnych błędów nie było, więc to nie w tym ktwi sęk.

[dodano po kolejnej próbie]

Owy błąd wywala, gdy flex nie jest "rozciągnięty" między końcami torów ;)

Offline Grand

  • Wiadomości: 382
    • Zobacz profil
  • Otrzymane polubienia: 0
Blad too many iterations
« Odpowiedź #4 dnia: 14 Listopada 2005, 22:16:30 »
Apropo powyzszego problemu z bledem juz rozwiazalem go :) poprawilem torowisko w tamtym miejscu, wydaje mi sie ze mialem za duzo krotkich torow zwyklych i flexowych albo za dlugi flex , w kazdym badz razie juz jest ok :)


Jeszcze takie pytanko mam apropo zwrotnic. Staram sie jak moge w miare prosto laczyc zwrotnice z torami, flexami , zaokragleniami, a jakos w niektorych miejscach jak jade przez zwrotnice lokiem, to lok sie buja i albo tyl gdzies zostaje z tylu (jeden wozek) i po chwili wraca tak jak byc powinno. Pewnie wiecie o co chodzi, bardzo to widac jak sie w kabinie siedzi, i tak rzuci ni stad ni z owont. Macie jakis sposob na to ?
/ \  / \  / \

Offline Quark-t

  • Administrator
  • Wiadomości: 3590
  • Automaty liczą...
    • Zobacz profil
  • Otrzymane polubienia: 47
Blad too many iterations
« Odpowiedź #5 dnia: 14 Listopada 2005, 22:35:59 »
To tylko domysł, ale czy przypadkiem nie dzieje sięto kiedy rozprwasz zwrotnicę?

A co do układania zwrotek na wprost od torów, to kopiuj -> wklej współrzędne :] i nie ma siły, musi pasować.
Pozdrawiam, dr inż. Quark-t

Offline eu43

  • Wiadomości: 239
    • Zobacz profil
    • http://www.eu43.fora.pl/
  • Otrzymane polubienia: 0
Blad too many iterations
« Odpowiedź #6 dnia: 15 Listopada 2005, 15:09:38 »
Daj screena z tą zwrotnicą i lokiem gubiącym wózek.

Offline Grand

  • Wiadomości: 382
    • Zobacz profil
  • Otrzymane polubienia: 0
Blad too many iterations
« Odpowiedź #7 dnia: 15 Listopada 2005, 16:39:32 »
BEFORE :




AFTER :



Sami widzicie ze tor jest idealnie dopasowany a dzieja sie takie rzeczy.
/ \  / \  / \

Offline eu43

  • Wiadomości: 239
    • Zobacz profil
    • http://www.eu43.fora.pl/
  • Otrzymane polubienia: 0
Blad too many iterations
« Odpowiedź #8 dnia: 15 Listopada 2005, 17:04:33 »
Tak Ci się robi, bo chyba wkraczasz na zwrotkę przygotowaną do jazdy w bok i dlatego lok przeskakuje na tor zwrotny. Zaraz to wyjaśnimy, tylko daj jeszcze jednego sceern'a z tym lokiem, ale zrób go tak, żeby było widać ten wskaźnik przy zwrotnicy ;)

Zrobiłem na próbę scenerię tak, żeby pociąg wjechał na zwrotnicę nastawioną na bok i stało się tak samo, jak w twoim przypadku.

Offline Grand

  • Wiadomości: 382
    • Zobacz profil
  • Otrzymane polubienia: 0
Blad too many iterations
« Odpowiedź #9 dnia: 15 Listopada 2005, 17:44:28 »
Wlasnie w tym tkwil problem, dzieki juz poprawilem i przestawilem zwrotnice :) Pozdrawiam
/ \  / \  / \