Autor Wątek:  Nie mam inserta!!  (Przeczytany 14816 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Siwyopole

  • Wiadomości: 4
    • Zobacz profil
  • Otrzymane polubienia: 0
Nie mam inserta!!
« dnia: 19 Lutego 2005, 10:03:18 »
Mam bardzo, ale to bardzo głupi problem... Na mojej klawiaturze jest przedłuzony Delete, nie ma klawisza Insert.... Jak mogę zmienić sterowanie? Tylko napiszcie w prosty sposób, bo jestem w tym laik! Z góry dzięki :)

Offline Grand

  • Wiadomości: 382
    • Zobacz profil
  • Otrzymane polubienia: 0
Nie mam inserta!!
« Odpowiedź #1 dnia: 19 Lutego 2005, 10:11:25 »
To co to za klawiatura ? Made in ZSRR :D :P
/ \  / \  / \

Offline Siwyopole

  • Wiadomości: 4
    • Zobacz profil
  • Otrzymane polubienia: 0
Nie mam inserta!!
« Odpowiedź #2 dnia: 19 Lutego 2005, 10:50:47 »
Nie, Logitecha, kupiona pół roku temu.

Offline Elmer

  • Wiadomości: 12
    • Zobacz profil
  • Otrzymane polubienia: 0
Nie mam inserta!!
« Odpowiedź #3 dnia: 19 Lutego 2005, 11:31:16 »
Witam.

Kiedyś był dołączany wraz z MaSzyną taki programik keymap.exe. Dzięki niemu można było zmienić ustawienia klawiszy w MaSzynie. Posiadałem go, ale gdzieś mi go wcieło. Jak znajdę, to dam znać.

Pozdrawiam Was serdecznie.

Offline SQT

  • Zasłużony dla Symulatora
  • Wiadomości: 306
    • Zobacz profil
  • Otrzymane polubienia: 87
Nie mam inserta!!
« Odpowiedź #4 dnia: 19 Lutego 2005, 11:42:29 »
Zdawało mi się że w obecnej wersjii Maszyny ustawienia są zapisane na stałe i keymap nic niedaje.

Offline Elmer

  • Wiadomości: 12
    • Zobacz profil
  • Otrzymane polubienia: 0
Nie mam inserta!!
« Odpowiedź #5 dnia: 19 Lutego 2005, 11:58:24 »
Cytat: "SQT"
Zdawało mi się że w obecnej wersjii Maszyny ustawienia są zapisane na stałe i keymap nic niedaje.


Mylisz się. MaSzyna klawiszologie czyta z pliku keys.ini . Jeśli tego pliku nie ma, to w takim razie jest ładowana defaultowa klawiszologia. Więc za pomocą keymapa zmienisz klawiszologie.

Pozdrawiam Cię.

Offline jaras

  • Wiadomości: 224
    • Zobacz profil
  • Otrzymane polubienia: 12
Nie mam inserta!!
« Odpowiedź #6 dnia: 19 Lutego 2005, 14:45:35 »
Witajcie.

@ Elmer:
Również się mylisz :-).

Symulator, owszem, może i czyta klawisze z keys.ini, ale keymap.exe zapisuje je, z kolei, do pliku keys.dat. One mają, jak zauważyłem, inny format - zajrzyj do nich - oba są tekstowe.

U mnie jest tak:
    [*]keys.ini:107 107 109 109 111 111 106 106 97 35 103 36 99 105 102 96 104 101 98 100 110 13 83 77 68 82 78 67 88 70 71 66 32 65 65 69 33 34 37 39 38 40 36 35 45 46 121 114 70 188 190 188 190 191

    [*]keys.dat: MainCtrl+
    107
     MainCtrl++
    107
     MainCtrl-
    109
     MainCtrl--
    109
     ScndCtrl+
    111
     ScndCtrlFAST++
    111
     ScndCtrl-
    106
     ScndCtrl--
    106
     LocalBrakeLevel+
    103
     LocalBrakeLevel++
    (...)
    [/list]
    Cytat: "SQT"
    Zdawało mi się że w obecnej wersjii Maszyny ustawienia są zapisane na stałe i keymap nic niedaje.
    Kto wie, czy nie masz racji - ja nie wiem ;-).

    @ Siwyopole:
    Może popróbuj programem keymap.exe zmieniać klawisze w keys.dat i patrz, jaka liczba odpowiada temu Insert-owi, a potem wpisz zamiast kodu Insert tą liczbę do keys.ini.

    Jeśli bedzie działać, to @ Elmer ma rację; jeśli nie - @ SQT :-).

    Powodzenia i pozdrawiam :-).
    Jarosław Krasuski (@ jaras)

    Doc: tutaj.
    No cóż... trzeba się powoli zbierać do odejścia z tego forum - nic tu po mnie.

    Offline Siwyopole

    • Wiadomości: 4
      • Zobacz profil
    • Otrzymane polubienia: 0
    Nie mam inserta!!
    « Odpowiedź #7 dnia: 19 Lutego 2005, 18:46:09 »
    No popróbowałbym, ale nie mam czym :D nie mam tego programu ani w paczce maszyny, ani w niczym .... Gdzie mogę go znaleźć? W dziale download nie ma sprawdzałem :)

    Offline Cesky Kretek

    • Zasłużony dla Symulatora
    • Wiadomości: 1712
    • Trust no one.
      • Zobacz profil
    • Otrzymane polubienia: 159
    Nie mam inserta!!
    « Odpowiedź #8 dnia: 19 Lutego 2005, 18:53:49 »
    Cytat: "Siwyopole"
    nie mam tego programu ani w paczce maszyny, ani w niczym .... Gdzie mogę go znaleźć? W dziale download nie ma sprawdzałem


    Keymap :
    http://www.gdynia.mm.pl/~serwer/eu07/cheats/KeyMap.exe

    Offline Siwyopole

    • Wiadomości: 4
      • Zobacz profil
    • Otrzymane polubienia: 0
    Nie mam inserta!!
    « Odpowiedź #9 dnia: 19 Lutego 2005, 19:18:11 »
    Hmmm... problem w tym, że ja w ogóle nie mam pliku keys.dat, więc keymap nie może mi otworzyć, nie mogę niczego sprawdzić ani zmienić ;) Mam jeszcze jedno pytanko - po zainstalowaniu patcha, kiedy włączam maszynę, ekran robi się czarny a po chwili wyskakuje okienko z zapytaniem o właściwą częstotliwość (taki prostokącik z napisem : Hz ?) NIe wiem, czy to normalne i czy w ten sposób gra się ładuje. Odpiszcie, bo już mi się nie chce restartować kompa ;) I pomóżcie z tym porąbanym insertem (może jeśli ktoś ma ten plik keys.dat to niech mi wyśle błagam bo zwariuję! :)

    Offline youBy

    • Deweloper
    • Wiadomości: 6164
    • Co tam?
      • Zobacz profil
      • Automat Weryfikujący Regulację i Lambdę
    • Otrzymane polubienia: 870
    Nie mam inserta!!
    « Odpowiedź #10 dnia: 19 Lutego 2005, 19:25:36 »
    Symek uruchamia się na pełnym ekranie, w dowolnej rozdzielczości. to okkiienko moze byc spowodowane przechodzniem do innej rozdzielczości
    Xoov
    Powyższy post wyraża jedynie opinię autora w chwili publikacji. Autor zastrzega sobie prawo do zmiany poglądów bez podawania przyczyny, jak również informowania o tym.

    Offline SQT

    • Zasłużony dla Symulatora
    • Wiadomości: 306
      • Zobacz profil
    • Otrzymane polubienia: 87
    Nie mam inserta!!
    « Odpowiedź #11 dnia: 19 Lutego 2005, 20:58:18 »
    Oj jaras troche się pomyliłeś bo ja mam tak:
    dwa pliki keymap.exe i keys.dat - w keys.dat są orginalne ustawienia do keymapa. Gdy zapisze zmiane to to wszystko zapisuje się do keys.ini czyli ten plik sam sie tworzy. W każdym razie tak to u mnie działa i tutaj daje linka do keymapa z keys.dat
    http://www.janusz15.strony.gni.pl/keymap.rar

    Offline Undercover

    • Wiadomości: 4
      • Zobacz profil
      • http://www.fajnywozek.republika.pl
    • Otrzymane polubienia: 0
    Nie mam inserta!!
    « Odpowiedź #12 dnia: 19 Lutego 2005, 23:12:06 »
    Witam!
    jeśli chodzi o to okienko to Ja również nie dawno miałem z tym problem. Rozwiązałem go przeinstalowywując sterownik karty graficznej na inny Tobie proponuje to samo.

    Pozdrawiam
    Z wódką nie wygraaz ty ją w gębe a ona Cię na ziemię ....

    Offline jaras

    • Wiadomości: 224
      • Zobacz profil
    • Otrzymane polubienia: 12
    Nie mam inserta!!
    « Odpowiedź #13 dnia: 20 Lutego 2005, 05:02:46 »
    Witajcie.

    Cytat: "SQT"
    Oj jaras troche się pomyliłeś (...)
    Naprawdę nie wiem, gdzie się pomyliłem, bo tylko zaznaczyłem zawartość mojego pliku keys.ini, zrobiłem Ctrl+C, a w okienku posta zaś - Ctrl+V. Być może zatem autorzy symulatora się pomylili umieszczając mi taki plik w katalogu ;-). Tak się jednak składa, że całkiem niedawno miałem okazję rozmawiać z samym autorem programu keymap.exe i wiem, że plik keys.dat nieprzypadkowo znalazł się w katalogu z symulatorem. :-P

    Proszę więc, nie mów mi, że się pomyliłem, skoro nawet nie miałem takiej możliwości ;-).

    Ale skoro to działa dobrze - to OK.

    Cytat: "Undercover"
    (...) Rozwiązałem go przeinstalowywując sterownik karty graficznej (...)
    Panowie, temat wątku brzmi "Nie mam inserta!!" - co zatem ma sterownik karty graficznej do tego?

    Zapewniam Cię, że nawet jak zainstalujesz tam sterownik do odrzutowca, to nic nie poradzisz na fakt, że na klawiaturze nie ma klawisza Insert. :-P

    @ Siwyopole:
    Być może zatem sposób podany przez @ SQT będzie tutaj dobry.

    Ale, jeśli keymap.exe okazałby się również nieskuteczny, to proponuję ręczne grzebanie w pliku keys.ini.

    To nie jest, wbrew pozorom zbyt trudne, zważywszy, że klawisz Insert ma kod 45 (nie jest to kod ASCII, tylko tzw. virtual code, kod używany podczas obsługi klawiatury przez aplikacje w Windows). Poszukaj więc w pliku keys.ini liczby 45 i zamień ją na inną.

    Jaką?

    Taką, by nie użyć jakiegoś klawisza, który już jest używany przez symulator. Najlepszy, bo znajdujący się na każdej (mam nadzieję ;-) klawiaturze wydaje się BackSpace (cofacz), którego virtual code wynosi 8.

    No, to spróbuj podmienić w pliku keys.ini liczbę 45 na 8, a przyczepianie składu powinno od teraz być pod klawiszem BackSpace.

    No coż - miłej zabawy :-).

    Pozdrawiam Cię.
    Jarosław Krasuski (@ jaras)

    Doc: tutaj.
    No cóż... trzeba się powoli zbierać do odejścia z tego forum - nic tu po mnie.

    Offline SQT

    • Zasłużony dla Symulatora
    • Wiadomości: 306
      • Zobacz profil
    • Otrzymane polubienia: 87
    Nie mam inserta!!
    « Odpowiedź #14 dnia: 20 Lutego 2005, 08:10:29 »
    Sorry za OT. No mam nadzieję żę doszliśmy do porozumienia już i koniec sprzeczki o ten głupi keys.ini i keys.dat. :)

    Offline Sierakowiczanin

    • Wiadomości: 148
      • Zobacz profil
    • Otrzymane polubienia: 0
    Nie mam inserta!!
    « Odpowiedź #15 dnia: 22 Lutego 2005, 16:45:02 »
    Warto przestrzegać przed takim bublem.Ja kuoując nową klawiaturę jakoś nie sprawdzałem,czy ma wszystkie klawisze ;)Widocznie jednak trzeba ;)

    Offline Mutopompka

    • Wiadomości: 1155
    • Na IRC-u SPRĘŻAREK vel. tyqtyqtyq
      • Zobacz profil
    • Otrzymane polubienia: 2
    Nie mam inserta!!
    « Odpowiedź #16 dnia: 22 Lutego 2005, 16:57:27 »
    Już chyba wiem, jaki Ty masz problem!!!!! MASZ INSERT I MI TU NIE GADAJ!!! Jeśli masz klawiaturę Logitech LX-501 (a chyba taki model lub podobny masz), to popatrz na ten test: http://twojepc.pl/artykuly.php?id=logitech_cordless_lx_501&strona=2 a popatrz na to: http://twojepc.pl/html/logitech_cordless_lx_501/k3.jpg jest, tylko "zintegrowany z scroll lockiem" więc Insert masz.

    Offline Quark-t

    • Administrator
    • Wiadomości: 3590
    • Automaty liczą...
      • Zobacz profil
    • Otrzymane polubienia: 47
    Nie mam inserta!!
    « Odpowiedź #17 dnia: 22 Lutego 2005, 17:19:27 »
    Ja bym dorzucił jeszcze jedno.
    Powinieneś mieć insert na klawiszu "0" w części numerycznej. Na tym foto co @Mutopompka :] zapodał też widać. Po prostu musiałbyś operować NumLockiem przełączając miedzy łączeniem składu a hamowaniem nagłym.
    Pozdrawiam, dr inż. Quark-t