Autor Wątek:  UNOFF REV290706  (Przeczytany 47557 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Converter

  • Gość
UNOFF REV290706
« Odpowiedź #60 dnia: 05 Sierpnia 2006, 17:57:37 »
A ja może wiem coś o bugu. A mianowicie:
Wywala program, jeśli do dynamicu bez replacableskin w modelu wpiszemy zamiast "none" tekstury nazwę. Taki błąd miałem z Adu.
Zmieniłem i wszystko ok.
EDIT: Oczywiście ten błąd jest na exe Quequeda
 Uparcie nie ładują się tekstury liter pragotronu, ponieważ zamiast być wczytywane z : ścieżkaprogramu/textures/... są ładowane z E:/symulator2/textures/...
Właśnie dlatego mówiłem, że z pragotronem jest coś nie tak :/
Próbowałem w ustawieniach (chyba w folderze Qmod) zmienić ścieżkę domyślną, niestety nic to nie dało.
Ciekawa rzecz z Czechami. A więc, kto pierwszy znajdzie błąd ? ;)
EDIT2: Kolejna rzecz - WYDAJNOŚĆ. Tam, gdzie miałem ok.20 FPS
teraz mam 10FPS

Offline Mariusz1970

  • Zasłużony dla Symulatora
  • Wiadomości: 3927
    • Zobacz profil
  • Otrzymane polubienia: 287
UNOFF REV290706
« Odpowiedź #61 dnia: 05 Sierpnia 2006, 18:16:51 »
Cytuj
Czy ktos ma gorszy sprzet odemnie? (ATHLON 750 GF2 MX200 160ram)
bo ja nie nazekam, a nie lubie sluchac nazekania ludzi, ktorzy maja lepsze sprzety ;]


Nie narzekasz na co?, chyba nie powiesz mi że na fps. Min ilość fps to 25 tak jak w telewizorni. Można oczywiście przyzwyczaić się do 6 czy 5 i też nie narzekać, ale nie w tym rzecz. Gdyby podchodzić do tej sprawy tak, Ty proponujesz, nie byłoby exe 664 czy 674, gdzie fps się zwiększył wyraźnie od wersji 220604 i skoro 674 jest krytyczny pod tym kątem, należy go odchudzić, oczywiście jak ktoś wie co i jak w nim grzebać.

Pozdrawiam
Mariusz

PS Mój sprzęt jest niewiele lepszy od Twojego, na quarku na stacjach 5,6 fps czy innych w miare rozbudownych stacji, a Ty jako jeden z nielicznych masz tą możliwość zmiany exe i zamiast energii tracić na bajery, należy pomyśleć o zwiększeniu wydajności. Wiem to jest o wiele trudniejsze od dodawania bajerów, ale może się coś uda zrobić.

Offline Profeta

  • Wiadomości: 632
  • CM Czechowice-Dziedzice
    • Zobacz profil
    • http://my.opera.com/akvin-profeta/
  • Otrzymane polubienia: 1
UNOFF REV290706
« Odpowiedź #62 dnia: 05 Sierpnia 2006, 18:22:37 »
Cytat: "Converter"
A ja może wiem coś o bugu. A mianowicie:
Wywala program, jeśli do dynamicu bez replacableskin w modelu wpiszemy zamiast "none" tekstury nazwę. Taki błąd miałem z Adu.
Zmieniłem i wszystko ok.

Sprawdzałem to właśnie na EP05. Nie wywaliło błędu jak wpisałem nazwę tekstury. Ale sprawdzałem na zwykłym 674 kB, bo queuedowe Czecha nie obsługuje... przy okazji zauważyłem, że EP0208.chk też nie.
Pozdrawiam!
EP05 (100%), EU05 (100%), Projekt 201E (100%), Kabina SU46/SP47 (100%), Kabina 4E (100%), 104E (100%), Traxx F140MS (100%), Eurosprinter ES64F4 (80%).
www.my.opera.com/akvin-profeta

Offline lagerkvist

  • Wiadomości: 54
    • Zobacz profil
  • Otrzymane polubienia: 0
UNOFF REV290706
« Odpowiedź #63 dnia: 05 Sierpnia 2006, 19:14:49 »
Jeśli problem da się rozwiązać, exe roboty @ queuedEU rzeczywiście stanie się moim ulubionym.

Offline Czomo

  • Wiadomości: 152
    • Zobacz profil
  • Otrzymane polubienia: 3
UNOFF REV290706
« Odpowiedź #64 dnia: 05 Sierpnia 2006, 19:33:11 »
Ja pracuje na takim:
650 procesor Duron
64 ram
16 mega pamięci karty graficznej
ale.... radzo sobie i raczej w przeciągach osiągam max 15/20FPS
więc zaraz ktoś powie że mam najgorszy sprzęt ;)

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #65 dnia: 05 Sierpnia 2006, 20:46:14 »
Cytat: "Converter"
A ja może wiem coś o bugu. A mianowicie:
Wywala program, jeśli do dynamicu bez replacableskin w modelu wpiszemy zamiast "none" tekstury nazwę. Taki błąd miałem z Adu.
Zmieniłem i wszystko ok.
EDIT: Oczywiście ten błąd jest na exe Quequeda
 Uparcie nie ładują się tekstury liter pragotronu, ponieważ zamiast być wczytywane z : ścieżkaprogramu/textures/... są ładowane z E:/symulator2/textures/...


Zmienilem na c:\queued\ip\pragotron\ bo mam problem ze skladaniem sciezek, wiec narazie zalozcie sobie katalog 'queued\ip' i tam wciapnijcie katalog pragotron.


Cytuj
Ciekawa rzecz z Czechami. A więc, kto pierwszy znajdzie błąd ? ;)

Oczywiscie ze ja, bo zapomnialem ;P

Cytuj

Kolejna rzecz - WYDAJNOŚĆ. Tam, gdzie miałem ok.20 FPS
teraz mam 10FPS


Masz teraz srednio 10f/s to i tak o 4-7 wiecej niz ja, wiec oco chodzi?

Dodano po 6 minutach:

 I oto prosze panstwa ... Stalo sie...
Otoz prawdopodobnie za chwile o ile wygracie wojne z lycosem ;),
bedziecie posiadali przyjemnosc ogromna przejechac sie na calkowie, mocznikach i innych wypasiastych scn...

Narazie jeszcze w 100 procentach nie wiem co bylo powodem sypania sie ale mam nadzieje ze to co myslalem, bo procz tego jest jeszcze jedna rzecz brana pod uwage, a jest tak banalna ze poprostu wole narazie nie pisac o tym ;]. Jezeli faktycznie tym bugiem jest ta druga rzecz ;) to by to rozwiazywalo problem 674/675?.

http://www.members.lycos.co.uk/queued/exe/

Offline Mariusz1970

  • Zasłużony dla Symulatora
  • Wiadomości: 3927
    • Zobacz profil
  • Otrzymane polubienia: 287
UNOFF REV290706
« Odpowiedź #66 dnia: 05 Sierpnia 2006, 21:25:41 »
Z całym szacunkiem Q dla tego co zrobiłeś i jeszcze robisz, ale jeżeli jest tak jak napisał Converter, że wydajność spadła o 100%, Ty piszesz:
Cytuj
Masz teraz srednio 10f/s to i tak o 4-7 wiecej niz ja, wiec oco chodzi?


no weź.... przecież fps był i tak nie najwyższy, a teraz jeszcze o połowę mniejszy. Ja jeszcze tego Twojego nie odpalałem, więc nie wiem. Wiem, że dla sporej liczby userów fps to duży problem (piszę to na podstawie zainteresowania tym moim zmieniaczem, iż osoby zaczeły się tym interesować). Dla ludzkiego oka, aby mieć złudzenie płynnego ruchu to ok. 25/s. Ja 100 razy wolę nie mieć jakiś bajerów typu zegar, czy niebo w chmurki itp., a mieć max. płynniejszy fps. Ponadto dla fps<18 zablokowane jest kiwanie się loka, co znacznie odbiera przyjemność jazdy (nie wiem jak w Twoim to wygląda).
Zdolny jesteś i masz "łeb na karku" w wolnej chwili pomyśl na tym.

Pozdrawiam
Mariusz

Offline Profeta

  • Wiadomości: 632
  • CM Czechowice-Dziedzice
    • Zobacz profil
    • http://my.opera.com/akvin-profeta/
  • Otrzymane polubienia: 1
UNOFF REV290706
« Odpowiedź #67 dnia: 05 Sierpnia 2006, 22:05:51 »
Niestety bez zmian nadal się sypie.
EP05 (100%), EU05 (100%), Projekt 201E (100%), Kabina SU46/SP47 (100%), Kabina 4E (100%), 104E (100%), Traxx F140MS (100%), Eurosprinter ES64F4 (80%).
www.my.opera.com/akvin-profeta

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #68 dnia: 05 Sierpnia 2006, 22:48:55 »
Hmmmm... Dobra... Wiec moze tak...

pierw te mniej wazne rzeczy.. 1 segment pragotronu zajmuje... 120 poly
 jeden zegar to 12 poly?, wiec to wsumie nie duzo, a sa przeciez opcjonalne bo ladowane z pliku.
NIebo... to by bylo to co w tej chwili pewnie zre najwiecej, dlatego widze,
ze koniecznoscia bedzie zrobienie mozliwosci definiowania segmentacji,
jak i powtarzania textury...
Teraz odnosnie zwiekszania FPS... Siedzi mi w glowie pewien plan, ktorego
wykonanie moglo by zwiekszyc plynnosc moze nawt o 10-15 ramek, ale
to narazie plan, poniewaz bylo by duzo sprawdzaina psucia itp
- chodzi tu o dynamiczne ladowanie textur dla obiektow pojaiajacych sie
i zwalniaine ich gdy sa poza zasiegiem. Poprzednik napisal, ze nadal sie sypie... Dziwne mnie zaczely chodzic scenerie takie jak Baltyk, Moczniki, Calkowo a wczesniej sie sypaly na AI. No coz moze jest cos jeszcze? ...
Poki co prosba. Osoby ktorym sie sypia Moczniki poprosze o wystawienie pliku/plikow SCN. Obadam sprawe.

Offline MB

  • Wiadomości: 12
    • Zobacz profil
  • Otrzymane polubienia: 0
UNOFF REV290706
« Odpowiedź #69 dnia: 05 Sierpnia 2006, 22:59:27 »
1. W loaderze nie działa przycisk zamykania.
2. Po wybraniu scenerii loader nie zawsze pozwala na uruchomienie rzeczywistego składu, np. w KrewetkowieEU07 można jedynie prowadzić wagony, a rzeczywista lokomotywa jest oznaczona na czerwono i nie można uruchomić na niej scenerii.

Offline lagerkvist

  • Wiadomości: 54
    • Zobacz profil
  • Otrzymane polubienia: 0
Pliki z Mocznikami, których nie można uruchomić
« Odpowiedź #70 dnia: 05 Sierpnia 2006, 23:11:12 »
Po przetestowaniu najnowszej wersji paczuszki muszę przyznać, niestety, Moczników w dalszym ciągu nie daje się uruchomić. Zgodnie z prośbą zamieszczam więc odsyłacz do archiwum z wszytkimi plikami, które wchodzą w skład trasy Moczniki w mojej kompilacji Maszyny.

http://hyperupload.com/download/02ed2eab72/moczniki.zip.html

Pozdrawiam serdecznie!

Edit:

Rzeczywiście u mnie jest dokładnie tak, jak rzecze @ Profeta dwa posty niżej. Całkowo uruchamia się, nie uruchamiają się natomiast:
-Moczniki;
-Linia 546;
-Bochnia.
(Te trzy trasy miałem czas przetestować, podobnie jak @ Profeta.
Wydaje się, że pozostałe, próbowane na chybił trafił, ładują się.)

Sądząc po log.txt, nieprawidłowe umieszczenie pliku tła loadera nie wpływa na działanie programu.

Rozumiem, że wywalenie większości wagonów i wstawienie tylko jednego rodzaju rozwiązuje problem. Ale, czy dojdą Panowie do sedna? Bez usuwania składów?

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #71 dnia: 05 Sierpnia 2006, 23:13:05 »
I csooo?.. Fajnie sie prowadzi wagony? ;)

1. wiem
2. chk loka, plik scn,  -> gg
3. czekam

Offline Profeta

  • Wiadomości: 632
  • CM Czechowice-Dziedzice
    • Zobacz profil
    • http://my.opera.com/akvin-profeta/
  • Otrzymane polubienia: 1
UNOFF REV290706
« Odpowiedź #72 dnia: 05 Sierpnia 2006, 23:17:37 »
Więc tak...
Bałtyk i Całkowo działały już wczesniej (przynajmniej u mnie). W Mocznikach to kwestia taboru, a konkretnie wagonów decyduje o tym czy się sypie (jak zostawię wszystko prócz wagonów to sie uruchamia). Z tym, że te same wagony nie powodują wysypania się na innych sceneriach (typu 100 m prostego toru). Z ważniejszych scenerii nie uruchamia się jeszcze m. in. linia546, Jelitkowo i Bochnia. Kombinując dalej na Mocznikach pozostawiłęm tylko wagony:
node -1 0 505120-00256-5 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 0 enddynamic
wówczas się uruchamiało. Natomiast gdy dodałem wagon:
node -1 0 505120-00255-6 dynamic PKP\Syp  #syp.tga syp 0.0 nobody 3 0 enddynamic
to się wykrzaczyło. Jakoś nie podobał mi się nazwa tekstury to zamiast niej wpisałem "bla" i wtedy się symek nie wysypał na wagonach Syp.
Testowałem na scenerii moczniki_eu06_eu07.scn i składy mam tam takie jak autor ustawił standardowo (nie dokonywałem żadnych zmian).
Druga sprawa. Loader_background się nie wyświetla gdyż symek chce go wczytywać z katalogu Qmod a plik ten znajduje się w data, stąd przy uruchamianiu wyskakuje błąd, który jednak, jak sądzę, nie ma wpływu na uruchomienie się symulatora. Zamiast obrazka mamy zielone tło ;)
Pozdrawiam!
EP05 (100%), EU05 (100%), Projekt 201E (100%), Kabina SU46/SP47 (100%), Kabina 4E (100%), 104E (100%), Traxx F140MS (100%), Eurosprinter ES64F4 (80%).
www.my.opera.com/akvin-profeta

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #73 dnia: 05 Sierpnia 2006, 23:30:12 »
Ja bym tu raczej myslal badziej trojwymiarowo i zanim nym wylal swoje zale pobawilbym sie... ;)


node 600 0 505120-00255-6 dynamic PKP\Syp syp.tga syp 0.0 nobody 3 0 enddynamic
node 600 0 505120-00255-6 dynamic PKP\Syp syp.bmp syp 0.0 nobody 3 0 enddynamic
node 600 0 505120-00255-6 dynamic PKP\Syp syp syp 0.0 nobody 3 0 enddynamic
node 600 0 505120-00255-6 dynamic PKP\Syp syp.jpg syp 0.0 nobody 3 0 enddynamic

No to do testow :)

btw. na gygy bede za jakies 30-59 minut

Offline Profeta

  • Wiadomości: 632
  • CM Czechowice-Dziedzice
    • Zobacz profil
    • http://my.opera.com/akvin-profeta/
  • Otrzymane polubienia: 1
UNOFF REV290706
« Odpowiedź #74 dnia: 06 Sierpnia 2006, 09:27:10 »
Myślałem bardzo trójwymiarowo i znalazłem klucz do rozwiązania problemu. Otóż kombinując z wysypującymi się wagonami Z1 i Syp zauważyłem, że od innych wagonów różni je jedynie rozmiar tekstury. Otóż exe 674 kB i pochodne wysypuje się na wagonach posiadających tekstury w formacie 1024X256 (lub 512X128 bo to to samo tylko w mniejszej skali). Wstawienie wagonów z teksturami w innym formacie powoduje, że symek się uruchamia. Zatem wydaje mi się, że wsytarczy Q abyś sprawił, że exe będzie obsługiwał ten format i możemy zapomnieć o problemach z najnowszym exe.
Pozdrawiam!
EP05 (100%), EU05 (100%), Projekt 201E (100%), Kabina SU46/SP47 (100%), Kabina 4E (100%), 104E (100%), Traxx F140MS (100%), Eurosprinter ES64F4 (80%).
www.my.opera.com/akvin-profeta

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #75 dnia: 06 Sierpnia 2006, 12:04:23 »
No wiem :D, a btw to jeszcze z niepowiekszanymi texturami to tez moga dzialac Z1 jezeli sie dobrze ustawi sklad :]

Dodano po 4 minutach:

 a tak w ogoe... debuguje od 5** moczniki_eu06_eu07.scn i co no i wychodzi na to ze EP09 wadzi :] bo bez inej wsio dziala....

Dodano po 1 godzinach 40 minutach:

 Odwoluje to co powiedzialem w poprzednim poscie na temat EP09...
Ona takze dzial.. W ogole to... czeski film - pozniej caly log z debugowania
poprawione plik scn, 10 extra fps + wiele wiele innych ;)

Offline Profeta

  • Wiadomości: 632
  • CM Czechowice-Dziedzice
    • Zobacz profil
    • http://my.opera.com/akvin-profeta/
  • Otrzymane polubienia: 1
UNOFF REV290706
« Odpowiedź #76 dnia: 06 Sierpnia 2006, 12:10:13 »
U mnie wystarczyło wyrzucić wagony korzystające z tych tekstur i wszystko już działa. Teraz pozostaje albo sprawić w exe by wczytywał takie tekstury, albo nie używać tego taboru, bo w zasadzie można prawie wszystkie te sypiące się wagony zastąpić 1xxa. Problem takich tekstur dotyczy Z1, Syp, Wars, Adu, WRbd i pewnie się jakiś jeszcze znajdzie. Teraz uruchamiają już się u mnie wszystkie trasy z Mocznikami na czele (EP09 nie robi u mnie żadnej różnicy).
Pozdrawiam!
EP05 (100%), EU05 (100%), Projekt 201E (100%), Kabina SU46/SP47 (100%), Kabina 4E (100%), 104E (100%), Traxx F140MS (100%), Eurosprinter ES64F4 (80%).
www.my.opera.com/akvin-profeta

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #77 dnia: 06 Sierpnia 2006, 14:25:07 »
To csoo teraz debugujemy? :D

Dodano po 2 godzinach 1 minutach:

 LOG:

moczniki_eu06_eu07_060806 0845  -- z render alpha OK, bez kaszana
moczniki_eu06_eu07_060806 0857  -- z render alpha, dodany Adu                  OK
moczniki_eu06_eu07 060806 0906  -- z render alpha, dodany PKP\Ds (#bagazowy.tga) OK
moczniki_eu06_eu07 060806 0928  -- z render alpha, dodano PKP\IC (icc1_nowe.bmp, icc2.bmp) OK
moczniki_eu06_eu07_060806 0938  -- z render alpha, dorzucono reszte IC OK
moczniki_eu06_eu07_060806 0949  -- z render alpha, dorzucono wagony Z1 i PKP\wars (#wars.tga) OK

zostaja Sgs'y i EP09, obstawiamy obstawiamy. Do wygrania kabina EU04 :>

czy to beda Sgs'y? :]


moczniki_eu06_eu07_060806 1002  -- z render alpha, dodano 412zas OK
moczniki_eu06_eu07_060806 1030  -- z render alpha, dodano 412za  OK

EP09 ;]

moczniki_eu06_eu07 060806 1040  -- z render alpha, dodano EP09-005 OK :]
moczniki_eu06_eu07 060806 1054  -- z render alpha, dodano EP09-010 OK :>

Nie kumam nic, jestem wlasciwie w punkcie wejscia i wsio jest ok. Teraz szybka powtorka z debugowania.

Sciagam MOCZNIKI wystawione przez lagerkvist'a

http://hyperupload.com/download/02ed2eab72/moczniki.zip.html

Proba na orginale - wysypka. Pozniej hashowaie skladow prawie wszystkich procz tych na stacji z EU07+EU06 - jest OK.
Zmiana zasiegu widzialnosci na 404, pozniej juz jade jak wyzej w logu...

Btw. wiekszosc testu odbywala sie przy zakomentowanych elementach scenerii.

Dodano po 4 minutach:

 logi z debugowania ;]

http://www.members.lycos.co.uk/queued/exe/debug/moczniki/

Offline Profeta

  • Wiadomości: 632
  • CM Czechowice-Dziedzice
    • Zobacz profil
    • http://my.opera.com/akvin-profeta/
  • Otrzymane polubienia: 1
UNOFF REV290706
« Odpowiedź #78 dnia: 06 Sierpnia 2006, 14:55:06 »
Powiem tak...
U mnie sprawa jest czytelna i jasna.
Jeżeli w moczniki_eu06_eu07.scn pojawi się wpis dotyczący feralnych tekstur (1024X256, 512X128) to się wysypuje. Jeśli takiego wpisu nie ma to wszystko się ładuje. Czyli stąd prosty wniosek, że do exe 664 kB jeszcze takie tekstury nie powodowały błedu, a później już tak. Więc zostało coś zmienione co powoduje ten skutek uboczny.
Czy jeszcze u kogoś wpisanie za nazwy wyżej wymienionych tekstur np. "none" lub "nic" pomogło? Czy tylko ja mam jakieś zwidy?
EP05 (100%), EU05 (100%), Projekt 201E (100%), Kabina SU46/SP47 (100%), Kabina 4E (100%), 104E (100%), Traxx F140MS (100%), Eurosprinter ES64F4 (80%).
www.my.opera.com/akvin-profeta

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #79 dnia: 07 Sierpnia 2006, 04:34:28 »
Witam. Po wczorajajszym porannym debugowaniu, zaszczyt mam wielki..
... zapodac kolejny update, ktory:

a: zmniejszona ma segmentacje nieba z 64 na 24;
b: rozpoczeta implementacja ustawiania segmentacji nieba, wysokosci horyzontu, tilingu textury
c: poprawione sypanie sie AI w niektorych przypadkach


http://www.members.lycos.co.uk/queued/exe/


Pozdro 424

Dodano po 3 godzinach 43 minutach:

 btw. Czomo.. Az taki kiepski sprzet masz? O jaa :>

Offline PEKAP

  • Wiadomości: 588
    • Zobacz profil
  • Otrzymane polubienia: 0
UNOFF REV290706
« Odpowiedź #80 dnia: 07 Sierpnia 2006, 07:09:08 »
Moje spostrzeżenia:
1. Tam gdzie miałem 45FPS na Twoim .exe mam 20FPS, tam gdzie miałem 10FPS mam 6FPS, więc można powiedzieć, że FPS spadł mniej więcej o połowę.
2. Niektóre tekstury w kabinie się nie wyświetlają. Np. zamiast tekstury woltomierza, która działała na starym .exe, na tym .exe jest biały model bez tekstury.
3. Czy można wyłączyć jakoś ten napis i FPS na górze ("Symulator pojazdów...itd) bo trochę mnie to denerwuje.
-//-

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #81 dnia: 07 Sierpnia 2006, 08:35:20 »
Sciagnales najnowszy update wrzucony dzis w nocy (070806)?
64 segmentowe niebo zzeralo jakies 8-9 fpsow u mnie teraz ma 24 segmenty. Na calkowie mam 8-12 fps.

Dodano po 1 minutach:

 Napis zaraz wylaczymy a co do tekstur... nie zauwazylem coby czegos ne wczytywalo.... Opisz problem dokladnej, moze na gg?

Offline EP08_015

  • Zasłużony dla Symulatora
  • Wiadomości: 4339
    • Zobacz profil
  • Otrzymane polubienia: 313
UNOFF REV290706
« Odpowiedź #82 dnia: 07 Sierpnia 2006, 13:40:18 »
Ruszyłeś coś z tymi teksturami? Bo u mnie wysypało się na MZD na całkowie poszło ok. Posprawdzam dalej, narazie nie zmieniałem wpisów mam oryginalne wpisy autorskie. Moczniki EN57 wysypało.
Koniec tworczosci unoffowej i prywatnej.
http://chomikuj.pl/EP08-015

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #83 dnia: 07 Sierpnia 2006, 20:11:01 »
Re. Poki co jeszcze pod tym katem nic ine tworzylem w zrodlach.
Narazie mysle porownac funkcje wczytujace bmp ze zrodlami z 220604
i ewentualnie zamienic. Narazie pozostaje wywalanie zlych wpisow,
badz zmiana rozmiaru textur.

Offline EP08_015

  • Zasłużony dla Symulatora
  • Wiadomości: 4339
    • Zobacz profil
  • Otrzymane polubienia: 313
UNOFF REV290706
« Odpowiedź #84 dnia: 07 Sierpnia 2006, 21:30:05 »
Wiem tyle ze np w przypadku Z1 zwiekszenie x2 nic nie dalo. zeby uniknac formatu np 1024x256 zmienilem 2048x512 i tez kicha.
Koniec tworczosci unoffowej i prywatnej.
http://chomikuj.pl/EP08-015

Offline Profeta

  • Wiadomości: 632
  • CM Czechowice-Dziedzice
    • Zobacz profil
    • http://my.opera.com/akvin-profeta/
  • Otrzymane polubienia: 1
UNOFF REV290706
« Odpowiedź #85 dnia: 07 Sierpnia 2006, 21:42:15 »
Cytat: "EP08_015"
Wiem tyle ze np w przypadku Z1 zwiekszenie x2 nic nie dalo. zeby uniknac formatu np 1024x256 zmienilem 2048x512 i tez kicha.

Tak, wtedy też się sypie, bo każda wilokrotność tego formatu się sypie. Czyli zarówno 1024X256 jak i 512X128 oraz wspomniana 2048X512 itd w górę lub w dół.
Pozdrawiam!!!
EP05 (100%), EU05 (100%), Projekt 201E (100%), Kabina SU46/SP47 (100%), Kabina 4E (100%), 104E (100%), Traxx F140MS (100%), Eurosprinter ES64F4 (80%).
www.my.opera.com/akvin-profeta

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #86 dnia: 09 Sierpnia 2006, 05:14:19 »
Dzisiaj w nocy cos mnie tknelo ;). Otoz zapragnalem wlaczyc sobie ponownie MOCZNIKI ...
Sprawdzilem kazda misje dla tej trasy wszystko sie odpalilo :>. Nieco zaskoczony siegnalem
po orginalne MOCZNIKI wystawione przez lagerkvista...
... Zamienilem misje moczniki_eu06_eu07 na moczniki_eu06_eu07_gowno coby byl lepszy efekt ;),
i ruszylem w trase odpalajac je. Efekt zboczny poprawnego dzialania - zglupialem do reszty :>

Konfiguracja podczas testu:

width 1024
height 768
bpp 32
fullscreen yes
freefly no 20 10 -20
wireframe no
debugmode no
soundenabled yes
renderalpha yes
physicslog no
debuglog yes
adjustscreenfreq yes
mousescale 3.2 0.5
enabletraction yes
loadtraction yes
livetraction yes


Koniec posta.

http://www.members.lycos.co.uk/queued/exe/update090806.rar

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #87 dnia: 10 Sierpnia 2006, 12:20:38 »
TGround::TGround()
APPDIR=D:\EU07-220204\
SCENERY=linia546_et22-1.scn
 
Renderer:
GeForce2 MX/PCI/3DNOW!
Vendor:
NVIDIA Corporation
Version:
1.2.2
Supported Extensions:
GL_ARB_imaging
GL_ARB_multitexture
GL_ARB_texture_compression
GL_ARB_texture_cube_map
GL_ARB_texture_env_add
GL_ARB_texture_env_combine
GL_ARB_texture_env_dot3
GL_ARB_transpose_matrix
GL_S3_s3tc
GL_EXT_abgr
GL_EXT_bgra
GL_EXT_blend_color
GL_EXT_blend_minmax
GL_EXT_blend_subtract
GL_EXT_compiled_vertex_array
GL_EXT_draw_range_elements
GL_EXT_fog_coord
GL_EXT_packed_pixels
GL_EXT_paletted_texture
GL_EXT_point_parameters
GL_EXT_rescale_normal
GL_EXT_secondary_color
GL_EXT_separate_specular_color
GL_EXT_shared_texture_palette
GL_EXT_stencil_wrap
GL_EXT_texture_compression_s3tc
GL_EXT_texture_edge_clamp
GL_EXT_texture_env_add
GL_EXT_texture_env_combine
GL_EXT_texture_env_dot3
GL_EXT_texture_cube_map
GL_EXT_texture_filter_anisotropic
GL_EXT_texture_lod
GL_EXT_texture_lod_bias
GL_EXT_texture_object
GL_EXT_vertex_array
GL_EXT_vertex_weighting
GL_IBM_texture_mirrored_repeat
GL_KTX_buffer_region
GL_NV_blend_square
GL_NV_evaluators
GL_NV_fence
GL_NV_fog_distance
GL_NV_light_max_exponent
GL_NV_packed_depth_stencil
GL_NV_register_combiners
GL_NV_texgen_emboss
GL_NV_texgen_reflection
GL_NV_texture_env_combine4
GL_NV_texture_rectangle
GL_NV_vertex_array_range
GL_NV_vertex_array_range2
GL_NV_vertex_program
GL_SGIS_generate_mipmap
GL_SGIS_multitexture
GL_SGIS_texture_lod
GL_WIN_swap_hint
WGL_EXT_swap_control
 
 
RENDER INITIALIZATION ********************************
 
 
 
LIGHTING SETUP ********************************
 
 
 
FONT INITIALIZATION ********************************
 
 
 
SOUND INITIALIZATION ******************************
 
 
 
TEXTURES INITIALIZATION ***************************
 
 
 
MODELS INITIALIZATION *****************************
 
TGround::Init(linia546_et22-1.scn)


^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^



po zaimplementowaniu ZAAWANSOWANEGO DEBUGERA,
na jaw wyszlo, ze symulator sypie sie w funkcji

bool __fastcall TDynamicObject::Update(double dt, double dt1)

na


QueuedLog("03.1");
//McZapkie: parametry powinny byc pobierane z toru

//  TTrackShape ts;
    ts.R=MyTrack->fRadius;                                                                  // REM BY Q
//  ts.R=ComputeRadius(Axle1.pPosition,Axle2.pPosition,Axle3.pPosition,Axle4.pPosition);
    ts.Len= Max0R(MoverParameters->BDist,MoverParameters->ADist);                             // REM BY Q
    ts.dHtrack= Axle1.pPosition.y-Axle4.pPosition.y;                                          // REM BY Q
    ts.dHrail= (DegToRad(Axle1.GetRoll())+DegToRad(Axle4.GetRoll()))*0.5f;                    // REM BY Q

QueuedLog("03.2");
//    TTrackParam tp;        // ON BY QUEUED
    tp.Width= MyTrack->fTrackWidth;                                             // REM BY Q
//McZapkie-250202
    tp.friction= MyTrack->fFriction;                                            // REM BY Q
    tp.CategoryFlag= MyTrack->iCategoryFlag;                                    // REM BY Q
    tp.DamageFlag=MyTrack->iDamageFlag;                                         // REM BY Q
    tp.QualityFlag=MyTrack->iQualityFlag;                                       // REM BY Q

QueuedLog("04");




DEBUG.LOG CUT ----------------------------------------------------------------------

TDynamicObject::Update(0.00984966943078879, 0.196993388615776)
[eu07-486, 303e]
1
2
3
03.1

------------------------------------------------------------------------------------



Jak widac, do punktu 03.2 juz nie dochodzi. Usuwanie wyzej wymienionych zmiennych
nie wchodzi jednak w gre poniewaz sa niezbedne do poruszania sie pojazdow.

Zahashowanie...
ts.R=MyTrack->fRadius;
i zastapienie go wczesniejszym...
ts.R=ComputeRadius(Axle1.pPosition,Axle2.pPosition,Axle3.pPosition,Axle4.pPosition);
tez nic nie zmienia.


Zauwazylem jednak, ze wykszaczanie ma miejsce zawsze gdy przed pojazdem, na ktorym sie posypalo
jest pojazd i wykonane byl dla niego nastepujace procedury:

ABuFindObject()
ABuFindObject()
ABuFindObject()
ABuFindObject()
ABuFindObject()
ABuFindObject()
CouplersDettach(1, 1)



DEBUG.LOG CUT -------------------------------------------------------------------------------------

TDynamicObject::Update(0.01, 0.2)
[505120-00355-1, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0.00514322585473357)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-0, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0.00514238810071974)
08
09
10
15
16
ABuFindObject()
ABuFindObject()
ABuFindObject()
ABuFindObject()
ABuFindObject()
ABuFindObject()
CouplersDettach(1, 1)
17
TDynamicObject::Update(0.01, 0.2)
[eu07-503, 303e]
1
2
3
03.1

--------------------------------------------------------------------------------

Zasugerowany tym, postanowilem wylaczyc owe funkcje, ale jeszcze przed tym kopiuje caly sypiacy sie sklad ...


node -1 0 EU07-503 dynamic PKP\EU07 eu07-503 303E 0.0 headdriver 3 1 pantstate enddynamic
node -1 0 505120-00355-0 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 14 Passengers enddynamic
node -1 0 505120-00355-1 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 23 Passengers enddynamic
node -1 0 505120-00355-2 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 28 Passengers enddynamic
node -1 0 505120-00355-3 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 17 Passengers enddynamic
node -1 0 505120-00355-4 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 20 Passengers enddynamic
node -1 0 505120-00355-5 dynamic PKP\Wars #wars.tga wars 0.0 nobody 3 0 enddynamic
node -1 0 505120-00355-6 dynamic PKP\Adu #1klasa1.tga 112a 0.0 nobody 3 9 Passengers enddynamic
node -1 0 505120-00355-7 dynamic PKP\Adu #1klasa1.tga 112a 0.0 nobody 3 7 Passengers enddynamic


... na swoja testowa scenerie i co? No i.....


DEBUG.LOG CUT ------------------------------------------------------------------------------------------------------

PLAYER TRAIN INITIALIZATION ********************************
 
TTrain::TTrain()
TTrain::Init(eu07-503)
Player train init failed!
Ground.pTrain = Train;
Finding key events...
 

...
...

TDynamicObject::Update(0.01, 0.2)
[505120-00355-7, 112a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-6, 112a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-5, wars]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-4, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-3, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-2, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-1, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-0, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[eu07-503, 303e]
1
2
3
03.1

--------------------------------------------------------------------------------------------------------------------


Tu juz widze, ze nie ma ABuFindObject() i CouplersDettach(1, 1) wiec mysle sobie -  hmmmm parametr Passengers...

ale, ale czkaj... Dlaczego Player train init failed! na loku??? Czyzby Pantstate?


(node -1 0 EU07-503 dynamic PKP\EU07 eu07-503 303E 0.0 headdriver 3 1 pantstate enddynamic)

Zamieniam wpis na:

node -1 0 EU07-343 dynamic PKP\EU07 eu07-343.bmp 303E 0.0 headdriver 3 0 enddynamic

Odpalilo sie....Hmmmm.....ABu wieszz csooooo? Spie......., Popsules patyki, wszystko ogolnie ;)

Ale dobra Jeszcze nie ma co jechac po nickach ;) Czas na wylaczenie dwuch wyzej wymienionych funkcji.

Po wywaleniu ich nastepuje gowno.... Ale to z mojej winy bo zostawilem wywolania trj funkcji ;]
Wiec gowno nie.


DEBUG.LOG CUT ----------------------------------------------------------------------------------------------------------

TDynamicObject::Update(0.01, 0.2)
[505120-00355-7, 112a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0.0051396322429448)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-6, 112a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0.00514556914392935)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-5, wars]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0.00514008989901892)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-4, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0.00513577492291376)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-3, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0.0051461393445461)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-2, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0.00514942368744)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-1, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0.00514322585473357)
08
09
10
15
16
17
TDynamicObject::Update(0.01, 0.2)
[505120-00355-0, 111a]
1
2
3
03.1
03.2
04
05
06
07
TDynamicObject::Move(0.00514238810071974)
08
09
10
15
16


------------------------------------------------------------------------------------------------------------------------



CODE CUT ---------------------------------------------------------------------------------------------------------------


QueuedLog("16");
//ABu-160305 Testowanie gotowosci do jazdy
       if (Mechanik)
       {
          if (MoverParameters->BrakePress<0.01*MoverParameters->MaxBrakePress)
             Mechanik->Ready=true;
          TDynamicObject *tmp;
          tmp=GetLastDynamic(1);
          if(tmp!=this)
             if (tmp->MoverParameters->BrakePress>0.01*tmp->MoverParameters->MaxBrakePress)
                Mechanik->Ready=false;
          tmp=GetFirstDynamic(1);
          if(tmp!=this)
             if (tmp->MoverParameters->BrakePress>0.01*tmp->MoverParameters->MaxBrakePress)
                Mechanik->Ready=false;
       }

//ABu-160303 sledzenie toru przed obiektem: *******************************
    //Z obserwacji: v>0 -> Coupler 0; v<0 ->coupler1.
    //Rozroznienie jest tutaj, zeby niepotrzebnie
    //nie skakac do funkcji. Nie jest uzaleznione
    //od obecnosci AI, zeby uwzglednic np. jadace
    //bez lokomotywy wagony.
    EndTrack=false;
    if(CouplCounter>25)
    {
       if (
             (MoverParameters->V > 0)&&
             (MoverParameters->Couplers[0].CouplingFlag==ctrain_virtual)
          )
          ABuScanObjects(MyTrack, 1, 300);  
       if (
             (MoverParameters->V < 0)&&
             (MoverParameters->Couplers[1].CouplingFlag==ctrain_virtual)
          )
          ABuScanObjects(MyTrack,-1, 300);
       CouplCounter=random(20);
    }
    if (MoverParameters->V != 0)
       CouplCounter++;
    else
       CouplCounter=25;
QueuedLog("17");
}

bool __fastcall TDynamicObject::FastUpdate(double dt)

------------------------------------------------------------------------------------------------------------------------



Wywalamy 'testowanie gotowosci do jazdy' ....

Do czego to ma sluzyc? :> - WYWALILEM


... dalej ...


//ABu-160303 sledzenie toru przed obiektem: *******************************
    //Z obserwacji: v>0 -> Coupler 0; v<0 ->coupler1.
    //Rozroznienie jest tutaj, zeby niepotrzebnie
    //nie skakac do funkcji. Nie jest uzaleznione
    //od obecnosci AI, zeby uwzglednic np. jadace
    //bez lokomotywy wagony.
    EndTrack=false;
    if(CouplCounter>25)
    {
       if (
             (MoverParameters->V > 0)&&
             (MoverParameters->Couplers[0].CouplingFlag==ctrain_virtual)
          )
//          ABuScanObjects(MyTrack, 1, 300);  // REM BY Q
       if (
             (MoverParameters->V < 0)&&
             (MoverParameters->Couplers[1].CouplingFlag==ctrain_virtual)
          )
//          ABuScanObjects(MyTrack,-1, 300);  // REM BY Q
       CouplCounter=random(20);
    }
    if (MoverParameters->V != 0)
       CouplCounter++;
    else
       CouplCounter=25;
QueuedLog("17");


Wywalone odwolania do ABuScanObjects().

Po tym hashuje w hunterowej scenerii sklady-et22_1.scn siodemke z parametrem pantstate ...


trainset none krosowo_tor3-150m_ai 0.0 0.1
//node -1 0 EU07-503 dynamic PKP\EU07 eu07-503 303E 0.0 headdriver 3 1 pantstate enddynamic
node -1 0 505120-00355-0 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 14 Passengers enddynamic
node -1 0 505120-00355-1 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 23 Passengers enddynamic
node -1 0 505120-00355-2 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 28 Passengers enddynamic
node -1 0 505120-00355-3 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 17 Passengers enddynamic
node -1 0 505120-00355-4 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 20 Passengers enddynamic
node -1 0 505120-00355-5 dynamic PKP\Wars #wars.tga wars 0.0 nobody 3 0 enddynamic
node -1 0 505120-00355-6 dynamic PKP\Adu #1klasa1.tga 112a 0.0 nobody 3 9 Passengers enddynamic
node -1 0 505120-00355-7 dynamic PKP\Adu #1klasa1.tga 112a 0.0 nobody 3 7 Passengers enddynamic
endtrainset

... i jazda. Sceneria sie odpala :D


Na ten czas nie wiem, czy to pantstate czy funkcje ABu powodowaly taki stan rzeczy. Niemniej jednak stwierzam,
ze problem 674 zostal rozwiazany. Udanego szukania nowych bugs ;)

Dodano po 1 minutach:

 Aaaaaaaa....


http://www.members.lycos.co.uk/queued/exe/update100806.rar

Od moderatora: Doceniam wkład jaki wnosisz w ten wątek i ogólnie w symka, ale bardzo Cię proszę spróbuj skracać swoje posty. Na przykład można pominąć te linijki kodu, które i tak pewnie mało kto rozumie. Post wyszedł gigantyczny, chyba rozumiesz...

Offline EP08_015

  • Zasłużony dla Symulatora
  • Wiadomości: 4339
    • Zobacz profil
  • Otrzymane polubienia: 313
UNOFF REV290706
« Odpowiedź #88 dnia: 10 Sierpnia 2006, 13:31:14 »
Informuję z przykrością że moczniki et22 i linia546 z et22-1 się wy****sypuje. O dziwo w porównaniu z poprzednimi exekami np od 664 w zwyż to:

-na trasie MZD - odpaliło się
-fps z około 15 spadł mi do 1,5 :((((((

Coś ty narobił tam?

Queued czy jest sens dłubac w tym exeku? tak na siłe? Ja bym uznał że 664 jest ostatnim i oficjalnym exekiem i wsio gra. Mimo to podziwiam twój trud włozony w exeka.
Koniec tworczosci unoffowej i prywatnej.
http://chomikuj.pl/EP08-015

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
UNOFF REV290706
« Odpowiedź #89 dnia: 10 Sierpnia 2006, 13:37:31 »
:D:D:D:D:D wystaw log na rapidshare :D:D:D:D:D:D

Dodano po 2 minutach:

 Hmhmhmmh...Ta modyfikacja sprawila ze u mnie zaczela dzialac trasahuntera..... Ale jak napisalem jeszcze nie wiem czy pantstate czy ABu funkcje ....
Proponuje dla testu powywalac wsio co ma pantstate :)