Autor Wątek:  Problem z scenariuszem l053_calkowo-sluzba-tlk-1  (Przeczytany 9285 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline xZaGx

  • Wiadomości: 15
    • Zobacz profil
  • Otrzymane polubienia: 2
Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« dnia: 01 Września 2019, 22:53:05 »
Witajcie.

Mój problem polega na tym, iż dojeżdżam do pewnego momentu i ... klops...
Zanim zdecydowałem się zasięgnąć waszej porady do misji siadałem 3 razy. Za każdym razem ta sama sytuacja. Obszukałem internet, wasze forum oraz folder gry poszukując jakichkolwiek informacji. Niestety na nic…

Problem dotyczy scenerii l053_calkowo-sluzba-tlk-1. Przez całe pół godziny jadę według rozkładu I na każdej stacji znajduję się na czas. Po przejechaniu stacji Zlepieniec napotykam na swojej drodzę semafor S1

*


Zatrzymuję się przed nim. I mogę tak sobie tam czekać nawet godzinę… Na sąsiednim torze również stoi skład I ma przed sobą czerwone światło…

*


Gdy stwierdziłem że trwa to zbyt długo poleciałem na piechotę przed siebie i zobaczyłem skierowany w moją stronę skład który nie rusza pomimo tego, iż na semaforze przed nim widnieje S2.

*

Czy mógłbym was poprosić o jakąś wskazówkę?
Najmocniej przepraszam za jakość zdjęć. Mimo odpalonego symulatora printscreen robi zdjęcie pulpitu... A męczy mnie bardzo co zrobiłem źle, ponieważ ta sceneria przewiduje jeszcze ponad godzinę prowadzenia składu.

Z góry dziękuję za jakąkolwiek pomoc
Pozdrawiam

PS. poprawiłem screenshoty, dojechałem tam po raz czwarty. Niestety w tym momencie kończy się dla mnie scenariusz
« Ostatnia zmiana: 16 Września 2019, 16:16:44 wysłana przez MaciejM »

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2603
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #1 dnia: 01 Września 2019, 23:22:44 »
Puściłem bota to pominął Sr1 w Całkowie nie wiedzieć czemu i wyjechał na czołówkę. Zobaczę jutro co tam słychać. Jakbyś jeszcze próbował to podleć do tej siódemki co nie chce jechać i rozwiń jej z panelu debug (F12) vehicle, engine, ai scantable.
Mój kanał youtube

Offline Miłosz Dorsz

  • Moderator
  • Wiadomości: 1300
    • Zobacz profil
  • Otrzymane polubienia: 3315
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #2 dnia: 01 Września 2019, 23:25:58 »
Jak coś, to screenshoty nie wklejają się do schowka tak jak ma to miejsce przy screenowaniu np. pulpitu, tylko zapisują się w folderze screenshots, który znajduje się w głównym folderze z MaSzyną.
Projekty skończone i potencjalnie przyszłe: KLIK

Offline xZaGx

  • Wiadomości: 15
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #3 dnia: 02 Września 2019, 00:11:22 »
Puściłem bota to pominął Sr1 w Całkowie nie wiedzieć czemu i wyjechał na czołówkę. Zobaczę jutro co tam słychać. Jakbyś jeszcze próbował to podleć do tej siódemki co nie chce jechać i rozwiń jej z panelu debug (F12) vehicle, engine, ai scantable.

Przepraszam, nie do końca chyba rozumiem co do mnie napisałeś...
Wkleiłem kilka screenów. Nie wiem niestety czy to jest to czego potrzebowałeś

*
« Ostatnia zmiana: 16 Września 2019, 16:17:00 wysłana przez MaciejM »

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2603
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #4 dnia: 02 Września 2019, 00:26:32 »
Dobra, sterczy w trybie manewrowym z przerżniętym wskaźnikiem W5 pod składem. Dziwne, bo ma słowo kluczowe "rozklad" i niezerową prędkość startową, to powinna być w trybie liniowym. Tak czy inaczej muszę sam obadać co tam się dzieje. Dzięki.

Po pierwsze semafor cal_e jest nieprzypisany. Nie blokuje ai jak powinien. Ale twojego błędu nie udało mi się powtórzyć. Rzeczony skład przejechał z Sandomierza na koniec mapy nim do niego dojechałem.
Przejechałem ponownie na innym exeku i też bez problemów.
Daj log.txt.
« Ostatnia zmiana: 02 Września 2019, 18:55:33 wysłana przez Stele »
Mój kanał youtube

Offline xZaGx

  • Wiadomości: 15
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #5 dnia: 03 Września 2019, 23:36:22 »
To chyba to

Offline miko22

  • Wiadomości: 615
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 192
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #6 dnia: 03 Września 2019, 23:51:54 »
Ostatnio jak byłem w Warszawie z EN71, to miałem dokładnie ten sam problem na exe paczkowym z 19_08. Za każdym razem to samo, chyba ze dwadzieścia razy - S1 w tym miejscu, a jego pominięcie skutkowało wjechaniem w kozioł, ale nie miałem czasu sprawdzać, co tam dalej blokuje. Na 19_04 i poprzednich działało dobrze.

Offline xZaGx

  • Wiadomości: 15
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #7 dnia: 04 Września 2019, 00:13:32 »
Tutaj jest dokładnie to samo. Pomijając czerwony semafor nie wjadę na czołówkę z siódemką, tylko zlecę składem z torów.

Ale jestem uparty, jadę po raz piąty... Nie znam się za bardzo na mechanice tego symulatora, lecz tym razem uznałem że nie będę się przełączać w tryb ctrl+shift+f12 by podgonić czas oczekiwania. Wątpię, by miało to wpływ na zachowanie innych składów, lecz jeżeli Stele nie udało się powtórzyć mojego błędu próbuję doszukać się w nim mojej ingerencji...


Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2603
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #8 dnia: 04 Września 2019, 00:19:02 »
Z tym, że jechałem na exekach tmj190902 i M7sim190826. Teoretycznie nic tam w aspektach eventów i ai pociągów nie było zmieniane, ale cholera wie. Spróbujcie na nowszych a ja odkopię starsze. W każdym razie problemem jest to, że 303eb eu07-1504 mimo dostania semafora przed sobą nie wchodzi w tryb liniowy. Log urywa się w Sandomierzu, więc nic nie powie. Trzeba mi takiego z dojazdem do Furman aż rzeczona siódemka dostanie semafor. Jak dogracie poprawkę semafora w Całkowie: https://wiki.eu07.pl/websvn/revision.php?repname=pctga&path=%2F&rev=4330&peg=4330 to całość jest przejezdna dla ai w składzie gracza na przyspieszeniu.
Mój kanał youtube

Offline xZaGx

  • Wiadomości: 15
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #9 dnia: 04 Września 2019, 00:31:45 »
Niestety, ta sama historia

*



Nie wiem czy ma to jakiekolwiek znaczenie, jak napisałem wcześniej konstrukcja tego symulatora jest mi kompletnie obca... Jednakże zaskoczyło mnie trochę, iż pociąg równolegle czekający ze mną na zielone światło również przełączony jest w tryb manewrowania. Lecz być może nie jest to w ogóle istotna rzecz...

*
« Ostatnia zmiana: 16 Września 2019, 16:17:17 wysłana przez MaciejM »

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2603
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #10 dnia: 04 Września 2019, 13:06:21 »
Chyba nie. Na tym scenariuszu nie ma oskryptowanego zbytniego ruchu ai. One tam startują, twoje zbliżenie się podaje im semafory i jadą kilka km raptem. Ma niezerową prędkość początkową, więc się uruchamia. Stoi sobie taki w trybie manewrowym (Shunt) i podanie mu semafora (komendy SetVelovity) w drodze skanowania toru powinno go przełączyć w tryb liniowy (ObeyTrain). U ciebie z jakiegoś powodu się to nie dzieje.
Mój kanał youtube

Offline Marconi

  • Zasłużony dla Symulatora
  • Wiadomości: 398
    • Zobacz profil
  • Otrzymane polubienia: 61
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #11 dnia: 04 Września 2019, 16:15:38 »
Potwierdzam. Po dojeździe do Furman stajemy pod semaforem. EU07-1512 nie reaguje na podany sygnał i blokuje drogę. Ponadto sama lokomotywa dziwnie się zachowuje. Po przejęciu lokomotywy np. nie można przełączyć świateł. To samo dzieje się na .exe z 31 sierpnia (przedostatnia wersja). Będę dalej testował, żeby ustalić ostatnie dobrze działające .exe.
« Ostatnia zmiana: 06 Września 2019, 13:04:56 wysłana przez Marconi »
Pozdrawiam.

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2603
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #12 dnia: 04 Września 2019, 16:48:24 »
Odpaliłem scenariusz na exe z ostatniej paczki. Również działa. Co lepwsze oba składy w Furmanach wchodzą w jazdę liniową od razu. Nie czekają na sygnał w manewrowym. Nie mam pomysłu co wam nie działa. Jak ktoś się przejedzie i złapie buga, to oprócz logu poproszę scenery/$l053_calkowo-sluzba-tlk-1.scn.

xZaGx wyświetlanie sieci masz wyłączone ze względów wydajnościowych? Rozumiem intel, ale nie tędy droga. Po pierwsze skręć multisampling, potem przełącz się na uproszczony renderer by ciachnąć cienie i odbicia.
Mój kanał youtube

Offline xZaGx

  • Wiadomości: 15
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #13 dnia: 04 Września 2019, 17:52:28 »
Dokładnie tak. Wyłączyłem ze względów wydajnościowych.

Multiasampling miałem nakręcone na max, w ogóle nie zwróciłem na to uwagi. O wiele płynniej się to wszystko teraz odbywa i to przy włączonych liniach trakcyjnych, i bardzo za to dziękuję...
Mógłbyś mi tylko w skrócie napisać gdzie mogę się przełączyć na uproszczony render? Nie mogę tego nigdzie znaleźć.

Bardzo dziękuję za pomoc



Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2603
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #14 dnia: 04 Września 2019, 18:11:03 »
Bo starter jest cztery lata za paczką. eu07.ini gfxrenderer simple.
Mój kanał youtube

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #15 dnia: 04 Września 2019, 18:25:10 »
Puscilem ten scenariusz u siebie, pliki z paczki 19.08 i exe 19.902. Obawiam sie ze poza --wspomnianym przez Stele-- semaforem w Calkowie niepodpietym do toru i brakiem instrukcji dla ai by odpiac sie od skladu po dojezdzie do Debicy "u mnie tez dziala" ;/

Offline Marconi

  • Zasłużony dla Symulatora
  • Wiadomości: 398
    • Zobacz profil
  • Otrzymane polubienia: 61
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #16 dnia: 04 Września 2019, 20:33:45 »
Dla sprawdzenia najnowszego .exe puściłem scenariusz na plikach paczki 19.04. Działa bez zarzutu. Przestałem cokolwiek z tego rozumieć.
Pozdrawiam.

Offline xZaGx

  • Wiadomości: 15
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #17 dnia: 04 Września 2019, 21:44:29 »
Być może zadam bardzo głupie pytanie... Może powinienem odinstalować i zainstalować MaSzyne na nowo ?

Offline Marconi

  • Zasłużony dla Symulatora
  • Wiadomości: 398
    • Zobacz profil
  • Otrzymane polubienia: 61
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #18 dnia: 06 Września 2019, 13:01:26 »
Rozwiązałem problem blokującego składu w Furmanach. Z kilku możliwych opcji wybrałem najprostszą: zmieniłem sposób uruchamiania lokomotywy z pociągowego na manewrowy. Po podaniu sygnału na semaforze Furmany_A, lokomotywa przełącza się w tryb pociągowy i rusza w drogę.
Pozdrawiam.

Offline miko22

  • Wiadomości: 615
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 192
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #19 dnia: 06 Września 2019, 13:24:38 »
Mógłbyś opisać, jak to zrobić?

Offline M79r

  • Wiadomości: 184
    • Zobacz profil
  • Otrzymane polubienia: 189
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #20 dnia: 06 Września 2019, 14:27:38 »
A gdzie elektrowozy kabel mają ... Co wy na wifi jeździcie ? :D

Offline Marconi

  • Zasłużony dla Symulatora
  • Wiadomości: 398
    • Zobacz profil
  • Otrzymane polubienia: 61
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #21 dnia: 06 Września 2019, 15:12:03 »
Mógłbyś opisać, jak to zrobić?
Otwierasz plik składy w katalogu linia053_calkowo/sluzba_tlk-1 i odnajdujesz skład:
Cytuj
trainset rozklad furmany_brutto1_start 0.0 5.0
node -1 0 EU07-1512 dynamic pkp\303e_v1 303eb-zez-1512 303eb-zez 0.0 headdriver 3 0 enddynamic
...
endtainset
i zmieniasz istniejącą wartość 5.0 na 0.1.
Pozdrawiam.

Offline xZaGx

  • Wiadomości: 15
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #22 dnia: 06 Września 2019, 21:18:47 »
Niestety, w moim przypadku to nie pomogło...

*
« Ostatnia zmiana: 16 Września 2019, 16:17:26 wysłana przez MaciejM »

Offline Marconi

  • Zasłużony dla Symulatora
  • Wiadomości: 398
    • Zobacz profil
  • Otrzymane polubienia: 61
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #23 dnia: 06 Września 2019, 21:33:44 »
Szukając rozwiązania w jednym ze sposobów zaremowałem 10 ostatnich wagonów. Skład zareagował i w trybie manewrowym podciągnął pod semafor wjazdowy. Po otrzymaniu S2 ruszył w trybie pociągowym. Jednak skoro najprostszy sposób nie zadziałał, nie spodziewam się poprawy, ale spróbuj.
Edit:
A jednak trzeba skrócić skład o 10 wagonów. Po skróceniu na trzy próby zadziałał za każdym razem.
« Ostatnia zmiana: 06 Września 2019, 23:07:14 wysłana przez Marconi »
Pozdrawiam.

Offline mac310

  • Zasłużony dla Symulatora
  • Wiadomości: 518
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 73
Odp: Maszyna 19.08 - problemy
« Odpowiedź #24 dnia: 07 Września 2019, 00:18:41 »
l053_calkowo_sluzba-tlk-1 po dojechaniu do podg Furmany przed Sandomierzem mam S1 i nic się nie dzieje. Obok mnie stoi brutto i też czeka. Wybrałem się zatem na spacer w kierunku Sandomierza, a tam przed mostem stoi sobie brutto z kontenerami i czeka. Semafor w kierunku podg Furmany ma podany ale nie jedzie. No i tak sobie wszyscy stoimy.
Historia budowy pulpitu lokomotywy serii EU07.

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1038
    • Zobacz profil
  • Otrzymane polubienia: 870
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #25 dnia: 07 Września 2019, 01:13:28 »
Nie wiem czemu wam to nie działa. Puściłem AI na 19.08 i przejechało do końca bez problemów (poza chęcią pominięcia semafora w całkowie).

Offline Marconi

  • Zasłużony dla Symulatora
  • Wiadomości: 398
    • Zobacz profil
  • Otrzymane polubienia: 61
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #26 dnia: 07 Września 2019, 01:40:50 »
Znalazłem. Występuje jakaś dziwna interakcja między inicjacją składu, a zdarzeniem LineInfo:Sandomierz-Wilis. Skład ten jest na tyle długi, że ogon zajmuje tor, do którego jest przywiązane to zdarzenie. Po odłączeniu wagonów zajmujących ten tor lub zablokowaniu tego zdarzenia, skład reaguje na sygnały. Jednak nie uruchamia się w trybie pociągowym, jak to jest w opisie, lecz w trybie manewrowym. Podciąga skład pod semafor, a w tryb pociągowy przechodzi dopiero po otrzymaniu sygnału S2.
node 1000 0 none track normal 100.0 1.435 0.25 35.0 20 0 Flat vis
 Rail_screw_used1 4 TpD-oil3 0.2 0.5 1.1
-18459.9 0.199999 53196.8 0.0 //point 1
0.0 0.0 0.0 //control vector 1
0.0 0.0 0.0 //control vector 2
-18459.9 0.199999 53296.8 0.0 //point 2
0
//event2 LineInfo:Sandomierz-Wilis
endtrack
« Ostatnia zmiana: 07 Września 2019, 01:57:04 wysłana przez Marconi »
Pozdrawiam.

Offline Transkei

  • Deweloper
  • Wiadomości: 649
    • Zobacz profil
  • Otrzymane polubienia: 884
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #27 dnia: 07 Września 2019, 08:06:25 »
Niestety, w moim przypadku to nie pomogło...
*
Na tym obrazku widać, że wszystkie wagony tego składu mają identyczne nazwy dynamic. I zacząłbym od poprawienia tego, bo przy zduplikowanych nazwach niby wszystko działa, ale bardzo różne kwiatki wychodzą.
« Ostatnia zmiana: 16 Września 2019, 16:17:36 wysłana przez MaciejM »

Offline Marconi

  • Zasłużony dla Symulatora
  • Wiadomości: 398
    • Zobacz profil
  • Otrzymane polubienia: 61
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #28 dnia: 07 Września 2019, 11:16:49 »
Piszę dla tych, którzy mają problem z tym scenariuszem. Po sprawdzeniu różnych opcji doszedłem do wniosku, że w zasadzie istnieją dwa rozwiązania:
1. Skrócić skład z kontenerami o 10 wagonów,
2. Przenieść skład do Sandomierza Towarowego. Jednak ta opcja wymaga ingerencji w plik events dla ułożenia drogi przejazdu. Zapewne nie każdy sobie z tym poradzi.
Temat uważam za wyczerpany.
Pozdrawiam.

Offline xZaGx

  • Wiadomości: 15
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Problem z scenariuszem l053_calkowo-sluzba-tlk-1
« Odpowiedź #29 dnia: 07 Września 2019, 20:25:01 »
Czy mógłbym prosić jedynie o pomoc jak skrócić ten skład? Jak podmienić dane które podał Marconi? Doszedłem do tego, że chodzi tu chyba o plik tory.txt, lecz nie mogę znaleźć tam odpowiedniej linijki gdzie podmienić dane...

Z góry bardzo dziękuję za pomoc