Autor Wątek:  MaSzyna 18.12 - problemy  (Przeczytany 38870 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1012
    • Zobacz profil
  • Otrzymane polubienia: 763
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #90 dnia: 11 Grudnia 2018, 20:26:15 »
No to raczej nic konkretnego, po prostu nie wyrabia.
Zmniejsz multisampling, dopisz do ini
gfx.format.color r11f_g11f_b10f
Można też gfx.skippipeline yes, ale to wyłącza graficzne dodatki.

Offline Waldi 1978

  • Zasłużony dla Symulatora
  • Wiadomości: 106
    • Zobacz profil
  • Otrzymane polubienia: 22
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #91 dnia: 11 Grudnia 2018, 20:41:21 »
Dzięki za szybką odpowiedż sprawdzę. Symulator aż tak zasobożerny? Może to zły przykład ale pogrywam czasami  w Wiedzmina 3 i tam z włączonymi wszystkimi możliwymi bajerami mam średnio 90 fps :)

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1012
    • Zobacz profil
  • Otrzymane polubienia: 763
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #92 dnia: 11 Grudnia 2018, 21:10:11 »
Na CPU pewnie symulator jest bardziej zjadliwy. O tyle dziwne bo shadery powinny zmieniać głównie obciążenie GPU, a 1070Ti powinno się wyrabiać. Nie jestem pewny, może znowu kwestia sterowników GL1 a GL3.

Offline JAN21

  • Deweloper
  • Wiadomości: 396
    • Zobacz profil
  • Otrzymane polubienia: 1171
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #93 dnia: 11 Grudnia 2018, 23:23:39 »
Od siebie mogę dodać, że od pewnego momentu, chyba od wprowadzenia DX11, rozdzielczość cieni zaczęła znacząco ograniczać wydajność. Jak na starych wersjach gl3.3 i cieniach 8192 było stabilne 60fps tak teraz na cieniach 2048 jest ledwo stabilne 60fps.
Nie warto było robić nic.

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #94 dnia: 12 Grudnia 2018, 03:50:06 »
Dzięki za szybką odpowiedż sprawdzę. Symulator aż tak zasobożerny? Może to zły przykład ale pogrywam czasami  w Wiedzmina 3 i tam z włączonymi wszystkimi możliwymi bajerami mam średnio 90 fps :)
Z 16x multisamplingiem?

Sprobuj oprocz pozostalych elementow wylaczyc vsync; przy wlaczonym wystarczy drobny spadek ponizej 60 fps by zrobilo sie 30.
« Ostatnia zmiana: 12 Grudnia 2018, 03:53:28 wysłana przez tmj »

Offline centarail

  • ZbanowanyZbanowany
  • Wiadomości: 186
    • Zobacz profil
  • Otrzymane polubienia: 72
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #95 dnia: 12 Grudnia 2018, 11:58:30 »
Kolejne rewelacje... i milion dni testów poszedł się paść.

Brak możliwości zmiany lokomotywy. Wpis w .scm -> otwarcie rainsted -> dalej ta sama lokomotywa mimo wpisu w .scm. Podjęto próby aktualizacji Rainsted - bez skutku, aktualnie przeinstalowuję SuperMaSzynę. Zobaczymy czy to coś da.
« Ostatnia zmiana: 12 Grudnia 2018, 17:21:40 wysłana przez Stele »

Offline Waldi 1978

  • Zasłużony dla Symulatora
  • Wiadomości: 106
    • Zobacz profil
  • Otrzymane polubienia: 22
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #96 dnia: 12 Grudnia 2018, 12:56:30 »
Dzięki za szybką odpowiedż sprawdzę. Symulator aż tak zasobożerny? Może to zły przykład ale pogrywam czasami  w Wiedzmina 3 i tam z włączonymi wszystkimi możliwymi bajerami mam średnio 90 fps :)
Z 16x multisamplingiem?

Sprobuj oprocz pozostalych elementow wylaczyc vsync; przy wlaczonym wystarczy drobny spadek ponizej 60 fps by zrobilo sie 30.

Wczytałem dziś ustawienia domyślne panelu strerowania kartą,  wyłaczyłem v-sync na ustawaniech multisampling x16 i x8. Poprawa jest widoczna min co widziałem to 50 fps. Ja jakoś nie widziałem różnicy w ilości fps zmniejszając wartości multisamplingu nawet na min może ja ślepy :) ale co wpadło w oko to bardzo szybkie spadki i wzloty fps co czasami powoduje ścinki. Miałem troszke czasu i w domowy sposób sprawdziłem u siebie jak Maszyna sobie radzi na moim procesorze. Nie wykorzystuje całej danej mocy co może być czasami problemem w wydajności. Tmj@ co do Wiedzmina to nie wiem jakie tam są ustawienia bo nie ma tam żadnych podanych cyfer. W  załącznikach będzie widać jak maszyna męczy procesor i jego rdzenie wraz z wątkami i ustwieniach w Wiedzminie. 
I dzięki za pomoc :)   

Offline centarail

  • ZbanowanyZbanowany
  • Wiadomości: 186
    • Zobacz profil
  • Otrzymane polubienia: 72
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #97 dnia: 12 Grudnia 2018, 16:22:04 »
Tak przeinstalowanie nic nie dało. Pojawiły się jeszcze lepsze kwiatki - takie jak samoobsługujący się hamulec lokomotywy czy białe ściany lasu.
Loka udało się zmienić przez Rainsted usuwając dotychczasową ET22 i wstawiając wybraną EU07.

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1012
    • Zobacz profil
  • Otrzymane polubienia: 763
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #98 dnia: 12 Grudnia 2018, 16:24:50 »
Brak możliwości zmiany lokomotywy. Wpis w .scm -> otwarcie rainsted -> dalej ta sama lokomotywa mimo wpisu w .scm. Podjęto próby aktualizacji Rainsted - bez skutku, aktualnie przeinstalowuję SuperMaSzynę. Zobaczymy czy to coś da.
Witamy przybysza z przeszłości. (no bo milion dni temu to był 720r. p.n.e.)
Najprawdopodobniej po zapisie scn trzeba zrestartować rainsted.

Offline centarail

  • ZbanowanyZbanowany
  • Wiadomości: 186
    • Zobacz profil
  • Otrzymane polubienia: 72
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #99 dnia: 12 Grudnia 2018, 16:33:13 »
Brak możliwości zmiany lokomotywy. Wpis w .scm -> otwarcie rainsted -> dalej ta sama lokomotywa mimo wpisu w .scm. Podjęto próby aktualizacji Rainsted - bez skutku, aktualnie przeinstalowuję SuperMaSzynę. Zobaczymy czy to coś da.
Najprawdopodobniej po zapisie scn trzeba zrestartować rainsted.

Tak zrobiłem...

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #100 dnia: 12 Grudnia 2018, 16:36:31 »
Pojawiły się jeszcze lepsze kwiatki - takie jak samoobsługujący się hamulec lokomotywy czy białe ściany lasu.
A log albo errors tez sie pojawily? Bo bez nich to sobie mozna...

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1012
    • Zobacz profil
  • Otrzymane polubienia: 763
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #101 dnia: 12 Grudnia 2018, 16:42:17 »
Waldi 1978: Chyba standardowo mi zostaje zwalić winę na sterowniki GL.
Optymalizację renderera będę robił później, może luty/marzec.
Taka ciekawostka, z ciekawości odpaliłem l053_poranek u mnie, i jest ~22fps zarówno na legacy i shaderach.

Offline Bart28

  • Wiadomości: 16
    • Zobacz profil
  • Otrzymane polubienia: 15
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #102 dnia: 12 Grudnia 2018, 23:46:06 »
Witam, na forum jestem nowym użytkownikiem, jednak w Maszynę gram od kilku miesięcy. Mam dosyć nietypowe problemy związane z 2 rzeczami:

- końcówkami niektórych wagonów osobowych,
- dźwignią hamulca pomocniczego w lokomotywach oraz nastawnika prędkości tempomatu w Bombardier Traxx

A więc zacznijmy od tych końcówek. Dotychczas, jak klikałem E w celu włączenia końcówek w wagonach osobowych (nie licząc bezprzedziałowych Regio Express oraz tych z teksturami DDS bez wnętrza) zapalały się normalne końcówki elektryczne z normalną mocą. W Maszynie 18.12 po kliknięciu E końcówki owszem się zapalają, ale są to "zastępcze" końcówki, których z daleka nie widać tak, jak tych zwyczajnych. Oczywiście można użyć Shift+E, aby załączyć normalne końcówki i ponownie E, aby wyłączyć te zastępcze, jednak ich moc porównywalna jest do tego, jakby zamiast żarówki była tam... może świeczka?? Oczywiście z dalszej odległości wszystko działa normalnie, jedynie w nocy zapalone końcówki wyglądają tak, jakby światło brało się z nikąd, jak w wagonach z teksturami DDS. Końcówki wagonów towarowych działają bez zarzutu.

Następną rzeczą jest wspomniany hamulec pomocniczy i dźwignia nastawnika prędkości tempomatu w Bombardier Traxx. W Maszynie 18.10 można było sterować nimi za pomocą myszy i nie powracały na pozycję 0, tak jak ma to miejsce w wersji 18.12. Po prostu klikam na hamulec (lub nastawnik tempomatu), przesuwam go i jak puszczę LPM, powraca do pozycji 0.

Dodam, że te same błędy występują u mnie zarówno po 2 reinstallu Maszyny (z bibliotekami UCRT i bez) oraz na drugim komputerze. Korzystałem oczywiście z najnowszej wersji instalatora. W wersji 18.10 edytowałem i dodawałem niektóre scenerie, mimo to nawet z oryginalnym folderem scenery i wszystkimi innymi dzieje się to samo.

Cześć! Zgodnie z regulaminem forum (https://eu07.pl/forum/index.php/topic,17793.0.html) grafiki wrzucane jako załącznik nie mogą być większe niż 250 KB - uprzejmie proszę o poprawienie.
@MaciejM
« Ostatnia zmiana: 12 Grudnia 2018, 23:56:13 wysłana przez MaciejM »

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2602
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #103 dnia: 13 Grudnia 2018, 00:38:37 »
Końcówki to błąd w modelu. Jest poprawione od kilku dni. Będzie w kolejnej aktualizacji. Istotnie nie świeciły się.
Błąd z wajchami potwierdzam. Występuje również na najnowszych buildach Milka i tmj.
Mój kanał youtube

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #104 dnia: 13 Grudnia 2018, 01:00:53 »
Poprawka na dzialanie wajch bedzie w nastepnym uaktualnieniu. W miedzyczasie obsluga z klawiatury powinna funkcjonowac normalnie.

Offline Konrad_74

  • Wiadomości: 47
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #105 dnia: 13 Grudnia 2018, 03:13:01 »
Witam. jesli ktos jest zainteresowany tymczasowym rozwiazaniem, ktore zapewnia powrot lasow na L61 to prosze bardzo. Nalezy wrzucic  dwa zalaczone w paczuszce pliki do katalogu "textures". Z "errors" wynika, ze symulator probuje wczytac nieistniejaca teksture o nazwie "forest_b7". Skopiowalem wiec "forest_b8", zmenilem nazwe na forest_b7, dorzucilem do odpowiedniego katalogu. Dziala.
« Ostatnia zmiana: 13 Grudnia 2018, 03:56:38 wysłana przez Konrad_74 »

Offline joey

  • Deweloper
  • Wiadomości: 415
  • the Invisible Man
    • Zobacz profil
  • Otrzymane polubienia: 201
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #106 dnia: 13 Grudnia 2018, 06:26:42 »
Okazuje sie, ze przyczyna braku teksury lasu byla literowka w pliku forest_b8.mat. Poprawione w rev. 3283.

Offline Przemekm

  • Wiadomości: 154
    • Zobacz profil
  • Otrzymane polubienia: 8
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #107 dnia: 14 Grudnia 2018, 12:48:07 »
Mam problem z cieniami. Przy ruszeniu kamerą cień pokrywa cały teren. Przy widoku z zewnątrz jest ok. Natomiast w lokomotywie zależnie od kąta patrzenia kamery cień na zewnątrz pokrywa cały widoczny teren lub nie. Czasami są w nim kwadratowe dziury oświetlone.

Offline Krzysiek009

  • Wiadomości: 19
    • Zobacz profil
  • Otrzymane polubienia: 6
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #108 dnia: 14 Grudnia 2018, 21:56:30 »
Czyli nie ma rozwiązania na mój problem / problemy?

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1012
    • Zobacz profil
  • Otrzymane polubienia: 763
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #109 dnia: 14 Grudnia 2018, 22:00:56 »
Przemekm: Jaka karta, które exe, legacy czy shaderowe?
Krzysiek009: Tak jak pisałem, 'Sprawdź posiadany tabor' musi pomóc na tekstury.

Offline Krzysiek009

  • Wiadomości: 19
    • Zobacz profil
  • Otrzymane polubienia: 6
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #110 dnia: 15 Grudnia 2018, 00:19:39 »
A ja później odpisałem, że "Sprawdź posiadany tabor" nic nie zmieniło.

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1012
    • Zobacz profil
  • Otrzymane polubienia: 763
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #111 dnia: 15 Grudnia 2018, 00:51:05 »
Ale musiało, nie ma siły żeby ustawiło taką teksturę przy takim textures.txt jaki jest :D

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #112 dnia: 15 Grudnia 2018, 01:53:11 »
W scenariuszu Bałtyk_Interregio nie da się odpiąć wagonów w żaden sposób (Przynajmniej u mnie)
Sprawdzilem to przy okazji, i obawiam sie ze "u mnie dziala" ;/

Rozlaczenie okazalo sie lekko klopotliwe, podejscie na leniwca rzeczywiscie nic nie dalo (sklad nie byl dostatecznie docisniety, pozostal odstep na poziomie paru milimetrow) niemniej nastepnie po solidnym zahamowaniu skladu, zluzowaniu hamulca lokomotywy i drobnym ruchu w przod a nastepnie ponownie do tylu sklad udalo mi sie rozpiac -- w zalaczniku dowod ;d
« Ostatnia zmiana: 15 Grudnia 2018, 02:12:07 wysłana przez tmj »

Offline matek123

  • Moderator
  • Wiadomości: 5680
    • Zobacz profil
  • Otrzymane polubienia: 1800
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #113 dnia: 15 Grudnia 2018, 09:44:39 »
A ja później odpisałem, że "Sprawdź posiadany tabor" nic nie zmieniło.
Pobierałeś patch instalatorem, czy ręcznie torrentem?
Poszukuję zdjęć na tekstury pociągów sieciowych. Szczególnie platform z pomostami.

Offline Krzysiek009

  • Wiadomości: 19
    • Zobacz profil
  • Otrzymane polubienia: 6
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #114 dnia: 15 Grudnia 2018, 15:13:11 »
Instalator

Sprawdzilem to przy okazji, i obawiam sie ze "u mnie dziala" ;/
Spróbuję jeszcze, ale wątpię aby się udało jak na torze doświadczalnym nic nie dało :/

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #115 dnia: 15 Grudnia 2018, 16:29:10 »
Sprobuj jakby co tak, jak to zadzialalo u mnie: zahamuj porzadnie sklad (Num2), zluzuj hamulec w lokomotywie odluzniaczem, daj dla pewnosci lekko do przodu, a potem do tylu, tak nie za ostro.

Ze swojej strony zobacze czy nie warto w kodzie lekko zmniejszyc tutaj wymagan, bo przy roznicy rzedu dziesiatych milimetra nie powinien raczej blokowac rozpiecia.

Offline Krzysiek009

  • Wiadomości: 19
    • Zobacz profil
  • Otrzymane polubienia: 6
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #116 dnia: 15 Grudnia 2018, 22:14:23 »
Dałem i nic nie dało, tylko bufory zaczęły latać, gdy docisnąłem tak że skład aż jechał gdy był zahamowany to się udawało (Aż 10km/h), czyli mam jakiś sposób :P

Offline JAN21

  • Deweloper
  • Wiadomości: 396
    • Zobacz profil
  • Otrzymane polubienia: 1171
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #117 dnia: 28 Grudnia 2018, 14:23:29 »
Na gl3.3 takie dziwy z oświetleniem. Nawet z wyłączonymi światłami ten jeden tor jest wyraźnie jaśniejszy.
Nie warto było robić nic.

Offline Max_EN_57

  • Wiadomości: 15
    • Zobacz profil
  • Otrzymane polubienia: 3
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #118 dnia: 02 Stycznia 2019, 19:03:02 »
Jechałem dzisiaj Linią 053 (wieczór) ROJ23171 Kolei Mazowieckich z Dębicy do Sandomierza. W Turowie nie dostałem na semaforze wyjazdu ze stacji. Zauważyłem za to, że brązowa EU07 stojąca obok (AI) dostała białe światło manewrowe ale nie ruszała. Dopiero przejście do ów lokomotywy i ruszenie nią ręcznie przed siebie (musiałem ręcznie uruchomić sprężarkę do pantografu, bo nie chciały się podnieść) odblokowało kolejne eventy. Potem gdy wróciłem do EN57 Kolei Mazowieckich to pojawił się znowu problem, który już zgłaszałem w lipcu w Systemie Zgłaszania Błędów (brak runningnoise po przejściu do AI). MaSzyna w najnowszej wersji, niedawno na czysto instalowana. W załączeniu log i errors w pliku zip, ponieważ bezpośrednio pliki txt nie chciały się wrzucić. Zapomniałem dodać: najnowsze exe x64_181229 od tmj. Pozdrawiam!
« Ostatnia zmiana: 02 Stycznia 2019, 19:20:10 wysłana przez Max_EN_57 »

Offline Turbokibel

  • Zasłużony dla Symulatora
  • Wiadomości: 1533
    • Zobacz profil
  • Otrzymane polubienia: 1245
Odp: MaSzyna 18.12 - problemy
« Odpowiedź #119 dnia: 05 Stycznia 2019, 10:05:29 »
Cześć.  Jest problem z drzwiami w EN57 obojętnie jakim tylko oprócz 20xx
Jeśli zamykamy drzwi to dźwięk zamknięcia jest dopiero o 0.5 sekundy później niż drzwi fizycznie się zamknęły . Czyli chodzi tu po prostu o synchronizację dźwięków . We wszystkich członach się tak dzieje , tylko w co drugich drzwiach jest inny dźwięk ale nadal jest opóźniony dźwięk. 
exe x64_181229 od tmj.


Już zrobiłem I działa, przekazałem do Pana Stele.
« Ostatnia zmiana: 06 Stycznia 2019, 19:51:16 wysłana przez Turbokibel »