Autor Wątek:  Shaderowe exe do testów  (Przeczytany 13516 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Shaderowe exe do testów
« dnia: 16 Lipca 2018, 01:14:29 »
Drugie podejście do shaderowego exe, po, uh, roku czasu.
Wymagane OpenGL 3.3.

https://ci.appveyor.com/project/Milek7/maszyna/build/228/artifacts
wypakować exe i folder z shaderami do folderu shaders a nie luzem do roota!
wywalić e3d skydome_stars (użyć t3d)
dodać textures/stars.mat z zawartością shader: stars
dodać textures/sky/stratus.mat z texture1 teksturą chmur i shader: clouds
dodać textures/colored.mat z zawartością shader: colored
dodać textures/invalid.mat z zawartością shader: invalid

przetestować
Są to testy techniczne exe, czyli czy się nie wysypuje i nie ma kaszanki na ekranie. Walorów artystycznych brak, więc informacje że prześwietlone, przepalone, niedoświetlone mnie obecnie nie interesują.
Dokumentacja .mat i shaderów na wiki.

obecnie nie działa wyświetlanie ciał niebieskich i pickowanie w scenerii
« Ostatnia zmiana: 02 Sierpnia 2018, 21:03:12 wysłana przez Milek7 »

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8725
    • Zobacz profil
  • Otrzymane polubienia: 1669
Odp: Shaderowe exe do testów
« Odpowiedź #1 dnia: 16 Lipca 2018, 02:28:48 »
Jest to co już pokazywałeś. Obiekty na alfa-teście z 100% alfy, jak alternatywne klocki lokomotywy, dają dziury.
Na obiektech bez reflection, wagonach, wnętrzach wagonów, domkach, pojawia się projekcja cubemapy. Nawet na trawie odbija się słońce.
Elementy  burym diffuse, jak wnętrza wagonów, to olewają. Mają pełną jasność po załączeniu emisyjności.
Nie działają światła w domkach z lights 5. Nie zmergowałeś tego?
Kompletny brak smugi, a coś pokazywałeś.
Star shader jakiś dziwny. Wziąłeś poprawkę, że Ra nie podawał tam kolejności w RGB tylko coś poprzekręcał? Na wiki jest napisane jak.
Przy włączeniu trybu vireframe w debugu, pokazuje jednego quada na cały ekran, blokując kamerę/zawieszając grę. Reszta sceny jest niewzruszona.

Na TD mam 16.7 ms cpu i 3.1 gpu. Na najnowszym exe tmj mam 0.8 ms cpu i 15.5 ms gpu.
« Ostatnia zmiana: 16 Lipca 2018, 11:02:38 wysłana przez Stele »
Mój kanał youtube

Offline tmj

  • Deweloper
  • Wiadomości: 3526
    • Zobacz profil
  • Otrzymane polubienia: 1927
Odp: Shaderowe exe do testów
« Odpowiedź #2 dnia: 16 Lipca 2018, 02:31:07 »
"u mnie dziala"

Gdy kamera wycelowana jest "w gore" tzn. powyzej linii rownoleglej do horyzontu cos sie chyba sypie przy kalkulacji obszaru shadow mapy, lub samej shadow mapy -- moze tutaj pomoc zostawienie na mapie 'pustej' ramki szerokosci 1 piksela; w starym rendererze sluzyla do tego aktywacja scissor test.

edit: lampki kontrolne w kabinie siudemky swieca na bialo zamiast w kolorze diffuse submodelu.
« Ostatnia zmiana: 16 Lipca 2018, 02:36:05 wysłana przez tmj »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Odp: Shaderowe exe do testów
« Odpowiedź #3 dnia: 16 Lipca 2018, 09:27:43 »
Tak, nie podpiąłem jeszcze reflectionmapy do shadera więc wszystko się odbija. tmj: to chyba nie shadowmapa tylko właśnie reflection.
lights 5 chyba jeszcze nie jest zmergowane.
Gwiazdy poprawię, zapomniałem że są pomieszane kolory.
Czasy minimalnie większe bo lepsze oświetlenie. (inny rozkład cpu/gpu dlatego że to się inaczej mierzy niż u tmj, cpu to jest cpu+gpu z tmj, a gpu tmj nie pokazuje).
Wireframe poprawię.
Alpha test hm, powinien działać ale jeszcze zobaczę.
Smuga też jakaś powinna być. Jakie masz gpu?
« Ostatnia zmiana: 16 Lipca 2018, 09:28:53 wysłana przez Milek7 »

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8725
    • Zobacz profil
  • Otrzymane polubienia: 1669
Odp: Shaderowe exe do testów
« Odpowiedź #4 dnia: 16 Lipca 2018, 11:02:00 »
GTX1060 ze sterownikiem jakimś sprzed dwóch tygodni.
Myślałem, że coś na sztywno uciąłeś, ale na screenie tmj jest render distance x3. U mnie było 1.5 przy capie 60 fps.
« Ostatnia zmiana: 16 Lipca 2018, 11:29:49 wysłana przez Stele »
Mój kanał youtube

Offline AK2012

  • Wiadomości: 388
    • Zobacz profil
  • Otrzymane polubienia: 135
Odp: Shaderowe exe do testów
« Odpowiedź #5 dnia: 16 Lipca 2018, 12:10:07 »
Z tego, co na szybko zauważyłem, wskazówki na manometrach wyglądają tak, jak na screenie (testowane w EP07-10XX). Poza tym nie świeci się światło w kabinie.

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Odp: Shaderowe exe do testów
« Odpowiedź #6 dnia: 16 Lipca 2018, 13:21:43 »
Cytuj
Próbowałem uruchomić to shaderowe exe, ale pojawi mi się błąd: cannot read shader vertex.vert. O co może chodzić?
Trzeba też wypakować shaders.zip z appveyora

Obecnie jestem dosyć zajęty więc kolejne aktualizacja za tydzień-dwa.
« Ostatnia zmiana: 16 Lipca 2018, 13:23:29 wysłana przez Milek7 »

Offline Maciej

  • Wydział Repozytorium
  • Wiadomości: 1188
    • Zobacz profil
  • Otrzymane polubienia: 190
Odp: Shaderowe exe do testów
« Odpowiedź #7 dnia: 16 Lipca 2018, 13:30:20 »
Pobrałem i wypakowałem do głównego folderu symulatora następujące paczki: builds\eu07_x64_bin.zip, builds\eu07_x64_pdb.zip oraz shaders.zip i mam ten sam komunikat.

Offline tmj

  • Deweloper
  • Wiadomości: 3526
    • Zobacz profil
  • Otrzymane polubienia: 1927
Odp: Shaderowe exe do testów
« Odpowiedź #8 dnia: 16 Lipca 2018, 13:31:46 »
GTX1060 ze sterownikiem jakimś sprzed dwóch tygodni.
To samo co u mnie i swiatla tez wydaja sie nie dzialac.

Aa jeszcze, nie dziala oswietlenie kabiny.

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8725
    • Zobacz profil
  • Otrzymane polubienia: 1669
Odp: Shaderowe exe do testów
« Odpowiedź #9 dnia: 16 Lipca 2018, 21:29:00 »
Kolejny błąd z sortowaniem alfy. Modele statyczne na alfa-teście powodują znikanie przesłoniętego nimi taboru. Nawet elementów na alfa-teście. Wieszaki sieci, trawa.
Okienko debuga jest za małe. Ucina dobre 20 znaków z dłuższych wierszy.
Mam wrażenie, że te błędne cienie, to projekcja cubemapy odbić na shadowmapę. Jak na wszystko idzie to na wszystko. :P Rzeczy, które na niej są, a nie powinno ich tam być i okres w jakim się zmieniają, łudząco ją przypominają.
Brak shaderków barwionych diffuse materiału, wiec auta bez tekstur są białe.
« Ostatnia zmiana: 16 Lipca 2018, 22:39:53 wysłana przez Stele »
Mój kanał youtube

Offline CX MANIAK

  • Wiadomości: 205
    • Zobacz profil
  • Otrzymane polubienia: 31
Odp: Shaderowe exe do testów
« Odpowiedź #10 dnia: 16 Lipca 2018, 23:11:58 »
Pobrałem i wypakowałem do głównego folderu symulatora następujące paczki: builds\eu07_x64_bin.zip, builds\eu07_x64_pdb.zip oraz shaders.zip i mam ten sam komunikat.
Też tak miałem na początku, musisz utworzyć osobny folder "shaders" i do niego wypakować zawartość "shaders zip".
  Potestowałem trochę to exe i wygląda obiecująco, jednak strasznie wypalone obiekty w świetle, efekt podobny do zbyt dużego kontrastu światło-cień. Poza tym to co wspominał @Tmj, dziwny cień na scenie po podniesieniu widoku powyżej linii horyzontu. Na plus na pewno zaczątki interfejsu obsługiwanego myszką.
Pozdrawiam.
Edit:
 Coś dziwnego stało się z cieniami otoczenia. Nie dość że podążają za nami, to są jakby odwrócone o 180 stopni i sprawiają wrażenie lustrzanego odbicia. Ciężko to pokazać na screenach, trzeba po prostu się przejechać.
« Ostatnia zmiana: 17 Lipca 2018, 00:10:20 wysłana przez CX MANIAK »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Odp: Shaderowe exe do testów
« Odpowiedź #11 dnia: 19 Lipca 2018, 00:29:34 »
Kolejna wersja: https://ci.appveyor.com/project/Milek7/maszyna/build/206/artifacts
Dodać textures/colored.mat z zawartością shader: colored
Oczywiście wypakować zaktualizowane shadery
Zrobiłem duże zmiany w obsłudze materiałów, mam nadzieję opacity wreszcie działa dobrze, merge z głównym branchem, konfigurowalne parametry w shaderach, inne sposoby bindingu tekstur jeżeli jest rozszerzenie multibind i/lub DSA, poprawiony wireframe. (mapowanie otoczenia narazie zakomentowane w shaderze)
« Ostatnia zmiana: 19 Lipca 2018, 00:32:23 wysłana przez Milek7 »

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8725
    • Zobacz profil
  • Otrzymane polubienia: 1669
Odp: Shaderowe exe do testów
« Odpowiedź #12 dnia: 19 Lipca 2018, 00:59:47 »
Niestety alfa bez zmian. Przynajmniej na pojazdach.
Pojawiło się światło pojazdów, oczywiście świecące gdzieś w niebo, ale jest.
Gwiazdy nadal mają złe kolory, zmienne zależnie od kąta kamery.
Mój kanał youtube

Offline tmj

  • Deweloper
  • Wiadomości: 3526
    • Zobacz profil
  • Otrzymane polubienia: 1927
Odp: Shaderowe exe do testów
« Odpowiedź #13 dnia: 19 Lipca 2018, 13:11:17 »
Potwierdzam problem z alpha. Latwy do zauwazenia np na Calkowo Niebezpieczny Pociag -- wystarczy wysiasc na poczatku i spojrzec na trawe na stacji, wyraznie widac ze geometria w z-buforze laduje w calosci zamiast z pominieciem czesci przezroczystych, w rezultacie 'zaslaniajac' kepki za soba.

Wyglada tez na to, ze zapalone swiatla wplywaja na teren/tory tylko na kanale specular, albo cos podobnie dziwnego -- zapalone swiatla generuja waski stozek zmieniajacy kat padania wraz z ruchem kamery, podczas gdy modele 3d jak slupy, budynki itp oswietlane sa normalnie.

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8725
    • Zobacz profil
  • Otrzymane polubienia: 1669
Odp: Shaderowe exe do testów
« Odpowiedź #14 dnia: 19 Lipca 2018, 16:44:28 »
Trawa jest na blendzie i na milkowych exe tak źle się zachowuje chyba od zawsze. Mi chodzi o modele na teście, jak klima i bufory na 424 czy naklejki na czole bohuna w domyślnym składzie na TD.
Mój kanał youtube

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Odp: Shaderowe exe do testów
« Odpowiedź #15 dnia: 19 Lipca 2018, 17:24:04 »

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8725
    • Zobacz profil
  • Otrzymane polubienia: 1669
Odp: Shaderowe exe do testów
« Odpowiedź #16 dnia: 19 Lipca 2018, 17:35:42 »
Alfa na pojazdach już dobrze, ale teraz wywaliło inny problem. Zwykły z-buffer szaleje. Fragmenty wózka siódemki rysuje mi przed pudłem. W 111a na wierzchu rysuje drzwi po przeciwnej stronie składu. Bohuna na końcu składu rysuje przed przedostatnim. Testuję na t3d jak coś, bo to miewało znaczenie przy sortowaniu.
Nie uwzględnia emisyjności lampek na pojazdach. Teksturowe światła siódemki się nie świecą.
Jednak dziury z alfy wróciły, ale zależą od oświetlenia. W dzień ich nie ma, w nocy się pojawiają.
« Ostatnia zmiana: 19 Lipca 2018, 17:39:24 wysłana przez Stele »
Mój kanał youtube

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Odp: Shaderowe exe do testów
« Odpowiedź #17 dnia: 19 Lipca 2018, 19:25:39 »
Hmm, no u mnie wszystko działa :/
Sprawdź teraz, może nie commitnąłem wszystkiego https://ci.appveyor.com/project/Milek7/maszyna/build/209/artifacts
(shadery też zaktualizuj)

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8725
    • Zobacz profil
  • Otrzymane polubienia: 1669
Odp: Shaderowe exe do testów
« Odpowiedź #18 dnia: 19 Lipca 2018, 19:38:43 »
Dokładnie to samo. :/
A jednak nie. Wywaliłem wszystkie pliki shaderów przypadkowo wypakowane do roota, wywaliłem cały folder, wypakowałem od nowa i działa. Jakieś śmieci musiały się gryźć mimo nadpisania nowymi.
Gwiazdy są poprawione widzę. Alfa podsypki zaczęła działać.
Czyli z błędów które widać na td zostaje:
-brak emisyjności reflektorów pojazdów
-oświetlenie księżycowe
-kalibracja światła pojazdów
-------
I za szybko cię cieszyłem. Odpaliłem większą scenerię i znowu jest problem kolejności renderowania pojazdów. Wózki przed pudłem. Wnętrze przed pudłem. Człony w złej kolejności. W ramach jednego submodelu wszędzie ok.
I dodaj obsługę okienka wyjścia z programu z klawiatury (y/n), mam pamięć mięśniową i co rusz się drapię po głowie zanim sięgnę po mysz by kliknąć "yes".
« Ostatnia zmiana: 19 Lipca 2018, 20:21:27 wysłana przez Stele »
Mój kanał youtube

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Odp: Shaderowe exe do testów
« Odpowiedź #19 dnia: 19 Lipca 2018, 20:53:08 »

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8725
    • Zobacz profil
  • Otrzymane polubienia: 1669
Odp: Shaderowe exe do testów
« Odpowiedź #20 dnia: 19 Lipca 2018, 21:53:00 »
Jest lepiej, ale nadal sporadycznie z-buffer głupieje.
Zły kolor jest na latarni rozjazdu krzyżowego. Zaraz zerknę jak ona jest zbudowana. Jest to lampka w modelu statycznym, bez tekstury o białym diffuse. Wyświetla się jako niebieska. Ogólnie color shader nie bangla. Auta są w odcieniach szarości.
Node stars mają dobry kolor na star shaderze, ale zły w t3d statycznym.
Reflektory dynamiców mają dobrą emisyjność.
« Ostatnia zmiana: 19 Lipca 2018, 21:58:33 wysłana przez Stele »
Mój kanał youtube

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Odp: Shaderowe exe do testów
« Odpowiedź #21 dnia: 19 Lipca 2018, 21:56:33 »
>ale nadal sporadycznie z-buffer głupieje
Na jakich obiektach, kiedy? Teraz to naprawdę już powinno być dobrze ;d
>zły w t3d statycznym
Czyli co to jest? Daj jakiś przykład.

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8725
    • Zobacz profil
  • Otrzymane polubienia: 1669
Odp: Shaderowe exe do testów
« Odpowiedź #22 dnia: 19 Lipca 2018, 22:00:11 »
Lampki pozycyjne na kominach. Submodel typu stars w zwykłym t3d wstawionym przez node model.
Odpaliłem l053 poranek. Obejrzałem kilka składów i tylko na ST45 zauważyłem problem. Przekręciłem zegar by obejrzeć efekty w nocy i już wyświetlała się poprawnie.
Mój kanał youtube

Offline tmj

  • Deweloper
  • Wiadomości: 3526
    • Zobacz profil
  • Otrzymane polubienia: 1927
Odp: Shaderowe exe do testów
« Odpowiedź #23 dnia: 19 Lipca 2018, 22:03:43 »
Prawie ladnie ;d

Reflektory nadal rzucaja slaba ilosc swiatla diffuse, ale juz jakas rzucaja. Teren, podsypki itp maja raczej niepotrzebnie wysoki domyslny specular, i slonce i swiatla generuja refleksy jakby ktos wszystko szmata wypolerowal.

Wypadaloby cos jeszcze zrobic z kalkulacja koloru nieba -- w tej chwili jest robiona per vertex i to dosc paskudnie widac rano/wieczorem, jak na zalaczniku. Mozna by pokusic sie o wersje per-pixel wstawiona do shadera.

przyklad implementacji: https://github.com/zeux/sandvox/blob/master/src/shaders/sky-preetham-fs.glsl

(uzyty jest tam ten sam algorytm co w symulatorze, chociaz tylko w wersji podstawowej, bez dodanych recznych korekt)

edit:
troche nie bardzo tez z nakladaniem odbic, widac je nalozone na budynku ze zbyt duza intensywnoscia, a dodatkowo obracaja sie przy zmianie kata kamery w gore/dol
« Ostatnia zmiana: 19 Lipca 2018, 22:08:17 wysłana przez tmj »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Odp: Shaderowe exe do testów
« Odpowiedź #24 dnia: 23 Lipca 2018, 01:24:01 »
Zamiast uzupełniać braki i optymalizować to ja postefekty dorabiam, ale to ciekawsze jest ;P

https://ci.appveyor.com/project/Milek7/maszyna/build/214/artifacts

doszło ustawienie do ini:
gfx.postfx.motionblur.shutter 0.01 // "czas naświetlania" efektu motion blur (w sekundach)

Offline tmj

  • Deweloper
  • Wiadomości: 3526
    • Zobacz profil
  • Otrzymane polubienia: 1927
Odp: Shaderowe exe do testów
« Odpowiedź #25 dnia: 23 Lipca 2018, 01:49:28 »
No zawsze fajniej nowe bugi dokladac niz usuwac stare ;>

Ale cos nie teges, wywala od razu na starcie i to tak ambitnie ze nawet loga nie zdazy dobrze zapisac.

chodzi, nie pomyslalem zeby shadery zaktualizowac.
« Ostatnia zmiana: 23 Lipca 2018, 02:06:25 wysłana przez tmj »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Odp: Shaderowe exe do testów
« Odpowiedź #26 dnia: 24 Lipca 2018, 18:23:34 »
zmiennoprzecinkowy odwrócony Z buffer, w przypadku obecności rozszerzenia ARB_clip_control ze zwiększoną precyzją.
edit:
może tak lepiej https://ci.appveyor.com/project/Milek7/maszyna/build/219/artifacts
« Ostatnia zmiana: 24 Lipca 2018, 18:56:47 wysłana przez Milek7 »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 893
    • Zobacz profil
  • Otrzymane polubienia: 560
Odp: Shaderowe exe do testów
« Odpowiedź #27 dnia: 25 Lipca 2018, 12:16:22 »
https://ci.appveyor.com/project/Milek7/maszyna/build/223/artifacts
doszły do ini wpisy:
gfx.framebuffer.width x
gfx.framebuffer.height y
gfx.shadowmap.enabled yes/no
gfx.envmap.enabled yes/no
gfx.postfx.motionblur.enabled yes/no
« Ostatnia zmiana: 25 Lipca 2018, 12:34:07 wysłana przez Milek7 »

Offline firleju

  • Zasłużony dla Symulatora
  • Wiadomości: 1590
  • bawię się (w) exe...
    • Zobacz profil
  • Otrzymane polubienia: 119
Odp: Shaderowe exe do testów
« Odpowiedź #28 dnia: 25 Lipca 2018, 13:02:19 »
Może wydzielić ustawienia graficzne do osobnego ini, żeby nie rozbudowywać już obecnego.
Skrypty do Blendera dostępne tutaj
W miarę aktualne wiki EXE wiki.eu07.es

Offline CX MANIAK

  • Wiadomości: 205
    • Zobacz profil
  • Otrzymane polubienia: 31
Odp: Shaderowe exe do testów
« Odpowiedź #29 dnia: 25 Lipca 2018, 13:36:42 »
Ja bym prosił również o komentarz dla najnowszych wpisów w ini. Metodą chybił-trafił za wiele nie zdziałam.
Edit: gfx.framebuffer.width x
gfx.framebuffer.height y
Wpisałem dla tych parametrów rozdzielczość monitora (1024x1280) i działa, ale czy to tak ma być?
« Ostatnia zmiana: 25 Lipca 2018, 13:47:13 wysłana przez CX MANIAK »