Autor Wątek:  Exe - zmiany w stosie graficznym i dźwiękowym  (Przeczytany 764090 razy)

0 użytkowników i 5 Gości przegląda ten wątek.

Offline SM40

  • Zasłużony dla Symulatora
  • Wiadomości: 212
    • Zobacz profil
  • Otrzymane polubienia: 29
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2730 dnia: 08 Grudnia 2019, 21:08:23 »
WS nie ma nic wspólnego z dźwiękiem przekładni na żadnej lokomotywie a problem występuje od co najmniej wersji "eu07-160704-unoff" a więc od wielu wielu lat dokucza mi to zjawisko.

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 9706
    • Zobacz profil
  • Otrzymane polubienia: 2292
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2731 dnia: 08 Grudnia 2019, 21:10:52 »
Z tym czy to sampel przekładni czy trakcyjnych?
Mój kanał youtube

Online Turbokibel

  • Wydział Repozytorium
  • Wiadomości: 1129
    • Zobacz profil
  • Otrzymane polubienia: 789
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2732 dnia: 08 Grudnia 2019, 21:14:16 »
Jakies konkretne warianty czy wszystkie? Zawsze, czy czasami? W jakichs okreslonych okolicznosciach, po wykonaniu jakichs czynnosci czy samo z siebie? Moze ktorys konkretny dzwiek, wyizolowany w mmd?

No we wszystkich lokomotywach, ale czasami.

Youby, tak właśnie chodzi mi o ten dźwięk, co jest na początku filmu, taki jakby samolot leciał.

Offline SM40

  • Zasłużony dla Symulatora
  • Wiadomości: 212
    • Zobacz profil
  • Otrzymane polubienia: 29
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2733 dnia: 08 Grudnia 2019, 21:14:53 »
Może trakcyjnych ale to nie zmienia faktu że takiego uzależnienia nie powinno być.

Online mareczek

  • Deweloper
  • Wiadomości: 546
    • Zobacz profil
    • Galeria Fotograficzna Mareczka
  • Otrzymane polubienia: 197
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2734 dnia: 08 Grudnia 2019, 21:15:31 »
Nie ma zaimplementowanych trakcyjnych, tylko przekładnia (podpięta błędnie pod tractionmotor). Przypuszczam, że nakładają się dwa dźwięki przekładni, z obu wózków, a dźwięk ma ustawiony duży zasięg?

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2348
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2735 dnia: 08 Grudnia 2019, 21:29:14 »
WS nie ma nic wspólnego z dźwiękiem przekładni na żadnej lokomotywie a problem występuje od co najmniej wersji "eu07-160704-unoff" a więc od wielu wielu lat dokucza mi to zjawisko.
Powtarzam, dzwiek transmission: nie ma w kodzie uzaleznienia od WSa. Moze w 2016 bylo inaczej, ale jest grudzien 2019 wiec jesli mozliwe zweryfikuj to na obecnym exe..? :v

Dzwiek silnikow trakcyjnych tractionmotor: takie uzaleznienie posiada, ale to akurat ma uzasadnienie poniewaz jest to dzwiek pracujacych silnikow, zasilanych elektrycznie.

edit:
No we wszystkich lokomotywach, ale czasami.
"Czasami" to znaczy kiedy? W jakis okreslonych okolicznosciach czy tak sobie od czapy? Moze inaczej: co robisz zeby go uslyszec, siedzisz w kabinie, wychodzisz na zewnatrz, jeszcze cos innego?
« Ostatnia zmiana: 08 Grudnia 2019, 21:36:56 wysłana przez tmj »

Offline SM40

  • Zasłużony dla Symulatora
  • Wiadomości: 212
    • Zobacz profil
  • Otrzymane polubienia: 29
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2736 dnia: 08 Grudnia 2019, 21:36:53 »
Nie z 2016 tylko 2004. A problem występuje co najmniej od tam tego czasu i w obecnym EXE jak najbardziej też. Nie nie jest uzasadnione, niema nastawnika na pozycji jazdy nie ma dźwięku pracujących silników, tym bardziej z kierunkiem na 0.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2348
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2737 dnia: 08 Grudnia 2019, 21:38:57 »
Nie z 2016 tylko 2004. A problem występuje co najmniej od tam tego czasu i w obecnym EXE jak najbardziej też. Nie nie jest uzasadnione, niema nastawnika na pozycji jazdy nie ma dźwięku pracujących silników, tym bardziej z kierunkiem na 0.
Ale jaki konkretnie problem, bo nie bardzo rozumiem? Ze ktos blednie podpial sobie w mmd dzwiek mechanicznej przekladni pod tractionmotor: a nie pod transmission: albo odwrotnie? To nie jest problem z exe tylko z "elementem ludzkim miedzy krzeslem i klawiatura".

Online Turbokibel

  • Wydział Repozytorium
  • Wiadomości: 1129
    • Zobacz profil
  • Otrzymane polubienia: 789
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2738 dnia: 08 Grudnia 2019, 21:41:14 »
"Czasami" to znaczy kiedy? W jakis okreslonych okolicznosciach czy tak sobie od czapy? Moze inaczej: co robisz zeby go uslyszec, siedzisz w kabinie, wychodzisz na zewnatrz, jeszcze cos innego?
Tak sobie od czapy, myślę, że to jest losowe, raz na może 5 uruchomień mi się ten dźwięk trafił, no ale trafił, by go usłyszeć wychodzę na zewnątrz.

Offline SM40

  • Zasłużony dla Symulatora
  • Wiadomości: 212
    • Zobacz profil
  • Otrzymane polubienia: 29
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2739 dnia: 09 Grudnia 2019, 09:11:05 »
Chodzi oto że wkurza mnie taka sytuacja że załączam WS słychać brrrr, wyłączam nie słychać, cokolwiek był by tam podpięte pod tractionmotors nie powinno to tak działać.

Offline adamst

  • Zasłużony dla Symulatora
  • Wiadomości: 354
    • Zobacz profil
  • Otrzymane polubienia: 75
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2740 dnia: 09 Grudnia 2019, 12:39:39 »
Jak to nie? O ile dobrze kojarzę, w rzeczywistości tak właśnie jest - jak siódemka toczy się na wybiegu (bezprądowo) to przekładni/silników niemal nie słychać. Można też to bardzo dobrze zaobserwować siedząc nad wózkiem napędnym w EN57 - przekładnia wyje tylko przy jeździe "pod prądem". Od razu słychać, kiedy maszynista wyrzuca nastawnik na zero, bo się robi sporo ciszej - słychać wtedy tylko szum/łomot toczącego się wózka.
« Ostatnia zmiana: 09 Grudnia 2019, 12:41:18 wysłana przez adamst »

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2348
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2741 dnia: 09 Grudnia 2019, 12:48:46 »
Chodzi oto że wkurza mnie taka sytuacja że załączam WS słychać brrrr, wyłączam nie słychać, cokolwiek był by tam podpięte pod tractionmotors nie powinno to tak działać.
Nadal nie rozumiem dlaczego "nie powinno to tak dzialac". Moze powtorze jeszcze raz -- "tractionmotors:" jest w zalozeniu dzwiekiem motorow trakcyjnych generowanym gdy motory te pracuja, przetwarzajac otrzymany prad na sile. Gdy nie ma pradu nie ma pracy, i tym samym nie ma dzwieku ich pracy.

Jesli pod ten klucz podepniesz dzwiek czego innego jest to wylacznie twoj blad, i nie wiem dlaczego domagasz sie zeby to exe dostosowywalo sie do twojej pomylki. Podepnij ten swoj dzwiek pod wlasciwy klucz a bedziesz go slyszal zgodnie ze swymi oczekiwaniami.

Offline Miłosz Dorsz

  • Wydział Repozytorium
  • Wiadomości: 1007
    • Zobacz profil
  • Otrzymane polubienia: 1653
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2742 dnia: 09 Grudnia 2019, 13:49:48 »
Tak z innej beczki - dźwięk pracy silnika trakcyjnego to ciche huczenie łożysk i piszczenie szczotek. Niesłyszalne podczas jazdy.
Aktualne projekty: KLIK

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2348
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2743 dnia: 09 Grudnia 2019, 13:57:33 »
Jesli to co slychac na tym nagraniu jest dla ciebie ciche, mamy rozna definicje slowa "ciche". Co do slyszalnosci podczas jazdy to, o ile to co pisze adamst jest zgodne z prawda, cos najwidoczniej slychac jesli nawet z wnetrza pojazdu zauwazalne jest zanikniecie tego dzwieku przy jezdzie na wybiegu.

Offline Miłosz Dorsz

  • Wydział Repozytorium
  • Wiadomości: 1007
    • Zobacz profil
  • Otrzymane polubienia: 1653
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2744 dnia: 09 Grudnia 2019, 14:30:14 »
Włącz sobie przetwornicę, sprężarkę i dodaj jeszcze ogólny szum jazdy, a podczas jazdy z poborem prądu jeszcze wycie przekładni. Już nie będzie to wydawało się głośne. Na filmie wydaje się głośno, bo kamerzysta filmuje bardzo blisko silnika, a po drugie nie ma tu tła w postaci innych dźwięków lokomotywy.
« Ostatnia zmiana: 09 Grudnia 2019, 14:32:29 wysłana przez Miłosz Dorsz »
Aktualne projekty: KLIK

Offline adamst

  • Zasłużony dla Symulatora
  • Wiadomości: 354
    • Zobacz profil
  • Otrzymane polubienia: 75
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2745 dnia: 09 Grudnia 2019, 14:32:05 »
Może sprecyzujmy - to "wycie" które słyszymy podczas jazdy, i nazywamy potocznie dźwiękiem silników trakcyjnych, to tak naprawdę dźwięk układu silnik+przekładnia, przy czym głównym źródłem dźwięku są zębatki przekładni. Sam silnik rzeczywiście nie jest głośny - tego, co na filmie od Miłosza normalnie nie słychać, bo zagłusza to przekładnia.
Ale tak czy inaczej zachowanie takie jak obecnie w symulatorze, tzn. słyszalność tego dźwięku przekładni tylko pod obciążeniem (=jazda z poborem prądu, lub ewentualnie hamowanie ED), jest prawidłowe.

Offline SM40

  • Zasłużony dla Symulatora
  • Wiadomości: 212
    • Zobacz profil
  • Otrzymane polubienia: 29
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2746 dnia: 09 Grudnia 2019, 14:57:27 »
Jak to nie? O ile dobrze kojarzę, w rzeczywistości tak właśnie jest - jak siódemka toczy się na wybiegu (bezprądowo) to przekładni/silników niemal nie słychać. Można też to bardzo dobrze zaobserwować siedząc nad wózkiem napędnym w EN57 - przekładnia wyje tylko przy jeździe "pod prądem". Od razu słychać, kiedy maszynista wyrzuca nastawnik na zero, bo się robi sporo ciszej - słychać wtedy tylko szum/łomot toczącego się wózka.
No właśnie dokładnie tak jest i to próbuje cały czas powiedzieć. Nie ma prądu nie ma dźwięku. A obecnie w Maszynie aby wyłączyć dźwięk nie wystarczy zjechać do zera trzeba rozłączyć WS'a, wtedy robi się cicho.

Nadal nie rozumiem dlaczego "nie powinno to tak dzialac". Moze powtorze jeszcze raz -- "tractionmotors:" jest w zalozeniu dzwiekiem motorow trakcyjnych generowanym gdy motory te pracuja, przetwarzajac otrzymany prad na sile. Gdy nie ma pradu nie ma pracy, i tym samym nie ma dzwieku ich pracy.

Jesli pod ten klucz podepniesz dzwiek czego innego jest to wylacznie twoj blad, i nie wiem dlaczego domagasz sie zeby to exe dostosowywalo sie do twojej pomylki. Podepnij ten swoj dzwiek pod wlasciwy klucz a bedziesz go slyszal zgodnie ze swymi oczekiwaniami.
Nie domagam się dostosowania do mojej pomyłki, niczego nie ruszałem w plikach. Powinno być właśnie tak jak piszesz nie mam prądu nie ma dźwięku a nie że prąd 0A a dźwięk jest i jak np. zwolnimy to słychać że zwalniamy a jak rozłączymy WS to nic nie słychać.
« Ostatnia zmiana: 09 Grudnia 2019, 15:41:59 wysłana przez SM40 »

Offline CX MANIAK

  • Wiadomości: 237
    • Zobacz profil
  • Otrzymane polubienia: 39
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2747 dnia: 09 Grudnia 2019, 15:14:07 »
Witam.
 Na najnowszym exe na szybko sprawdziłem w "sódemce" na TD i efektu który opisujesz brak. Przy jeździe na wybiegu słychać jedynie runningnoise, bez względu na stan WS-a. Jest najprawdopodobniej tak jak pisze @TMJ, niektóre MMD mają nieaktualne wpisy. Podaj może jakiś konkretny typ pojazdu z tym efektem dźwiękowym ( stawiam na ET22).
 Tak na marginesie, hałasuje najbardziej przekładnia osiowa, a nie silnik trakcyjny. Wynika to z jej budowy-koła z prostymi zębami. Im bardziej obciążona, wyższe obroty - tym głośniejsza. Natomiast na wybiegu to koło napędza silnik, i przekładnie również czasem słychać, ale jest to niejednostajne ciche buczenie.
Pozdrawiam.

Offline SM40

  • Zasłużony dla Symulatora
  • Wiadomości: 212
    • Zobacz profil
  • Otrzymane polubienia: 29
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2748 dnia: 09 Grudnia 2019, 15:16:34 »
Weź sobie domyślną EU07 na TD i masz ten efekt. Testowane zarówno na plikach z paczki jak i repo. Wiem że najbardziej hałasuje przekładnia a nie silnik jest tak jak piszesz.
« Ostatnia zmiana: 09 Grudnia 2019, 15:50:42 wysłana przez SM40 »

Offline CX MANIAK

  • Wiadomości: 237
    • Zobacz profil
  • Otrzymane polubienia: 39
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2749 dnia: 09 Grudnia 2019, 15:59:34 »
Witam.
 Właśnie na domyślnym składzie  na TD sprawdzałem i nic takiego nie słychać, niezależnie od  stanu WS-a.
 Pozdrawiam.

Offline Joachimowicz

  • Wydział Repozytorium
  • Wiadomości: 1467
  • Nazywam się N'Avoie
    • Zobacz profil
  • Otrzymane polubienia: 1440
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2750 dnia: 09 Grudnia 2019, 16:05:08 »
Wziąłem sobie domyślną EU07 na TD i nie słyszę różnicy przełączając stan WS.

https://soundcloud.com/micha-anio-846435530/1a-1
| Z maszyną od 20 Kwietnia 2010! |

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2348
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2751 dnia: 09 Grudnia 2019, 19:18:55 »
No właśnie dokładnie tak jest i to próbuje cały czas powiedzieć. Nie ma prądu nie ma dźwięku. A obecnie w Maszynie aby wyłączyć dźwięk nie wystarczy zjechać do zera trzeba rozłączyć WS'a, wtedy robi się cicho.
... Ja moze jestem nienormalny, ale do tej pory caly czas pisales o "uzaleznieniu od WSa" i ze tego nie powinno byc, i w zyciu bym na podstawie tego nie wpadl ze chodzi o to, ze chcesz zeby bylo wprowadzone dodatkowe uzaleznienie od pozycji nastawnika, a nie ze domagasz sie usuniecia tego uzaleznienia ktore juz jest.

Online mareczek

  • Deweloper
  • Wiadomości: 546
    • Zobacz profil
    • Galeria Fotograficzna Mareczka
  • Otrzymane polubienia: 197
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2752 dnia: 09 Grudnia 2019, 19:20:58 »
Ale dyskusja, to po kolei:

1) Przekładnia powinna być w mmd pod "transmission", a silniki trakcyjne pod "tractionmotor". POWINNA, ale nie jest! Ponieważ oba te dźwięki w EXE zachowują się odwrotnie do rzeczywistości. Z resztą już nie raz o tym pisałem.

Przekładnia powinna być słyszalna przy zadanym nastawniku jazdy (obciążeniu), natomiast silniki trakcyjne pracują ciągle (w czasie jazdy oczywiście). W EXE te elementy są opisane odwrotnie - tzn przekładnia (transmission) "buczy" ciągle, także przy jeździe na wybiegu, a silniki trakcyjne (tractionmotor) przy jeździe na wybiegu nie są słyszalne. I stąd dźwięki są podpięte odwrotnie niż być powinny.

2) Silniki trakcyjne na nagraniu są głośne, ale po pierwsze przetwornica jest jeszcze głośniejsza, a dwa, kabiny są dość nieźle wytłumione. Ogólnie silniki trakcyjne słyszalne są przeważnie na ET41 (znajomy mówił że wynika to prawdopodobnie z charakteru pracy lokomotywy, tj jazda z ciężkimi pociągami, wyrobione szczotki itp.), natomiast w czasie jazdy silniki trakcyjne na klasycznej EU07 są niesłyszalne.
« Ostatnia zmiana: 09 Grudnia 2019, 19:23:53 wysłana przez mareczek »

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2348
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2753 dnia: 09 Grudnia 2019, 19:44:09 »
OK, gwoli scislosci od strony kodu wyglada to w tej chwili nastepujaco:

- transmission: jest dzwiekiem odtwarzanym jesli pojazd porusza sie z dowolna predkoscia, bez wzgledu na jego stan. Byc moze dlatego ze oryginalnie byla uzyta tylko w mmd jakiegos smierdziela z przekladnia mechaniczna i tam mialo to sens

- tractionmotor: ten dzwiek jest odtwarzany gdy dany pojazd ma uruchomiony silnik (w spal-ele) lub zamkniety WS (w elektrycznych) z glosnoscia kalkulowana na podstawie aktualnej mocy napedowej i/lub aktualnych obrotow. Tzn lopatologicznie, jesli jest zalaczony WS i motor sie kreci, to sobie buczy (tym glosniej im szybciej sie kreci) a jesli dostaje prad to buczenie jest glosniejsze, tym bardziej im wiecej tego pradu dostaje. Dodatkowo glosnosc zwiekszana jest przy aktywnych hamowaniu elektrodynamicznym. Na ile sieorientuje jest to robione w ten sposob gdyz piszczenie nie zanika natychmiast po odjeciu pradu, co mozna zaobserwowac np tutaj:


Offline Miłosz Dorsz

  • Wydział Repozytorium
  • Wiadomości: 1007
    • Zobacz profil
  • Otrzymane polubienia: 1653
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2754 dnia: 09 Grudnia 2019, 19:59:37 »
a jesli dostaje prad to buczenie jest glosniejsze, tym bardziej im wiecej tego pradu dostaje
Jakby co, tak nie powinno być. Wartość prądu nie ma znaczenia na głośność piszczenia szczotek. Wraz ze wzrostem prędkości powinna się zmieniać częstotliwość.
Cytuj
piszczenie nie zanika natychmiast po odjeciu pradu
Na filmie nie zanika od razu - prawda. Zanika wraz ze spadkiem prędkości po odłączeniu zasilnia.
« Ostatnia zmiana: 09 Grudnia 2019, 20:03:29 wysłana przez Miłosz Dorsz »
Aktualne projekty: KLIK

Offline SM40

  • Zasłużony dla Symulatora
  • Wiadomości: 212
    • Zobacz profil
  • Otrzymane polubienia: 29
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2755 dnia: 09 Grudnia 2019, 20:50:11 »
Tzn lopatologicznie, jesli jest zalaczony WS i motor sie kreci, to sobie buczy (tym glosniej im szybciej sie kreci)
No właśnie sobie buczy a czemu buczy jak jest WS załączony i nie buczy jak jest wyłączony? Przecież prąd się nie zmienia, cały czas jedzie z wybiegu.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2348
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2756 dnia: 09 Grudnia 2019, 20:58:35 »
Jakby co, tak nie powinno być. Wartość prądu nie ma znaczenia na głośność piszczenia szczotek. Wraz ze wzrostem prędkości powinna się zmieniać częstotliwość.
Ja nie wiem jak powinno byc, a na przestrzeni ostatnich dwoch lat otrzymalem juz kilka roznych wersji i tylez bylo poprawek. Uzgodnicie sobie najpierw jak rzeczywiscie "ma byc", dacie papier z pieczatka i podpisami zeby potem nie bylo "a dlaczego tak i kto to wymyslil" to sie zmieni :V

Offline SM40

  • Zasłużony dla Symulatora
  • Wiadomości: 212
    • Zobacz profil
  • Otrzymane polubienia: 29
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2757 dnia: 09 Grudnia 2019, 22:15:06 »
Ale dyskusja, to po kolei:

1) Przekładnia powinna być w mmd pod "transmission", a silniki trakcyjne pod "tractionmotor". POWINNA, ale nie jest! Ponieważ oba te dźwięki w EXE zachowują się odwrotnie do rzeczywistości. Z resztą już nie raz o tym pisałem.

Przekładnia powinna być słyszalna przy zadanym nastawniku jazdy (obciążeniu), natomiast silniki trakcyjne pracują ciągle (w czasie jazdy oczywiście). W EXE te elementy są opisane odwrotnie - tzn przekładnia (transmission) "buczy" ciągle, także przy jeździe na wybiegu, a silniki trakcyjne (tractionmotor) przy jeździe na wybiegu nie są słyszalne. I stąd dźwięki są podpięte odwrotnie niż być powinny.

2) Silniki trakcyjne na nagraniu są głośne, ale po pierwsze przetwornica jest jeszcze głośniejsza, a dwa, kabiny są dość nieźle wytłumione. Ogólnie silniki trakcyjne słyszalne są przeważnie na ET41 (znajomy mówił że wynika to prawdopodobnie z charakteru pracy lokomotywy, tj jazda z ciężkimi pociągami, wyrobione szczotki itp.), natomiast w czasie jazdy silniki trakcyjne na klasycznej EU07 są niesłyszalne.

Nie bardzo, silnik wydaje dźwięk buczenia wtedy kiedy pracuje pod obciążeniem (aczkolwiek jest to praktycznie niesłyszalne) a gdy leci bez obciążenia jest tylko świst (który podczas jazdy jest niesłyszalny) trochę inaczej dzieje się z przekładnią, bez obciążenia klekocze, delikatnie mruczy (co trochę słychać) a jak damy obciążanie zaczyna świdrować, mruczeć (co mocno słychać) wiec jak przyspieszamy z użyciem napędu to słychać głównie przekładnie a jadąc na wybiegu słychać tylko przekładnie która sobie klekocze, silnik jest praktycznie niesłyszalny.

np. w tym filmie słychać przekładnie w ET40 jadące bez obciążenia (z wybiegu):



inny przykład lokomotywa EU07 silniki niesłyszalne ale przekładnia jak najbardziej (zarówno pod obciążeniem jak i bez):


« Ostatnia zmiana: 09 Grudnia 2019, 23:24:30 wysłana przez SM40 »

Offline CX MANIAK

  • Wiadomości: 237
    • Zobacz profil
  • Otrzymane polubienia: 39
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2758 dnia: 09 Grudnia 2019, 23:59:16 »
Witam.
Zacznijmy od tego czy mamy w ogóle wyodrębnione osobno dźwięki przekładni oraz silnika dla poszczególnych pojazdów. Z ciekawości przejrzałem wyrywkowo kilka MMD elektryków i wpisów transmision jako odrębnych dźwięków nie znalazłem. Są one jedynie przypisane pod tractionmotor. Przykład poniżej:
Cytuj
tractionmotor: 697_303e_transmission.wav 90.0 1.5 0.1 0.035 0.01
Tak jest w większości "siódemkowatych". Wynika z tego że pomimo jak koledzy piszecie błędnego działania kodu exe w tym zakresie, dźwięki te słychać poprawnie. Włączamy jazdę mamy dźwięk przekładni, wyłączamy zanika. Oczywiście bez prądu powinno być klekotanie jak to opisał @SM40, tu trzeba by pewnie podzielić sekcję transmission na jazdę z prądem i bez, oraz przygotować odpowiednie pliki. Ewentualnie sposób odtwarzania tego dźwięku zakodować w exe, o ile w ogóle jest taka możliwość.
Na zakończenie, kiedyś mieliśmy przekładnie uzależnioną od stanu WS-a, @TMJ podpiął ten dźwięk pod aktualne obciążenie co jest chyba lepszym rozwiązaniem. 
Pozdrawiam.       
 
   

Offline EU40

  • Zasłużony dla Symulatora
  • Wiadomości: 2158
  • Kochaj myśl twórczą-ćwicz dłoń!
    • Zobacz profil
  • Otrzymane polubienia: 339
Odp: Exe - zmiany w stosie graficznym i dźwiękowym
« Odpowiedź #2759 dnia: 12 Grudnia 2019, 14:13:22 »
Na wszystkich SU45 przestały się świecić lampki czuwaka. Dies verbum EU40.
Rozczyn dzieł Marksa wlany w bydląt czaszki
Wytwarza z mózgiem przedziwną miksturę.