Autor Wątek:  Problem z semaforami kształtowymi i przejazdami.  (Przeczytany 2468 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Kipek von Chojna

  • Wiadomości: 139
  • Kiperancki Kipek
    • Zobacz profil
  • Otrzymane polubienia: 0
Problem z semaforami kształtowymi i przejazdami.
« dnia: 19 Maja 2008, 00:03:25 »
Witam.
Dawno mnie tu nie było, bo i czasu mało skoro ciągle w drodze jestem. Mam problem... No właśnie i nie wiem z czym. Rzecz tyczy się tworzenia scenerii w 3DS i wstawianiem semaforów kształtowych oraz z przejazdami typu zrób to sam.

Mam sk12-sz.inc. po wstawieniu i wyeksportowaniu jest ok. Jak włączam symka to wyskakuje kochane ABNORMAL... w czym rzecz?

Problem z przejazdami pojawia się już na etapie wstawiania modelu np. rogatki. Wyskakuje okienko jakiegoś błędu skryptów? Po czym "niby" jest wstawiony model, ale przy uruchomieniu symulatora ABNORMAL...

Sugestie jakieś ? Będę wdzięczny za pomoc.
:)

Offline Mariusz1970

  • Zasłużony dla Symulatora
  • Wiadomości: 3927
    • Zobacz profil
  • Otrzymane polubienia: 287
Odp: Problem z semaforami kształtowymi i przejazdami.
« Odpowiedź #1 dnia: 19 Maja 2008, 00:48:44 »
Nie wiem co tam w 3ds, ale podejrzewam o co chodzi z abnormalem.
Sprawdź czy includując w scn plik sk12-sz.inc jest podana ta sama liczba parametrów np. dla pliku:
SS5zpcpbI.inc wymaganych jest 7 parametrów:
// semafor 5-komorowy: p1=nazwa p2,p3,p4=lokacja, p5=rotacja, p6=symbol, p7=nazwa tarczy ostrzegawczej
//semafor ten stosuje sie jako wjazdowy, UWAGA - (p7) jest nazwa poprzedzajacej tarczy ostrzegawczej sprzezonej z tym semaforem!

Wpis w scn dla tego pliku powinen wyglądać tak:
include;MZD\SS5zpcpbI.inc;Dobczyce_C;-41202.1;0.0;-825.207;98.6421;C;dobczyce_toc;end
Wpisanie mniejszej liczby parametrów w scn spowoduje abnormal.
Czasami wystarczy dodać średnik (parametr pusty) i abnormal znika albo jeśli nie pusty, to bardziej "skomplikowany" :).

Mam nadzieję, iż mnie zrozumiałeś.
Może się mylę w moich domysłach, ale takie właśnie mam doświadczenie z abnormalami.
 
« Ostatnia zmiana: 19 Maja 2008, 01:01:11 wysłana przez Mariusz1970 »

Offline uetam

  • Zasłużony dla Symulatora
  • Wiadomości: 2641
    • Zobacz profil
  • Otrzymane polubienia: 6
Odp: Problem z semaforami kształtowymi i przejazdami.
« Odpowiedź #2 dnia: 19 Maja 2008, 18:06:49 »
Nie masz pewnie odwolania do sz-ksztalt.inc ;)