Autor Wątek:  Bardzo dziwny bug [en57]  (Przeczytany 6714 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline MKaczy

  • Zasłużony dla Symulatora
  • Wiadomości: 485
  • ^Służbowe BMW^
    • Zobacz profil
    • http://zyciekolei.blox.pl/html
  • Otrzymane polubienia: 53
Bardzo dziwny bug [en57]
« dnia: 06 Lutego 2007, 01:40:02 »
Witam Państwa. Nie dawno postanowialem sobie zrobic porzadek w katalogu z en57. Miałem tam dwie wersje jednostki:
1. z odgarniaczem całym
2. z odgarniaczem połówkowym (Epek robił)

Postanowiłem sobie to posegregowac, robiąc dodatkowe pliki dla tych ów, modeli. A z racji iż odgarniacz mamy tylko przy członie ra i rb zrobilem tylko pliki da tych wagonów. Nazwałem je 6Wba i 6Wbb (mmd,chk, i t3d)
Wszytsko pieknie było do czasu az przypadkiem zerknełem na bok jednostki, cos mi tam nie pasowało przy drzwiach (byla za duza szpara, przez co był przeswit) .Z ciekawosci otworzyalem drzwi i zobaczyalem taki widok:

Gdzie sie podziały przedsionki?...

Nastepnie juz w kabinie zerknełem w tył jednostki i widok był taki:

Gdzie sie podziały drzwi od przedziałów?

I jeszce wyszedlem z EZTa i wjechalem kamerka w skald RA, poczym ukazał sie taki widok:
http://img152.imageshack.us/img152/6761/22214838te7.jpg
Nie było przedsionków.

Podsumownie:
W przedziale "s" i "rb" wszytsko jest ok. Zaznaczam ze nic nie robilem z przedsionkami. W folderze ze zmodernizowana wersja zrobilem podobnie i było dokładnie tak samo. Myślałem ze moze jednak ja cos spsułem, ale nie...
Posiadam paczke Mariusza1970 (która kiedys tu była), obecnie w stanie "spakownym" i nie ruszonym. Pamitam ze tam tez Mariusz wprowadził dodatkowe pliki dla wersji kibla bez switałe, i ze switałami, nazywajac te dodatkowe "7ba" i "7bb" (mmd,chk i t3d). Z ciekawosci odplaiłem to tam, przy wersjach "7b..." i tez było tak samo, czyli brak przedisonków w wagonie "ra".

Na tym koncze opis mojego problemu. Jeśli macie "wielopak EZTa" lub inne podwójnie modelowo kible, sprawdzicie jak u Was z tym jest, czy macie podobnie.

Dziękuje i pozdrawiam:)
"Wsiąść do pociągu... towarowego..." :)
Maszynista - PKP Cargo CTOE-Szczecinek - ET22, 201EK, EU06, EU07, ET41, ET42, SM42, ST44-ko, SM42-6dg, ST48-Da

Offline Titanium

  • Wiadomości: 16
    • Zobacz profil
  • Otrzymane polubienia: 0
Bardzo dziwny bug [en57]
« Odpowiedź #1 dnia: 06 Lutego 2007, 08:36:20 »
U mnie na EXE 664 wszystko Oki. Na EXE Q też wszystko w porządku.

Offline youBy

  • Deweloper
  • Wiadomości: 6161
  • Co tam?
    • Zobacz profil
    • Automat Weryfikujący Regulację i Lambdę
  • Otrzymane polubienia: 862
Bardzo dziwny bug [en57]
« Odpowiedź #2 dnia: 06 Lutego 2007, 14:12:22 »
Do charakterystyk 6ba.chk jest zawsze załączany model przedsionków (przedsionki.t3d? - teraz nie pamiętam). Model pierwszego członu 6Ba nie zawiera przedsionków. Trzeba by obrócić model 6bb. W Wielopaku tego nie ma, gdyż charakterystyki są inaczej nazwane (5Ba) i w związku z tym przedsionki są wsadzone do modelu t3d. Przez to nie ma tego efektu. Masz dwie drogi:
a) wsadzić przedsionki do modelu jednostki
b) uzyć wpisu w mmd, bodajże lowpolyint: model-przedsionków.t3d. Przez to będąone ładowane i wyświetlane niezależnie od nazwy charakterystyki.
Xoov
Powyższy post wyraża jedynie opinię autora w chwili publikacji. Autor zastrzega sobie prawo do zmiany poglądów bez podawania przyczyny, jak również informowania o tym.

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5925
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 443
Bardzo dziwny bug [en57]
« Odpowiedź #3 dnia: 06 Lutego 2007, 15:37:03 »
Ten sam problem dotyczy kabin. Po zmianie  home/end przdsionki i kabiny są w innych miejscach niż powinny być w modelu.
Chciałem taką misję zrobić w SDR18 ze zmianą czoła w EZT i sobie odpóściłem ze względu na ten błąd.

Offline MKaczy

  • Zasłużony dla Symulatora
  • Wiadomości: 485
  • ^Służbowe BMW^
    • Zobacz profil
    • http://zyciekolei.blox.pl/html
  • Otrzymane polubienia: 53
Bardzo dziwny bug [en57]
« Odpowiedź #4 dnia: 06 Lutego 2007, 16:53:34 »
Problem wydaje sie ze został rozwiazany. Podziekowania skaldam youBemu, gdyz jak zwykale okazał sie pomocny:)

Jesli ktos ma podobnie nalezy wykonac ta czynnosc:
Otwieramy pliki mmd jednstki w który mamy problem jak wyzej opisalem i zaraz na poczatku mamy taki wpsi:

//model pojazdu i definicje podmodeli:
models: 6Wb-a.t3d
//ruchome czesci (animations)
//krecace sie kola (o srednicy jak w *.chk)
animwheelprefix: wheel0
animdoorprefix: door0
// aktualnie mozna jeszcze animrodprefix, animpendulumprefix,
endmodels


Pod definicja modelu w tym przypadku "models: 6Wb-a.t3d"
dopisujemy:
lowpolyinterior: przedsionki.t3d
I to wszystko.

Dziekuje.
"Wsiąść do pociągu... towarowego..." :)
Maszynista - PKP Cargo CTOE-Szczecinek - ET22, 201EK, EU06, EU07, ET41, ET42, SM42, ST44-ko, SM42-6dg, ST48-Da

Offline Interesant

  • Wiadomości: 376
    • Zobacz profil
    • Drogowe Ochotnicze Pogotowie Ratunkowe
  • Otrzymane polubienia: 2
Bardzo dziwny bug [en57]
« Odpowiedź #5 dnia: 07 Lutego 2007, 18:30:51 »
Witam.
Cytat: "MKaczy"
Problem wydaje sie ze został rozwiazany. Podziekowania skaldam youBemu, gdyz jak zwykale okazał sie pomocny:)

Jesli ktos ma podobnie nalezy wykonac ta czynnosc:
Otwieramy pliki mmd jednstki w który mamy problem jak wyzej opisalem i zaraz na poczatku mamy taki wpsi:

//model pojazdu i definicje podmodeli:
models: 6Wb-a.t3d
//ruchome czesci (animations)
//krecace sie kola (o srednicy jak w *.chk)
animwheelprefix: wheel0
animdoorprefix: door0
// aktualnie mozna jeszcze animrodprefix, animpendulumprefix,
endmodels


Pod definicja modelu w tym przypadku "models: 6Wb-a.t3d"
dopisujemy:
lowpolyinterior: przedsionki.t3d
I to wszystko.

Dziekuje.

Czy moge prosić z polskiego na "nasze"?? bo nie rozumiem.
Interesant.

Offline MKaczy

  • Zasłużony dla Symulatora
  • Wiadomości: 485
  • ^Służbowe BMW^
    • Zobacz profil
    • http://zyciekolei.blox.pl/html
  • Otrzymane polubienia: 53
Bardzo dziwny bug [en57]
« Odpowiedź #6 dnia: 07 Lutego 2007, 20:21:51 »
Cytat: "Interesant"
Witam (...) Czy moge prosić z polskiego na "nasze"?? bo nie rozumiem.


Oczywiście:
Jesli z Tobie występuje taki błąd, jaki został opisany w pierwszyszm poscie (czyli nie masz przedsionków w EZT) to wykonaj ta czynność:


Otwórz plik mmd modelu EZTa w którym nie masz przedsionków i zaraz na pocztaku, u góry masz takie cos:

//model pojazdu i definicje podmodeli:
models: 6Wb-a.t3d
//ruchome czesci (animations)
//krecace sie kola (o srednicy jak w *.chk)
animwheelprefix: wheel0
animdoorprefix: door0
// aktualnie mozna jeszcze animrodprefix, animpendulumprefix,
endmodels
...

Pod definicja modelu dopisz lowpolyinterior: przedsionki.t3d
Czyli ma to w pliku mmd wygladac następująco

//model pojazdu i definicje podmodeli:
models: 6Wb-a.t3d
lowpolyinterior: przedsionki.t3d
//ruchome czesci (animations)
//krecace sie kola (o srednicy jak w *.chk)
animwheelprefix: wheel0
animdoorprefix: door0
// aktualnie mozna jeszcze animrodprefix, animpendulumprefix,
endmodels
...

i wsio:)
"Wsiąść do pociągu... towarowego..." :)
Maszynista - PKP Cargo CTOE-Szczecinek - ET22, 201EK, EU06, EU07, ET41, ET42, SM42, ST44-ko, SM42-6dg, ST48-Da

Offline Interesant

  • Wiadomości: 376
    • Zobacz profil
    • Drogowe Ochotnicze Pogotowie Ratunkowe
  • Otrzymane polubienia: 2
Bardzo dziwny bug [en57]
« Odpowiedź #7 dnia: 08 Lutego 2007, 00:13:06 »
Witam, dzięki.
ps czy moze ktoś wie jak można się pozbyć n/w błędu??



Paczka oparta o paczkę @Mariusz1970 z modyfikacją @Defiler'a + kilka dodatków: Bałtyk, SDRplus, ET22-2000, EN57 Modernizacje, Przełącznik Lato-Zima, ale odkąd pamiętam mam problem z przedsionkami i kabiną w sekcji rb.
Interesant.

Offline Mariusz1970

  • Zasłużony dla Symulatora
  • Wiadomości: 3925
    • Zobacz profil
  • Otrzymane polubienia: 276
Bardzo dziwny bug [en57]
« Odpowiedź #8 dnia: 08 Lutego 2007, 01:26:38 »
Najprościej, to zakładaj następne katalogi i jakoś je różnie nazywaj np. EN57s. Doprowadź do tagiego stanu, aby we wszystkich folderach były tylko 6ba,6bb i 6bs.
Aby dostosować do tego jakieś pliki np. 7ba,7bb,7bs należy:
1)założyć podfolder w dynamic np. en57s
2)przekopiować zawartość całego falderu en57 do 1
3)usunąć z 1 wszystkie pliki typu 6ba,6bb,6bs i inne mutacje (opróćz tego co zmieniamy czyli tutaj 7ba,7bb,7bs)
4)zmienić nazwy plików z 7 na 6
5)edytować dla każdej 7 plik mmd i zamiast 7 wstawić 6 np. z models: 7b-a.t3d na models: 6b-a.t3d
6)zmienić wpisy w sceneriach odpowiednio np. jak było:
node -1 0 EN57-1708ra dynamic PKP\en57 en57-1708r 7ba 0.0 headdriver 7 0 enddynamic

zmienić na:
node -1 0 EN57-1708ra dynamic PKP\en57s en57-1708r 6ba 0.0 headdriver 7 0 enddynamic

Dla wyszukania, które wpisy w scn należy zmienić najlepiej użyć opcji znajdź pliki, wskazać miejsce, szukane pliki *.*, z tekstem (i tu w zależności czego czukamy- w tym przypadku 7ba). Wypisze się nam lista plików do poprawienia.

Może to co napisałem na 1 rzut oka jest skomplikowane, ale tak nie jest, to jest chwila moment.
Wada tego rozwiązania, to trochę rozrzutność miejsca na dysku, ale skuteczność 100% i nie wymaga za bardzo myślenia. Jak tak sam
zrobiłem.

PS
Najepiej wywalić to co radził yB w tym momencie, gdyż te 2 rozwiązania się gryzą (nakładają na siebie).