Autor Wątek:  Video issues  (Przeczytany 247 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline plpazodo

  • Wiadomości: 3
    • Zobacz profil
  • Otrzymane polubienia: 0
Video issues
« dnia: 12 Maja 2020, 23:47:54 »
Hi Guys,

I am new to both simulator and forum, so far enjoying a lot but have some issues with video at night scenes. (please see attachments).

I have tested with both rendering modes simple and full but lights do not see correct.

By the way I am using an old laptop with the Intel HD 4400 integrated video, the simulation (20.04) runs smoothly but I have lightning issues at night, I tested with both Starter and Rainsted.

So my video card might be causing the issue but just wanted to confirm with some of you or if there is any available patch or adjustment in setting to fix this issue.

thanks

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8707
    • Zobacz profil
  • Otrzymane polubienia: 1663
Odp: Video issues
« Odpowiedź #1 dnia: 13 Maja 2020, 00:06:57 »
It's common issue with Intel gpu but should appear only on legacy renderer. For such configurations "simple (shaders)" rendering mode is recomended. Are you sure that screenshots are labeled correctly? Pixelated shadows and artifacts on the edge of that platform on full1 suggests otherwise.
« Ostatnia zmiana: 13 Maja 2020, 10:04:03 wysłana przez Stele »
Mój kanał youtube

Offline plpazodo

  • Wiadomości: 3
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Video issues
« Odpowiedź #2 dnia: 13 Maja 2020, 00:34:54 »
Yes, I think the Full1.jpg was "Simple" renderer.

Anyways I tested with "Full" and "Simple (Shaders)" rendering modes and same issue still happens.

So basically do I need to get a new laptop?

I have another one but also with integrated Intel UHD 620, do you think it will be same thing?

Thanks
« Ostatnia zmiana: 13 Maja 2020, 00:36:26 wysłana przez plpazodo »

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 8707
    • Zobacz profil
  • Otrzymane polubienia: 1663
Odp: Video issues
« Odpowiedź #3 dnia: 13 Maja 2020, 10:12:40 »
Strange. From bug reports it looks that intels openGL drivers has issue with half tones in fixed pipeline lighting calculations. As almost always peple reported white nights if any lamp is lit in the scene. But it never appeared in more modern renderer utilising shaders.
There might be something that forces lower setting when certain gpus are detected to prevent crashes. Please attach log.txt from test in simple (shaders) mode.
Mój kanał youtube

Offline plpazodo

  • Wiadomości: 3
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Video issues
« Odpowiedź #4 dnia: 13 Maja 2020, 23:13:56 »
Attached the log file together with 2 pictures.

With Simple (shaders) mode I can get dark nigh but as you can see the loco headlamps will not light the ground outside, I can see just a weird white texture.

I think I will keep playing only during daylight, but if you have any suggestion let me know. Thanks.