Autor Wątek:  Drawinowo.  (Przeczytany 4753 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline EP08_015

  • Zasłużony dla Symulatora
  • Wiadomości: 4339
    • Zobacz profil
  • Otrzymane polubienia: 312
Drawinowo.
« dnia: 14 Marca 2019, 10:42:40 »
Zauwazylem niedzialajace sygnalizatory przed tunelem te 4 komorowe mogące podac sygnal s1a. Wszystkie te semaforki na obu koncach tunelu sa ciemne dla wszystkich torow.
« Ostatnia zmiana: 14 Marca 2019, 12:33:00 wysłana przez EP08_015 »
Koniec tworczosci unoffowej i prywatnej.
http://chomikuj.pl/EP08-015

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2610
Odp: Drawinowo.
« Odpowiedź #1 dnia: 17 Marca 2019, 10:26:48 »
Uszkodzony model semafora sem/glowice/sbl4ypzcpc_dd.t3d. Nic z tym nie zrobię, bo semafory są tak skopane, że nie idzie ich zaimportować. Chyba, że istnieje jakiś podobny, różniący się tylko kolorami komór, który by szło dostosować w notatniku.
Mój kanał youtube

Offline Maciej

  • Zasłużony dla Symulatora
  • Wiadomości: 1195
    • Zobacz profil
  • Otrzymane polubienia: 192
Odp: Drawinowo.
« Odpowiedź #2 dnia: 23 Marca 2019, 17:02:56 »
Czy submodel o nazwie: _on koniecznie musi mieć wyzerowany transform? Bo najprostszym rozwiązaniem jest tutaj jego zastąpienie transformem sprzed rev. 3088. Czyli dla tego konkretnego przypadku byłby to transform z submodelu dokomory:
Cytuj
Transform:
           -1.62921e-007 -1.0 0.0 0.0
           -1.62921e-007 0.0 1.0 0.0
           -1.0 1.62921e-007 -1.62921e-007 0.0
           0.22539 -0.0875538 -0.125711 1.0

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2610
Odp: Drawinowo.
« Odpowiedź #3 dnia: 23 Marca 2019, 17:04:28 »
Nie, nie musi. Byle lampki były dobrze rozłożone, bo teraz wszystkie wywaliło w jedną komorę i obróciło.
Mój kanał youtube

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Drawinowo.
« Odpowiedź #4 dnia: 23 Marca 2019, 17:06:11 »
Podmien eksperymentalnie i zobacz czy to uleczy sytuacje. Z transformami jest sprawa o tyle skomplikowana ze ustawienie danego submodelu wplywa na ustawienie submodeli potomnych, wiec trudno na slepo stwierdzic czy efekt zmiany bedzie pozytywny.

Offline Maciej

  • Zasłużony dla Symulatora
  • Wiadomości: 1195
    • Zobacz profil
  • Otrzymane polubienia: 192
Odp: Drawinowo.
« Odpowiedź #5 dnia: 23 Marca 2019, 17:10:25 »
Sprawa byłaby załatwiona z tym semaforem, gorzej że są kolejne takie przypadki niestety, gdzie lampki były podpięte nie pod pierwszy submodel, tylko drugi (czyli dokomory). Wprowadzenie submodelu _on z zerowym transformem poprzestawiało lampki. Trzeba by wylistować, które z modeli z rev. 3088 miały lampki podpięte nie pod pierwszy submodel (chyba wszędzie jest to submodel komory).

EDIT: Znalazłem sobie sposób na szybkie ogarnięcie tego, bez konieczności porównywania każdego zmienionego pliku. Efekt jest taki, że poprawiłem w sumie 6 modeli z tym błędem. Poszło jako rev. 3641.
« Ostatnia zmiana: 23 Marca 2019, 19:06:29 wysłana przez Maciej »