Autor Wątek:  Dziwne szumy w lokomotywach  (Przeczytany 3474 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Javist

  • Wiadomości: 9
    • Zobacz profil
  • Otrzymane polubienia: 2
Dziwne szumy w lokomotywach
« dnia: 17 Listopada 2018, 20:24:29 »
Witam serdecznie,
przeglądając ostatnio scenerie i relacje, w które nigdy nie grałem, natknąłem się na bardzo irytujący problem związany z dźwiękami z gry. W niektórych lokomotywach jeszcze przed rozruchem słyszę przerywane szumy, ale nie takie, które można usłyszeć z radia (link do filmu niżej). Nie znikają one w czasie jazdy i pozostają właściwie do końca. Nie umiem do końca zidentyfikować źródła owych szumów, ale dochodzą one gdzieś z okolic Haslera.
Jak na razie problem występuje w kilku EU07 (na filmiku EU07-150 na scenerii l053-sluzba-1-night) oraz EP07 (m.in. 183 i 187 na mapie Drawinowo).

Co może być przyczyną i czy jest to normalne?
Problem występuje niekiedy na normalnym EXE, a nieraz tylko na eksperymentalnym z ostatniej aktualizacji, nie jestem w stanie stwierdzić kiedy i dlaczego, bo "losowo" coś szumi albo nie.

Dodatkowo załączam logi z tego samego uruchomienia normalnego EXE (eu07), akurat w tym wypadku gl33 wygląda podobnie.

Link do filmu:


Pozdrawiam.

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2610
Odp: Dziwne szumy w lokomotywach
« Odpowiedź #1 dnia: 17 Listopada 2018, 21:41:44 »
Kuny w warstwie izolacyjnej kabiny.
A tak serio. Nie jest to raczej wina konkretnego sampla. Nikt nie zgłaszał podobnego problemu do tej pory. Jedyne co mi przychodzi do głowy, to byś pobrał binarki do openal-soft. Jest tam program do zmiany ustawień. Może pokręcenie w nim coś da. Tylko mamy problem, bo strona wydawcy z której pobierałem padła. Znajduję tylko źródła na githubie, ale skompilowanych binarek nie ma.
Mój kanał youtube

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Dziwne szumy w lokomotywach
« Odpowiedź #2 dnia: 17 Listopada 2018, 22:18:18 »
Skompilowana aktualna wersja openAL-Soft jest dostepna ze strony projektu, http://openal-soft.org/#download

Offline joey

  • Deweloper
  • Wiadomości: 421
  • the Invisible Man
    • Zobacz profil
  • Otrzymane polubienia: 208
Odp: Dziwne szumy w lokomotywach
« Odpowiedź #3 dnia: 18 Listopada 2018, 00:45:26 »
Potwierdzam istnienie takiego szumiacego osmiobitowo sampla: 20786_203e_hasler_clock.wav. W zalaczniku radykalnie odszumiona przeze mnie wersja, pozbawiona niestety "ambientu", ale cos za cos.

Offline miko22

  • Wiadomości: 616
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 196
Odp: Dziwne szumy w lokomotywach
« Odpowiedź #4 dnia: 18 Listopada 2018, 11:12:07 »
W załączniku wersja z paczki 18_01. W 18_03 już jest chyba ciut gorzej, a w 18_07 jest już jak na filmiku.

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2610
Odp: Dziwne szumy w lokomotywach
« Odpowiedź #5 dnia: 18 Listopada 2018, 11:36:03 »
Przyciszam o 5dB i wrzucam. Rzeczywiście doszło pełno szumów przez normalizacje Żaby. Tylko czemu u mnie nie ma efektu jak na filmie podczas jazdy?
Mój kanał youtube

Offline miko22

  • Wiadomości: 616
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 196
Odp: Dziwne szumy w lokomotywach
« Odpowiedź #6 dnia: 18 Listopada 2018, 13:09:31 »
U mnie w paczkach 18_07 i 18_10 efekt też jest taki sam, jak na filmie. Sprawdziłem zarówno sam dźwięk, jak i jego odtwarzanie w EU07-150 (przy wyłączonej przetwornicy, bo to nie od niej dźwięk, tylko z dźwiękiem zegara w Haslerze coś się stało).
« Ostatnia zmiana: 18 Listopada 2018, 13:10:56 wysłana przez miko22 »

Offline Joachimowicz

  • ZbanowanyZbanowany
  • Wiadomości: 1701
  • Nazywam się N'Avoie
    • Zobacz profil
  • Otrzymane polubienia: 1950
Odp: Dziwne szumy w lokomotywach
« Odpowiedź #7 dnia: 18 Listopada 2018, 13:14:19 »
Exe też ma znaczenie. U TMJ dźwięk jest zdecydowanie lepszej jakości niż u Milka.
| Z maszyną od 20 Kwietnia 2010! |

Offline Javist

  • Wiadomości: 9
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Dziwne szumy w lokomotywach
« Odpowiedź #8 dnia: 18 Listopada 2018, 14:13:19 »
Dzięki wszystkim za odpowiedzi :)
Gdzie mam wstawić ten plik audio z haslerem i czy coś mam zmieniać w plikach? Bo w folderze sounds nic innego mi nie podmieniło.

//Edit:
W załączniku wersja z paczki 18_01. W 18_03 już jest chyba ciut gorzej, a w 18_07 jest już jak na filmiku.

Potwierdzam istnienie takiego szumiacego osmiobitowo sampla: 20786_203e_hasler_clock.wav. W zalaczniku radykalnie odszumiona przeze mnie wersja, pozbawiona niestety "ambientu", ale cos za cos.

Wersje z paczki nie chciały mi się podmienić na inny plik, więc musiałem znaleźć je ręcznie i podmienić... Windows. Gdy usunąłem tamten plik i podmieniłem z Waszymi rzeczywiście już szumów nie słychać (na obu wersjach exe w 18.10).

Dziękuję jeszcze raz wszystkim za pomoc i życzę miłego dnia :)

« Ostatnia zmiana: 18 Listopada 2018, 14:32:44 wysłana przez Javist »

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Dziwne szumy w lokomotywach
« Odpowiedź #9 dnia: 18 Listopada 2018, 14:33:41 »
Exe też ma znaczenie. U TMJ dźwięk jest zdecydowanie lepszej jakości niż u Milka.
Zapewne cos do rzeczy ma inna biblioteka uzywana do dekodowania sampli i/lub ustawienia tejze. Sprobujcie przekonwertowac te 8 bit na jakis format o normalnej rozdzielczosci, jest szansa ze cos sie dzieki temu poprawi.