Autor Wątek:  Ścina gry po skonfigurowaniu COM'a  (Przeczytany 3717 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Bartosz Dworniczek

  • Wiadomości: 17
    • Zobacz profil
  • Otrzymane polubienia: 0
Ścina gry po skonfigurowaniu COM'a
« dnia: 15 Października 2017, 12:24:01 »
Cześć. Mam Arduino i próbuję go skonfigurować pod EU07. W INI mam zapisane Arduino na COM3, w konsoli jak widać też konfiguruje: https://i.imgur.com/3FhdkVW.png I nagle słychać hamulec uderzeniowy, wszystko łubudubu w loku i laguje symka na wieczność. Jakieś rozwiązania?
Pozdrawiam!

Post piszemy poziomo. Obrazki umieszczamy na serwerze EU07.pl
Matek123
« Ostatnia zmiana: 15 Października 2017, 21:18:41 wysłana przez matek123 »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1002
    • Zobacz profil
  • Otrzymane polubienia: 746
Odp: Ścina gry po skonfigurowaniu COM'a
« Odpowiedź #1 dnia: 15 Października 2017, 16:19:25 »
Zacznijmy od tego że obsługa COM na starym systemie sterowania nie jest już rozwijana.
Exe z uartem w nowym systemie dostępne jest tu http://eu07.pl/forum/index.php/topic,28920.msg464659.html#msg464659, opis konfiguracji tu http://eu07.pl/forum/index.php/topic,28460.msg471061.html#msg471061

Jakiego kodu na arduino używasz? Prawdopodobnie wielkość ramek nie zgadza się z tą oczekiwaną przez exe.

Offline Bartosz Dworniczek

  • Wiadomości: 17
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Ścina gry po skonfigurowaniu COM'a
« Odpowiedź #2 dnia: 15 Października 2017, 17:18:24 »
Póki co nie wgrałem żadnego kodu do Arduino, na samym początku wolałem rozwiązać sam problem z zacinaniem się gry. Czy sam kod w Arduino może wpływać na to, czy symek się przytnie czy nie?

//EDIT

Po odpaleniu nowego EXE następujący error. Nie mogę znaleźć tego DLL nigdzie na Internecie.

« Ostatnia zmiana: 15 Października 2017, 17:20:16 wysłana przez Bartosz Dworniczek »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1002
    • Zobacz profil
  • Otrzymane polubienia: 746
Odp: Ścina gry po skonfigurowaniu COM'a
« Odpowiedź #3 dnia: 15 Października 2017, 17:21:28 »
Przecież on jest w paczce z libami w wątku z exe.
« Ostatnia zmiana: 15 Października 2017, 17:25:37 wysłana przez Stele »

Offline Bartosz Dworniczek

  • Wiadomości: 17
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Ścina gry po skonfigurowaniu COM'a
« Odpowiedź #4 dnia: 15 Października 2017, 17:27:36 »
Jasne, mój błąd, nie wiem dlaczego to przeoczyłem.

Jednak po odpaleniu symulatora z tego nowego EXE++ nie initializuje mi COM'a z Arduino. W przypadku odpalenia ze standardowego EXE działa.

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1002
    • Zobacz profil
  • Otrzymane polubienia: 746
Odp: Ścina gry po skonfigurowaniu COM'a
« Odpowiedź #5 dnia: 15 Października 2017, 17:32:41 »
Jasne, mój błąd, nie wiem dlaczego to przeoczyłem.

Jednak po odpaleniu symulatora z tego nowego EXE++ nie initializuje mi COM'a z Arduino. W przypadku odpalenia ze standardowego EXE działa.
Co to znaczy że nie inicjalizuje? Skonfigurowałeś zgodnie z opisem w drugim linku?
przykład:
//uart <nazwa portu><częstość wysyłania danych (czas)>
uart COM3 500000 0.1

//uarttune <ham. zespolony min> <max> <ham. dodatkowy min> <max> <ciśnienie max w zbiorniku gł.> <max wartość dla PWM> (to samo dla przewodu gł i cylindrów hamulcowych)
uarttune 46.0 943.0 175.0 874.0 0.9 1023.0 0.7 1023.0 0.5 1023.0 4000.0 1023.0 800.0 1023.0

//uartfeature <nastawnik> <bocznik> <hamulec> <hamulec lokomotywy>
uartfeature no no yes yes

//uartdebug <wyświetlanie danych debugowania w konsoli>
uartdebug yes

Offline Bartosz Dworniczek

  • Wiadomości: 17
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Ścina gry po skonfigurowaniu COM'a
« Odpowiedź #6 dnia: 15 Października 2017, 17:35:28 »
Tak, dodałem ten kod do eu07.ini zmieniając odpowiedni slot COM dla mojego Arduino. Brak oddzewu w konsoli, że COM zainicjalizowany.




« Ostatnia zmiana: 15 Października 2017, 17:36:47 wysłana przez Bartosz Dworniczek »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1002
    • Zobacz profil
  • Otrzymane polubienia: 746
Odp: Ścina gry po skonfigurowaniu COM'a
« Odpowiedź #7 dnia: 15 Października 2017, 17:38:31 »
Nie ma obecnie żadnego komunikatu. Włącz uartdebug yes i sprawdź czy wypisuje co wysyła.

Offline Bartosz Dworniczek

  • Wiadomości: 17
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Ścina gry po skonfigurowaniu COM'a
« Odpowiedź #8 dnia: 15 Października 2017, 17:44:24 »
Tylko raz wyskoczyła następująca linijka w debugu.



Przeczuwam, że to dobrze i ogólna komunikacja działa.

Załadowałem plik HEX do Arduino, jednak jak mogę sprawdzić na jaki pin jaka informacja będzie wysyłana?

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1002
    • Zobacz profil
  • Otrzymane polubienia: 746
Odp: Ścina gry po skonfigurowaniu COM'a
« Odpowiedź #9 dnia: 15 Października 2017, 17:52:09 »
Używasz gotowego kodu czy piszesz własny?
Nie wiem jak jest w arduino, ale jak podłączasz przez usb-uart to pewnie jest pod domyślnym Serial.
I choć na czat (link w nagłówku) bo ciężko gadać z takim lagiem przez forum.