Autor Wątek:  Symulator się nie uruchamia  (Przeczytany 11395 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Symulator się nie uruchamia
« dnia: 07 Sierpnia 2017, 22:24:29 »
Witam. Pobrałem najnowszą wersję Maszyny 17.07, ale nie mogę uruchomić żadnej scenerii. Wywala mi błąd. Wszystko zrobiłem wg instrukcji. Moja specyfikacja:
Procesor: Intel(R) Core(TM)2 Duo CPU T6600 @ 2 x 2.20GHz
Karta graficzna: ATI Mobility Radeon HD 4300 Series
RAM: 4 GB

Offline SMemek

  • Wiadomości: 126
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Symulator się nie uruchamia
« Odpowiedź #1 dnia: 08 Sierpnia 2017, 13:24:17 »
Te radeony często nie obsługują wymaganej wersji openGL. Sam to przerabiałem ze swoim zintegrowanym ATI  Radeon 2100. Przydałby się jeszcze log i errors.txt
« Ostatnia zmiana: 08 Sierpnia 2017, 14:19:42 wysłana przez SMemek »

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #2 dnia: 08 Sierpnia 2017, 21:21:49 »
W specyfikacji przeczytałem, że obsługuje OpenGL w wersji 1.5. Co do errors.txt, symulator nie wygenerował takiego pliku natomiast log.txt poniżej.

Offline Anrej

  • Wiadomości: 825
    • Zobacz profil
  • Otrzymane polubienia: 16
Odp: Symulator się nie uruchamia
« Odpowiedź #3 dnia: 10 Sierpnia 2017, 12:16:05 »
Niestety nic tam nie ma.

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #4 dnia: 11 Sierpnia 2017, 12:56:50 »
W takim razie co mam zrobić żeby symulator działał poprawnie?

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 994
    • Zobacz profil
  • Otrzymane polubienia: 744
Odp: Symulator się nie uruchamia
« Odpowiedź #5 dnia: 11 Sierpnia 2017, 13:10:13 »
ten log jest dosyć.. dziwny.
nie wygenerował się jakiś .dmp? jak jest to wrzuć to może tmj by mógł zobaczyć na niego.

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #6 dnia: 11 Sierpnia 2017, 15:02:47 »
.dmp w załączniku.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: Symulator się nie uruchamia
« Odpowiedź #7 dnia: 11 Sierpnia 2017, 15:22:08 »
Wyglada na to ze wysyp nastepuje przy inicjalizacji pythona. Do wersji 64-bit exe w systemie powinna byc zainstalowana 64-bitowa wersja pakietu python. Nie wiem, czy niezbedny komplet jest dolaczony do instalatora, jesli nie nalezy go pobrac z https://www.python.org/

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #8 dnia: 11 Sierpnia 2017, 15:27:36 »
3.6.2 czy 2.7.13?

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: Symulator się nie uruchamia
« Odpowiedź #9 dnia: 11 Sierpnia 2017, 16:13:41 »
2.7.13

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #10 dnia: 11 Sierpnia 2017, 16:27:09 »
Teraz po kliknięciu przycisku "Uruchom symulator" w Rainsted nie wyświetla się nawet okienko z zapisem przebiegu symulacji w log.txt, nic się nie ładuje, zero reakcji.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: Symulator się nie uruchamia
« Odpowiedź #11 dnia: 11 Sierpnia 2017, 16:55:03 »
Po zainstalowaniu pythona (z ustawieniami domyslnymi, tzn do 'program files' itp) zrestartuj system, przesun (lub skasuj) biblioteke python27.dll z folderu symulatora, upewnij sie ze w folderze symulatora jest podkatalog "python64" i uruchom exe bezposrednio zamiast poprzez starter. Daj znac, czy bedzie jakas zmiana.

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #12 dnia: 11 Sierpnia 2017, 17:07:34 »
Wywala taki oto błąd.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: Symulator się nie uruchamia
« Odpowiedź #13 dnia: 11 Sierpnia 2017, 18:01:54 »
Znaczy sie, albo sie python nie zainstalowal w ogole, albo zainstalowana zostala wersja 32-bit zamiast 64. Dla pewnosci, instalator wersji 64-bit jest tutaj: https://www.python.org/ftp/python/2.7.13/python-2.7.13.amd64.msi
sprobuj zainstalowac toto z wartosciami domyslnymi, restart i zobacz, czy pomoglo? Jesli nie pomoze, w ostatecznosci mozesz tez sprobowac uruchomic zamiast tego wersje 32-bit exe, to w sumie moze byc lepsza opcja na komputerze z 4 gb (wersja 64-bit jest nieco bardziej pamieciozerna)

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #14 dnia: 11 Sierpnia 2017, 23:25:35 »
Mamy taki oto błąd. Microsoft C++ Runtime Library z 2015 roku pobrane oraz zainstalowane a mimo to wyskakuje ten błąd.

Zmniejsz rozmiar załącznika. @matek123
« Ostatnia zmiana: 15 Sierpnia 2017, 22:40:37 wysłana przez matek123 »

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: Symulator się nie uruchamia
« Odpowiedź #15 dnia: 12 Sierpnia 2017, 01:22:00 »
Zwroc uwage, ze runtime wystepuje w dwoch wariantach, 32-bit i 64-bit. Jesli uruchamiasz wersje 64-bitowa potrzebne bedzie to drugie. Dla pewnosci warto byc moze pobrac wersje ze strony microsoftu: https://www.microsoft.com/en-us/download/details.aspx?id=48145 i zainstalowac jeszcze raz (obie wersje, x86 i x64)

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #16 dnia: 12 Sierpnia 2017, 14:50:23 »
Gdzie ten program się ma znajdować? Domyślnie czy w folderze Maszyny? Mam dwie partycje dysku, na C system a na D m.in. mam Maszynę.

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 10046
    • Zobacz profil
  • Otrzymane polubienia: 2571
Odp: Symulator się nie uruchamia
« Odpowiedź #17 dnia: 12 Sierpnia 2017, 15:02:12 »
Na systemowym. Te biblioteki nie mają nawet opcji instalacji gdzie indziej o ile pamiętam.
Mój kanał youtube

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #18 dnia: 12 Sierpnia 2017, 15:16:16 »
Obydwie wersje (x64 i x86) zainstalowane, dalej wywala błąd taki sam jak w pierwszej wiadomości wątku.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: Symulator się nie uruchamia
« Odpowiedź #19 dnia: 12 Sierpnia 2017, 16:39:25 »
Pokaz jak teraz wyglada log.txt, i jesli generuje sie crashdump, dolacz go do wiadomosci. Czy probowales tez uruchomic wersje 32-bit (x86), czy tylko x64?
« Ostatnia zmiana: 12 Sierpnia 2017, 16:42:31 wysłana przez tmj »

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #20 dnia: 12 Sierpnia 2017, 16:51:06 »
log.txt i crashdump w załączniku. Próbowałem obydwie wersje, żadna nie działa.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: Symulator się nie uruchamia
« Odpowiedź #21 dnia: 12 Sierpnia 2017, 19:27:47 »
W folderze symulatora ponownie/nadal znajduje sie python27.dll mimo, ze miales go stamtad usunac.

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #22 dnia: 12 Sierpnia 2017, 23:14:40 »
Usunięcie python27.dll i tak nic nie daje. Problem ten sam.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: Symulator się nie uruchamia
« Odpowiedź #23 dnia: 13 Sierpnia 2017, 00:30:08 »
Trzymanie tej biblioteki w katalogu symulatora jest o tyle problematyczne, ze przeszkadza ona przy probie uruchomienia wersji 64-bit. Pomijajac to, wyglada na to ze problemem jest nadal nieprawidlowa/niekompletna instalacja pakietow pythona -- symulator jako taki w ogole sie nie uruchamia, wysyp nastepuje wczesniej. Niestety na odleglosc trudno jest stwierdzic, co jest konkretnie nie tak.

Offline Anrej

  • Wiadomości: 825
    • Zobacz profil
  • Otrzymane polubienia: 16
Odp: Symulator się nie uruchamia
« Odpowiedź #24 dnia: 13 Sierpnia 2017, 23:54:13 »
A tam na pewno jest system 64-bit? w jednej linijce pliku dmp jest:
Windows 7 Version 7601 (Service Pack 1) MP (2 procs) Free x86 compatibleW moim przypadku system 64-bit jest:
Windows 7 Version 15063 MP (4 procs) Free x64

Offline Arpagus

  • Wiadomości: 14
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Symulator się nie uruchamia
« Odpowiedź #25 dnia: 14 Sierpnia 2017, 00:16:36 »
64 bit.

Offline Anrej

  • Wiadomości: 825
    • Zobacz profil
  • Otrzymane polubienia: 16
Odp: Symulator się nie uruchamia
« Odpowiedź #26 dnia: 14 Sierpnia 2017, 19:43:07 »
Nie masz odznaczone w ustawieniach zapis pliku "log txt"? Jak ja odznaczyłem, to miałem zapis logu taki jak Ty.