Autor Wątek:  Maszyna nie chcę się uruchomić  (Przeczytany 10007 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline konwi

  • Wiadomości: 3
    • Zobacz profil
  • Otrzymane polubienia: 0
Maszyna nie chcę się uruchomić
« dnia: 02 Sierpnia 2017, 18:51:38 »
Witam, prawdopodobnie ktoś już poruszał ten temat, ale moj problem tyczy się wersji 17.07. Zainstalowałem wszystko wg. instrukcji na stronie. Otwieram RAINSTED i mam wszystkie scenerie załadowane. Wybieram jedną z nich klikam uruchom symulator, po czym wyskakuje taki komunikat [załącznik]. Mam WIndowsa 7, procesor Intel core i5 (2,6 GHz), kartę NVIDIA Geforce 720m. Poprzedni patch - 16.08 działał poprawnie. Dodam również, że próbowałem zainstalować jeszcze raz C++ , ale zostałem powiadomiony, że aktualnie posiadam najnowszą wersję. Dziękuję za każdą pomoc :)
« Ostatnia zmiana: 02 Sierpnia 2017, 18:52:54 wysłana przez konwi »

Offline Piotr93

  • Deweloper
  • Wiadomości: 1501
    • Zobacz profil
  • Otrzymane polubienia: 825
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #1 dnia: 02 Sierpnia 2017, 18:56:21 »
Jaki masz system 64 czy 32 bitowy? pewnie wypakowałeś nie to exe dla tego wyświetla ci to.

Offline konwi

  • Wiadomości: 3
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #2 dnia: 02 Sierpnia 2017, 19:02:14 »
Mam 64-bitowy. Które exe powinienem zatem wypakować ?

Offline Piotr93

  • Deweloper
  • Wiadomości: 1501
    • Zobacz profil
  • Otrzymane polubienia: 825
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #3 dnia: 02 Sierpnia 2017, 19:02:50 »
x86, zapewne wypakowałeś 64 dla tego nie rusza, ja czasami się sam mylę na swoim 64bicie z tym i pobieram nie tą wersję, i wyskakuje mi to samo ;)
« Ostatnia zmiana: 02 Sierpnia 2017, 19:03:51 wysłana przez Piotr93 »

Offline konwi

  • Wiadomości: 3
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #4 dnia: 02 Sierpnia 2017, 19:04:18 »
Działa, dzięki. Mój, głupi błąd :P

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 10058
    • Zobacz profil
  • Otrzymane polubienia: 2572
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #5 dnia: 02 Sierpnia 2017, 19:46:33 »
Co ty bredzisz? Dla x64 powinny działać oba. Jak nie działa, to masz namieszane bilbioteki.
Mój kanał youtube

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 994
    • Zobacz profil
  • Otrzymane polubienia: 744
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #6 dnia: 03 Sierpnia 2017, 00:14:51 »
redist MSVC2015 64bit zainstalowany? jak tak, to doinstalować jeszcze redist MSVC2008 64bit.
jak nie pomoże to najlepiej pobrać Dependency Walkera i zobaczyć czego brakuje.
jak się potwierdzi że to brakuje 2008 to dodam do instalatora.

Offline Anrej

  • Wiadomości: 825
    • Zobacz profil
  • Otrzymane polubienia: 16
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #7 dnia: 03 Sierpnia 2017, 20:01:45 »
Ja instalowałem patach 2017.07.17 i z pliku instalacyjnego MaSzyna 2017.07.17 w każdym przypadku symulator się uruchamiał. Dlatego nie rozumiem, dlaczego coś ma być dodawane do instalatora. Jakby czegoś brakowała, to u mnie też nie powinno działać. Trzeba wiedzieć jaki się ma system i na bieżąco aktualizować.

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5904
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 428
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #8 dnia: 04 Sierpnia 2017, 13:53:52 »
Nie masz racji, niektore biblioteki w systemie nie sa instalowane jesli nie ma takiej potrzeby. Stad istnieje mozliwosc ich braku. Z tego powodu do niektorych instalatorow dolaczane jest pobieranie bibliotek i nie ma to nic wspolnego z aktualizacja windows!

Offline Anrej

  • Wiadomości: 825
    • Zobacz profil
  • Otrzymane polubienia: 16
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #9 dnia: 04 Sierpnia 2017, 21:13:20 »
Tak to od czego to zależy? Ja robię aktualizacją systemu i mnie aktualizuje. Sprawdziłem mam plik VC_redist.x64.exe, utworzony 22.07.2017, to jest wtedy jak instalowałem MaSzynę 2017.07.17. Jak kto nie wie jaki ma system, albo nie zezwoli aplikacji na zmiany, to ma problemy.
« Ostatnia zmiana: 04 Sierpnia 2017, 22:15:51 wysłana przez Anrej »

Offline Mariusz1970

  • Zasłużony dla Symulatora
  • Wiadomości: 3899
    • Zobacz profil
  • Otrzymane polubienia: 231
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #10 dnia: 04 Sierpnia 2017, 21:52:27 »
Jednego nie rozumiem, mianowicie, co to sa/jest "tedy"?

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5904
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 428
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #11 dnia: 06 Sierpnia 2017, 22:25:02 »
Anrej, przeczysz sobie w wypowiedzi. Aktualizacja systemu to zupelnie co innego niz aktualizacja paczki, a o obu rzeczach wspominasz. VC redist nigdy nie bylo w automatycznych aktualizacjach windows. Te biblioteki instaluja sie jako dodatkowe do roznych programow, teraz takze do symka.

Offline Anrej

  • Wiadomości: 825
    • Zobacz profil
  • Otrzymane polubienia: 16
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #12 dnia: 07 Sierpnia 2017, 17:24:55 »
Jak to przeczę sam sobie? Dodawałem patach do istniejącej paczki. Tylko tam trzeba uruchomić skrypt "usuń nie potrzebne pliki", rozpakować jedno z archiwów i dodać do paczki. Instalowałem też z instalki, gdzie na bieżąco wszystko pobiera i rozpakowuję. Przy końcu instalacji pyta się, czy zezwalasz VC redist na zmiany, czy coś tego. Problem w tym, że instalacja nigdzie nie została opisana.   

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5904
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 428
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #13 dnia: 08 Sierpnia 2017, 10:05:44 »
Ja instalowałem patach 2017.07.17 i z pliku instalacyjnego MaSzyna 2017.07.17 w każdym przypadku symulator się uruchamiał. Dlatego nie rozumiem, dlaczego coś ma być dodawane do instalatora. Jakby czegoś brakowała, to u mnie też nie powinno działać. Trzeba wiedzieć jaki się ma system i na bieżąco aktualizować.
W tej wypowiedzi napisales jakoby nalezy na bierzaco aktualizowac system operacyjny w biblioteki vcredist aby nie dodawac ich do instalatora. Tak zrozumialem Twoj post. Otoz uwazam ze dokladanie wszystkiego co wymysli Microsoft do systemu nie jest potrzebne jest czynnoscia zbedna. W naszym przypadku dolozenie instalacji bibliotek poprzez instalator jest sluszne i nie podlega dyskusji. Nie znam osob ktore aktualizuje windowsa na wyrost i instaluja cos, co nie przyda sie w zaden sposob. Byc moze trudno wyslowic co masz na mysli, podobnie jak w przypadku akomodacji oka do warunkow nocnych, gdzie pomyliles pojecia. Jeszcze cos, dodawanie pacza do starej paczki jest bledem w moim przekonaniu. Powinna byc instalacja do czystego folderu.
« Ostatnia zmiana: 08 Sierpnia 2017, 15:16:24 wysłana przez Krzysiek626 »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 994
    • Zobacz profil
  • Otrzymane polubienia: 744
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #14 dnia: 08 Sierpnia 2017, 10:09:28 »
Cytuj
Jeszcze cos, dodawanie pacza do starej paczki jest bledem w moim przekonaniu.
nie jest. w końcu to patch.

Offline Anrej

  • Wiadomości: 825
    • Zobacz profil
  • Otrzymane polubienia: 16
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #15 dnia: 08 Sierpnia 2017, 20:21:32 »
To mnie wytłumacz. Dlaczego ja instalowałem na dwa sposoby i nie miałem problemu. A inni mają problem. To co ja co innego ściągałem. Może źle się wyraziłem. Miałem na myśli. Instalujemy na czysty folder, paczkę MaSzyna 15-04, patach 16-08 i na to patach 17-07. To samo robi instalator MaSzyna 10-07.

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5904
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 428
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #16 dnia: 09 Sierpnia 2017, 09:37:40 »
Cytuj
Jeszcze cos, dodawanie pacza do starej paczki jest bledem w moim przekonaniu.
nie jest. w końcu to patch.
Eee tam. Zalezy jak na to patrzec. Jesli potraktujemy zmiany w paczu jako milowe, to otrzymujemy nowa jakosc, ktora niekoniecznie kazdemu odpowiada. W przypadku instalacji na istniejacej na dysku paczki tracimy bezpowrotnie starsza wersje symulatora. Czesto w tych folderach mamy swoje modyfikacje. Dobra zasada jest robienie kopii zapasowej... W tym przypadku jest to oznacza instalacje do pustego folderu, wszak instalator laduje poprzednia paczke z maszyna. Wszystko zalezy od punktu patrzenia, stad zalecam zachowanie starej paczki. Jesli sie znudzi, to zawsze zdazymy wyrzucic.

Offline mac310

  • Wiadomości: 446
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 44
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #17 dnia: 04 Września 2017, 16:06:16 »
To może ja nie będę zakładał nowego wątku tylko dopiszę się tutaj. Mam system 64-bit i powrzucałem wszystkie rzeczy dodatkowe (biblioteki itp) no i efekt jest taki, że exe podstawowe z paczki 17.07 oraz eu07++ng.exe i eu07++st_renew.exe uruchamiają się bez problemu, a gdy próbuję uruchomić eu07-x64_170903.exe to nie dzieje się nic (żadnych komunikatów o błędach) a w log.txt jest tylko jedna informacja Loading Python ...
Historia budowy pulpitu lokomotywy serii EU07.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #18 dnia: 04 Września 2017, 18:08:34 »
Podstawowe exe z paczki jest 32-bit, nie jestem pewien co do pozostalych. W paczce powinna byc tez wersja exe 64-bit, zobacz czy ona sie uruchomi? Jesli nie, to najprawdopodobniej brakuje plikow dla 64-bit wersji Pythona.

Offline mac310

  • Wiadomości: 446
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 44
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #19 dnia: 04 Września 2017, 23:59:39 »
Dziwna sprawa. Wrzuciłem jeszcze raz te same biblioteki Pythona i teraz ruszyło.
Historia budowy pulpitu lokomotywy serii EU07.

Offline Anrej

  • Wiadomości: 825
    • Zobacz profil
  • Otrzymane polubienia: 16
Odp: Maszyna nie chcę się uruchomić
« Odpowiedź #20 dnia: 06 Września 2017, 16:59:10 »
Jakbyś instalował, tak jak napisane, to powinno zadziałać. Powód prosty system masz może 64-bit, ale sterowniki do karty graficznej 32-bt. przecież sterowniki trzeba samemu zainstalować.