Autor Wątek:  Ratowanie MaSZyny, implementacja ficzerow od Q do głównej gałęzi, lifting exe  (Przeczytany 261289 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 9703
    • Zobacz profil
  • Otrzymane polubienia: 2292
13:48 to było z wiersza. Odpaliło mnie na TD2 w siódemce, więc parametr chyba powinien być taki sam, jak wysłany przez rainsted. :P
Mój kanał youtube

Offline mac310

  • Wiadomości: 420
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 38
Raczej nie bo ostatnie testy robię bez pulpitu na gołym laptoku. Może jeszcze zobaczę czy ustawienie informacji zwrotnych ma jakikolwiek wpływ. "Problem" w tym, że na razie wszystko działa ;)
Historia budowy pulpitu lokomotywy serii EU07.

Offline lukasn26

  • Wiadomości: 216
  • Zbanowany!
    • Zobacz profil
  • Otrzymane polubienia: 4
Co do pantografu w EP08 na drawinowo_ep07 ma połamany już od startu prawie, na 1-szym jedzie bez trakcji; na 2-gim w trakcję wkracza i pantograf łapie trakcję; na 3-cim i 4-tym jest już połamany... Zaraz sprawdzę na zwykłym exe, choć podejrzewam że będzie tak samo.

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5902
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 409
Zarejestrowałem nowy:
userpid: 1219702939
sysvers: 6.2.9200
sysname: Windows 8
servpak: No Service Pack Installed
Ciekawostka jest taka, że odpaliłem na windows10 a mimo to, w logu mam win8. Wszystko dla TD2 odbyło się poprawnie. Potwierdzam też, że przestało działać sterowanie zoomem za pomocą kółka myszy.

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
Raczej nie bo ostatnie testy robię bez pulpitu na gołym laptoku. Może jeszcze zobaczę czy ustawienie informacji zwrotnych ma jakikolwiek wpływ. "Problem" w tym, że na razie wszystko działa ;)

No to troche dziwne, ze wszystko dziala ;d

Offline lukasn26

  • Wiadomości: 216
  • Zbanowany!
    • Zobacz profil
  • Otrzymane polubienia: 4
Co do EP08 na zwykłym exe też się łamie.

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
Zarejestrowałem nowy:
userpid: 1219702939
sysvers: 6.2.9200
sysname: Windows 8
servpak: No Service Pack Installed
Ciekawostka jest taka, że odpaliłem na windows10 a mimo to, w logu mam win8. Wszystko dla TD2 odbyło się poprawnie. Potwierdzam też, że przestało działać sterowanie zoomem za pomocą kółka myszy.

6.2.9200 to jest windows 8, windows 10 jest 10.0.10586

Offline mac310

  • Wiadomości: 420
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 38
No to troche dziwne, ze wszystko dziala ;d
Może rzeczywiście trzeba było się wyspać ;)
Historia budowy pulpitu lokomotywy serii EU07.

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
E tam, wstalem wczoraj i nawet nie pamietam o ktorej, zaraz pewnie na 3h sie poloze, zobacze jak sie rozwinie sytuacja - jak bedzie dobrze to ide.

A tymczasem mam luzna propozycje do przedyskutowania. Niektorzy zapewne maja klawiatury multimedialne z powiedzmy dwudziestoma dodatkowymi przyciskami. Powiem ze mozna je oprogramowac, a nawet pokusic sie o konfiguracje coby mozna bylo sobie czynnosci przypisywac. Jesli byloby zapotrzebowanie to nie ma problemu zeby to oprogramowac.
Lista klawiszy multimedialnych:


 // 18 nowych klawiszy do przemyslenia czy jest sens (klawiatura multimedialna)
 if (Console::Pressed(VK_BROWSER_BACK)) WriteLog("VK_BROWSER_BACK");
 if (Console::Pressed(VK_BROWSER_FORWARD)) WriteLog("VK_BROWSER_FORWARD");
 if (Console::Pressed(VK_BROWSER_HOME)) WriteLog("VK_BROWSER_HOME");
 if (Console::Pressed(VK_BROWSER_SEARCH)) WriteLog("VK_BROWSER_SEARCH");
 if (Console::Pressed(VK_BROWSER_REFRESH)) WriteLog("VK_BROWSER_REFRESH");
 if (Console::Pressed(VK_BROWSER_STOP)) WriteLog("VK_BROWSER_STOP");
 if (Console::Pressed(VK_VOLUME_DOWN)) WriteLog("VK_VOLUME_DOWN");
 if (Console::Pressed(VK_VOLUME_UP)) WriteLog("VK_VOLUME_UP");                                                 
 if (Console::Pressed(VK_VOLUME_MUTE)) WriteLog("VK_VOLUME_MUTE");
 if (Console::Pressed(VK_LAUNCH_MAIL)) WriteLog("VK_LAUNCH_MAIL");
 if (Console::Pressed(VK_LAUNCH_MEDIA_SELECT)) WriteLog("VK_LAUNCH_MEDIA_SELECT");
 if (Console::Pressed(VK_MEDIA_PLAY_PAUSE)) WriteLog("VK_MEDIA_PLAY_PAUSE");
 if (Console::Pressed(VK_MEDIA_STOP)) WriteLog("VK_MEDIA_STOP");
 if (Console::Pressed(VK_MEDIA_NEXT_TRACK)) WriteLog("VK_MEDIA_NEXT_TRACK");
 if (Console::Pressed(VK_MEDIA_PREV_TRACK)) WriteLog("VK_MEDIA_PREV_TRACK");
 if (Console::Pressed(VK_SLEEP)) WriteLog("VK_SLEEP");
 if (Console::Pressed(VK_LAUNCH_APP1)) WriteLog("VK_LAUNCH_APP1");
 if (Console::Pressed(VK_LAUNCH_APP2)) WriteLog("VK_LAUNCH_APP2");
 
« Ostatnia zmiana: 12 Stycznia 2016, 15:31:10 wysłana przez queuedEU »

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5902
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 409
Q, po pierwsze nigdy nie miałem win8, dokonałem aktualizacji win7 do win10. W załączniku screen z właściwości kompa. Głupot bym z resztą nie pisał. 2 załącznik dotyczy opróżnienia peronu z pasażerów. Na Win10 pierwsze odpalenie z Rainsteda się posypało, powtórne było bez zająknięcia.
« Ostatnia zmiana: 12 Stycznia 2016, 15:32:28 wysłana przez Krzysiek626 »

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
No to pokaz jescze Krzysiek numer major minor build, na pewno sie gdzies doszukasz...

Offline mac310

  • Wiadomości: 420
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 38
Na razie wygląda bardzo obiecująco. Nie wiem tylko dlaczego przy wyświetlaniu pełnoekranowym pasek programów przykrywa okno symulacji i trzeba wyjść i wejść poprzez Alt+Tab żeby wyszło na wierzch.
« Ostatnia zmiana: 12 Stycznia 2016, 15:47:40 wysłana przez mac310 »
Historia budowy pulpitu lokomotywy serii EU07.

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
Ogarne to bo chyba wiem co popsulem, poniewaz eksperymentowalem z ustawieniami okna.

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5902
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 409
Q: dla Ciebie załącznik. Ja nie potwierdzam przymusu używania alt+tab, aby cokolwiek schować.

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
Przypominam, ze najnowsza paczka jest z dzisiaj z godziny 13.00

http://eu07.pl/forum/index.php/topic,27519.msg414450.html#msg414450

EU07-120116-1

http://eu07.es/EXETEST/EU07-120116-1.rar
« Ostatnia zmiana: 12 Stycznia 2016, 16:39:32 wysłana przez queuedEU »

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5902
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 409
Wczytuje się ładnie z Rainsteda i bezpośrednio z exe. Proponuje zmienić w exe domyślną nazwę wczytywanej scenerii na td2, nie trzeba będzie zmieniać nazwy scenerii po każdej jej aktualizacji do domyślnego uruchamiania bezpośrednio z exe. Tak więc u mnie banery nie przeszkadzają. Może dlatego, że mam starego rainsteda z kwietniowej paczki i pod żadnym pozorem nie zrobię jego aktualizacji. Za to u mnie po wciśnięciu F11, (screenshot) symulacja staje. To samo po prtScr. Z tymn, że po F11 mam zrzut ekranu z symulacji a po PrtScr w schowku mam ekran startowy. Tradycyjnie załącznik F11.

Offline mac310

  • Wiadomości: 420
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 38
No i jest to czego się obawiałem... samo przeszło i samo wróciło. Znowu się nie uruchamia i nawet z linii poleceń. Nic w międzyczasie nie robiłem więc to jakieś czary z mleka ;)
Chyba to przeczekam bo szkoda się kopać z koniem... może kiedyś przejdzie na dobre.
Może jeszcze spróbuję downgadować rainsteda jak sugeruje @Krzysiek626
« Ostatnia zmiana: 12 Stycznia 2016, 16:56:42 wysłana przez mac310 »
Historia budowy pulpitu lokomotywy serii EU07.

Offline trzecia_bateria

  • Wiadomości: 27
    • Zobacz profil
  • Otrzymane polubienia: 1
Tryb poglądu modeli-  wciśnięcie printscreena robi w folderze SCR działający plik BMP i jakiegoś popsutego jotpega. Wciśnięcie F11 robi to samo + wywala aplikacje. W configu mam ustawiony format zrzutów ekranu na JPG. W trakcie normalnej symulacji nie mam problemu z klawiszem F11.
userpid: 875721375

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
Juz sie zastanawialem kto mi robi konkurencje na liczbe logow na serwerze, a to mo super betatester :). Widze ze duzo modeli nie wczytuje tekstur, odpalasz z innej paczki z maszyna a w aktualnej ine ma ich, prawda?

Offline trzecia_bateria

  • Wiadomości: 27
    • Zobacz profil
  • Otrzymane polubienia: 1
Wybacz zapychanie serwera :) Pewnie 99% tych logów to te z modelviewera. Próbuje tam wybadać, co może powodować wysypywanie wczytywania modelu odpalanego z innej instalacji Maszyny (na logu widać to po tym, że urywa się on po linijce "aparams"). Mam parę potencjalnych przyczyn, ale póki co ciężko mi określić, która z nich (o ile nie jest to jeszcze jakaś inna) jest właściwa :)

A wracając do tekstur. Mam na dwóch różnych partycjach dwie w zasadzie jednakowe instalacje Maszyny, obie składają się z PC 15.04 plus pacz .26. Jedyna różnica to Twoje paczki wrzucone do jednej z nich. O ile więc dobrze Cię zrozumiałem, foldery z teksturami w obu powinny mieć tą samą zawartość :)

Ps. Aż mi głupio, w ogóle po lekturze pierwszych postów byłem przekonany, że niewczytywanie niektórych tekstur to póki co coś normalnego :P
userpid: 875721375

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 9703
    • Zobacz profil
  • Otrzymane polubienia: 2292
Jak w końcu działa, to zaczynam testować bajery. Zoom bez problemów. Filtr śnieżenia w 4:3 od lewego górnego rogu nie dochodząc do granic okna w żaden osi. Symek odpalany w 16:9 1080p.
Mój kanał youtube

Offline bohunIC

  • Zasłużony dla Symulatora
  • Wiadomości: 1407
  • Ну погоди
    • Zobacz profil
  • Otrzymane polubienia: 14
Nawet u mnie sie uruchamia :)

Offline eu07-001

  • Wiadomości: 336
    • Zobacz profil
  • Otrzymane polubienia: 3
Zaczyna być fajnie, bo w miarę stabilnie. Zmieniałeś coś w ustawieniu początkowym myszy? Teraz kursor ląduje u mnie w lewym górnym rogu zamiast na środku, uniemożliwiając patrzenie w lewo i w górę. Linux elementary 0.3.1, pid 21058, wine 1.6.2. Sprawdzę jeszcze jak to będzie na Windowsach.

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
Q, nie popsuj tylko blagam sie... ;).
Tak, mialo byc opcjonalne pokazanie sie kursora trzymajac prawy CTRL czy ALT, takie testy rozne robilem z mysla o przyszlosci modelwiewera, widocznie czegos tam nie przywrocilem do stanu poprzedniego - zaraz ogarne.
« Ostatnia zmiana: 12 Stycznia 2016, 23:42:53 wysłana przez queuedEU »

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 9703
    • Zobacz profil
  • Otrzymane polubienia: 2292
Jak szukałem klawisza do zooma, wcisnąłem prawy alt i kursor potem nie chciał zniknąć.
Mój kanał youtube

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
Stele, dziala Ci juz z Rainstedem? :>

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 9703
    • Zobacz profil
  • Otrzymane polubienia: 2292
Działa.
Mój kanał youtube

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
Jakies szczegoly, tak poprostu zaczelo sie przez polecenia Rainsteda odpalac?

-------------------------------------------------------------------------------------------------------------------
Paczka sprawdzajaca czy wszystko ok po sprzataniu pulapek w kodzie, kilka drobnych poprawek zgloszonych pomiedzy ta a poprzednia.

EU07-120116-2


« Ostatnia zmiana: 13 Stycznia 2016, 00:49:09 wysłana przez queuedEU »

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 9703
    • Zobacz profil
  • Otrzymane polubienia: 2292
Hm,, billboardy ciągle zakomentowane. Wychodzi, że testowałem na wczorajszej paczce albo nie nadpisałem czegoś.
Mój kanał youtube

Offline queuedEU

  • Zasłużony dla Symulatora
  • Wiadomości: 1265
    • Zobacz profil
    • Celebrity Maszyna
  • Otrzymane polubienia: 33
Dzis w planach wczytywanie indywidualnych charakterystyk dla konkretnego  pojazdu. Bedzie overridowanie parametrow wczytanych wczesniej z .fiz, .mmd oraz mozliwosc definiowania tekstur zmienialnych i dolaczania modeli (np przedmioty w kabinie).
Teraz pytanie... Co w pierwszej kolejnosci mozna by z parametrow fizyki nadpisywac, tak coby zmian byla zauwazalna?

Proponowany format pliku charakterystyki indywidualnej w zalaczniku.
« Ostatnia zmiana: 13 Stycznia 2016, 02:23:44 wysłana przez queuedEU »