Autor Wątek:  Niewłaściwy obraz na semaforze  (Przeczytany 5415 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline danniel

  • Wiadomości: 309
  • Degustator w Lokalnym Centrum Lepienia Pierogów
    • Zobacz profil
  • Otrzymane polubienia: 93
Niewłaściwy obraz na semaforze
« dnia: 30 Marca 2016, 10:56:43 »
Cytuj
Jak postanowiłem, tak i zrobię.
Zacząłem znowu coś rozgrzebywać... Jadąc razem z AI SM42-1154 (zaznaczone na czerwono, kropka - tu stoi SM04) zauważyłem, że "świeci się czerwone", a w tabelce jest -1 czyli maksymalna prędkość. Skład jedzie sobie dalej, ale zwykły użytkownik miałby tutaj koniec jazdy. Dlaczego tak jest?

W pośpiechu zapomniałem dodać, że sceneria oparta jest na układzie torowym programu ISDR Lisków Miasto - http://www.dokumentacja.isdr.pl/
« Ostatnia zmiana: 30 Marca 2016, 11:52:35 wysłana przez danniel »
Pierogi lepić! A nie, na szołtbuksach siedzić.

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10132
    • Zobacz profil
  • Otrzymane polubienia: 2601
Odp: Niewłaściwy obraz na semaforze
« Odpowiedź #1 dnia: 30 Marca 2016, 17:17:21 »
Jakim incem jest ten semafor? Poprawny stan komórki mu się ustawia przy takim evencie? Zaloguj sobie stan komórek i sprawdź co się dzieje w scenerii.
Mój kanał youtube

Offline danniel

  • Wiadomości: 309
  • Degustator w Lokalnym Centrum Lepienia Pierogów
    • Zobacz profil
  • Otrzymane polubienia: 93
Odp: Niewłaściwy obraz na semaforze
« Odpowiedź #2 dnia: 30 Marca 2016, 19:41:13 »
Jest to ss5zcpbi.inc.
Przed podaniem semafora:
Memcell "lr_tox_sem_distmem": SetProximityVelocity 500 0
Memcell "lr_x_sem_mem": SetVelocity 0 0
Po:
Memcell "lr_tox_sem_distmem": SetProximityVelocity 500 0
Memcell "lr_x_sem_mem": SetVelocity -1 0
Dodatkowo zastanawia mnie komórka, której wartość jest "dziwna":
Memcell "": Ĺ☻˘ 0 0
« Ostatnia zmiana: 31 Marca 2016, 15:38:19 wysłana przez danniel »
Pierogi lepić! A nie, na szołtbuksach siedzić.

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10132
    • Zobacz profil
  • Otrzymane polubienia: 2601
Odp: Niewłaściwy obraz na semaforze
« Odpowiedź #3 dnia: 31 Marca 2016, 18:08:05 »
Wg repowskiego inca to światła powinny działać. Obadaj S10, może ma kopniętą trzecią komorę w modelu. Choć wtedy by czerwone zgasło...
Wartość tej komórki nie jest dziwna. To efekt deklaracji bez ustalenia wartości początkowej. Interpretacja przydzielonej jej pamięci na tekst dała takie znaczki. Mnie bardziej dziwi jej nazwa.
Mój kanał youtube

Offline firleju

  • Zasłużony dla Symulatora
  • Wiadomości: 1588
  • bawię się (w) exe...
    • Zobacz profil
  • Otrzymane polubienia: 120
Odp: Niewłaściwy obraz na semaforze
« Odpowiedź #4 dnia: 31 Marca 2016, 20:49:56 »
Nie wiem czy to ma znaczenie. Ale w pliku inc linijka z eventem ligh5 pomiędzy 3 i 4 parametrem ma dwie spacje.
Skrypty do Blendera dostępne tutaj
W miarę aktualne wiki EXE wiki.eu07.es

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10132
    • Zobacz profil
  • Otrzymane polubienia: 2601
Odp: Niewłaściwy obraz na semaforze
« Odpowiedź #5 dnia: 31 Marca 2016, 21:35:13 »
Ma ale teoretycznie ilość białych znaków nie ma znaczenia...
Mój kanał youtube

Offline firleju

  • Zasłużony dla Symulatora
  • Wiadomości: 1588
  • bawię się (w) exe...
    • Zobacz profil
  • Otrzymane polubienia: 120
Odp: Niewłaściwy obraz na semaforze
« Odpowiedź #6 dnia: 31 Marca 2016, 22:15:41 »
W niektórych nie ma, w niektórych ma...
Skrypty do Blendera dostępne tutaj
W miarę aktualne wiki EXE wiki.eu07.es

Offline danniel

  • Wiadomości: 309
  • Degustator w Lokalnym Centrum Lepienia Pierogów
    • Zobacz profil
  • Otrzymane polubienia: 93
Odp: Niewłaściwy obraz na semaforze
« Odpowiedź #7 dnia: 01 Kwietnia 2016, 16:06:02 »
Przypatrzyłem się dokładniej incowi. Wyszło na to, że to jakaś "zmutowany" semafor :) pochodzenia ss5zpcpbi.inc i ss4zcpbi.inc. Nie widzę sensu istnienia takiej niedoróbki.
« Ostatnia zmiana: 01 Kwietnia 2016, 16:14:05 wysłana przez danniel »
Pierogi lepić! A nie, na szołtbuksach siedzić.