Autor Wątek:  Brak renderowania niektórych elementów  (Przeczytany 649 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Benek

  • Moderator
  • Wiadomości: 4500
  • fb.com/benek.maszyna
    • Zobacz profil
    • Moja strona o MaSzynie
  • Otrzymane polubienia: 11
Brak renderowania niektórych elementów
« dnia: 13 Kwietnia 2022, 20:56:46 »
Maszynę uruchomiam przez Wine, więc jedynie można jej płynnie używać ze starym trybem renderowania wraz z minimalnymi ustawieniami. Zainstalowałem paczkę całościową 2203 i na tych ustawieniach brakuje screena podczas ładowania scenerii (jest zielone tło), a także dodatkowych okien jak pomocnik maszynisty. Problem ten zgłaszałem w tym poście. Wszystkie te problemy znikają w pełnym trybie renderowania, ale symulacja tnie. Z tego powodu wgrałem sobie do paczki 2203 exe z paczki 2104, by móc korzystać z okienek (cały czas mam na myśli stary tryb renderowania). W pewnym momencie chciałem sobie przetestować Impulsa i ku mojemu zdziwieniu nie załączają się ekrany na exe 2104. Sprawdziłem jak to wygląda na exe 2203 i tam wszystko działa, ale przez brak dodatkowych okien nie jest to satysfakcjonujące rozwiązanie. W załączniku zrzuty z ekranu, logi i błędy.

P. S. Czy ekran z podglądem przedziałów nie powinien być także włączony (obraz 2203.png)?

Offline youBy

  • Deweloper
  • Wiadomości: 6114
  • Co tam?
    • Zobacz profil
    • Automat Weryfikujący Regulację i Lambdę
  • Otrzymane polubienia: 751
Odp:  Brak renderowania niektórych elementów
« Odpowiedź #1 dnia: 13 Kwietnia 2022, 21:00:51 »
Exe z paczki 21.04 nie obsługuje funkcji wykorzystywanych w nowych ekranach, o czym świadczy log:
Traceback (most recent call last):
  File "<string>", line 62, in render
  File "<string>", line 369, in _render
KeyError: 'universal6'

Ad PS - to jest ogólnie widok podglądu monitoringu. Na pojazdach z ENTE są przygotowane "zastępcze" lusterka, tutaj kiedyś też się pojawią. Pełne renderowanie kolejnych widoków z kamer mogłoby jeszcze bardziej dobić płynność symulacji.
Xoov
Powyższy post wyraża jedynie opinię autora w chwili publikacji. Autor zastrzega sobie prawo do zmiany poglądów bez podawania przyczyny, jak również informowania o tym.

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 990
    • Zobacz profil
  • Otrzymane polubienia: 741
Odp: Brak renderowania niektórych elementów
« Odpowiedź #2 dnia: 13 Kwietnia 2022, 21:50:17 »
Z tego powodu wgrałem sobie do paczki 2203 exe z paczki 2104, by móc korzystać z okienek (cały czas mam na myśli stary tryb renderowania). W pewnym momencie chciałem sobie przetestować Impulsa i ku mojemu zdziwieniu nie załączają się ekrany na exe 2104.
- Panie doktorze, boli jak wyciągnę z archiwum stare exe i użyję z nową paczką.
- To niech Pan tak nie robi.

Co do GUI, to zbudowanie sobie exeka z -DUSE_IMGUI_GL3=OFF ma szansę pomóc. Ewentualnie sprawdzić z nowym Mesa (bo masz jakąś sprzed ponad roku), ale nie liczyłbym że coś dużo poprawiali w zakresie miksowania GL3 z compatiblity profile.

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 990
    • Zobacz profil
  • Otrzymane polubienia: 741
Odp: Brak renderowania niektórych elementów
« Odpowiedź #3 dnia: 13 Kwietnia 2022, 22:18:02 »
Ok, było prościej niż myślałem. Zmieniłem wybór wersji imgui na dynamiczny przy uruchamianiu, więc tryb legacy będzie używał GL2 i nie trzeba kompilować samemu. Nowe exe będą na azure jak się zbudują.

Offline Benek

  • Moderator
  • Wiadomości: 4500
  • fb.com/benek.maszyna
    • Zobacz profil
    • Moja strona o MaSzynie
  • Otrzymane polubienia: 11
Odp: Brak renderowania niektórych elementów
« Odpowiedź #4 dnia: 14 Kwietnia 2022, 19:58:54 »
Można prosić link? Dogrzebałem się do logów z jobów i nie bardzo widzę, gdzie można pobrać exe.

Online Turbokibel

  • Wydział Repozytorium
  • Wiadomości: 1416
    • Zobacz profil
  • Otrzymane polubienia: 1108
Odp: Brak renderowania niektórych elementów
« Odpowiedź #5 dnia: 14 Kwietnia 2022, 20:00:07 »
« Ostatnia zmiana: 14 Kwietnia 2022, 20:01:44 wysłana przez Turbokibel »

Offline Benek

  • Moderator
  • Wiadomości: 4500
  • fb.com/benek.maszyna
    • Zobacz profil
    • Moja strona o MaSzynie
  • Otrzymane polubienia: 11
Odp: Brak renderowania niektórych elementów
« Odpowiedź #6 dnia: 14 Kwietnia 2022, 21:07:13 »
Działa. I jeszcze zwiększył się FPS. Czy można te zmiany uwzględnić w jakimś patchu?