Autor Wątek:  Poważne problemy z exe  (Przeczytany 837 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Celuś

  • Wiadomości: 10
    • Zobacz profil
  • Otrzymane polubienia: 319
Poważne problemy z exe
« dnia: 10 Września 2022, 20:35:43 »
Po kilku miesiącach problem mnie już na tyle denerwuje, że czas wywlec na forum. Sprawa wygląda następująco.

Problem:
Symulator w pewnych okolicznościach chwilę po uruchomieniu w towarzystwie przerywanego dźwięku i jednolicie kolorowego nieba wywala do pulpitu, bez żadnego chrashdumpa, albo wskazówki w logu.

Okoliczności:
0. Problem występuje od wersji 22.03 oraz początku dołączania doń exe z gałązki milka.
1. Operujemy na terenie autorskim, ciężkim terenie z NMT. Nie ważne jest ile go jest.
2. Problem występuje jedynie na starym trybie renderowania.
3. W logu brak informacji o zdarzeniu. Brak crashdumpa.
4. Problem występuje po ukończeniu zaczytywania scenerii z zaincludowanym terenem z plików *.scm. Po ich zakomentowaniu i ponownym uruchomieniu scenerii, tym razem z *.sbt problem nie występuje.
4a. Oddzielnym problem jest, iż w ostatnim czasie dopiero ponowne uruchomienie scenerii z sbt pozwala na symulację - za pierwszym razem kończy się to tak samo jak w pkt 4. Po drugim uruchomieniu, każde następne również jest sukcesywne, chyba że nastąpi zmiana w *.scn.

Informacje dodatkowe:
0. Problem występuje jedynie w kontekście terenu, nie mają na niego wpływy inne elementy scenerii, ani pojazdy.
1. Problem nie występował na ostatnim exe tmj.
2. Problem nie występuje w przypadku innych scenerii, nawet przy terenie do nowej części L61, mimo że powstawał dokładnie tą samą metodą.
3. Problem występuje nawet jeśli był obrabiany przez inną osobę, a mi podesłane zostały finalne scm i sbt.
4. Problem wydaje się nie występować u innych (testowane milek7, jan21, kolejarz).
5. Problemem wydaje się nie być w specyfikacja komputera. Dalsza symulacja - po załadowaniu, pkt 4a okoliczności - jest w pełni płynna.

Bardzo proszę o pomoc gdyż jeśli problem będzie się utrzymywał, to być może w ostateczności będę zmuszona zaprzestać prac nad scenerią. Proszę sobie darować porady o wymianie komputera - nie jestem w stanie teraz sobie nowego sprzętu zafundować, ale również jak w liście wyżej - wywalanie symulatora po załadowaniu w pewnych okolicznościach jest jedynym problem. Również w przyszłości, jeżeli problemu nie da się rozwiązać, może on występować u innych osób. Choć nie widzę sensu, załączam log - nic tam nie ma. Crashdumpa również brak.

Ed.: Sytuacja z punktu 4a napotakała mnie o dziwo na Td przed chwilą.
« Ostatnia zmiana: 12 Września 2022, 13:07:31 wysłana przez Celuś »

Offline Celuś

  • Wiadomości: 10
    • Zobacz profil
  • Otrzymane polubienia: 319
Odp: Poważne problemy z exe
« Odpowiedź #1 dnia: 15 Września 2022, 23:15:33 »
Okazuje się, że antidotum na powyższe problemy to opcja pauzy po uruchomieniu. To jednak budzi pewne pytania - czy symulator wyrzuca dlatego, że bez pauzy na starcie nie jest w stanie załadować wszystkiego do czasu uruchomienia symulacji, a gdy ta się uruchamia to ją wywala? Czy chodzi jednak o coś innego...

Offline matek123

  • Moderator
  • Wiadomości: 5624
    • Zobacz profil
  • Otrzymane polubienia: 1773
Odp: Poważne problemy z exe
« Odpowiedź #2 dnia: 16 Września 2022, 07:35:55 »
Obecnie ai obsiada wszystkie pojazdy i dopiero user wsiada i przejmuje. Prży wymagajacych sceneriach/scenariuszach zanim doładowało do końca maszynę, to Ai potrafiło częściowo odpalić lokomotywę. Tu też pomaga pauza na starcie.

Ale Twój przypadek jest dziwny, bo teren i resztę ładuje przed pojazdami...
« Ostatnia zmiana: 16 Września 2022, 07:37:06 wysłana przez matek123 »
Poszukuję zdjęć na tekstury pociągów sieciowych. Szczególnie platform z pomostami.

Offline Celuś

  • Wiadomości: 10
    • Zobacz profil
  • Otrzymane polubienia: 319
Odp: Poważne problemy z exe
« Odpowiedź #3 dnia: 16 Września 2022, 08:07:13 »
Wskazówką mogą być ostatnie chwilę przed wysypem, oraz teraz gdy już wszystko działa - pierwsze sekundy po odpauzowaniu. W obu przypadkach pojawia się widok z kabiny. Jednak po pierwsze - niebo nie wyświetla się poprawnie. Zamiast zanimowanej kopuły jest ono jednokolorowe, podobnie mgła. Przypomina to maszynę 2010. Światła semaforów również zapalają się (w przypadku sukcesu przy uruchomieniu) dopiero po chwili, wraz z niebem. Dźwięk, o ile jest jakiś na starcie chwilę przed wysypem zaczyna szarpać. Po chwili symulator wysypuje do pulpitu, bez żadnego braku odpowiedzi.

Offline M79r

  • Wiadomości: 162
    • Zobacz profil
  • Otrzymane polubienia: 174
Odp: Poważne problemy z exe
« Odpowiedź #4 dnia: 17 Września 2022, 23:45:45 »
Ja mam dziwną sprawe. Wczoraj samo włączyło mi się dembug mode. Dziś tor jakby się rozwarstwił lub był szyna na szyne nałożony i nie spasowany. Dodam nić w torach na tym odcinku nie robiłem. Wczoraj śmigał ok skład ta dziś w obydwu kierunkach składy zatrzymują się (AI). Chcesz przejechać normalnie na loku to wykolejenie sie robi. Czary mary jakieś sie dzieją
« Ostatnia zmiana: 18 Września 2022, 00:07:41 wysłana przez M79r »

Offline JAN21

  • Deweloper
  • Wiadomości: 377
  • Spec od budowy scenerii
    • Zobacz profil
  • Otrzymane polubienia: 1124
Odp: Poważne problemy z exe
« Odpowiedź #5 dnia: 17 Września 2022, 23:56:33 »
Porządek w plikach trzeba trzymać i do Loga zaglądać :P

Zdublowane tory na unoffowej mapce nie są poważnym problemem w exe. Problem Celusi rozwiązany, to zamykam. @Stele
« Ostatnia zmiana: 18 Września 2022, 00:47:47 wysłana przez Stele »
Na codzień grzebie przy Alfach i reszcie Włoszczyzny, po godzinach buduję scenerie.

Aktualne projekty:  Linia 61 Cz. Stradom - Kielce: 80% GKT: 10%