Autor Wątek:   Maszyna 19.08 - problemy  (Przeczytany 81922 razy)

0 użytkowników i 2 Gości przegląda ten wątek.

Offline joey

  • Deweloper
  • Wiadomości: 422
  • the Invisible Man
    • Zobacz profil
  • Otrzymane polubienia: 209
Odp: Maszyna 19.08 - problemy
« Odpowiedź #150 dnia: 08 Września 2019, 12:08:11 »
Cookie: czy jest to zwiazane z ustawieniem okienka pomocnika w lewym gornym rogu?
https://eu07.pl/forum/index.php/topic,29423.msg501018.html#msg501018

Offline Cookie

  • Wiadomości: 273
  • Dzień dobry, jak leci?
    • Zobacz profil
  • Otrzymane polubienia: 121
Odp: Maszyna 19.08 - problemy
« Odpowiedź #151 dnia: 08 Września 2019, 12:22:22 »
Zgadza się, mam tam pomocnik i po przesunięciu go lekko w prawo zaczęło wszystko ładnie działać. Dzięki wielkie!
Ta piękna stalowa MaSzyna... Która wozi mnie na wakacje...

Offline esemzerotrzy

  • Wiadomości: 18
    • Zobacz profil
  • Otrzymane polubienia: 3
Odp: Maszyna 19.08 - problemy
« Odpowiedź #152 dnia: 09 Września 2019, 17:26:52 »
Ja mam podobnie (niskie FPS) jak włączę cienie. Bez cieni jest OK oczywiście przy założeniu, że odpala z normalnej grafiki, a nie intelowskiego erzacu.

U mnie wyłączenie cieni niewiele pomaga, a dla porównania, do tej pory miałem wydanie sprzed roku i tam wszystko płynnie szło, teraz się grać nie da, czy to możliwe, żeby przez ten rok aż tak się Maszyna zmieniła?... Nawet na td jest bardzo mało FPS

Offline mac310

  • Zasłużony dla Symulatora
  • Wiadomości: 518
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 73
Odp: Maszyna 19.08 - problemy
« Odpowiedź #153 dnia: 09 Września 2019, 17:57:48 »
Nie wiem co u Ciebie jest przyczyną ale ja miałem taki efekt, że mimo tego że ustawiłem wybór karty graficznej na GeForce i taka w logu się pojawiała to i tak wydajność była na poziomie kilkunastu FPSów. Kompletnie nie mam pojęcia dlaczego. Czasami po restarcie całego komputera zaczynało działać dobrze, a czasami nie. Jak podłączałem się pod monitor to zawsze było dobrze, a jak podpisałem do TV to lipa. Czasami na ekranie laptopa też było słabo. Od jakiegoś czasu jest znowu dobrze ale nie wiem co powoduje takie drastyczne sparki wydajności. Jak było źle to wymuszenie Intela zaskakująco dawało wyższe FPS niż na GeForce choć i tak nie było więcej niż 30.
Jak masz możliwość to zobacz czy na zewnętrznym monitorze się nie poprawi. Może u Ciebie jest inny problem ale może coś to da. Jak wrócę do domu to wstawię moje ustawienia z eu07.ini.
Historia budowy pulpitu lokomotywy serii EU07.

Offline Turbokibel

  • Zasłużony dla Symulatora
  • Wiadomości: 1598
    • Zobacz profil
  • Otrzymane polubienia: 1293
Odp: Maszyna 19.08 - problemy
« Odpowiedź #154 dnia: 09 Września 2019, 17:58:40 »
Ja mam podobnie (niskie FPS) jak włączę cienie. Bez cieni jest OK oczywiście przy założeniu, że odpala z normalnej grafiki, a nie intelowskiego erzacu.

U mnie wyłączenie cieni niewiele pomaga, a dla porównania, do tej pory miałem wydanie sprzed roku i tam wszystko płynnie szło, teraz się grać nie da, czy to możliwe, żeby przez ten rok aż tak się Maszyna zmieniła?... Nawet na td jest bardzo mało FPS
Czy masz aktualne sterowniki do GPU?
Otrzymałem permanentnego bana na 6h xD

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Maszyna 19.08 - problemy
« Odpowiedź #155 dnia: 09 Września 2019, 18:02:19 »
pobrałem dzisiaj najnowsze wydanie symulatora i po uruchomieniu misji większość tekstur nie wczytała się poprawnie. Czy jest jakaś możliwość żebym mógł normalnie grać? Poza tym mimo procesora i7 i 16 GB ramu symulator paskudnie się przycina, jest bardzo mało fps, z tym też można coś zrobić?
Renderer: Quadro 4000/PCIe/SSE2
Vendor: NVIDIA Corporation
Karty Quadro sa dla symulatora dosc problematyczne, ze wzgledu na to ze sa to (w zalozeniu) uklady do profesjonalnego projektowania CAD ktore ma nieco inne potrzeby niz gry. Z tego co pamietam inni uzytkownicy tych kart przynajmniej czesciowo rozwiazali swoje problemy ustawiajac w aplikacji kontrolujacej parametry karty profil "do gier" czy cos w tym stylu.

edit Dodatkowo:
texture sizes capped at 8192px
using multisampling x16
To sa dosc szalone parametry, do zastosowania raczej na najsilniejszym sprzecie. Proponuje wstepnie dac w pliku eu07.ini cos na poziomie
maxtexturesize 2048
multisampling 1
i zobaczyc czy sytuacja sie nie poprawi.
« Ostatnia zmiana: 09 Września 2019, 18:06:04 wysłana przez tmj »

Offline esemzerotrzy

  • Wiadomości: 18
    • Zobacz profil
  • Otrzymane polubienia: 3
Odp: Maszyna 19.08 - problemy
« Odpowiedź #156 dnia: 09 Września 2019, 18:57:29 »
Dziękuję za pomoc, karta dawała radę na Maszynie sprzed roku, oczywiście tylko na drugim exe. Nie mam żadnej aplikacji do tej karty, więc nie mogę tego ustawić. Po zmianie tych parametrów nic lub prawie nic się nie zmieniło (nie zauważyłem zmian).

Offline Turbokibel

  • Zasłużony dla Symulatora
  • Wiadomości: 1598
    • Zobacz profil
  • Otrzymane polubienia: 1293
Odp: Maszyna 19.08 - problemy
« Odpowiedź #157 dnia: 09 Września 2019, 19:01:12 »
Aby sprawdzić wersję sterownika GPU, wejdź w menedżer urządzeń > karty graficzne > Naciśnij 2x LPM na twoją kartę graficzną > Sterownik i tam powinna być wersja sterownika.
« Ostatnia zmiana: 09 Września 2019, 19:02:18 wysłana przez Turbokibel »
Otrzymałem permanentnego bana na 6h xD

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2610
Odp: Maszyna 19.08 - problemy
« Odpowiedź #158 dnia: 09 Września 2019, 19:06:14 »
Nvidia zawsze wraz ze sterownikiem instaluje aplikację konfiguracyjną. Jak serio masz goły sterownik, to dociągnij sobie pełniejszy pakiet ze strony wydawcy.
Mój kanał youtube

Offline esemzerotrzy

  • Wiadomości: 18
    • Zobacz profil
  • Otrzymane polubienia: 3
Odp: Maszyna 19.08 - problemy
« Odpowiedź #159 dnia: 09 Września 2019, 19:08:00 »
Wersja sterownika to 21.21.13.6909
Kojarzę, że miałem kiedyś jakiś program do tego, ale teraz już nie (musiałem przypadkowo usunąć).

Offline Turbokibel

  • Zasłużony dla Symulatora
  • Wiadomości: 1598
    • Zobacz profil
  • Otrzymane polubienia: 1293
Odp: Maszyna 19.08 - problemy
« Odpowiedź #160 dnia: 09 Września 2019, 19:37:16 »
Otrzymałem permanentnego bana na 6h xD

Offline mac310

  • Zasłużony dla Symulatora
  • Wiadomości: 518
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 73
Odp: Maszyna 19.08 - problemy
« Odpowiedź #161 dnia: 09 Września 2019, 22:05:20 »
U mnie przyzwoicie działa na tych ustawieniach w ini
// Parametry wydajnościowe - zmiana może poprawić FPS:
vsync yes                   // (no) ogranicznik klatek do 60 lub 30 fps zaleznie od wydajności
maxtexturesize 4096      // (16384) skalowanie zbyt dużych tekstur do podanego rozmiaru
multisampling 2         // (2) wygładzanie krawędzi (poprawia obraz, ale obniża FPS): 0 - wyłaczone, 1 - dwukrotne, 2 - czterokrotne, 3 - ośmiokrotne
usevbo no         // (yes) Tryb renderowania VBO lub DisplayList
defaultext dds         // (dds) domyślne rozszerzenie tekstur
convertmodels 135      // (135) tworzenie plików modeli binarnych E3D z T3D: 0 - wyłączone, +1 - nowe Opacity, +2 - z optymalizacją, +4 - z bananami, +128 - rozszerzony pod exe C++, niekompatybilny ze starymi
anisotropicfiltering 8     // (8) 1-16 jakość filtrowania anizotropowego tekstur
dynamiclights 7            // (7) 1-7 ilość świateł OpenGL przydzielanych pojazdom w scenie; przy starych kartach graficznych zmiejszyć do 3
pyscreenrendererpriority normal // (normal, lower, lowest, idle) priorytet wątku pythonowego renderera. Odciąża procesor zmniejszając odświeżanie ekranów w lokomotywach.
shadowtune 2048 250 250 300   // parametry shadowmapy (rozdzielczość, nieużywany, promień projekcji, nieużywany)
splinefidelity 2      // (1) 1-4 dodatkowy podział trajektorii na łukach, zwiększający krągłość
gfxrenderer simple       // (full/simple) pełny lub uproszczony tryb renderowania, może poprawić wydajność
fullphysics yes       // obliczanie fizyki ze zwiększoną dokładnością. wyłączenie może spowodować dziwne zachowania
gfx.resource.sweep no       // usuwanie nieużywanych tekstur z opengl, zalecane wyłączenie gdy pamięć karty graficznej jest wystarczająca
gfx.resource.move no       // tryb konserwacji pamięci przy usuwaniu nieużywanych tekstur, może powodować problemy na niektórych kartach
gfx.shadowmap.enabled no    // włączanie cieni
gfx.smoke yes          // (yes) zalacza/wylacza obsluge dymu
gfx.smoke.fidelity 4       // wartosc w przedziale 1-4 (domyslnie 1) ilosc generowanych czastek dymu
shadows no         // (yes) renderowanie cieni od słońca
Historia budowy pulpitu lokomotywy serii EU07.

Offline esemzerotrzy

  • Wiadomości: 18
    • Zobacz profil
  • Otrzymane polubienia: 3
Odp: Maszyna 19.08 - problemy
« Odpowiedź #162 dnia: 09 Września 2019, 22:24:04 »
Na stronie głównej forum, na górnej belce, masz taki dość widoczny napis capsem REPOZYTORIUM. Wchodzisz w to. Wybierasz repozytorium, potwierdzasz autoryzację, wybierasz PCTGA. Znajdujesz w dzienniku zmian podane numerki, klikasz i wypisuje listę plików edytowanych. Pobierasz sobie te dwa scn i nadpisujesz odpowiadające im w lokalnej instalacji.

Również mam podobny problem, konkretnie prawie wszystko jest białe, pulpity w niektórych pojazdach, otoczenie itp. Czy działając według cytowanej instrukcji mogę to naprawić? Obecnie nie ma nic takiego w dzienniku zmian. Przepraszam, nie dopatrzyłem
« Ostatnia zmiana: 09 Września 2019, 22:25:13 wysłana przez esemzerotrzy »

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Maszyna 19.08 - problemy
« Odpowiedź #163 dnia: 09 Września 2019, 22:25:06 »
Taka uwaga co do vsync, zalaczenie go moze powodowac utrate nawet do 30 fps (w sytuacji gdy generowane jest mniej niz 60 klatek czyli rowniez 58-59 czestotliwosc rysowania spada do 30) wiec warto sie dobrze zastanowic czy skorka warta jest wyprawki. Najlepiej sprawdzic na panelu F12 w sekcji Gfx Renderer przy wylaczonym vsync ile klatek dany sprzet generuje bez sztucznych ograniczen.
« Ostatnia zmiana: 09 Września 2019, 22:26:38 wysłana przez tmj »

Offline mac310

  • Zasłużony dla Symulatora
  • Wiadomości: 518
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 73
Odp: Maszyna 19.08 - problemy
« Odpowiedź #164 dnia: 10 Września 2019, 09:04:15 »
Właśnie wczoraj spróbowałem z wyłączoną synchronizacją i pokazywało mi między 55 a 120. Nie wiem czy to z powodu vsync ale wcześniej były miejsca gdzie wydajność chwilowo spadała do 30-40 i od razu wskakiwała na 58-60. Było wtedy widać krótkie przycięcie. Teraz jest to mniej zauważalne. Włączałem vsync bo sądziłem, że odciążę kartę od generowania nadmiarowych klatek, których i tak nie widać przy 60 fps'ach, które potrafi wyświetlić monitor ale okazuje się, że ta funkcja niekoniecznie pomaga.
Historia budowy pulpitu lokomotywy serii EU07.

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Maszyna 19.08 - problemy
« Odpowiedź #165 dnia: 10 Września 2019, 13:47:25 »
Nie wiem jak z AMD ale w przypadku NVidii mozna ustawic w konfiguracji karty tzw Adaptive VSync, tzn synchronizacje aktywna tylko gdy generowanych jest powyzej 60 fps -- tym sposobem karta sie nie przemecza robiac 'za duzo' a z drugiej strony nie ma utraty fps ponizej 60:


Offline mac310

  • Zasłużony dla Symulatora
  • Wiadomości: 518
    • Zobacz profil
    • Moim Okiem...
  • Otrzymane polubienia: 73
Odp: Maszyna 19.08 - problemy
« Odpowiedź #166 dnia: 10 Września 2019, 14:00:51 »
Hmmm, ja w tej funkcji mam tylko do wyboru włącz, wyłącz i ustawienia aplikacji. To co u Ciebie widać to tylko dla opcji trybu zarządzania energią jest.
Historia budowy pulpitu lokomotywy serii EU07.

Offline Marys01

  • Wiadomości: 27
    • Zobacz profil
  • Otrzymane polubienia: 11
Odp: Maszyna 19.08 - problemy
« Odpowiedź #167 dnia: 16 Września 2019, 23:55:16 »
Zgodnie z wytycznymi z pierwszego postu:
Odpalam EP07-376-IC na scenerii I053-day-tlk83202. Po odpaleniu scenerii brak tekstur wagonów. Plik log.txt dotyczy tej scenerii i lokomotywy ale problem dotyczy wszystkich scenerii.
Załączam screeny z Rainsted z trzech przykładowych scenerii Bałtyk z listą brakujących plików.
Paczka postawiona na czysto.

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2610
Odp: Maszyna 19.08 - problemy
« Odpowiedź #168 dnia: 17 Września 2019, 00:22:37 »
Ło ło ło. Exek ma przeszło półtora roku. Załączony plik scn około roku. Nie mam pojęcia co czynisz, ale to nie jest 19.08.
Mój kanał youtube

Offline Marys01

  • Wiadomości: 27
    • Zobacz profil
  • Otrzymane polubienia: 11
Odp: Maszyna 19.08 - problemy
« Odpowiedź #169 dnia: 17 Września 2019, 01:04:01 »
No to co pobieram i instaluję? Z Maszyną jestem od 2010 roku i wiem co i jak pobierać. Paczkę pobieram z linku z głównej strony (obrazek1), Zaznaczone jest wszystko jak na obrazku2, a wychodzą kwiatki jak w opisie.

Offline Miłosz Dorsz

  • Administrator
  • Wiadomości: 1383
    • Zobacz profil
  • Otrzymane polubienia: 3537
Odp: Maszyna 19.08 - problemy
« Odpowiedź #170 dnia: 17 Września 2019, 06:04:33 »
Zainstaluj do nowego folderu z zaznaczeniem opcji "MaSzyna 19.01".
Projekty skończone i potencjalnie przyszłe: KLIK

Offline Cookie

  • Wiadomości: 273
  • Dzień dobry, jak leci?
    • Zobacz profil
  • Otrzymane polubienia: 121
Odp: Maszyna 19.08 - problemy
« Odpowiedź #171 dnia: 17 Września 2019, 06:07:46 »
Ewentualnie jeśli to nie podziała, spróbuj zainstalować symulator na drugą partycję dysku jeśli takową posiadasz.
Ta piękna stalowa MaSzyna... Która wozi mnie na wakacje...

Offline Marys01

  • Wiadomości: 27
    • Zobacz profil
  • Otrzymane polubienia: 11
Odp: Maszyna 19.08 - problemy
« Odpowiedź #172 dnia: 17 Września 2019, 09:31:37 »
Problem rozwiązany. Próbowałem nawet na dwóch komputerach i robiło się to samo. Okazuje się, że choć zaznaczone były wszystkie paczki (19.01, 19.04 i 19.08) to instalator pobierał i instalował tylko 19.01 z komunikatem o zakończeniu instalacji (?). Dziękuję za pomoc.

Offline PodlasiakMK

  • ZbanowanyZbanowany
  • Wiadomości: 2
    • Zobacz profil
  • Otrzymane polubienia: 1
Odp: Maszyna 19.08 - problemy
« Odpowiedź #173 dnia: 17 Września 2019, 09:38:59 »
Dlaczego jak włączam Cienie w grze to mi się lekko przycina a jak mam wyłączone to gra mi działa płynnie?

Offline Piotr93

  • Deweloper
  • Wiadomości: 1679
    • Zobacz profil
  • Otrzymane polubienia: 1090
Odp: Maszyna 19.08 - problemy
« Odpowiedź #174 dnia: 17 Września 2019, 09:45:54 »
To zmniejsz rozdzielczość cieni wpisem w eu07.ini to był chyba ten: shadowtune 2048 250 250 300 // parametry shadowmapy (rozdzielczość, nieużywany, promień projekcji, nieużywany)

Offline Miłosz Dorsz

  • Administrator
  • Wiadomości: 1383
    • Zobacz profil
  • Otrzymane polubienia: 3537
Odp: Maszyna 19.08 - problemy
« Odpowiedź #175 dnia: 17 Września 2019, 09:46:39 »
Może dlatego, że cienie obciążają komputer?
P.S. Kolega rozumiem na dostęp do TD ciężko pracuje?
Projekty skończone i potencjalnie przyszłe: KLIK

Offline Kamil14

  • Wiadomości: 84
    • Zobacz profil
  • Otrzymane polubienia: 9
Odp: Maszyna 19.08 - problemy
« Odpowiedź #176 dnia: 17 Września 2019, 13:47:47 »
Witam, mam taki problem podczas uruchamiania dowolnej scenerii w Maszynie:
Log w załączniku.

Offline Turbokibel

  • Zasłużony dla Symulatora
  • Wiadomości: 1598
    • Zobacz profil
  • Otrzymane polubienia: 1293
Odp: Maszyna 19.08 - problemy
« Odpowiedź #177 dnia: 17 Września 2019, 15:00:47 »
Zainstaluj biblioteki UCRT, w instalatorze Maszyny znajdują się.
Otrzymałem permanentnego bana na 6h xD

Offline Milek7

  • Administrator
  • Wiadomości: 1051
    • Zobacz profil
  • Otrzymane polubienia: 906
Odp: Maszyna 19.08 - problemy
« Odpowiedź #178 dnia: 17 Września 2019, 15:03:01 »
Witam, mam taki problem podczas uruchamiania dowolnej scenerii w Maszynie:
Log w załączniku.
Masz dźwięk w systemie?
W nowych exe ten błąd nie powinien być krytyczny: https://dev.azure.com/milek7/maszyna/_build/results?buildId=201&view=results

Offline Milek7

  • Administrator
  • Wiadomości: 1051
    • Zobacz profil
  • Otrzymane polubienia: 906
Odp: Maszyna 19.08 - problemy
« Odpowiedź #179 dnia: 17 Września 2019, 15:10:35 »
No to co pobieram i instaluję? Z Maszyną jestem od 2010 roku i wiem co i jak pobierać. Paczkę pobieram z linku z głównej strony (obrazek1), Zaznaczone jest wszystko jak na obrazku2, a wychodzą kwiatki jak w opisie.
Takie zahaczenie pól wskazuje że instalator wykrył plik z informacją o wersji 19.01 i będzie instalował 19.04 oraz 19.08.
Ciężko określić dlaczego pobieranie paczy miałoby się nie powieść, może jakiś nadgorliwy antywirus?