Autor Wątek:  Problem z eksportem do .t3d - 3DSMAX  (Przeczytany 1969 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline gg

  • Deweloper
  • Wiadomości: 550
  • Bawię się w... dodatki do MaSzyny :P
    • Zobacz profil
  • Otrzymane polubienia: 404
Problem z eksportem do .t3d - 3DSMAX
« dnia: 05 Sierpnia 2019, 08:40:20 »
Dzisiaj do Was przychodzę z moim problemem po raz kolejny. Tym razem chodzi o eksport do .t3d z maxa. Otóż gdy zrobiłem już swój model. (Tworzony z boxa i teksturowany mapami UV oraz w przypadku dwóch różnych tekstur oddzielane były submodele klawiszem "detach") Chciałem go wyeksportować do .t3d, a tu takie coś:
Format ("Ambient: % % %\n") meshObj.material.ambient.r meshObj.material.ambient.g meshObj.material.ambient.b to:ostreamBłąd: Unknown property "Ambient" in material #25 (w T3dExp.ms) (Błąd jest w w/w linijce skryptu,albo ja coś skopałem)
Z góry dziękuje za każdą pomoc ;)
PS Wrzucam również cały t3d.export :
Edit: Material #25 to był mój materiał.
« Ostatnia zmiana: 05 Sierpnia 2019, 08:41:40 wysłana przez gg »

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 10106
    • Zobacz profil
  • Otrzymane polubienia: 2592
Odp: Problem z eksportem do .t3d - 3DSMAX
« Odpowiedź #1 dnia: 05 Sierpnia 2019, 13:25:42 »
Daj raczej maxa swojego modelu. Przypisałeś każdemu obiektowi materiał typu standard? Dziwny błąd, bo ambient jest ustawiany domyślnie i nic tam nie trzeba klikać.
Mój kanał youtube

Offline gg

  • Deweloper
  • Wiadomości: 550
  • Bawię się w... dodatki do MaSzyny :P
    • Zobacz profil
  • Otrzymane polubienia: 404
Odp: Problem z eksportem do .t3d - 3DSMAX
« Odpowiedź #2 dnia: 05 Sierpnia 2019, 14:15:14 »
Stworzyłem jakiegokolwiek boxa z teksturą (bez dopasowywania ,tylko na test) i wyeksportowało. Używam teraz innego pliku (starszego). Sam nie wiem, co mogło być przyczyną. Ten błąd najprawdopodobnie był jakimś błędem składniowym w skrypcie lub sobie coś po prostu coś max ubzdurał. To też nie był jedyny przypadek: było raz też tak, że nawet postępując ściśle wg poradnika skrypt się wysypywał błędem [ Runtime error : Cannot Create "nazwa pliku modelu" ]. Wrzucam plik, który działa w razie czego:
PS Plik wadliwy został podmieniony na inny z plików z 2002 roku. W razie podobnych błędów z eksportem można je zgłaszać w tym wątku.
Edit: Prosiłbym również moderatorów lub administratorów o niezamykanie tego wątku.
« Ostatnia zmiana: 05 Sierpnia 2019, 14:16:18 wysłana przez gg »

Sebol82

  • Gość
Odp: Problem z eksportem do .t3d - 3DSMAX
« Odpowiedź #3 dnia: 05 Sierpnia 2019, 14:19:26 »
Stele pisałem z GG na mm. Podstawa skrypty bez polskich znaków i mesz przed exportem. Chłopak ma maxa vol 19. Więc skrypty bez polskich znaków. Bo się wszystko sypie. Zostało o tym uświadomiony (miał scrypty z polskimi znakami). Jak coś pominąłem to proszę poprawić