Autor Wątek:  MaSzyna 18.07 - problemy  (Przeczytany 28878 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5904
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 428
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #60 dnia: 29 Sierpnia 2018, 17:44:33 »
Winny był program AVG, zrywał połączenie ze stroną.
Natomiast na eksperymentalnym exe mam taki komunikat na końcu logu,
motion blur enabledco to oznacza, nie wiem.
« Ostatnia zmiana: 29 Sierpnia 2018, 17:49:51 wysłana przez Krzysiek626 »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1002
    • Zobacz profil
  • Otrzymane polubienia: 746
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #61 dnia: 29 Sierpnia 2018, 18:01:17 »
myślę że przeholowałeś z multisamplingiem (x16)

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5904
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 428
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #62 dnia: 29 Sierpnia 2018, 18:16:46 »
Zgadza się, zwykle w takich przypadkach tylko się przycinało.

Offline miko22

  • Wiadomości: 613
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 192
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #63 dnia: 05 Września 2018, 15:12:50 »
l053_wieczor, misja nr 6 z lokomotywą podmienioną na inną ET41 - scenariusz zaciął się po zatrzymaniu się w Żernikach. Od strony Sandomierza stoi pod wjazdowym do Żernik na S1 na torze nr 2 skład z EP07-444, a od strony Rudawy też na S1 pod wjazdowym do Żernik stoi skład z EP09-044 na torze nr 1. Ja stoję w stacji na torze 1., po mojej prawej na torze 3. stoi skład z E6ACT-001, na torze 4. pod wyjazdowym w kierunku Rudawy na S1 stoi luzem 6Dg-139 z osygnalizowaniem manewrowym, na torze 6. jakieś platformy, a na torze 8. w stronę Sandomierza skład z ST45-02. Do przejazdu przez stację wolny jest tylko tor 2. i 10. Do Żernik przyjechałem z ok. półgodzinnym opóźnieniem (po drodze stałem 2 razy), a sytuacja trwa już jakieś 50 minut. Poniżej link do archiwum z plikiem errors i log, w którym niestety załączone jest logowanie komunikacji przez UART, więc ma prawie 170MB. Exe @tmj 180903.
http://eu07.pl/userfiles/21606/priv-errors_i_log-l053_wieczor.7z

PS.: Na tym scenariuszu jadę pierwszy raz. Chciałem przetestować poprawki na zakłócenia, które mi się robiły w pulpicie podczas ostatnich wystaw i może za drugim przejazdem nagrać filmik z jazdy na pulpicie, ale jeśli znowu nie dojadę do końca, to trochę umniejsza to sens takiego filmu :(
« Ostatnia zmiana: 05 Września 2018, 19:45:54 wysłana przez miko22 »

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 1002
    • Zobacz profil
  • Otrzymane polubienia: 746
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #64 dnia: 05 Września 2018, 17:36:20 »
Coś poszło nie tak podczas konwersji dźwięków z .wav na .ogg - wszystkie dźwięki w paczce są okrojone na samym końcu o ułamek sekundy, w większości nie jest to słyszalne, ale sporo dźwięków zostało przez to okrojonych z ważnej treści, chociażby radio1.ogg, pospieszny3.ogg, mozna_do_tylu.ogg, ...
hm, nie potwierdzam.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #65 dnia: 05 Września 2018, 19:55:57 »
Puscilem AI po l053_wieczor w standardowym ET41 i scenariusz rowniez stanal w Zernikach towarowych, chociaz w innej kolejnosci -- po przyjezdzie do czesci towarowej Zernik ET41 dostal postoj pod semaforem wyjazdowym. W tym czasie na stacji byly tylko 6dg czekajaca luzem pod semaforem i SU45 z platformami czekajaca pod zgaszona tarcza manewrowa Tm9. Po dluzszej chwili takiego wspolnego postoju dolaczyla do nas EP09, ktora rowniez dostala postoj pod semaforem wyjazdowym, a nastepnie Dragon ktory z kolei dostal postoj pod semaforem wyjazdowym z Zernik osobowych. Szlak od Zernik do Sandomierza wygladal na calkowicie wolny, nie bylo wiec zadnego widocznego powodu dla tej blokady. Sprawdzane na exe 18.905

Offline miko22

  • Wiadomości: 613
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 192
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #66 dnia: 05 Września 2018, 20:26:59 »
Ja dopiero ok. godziny 00:20 czasu scenariusza pojechałem dalej pomijając próbnie S1 na wyjazdowym z Żernik towarowych, bo przebieg miałem ustawiony na wprost i resztę scenariusza dokończyłem normalnie łącznie z manewrami na koniec. Tylko na radiu co jakiś czas słyszałem informację dla jakiegoś towarowego (może dla tego, który stał też na S1 przy jakimś przystanku osobowym dosyć kawałek za EP09, a prowadzony był przez EU07-417), że na razie nie będzie wjazdu, bo nie ma wolnego toru. Jakby co, mam końcowego loga, ale na zapas nie wstawiam, bo ma 528MB.

Offline Transkei

  • Deweloper
  • Wiadomości: 649
    • Zobacz profil
  • Otrzymane polubienia: 882
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #67 dnia: 06 Września 2018, 06:25:47 »
Problem generuje ST45 - po wjechaniu na stację ignoruje polecenie odczepienia się (nie wykonuje Shunt 0 0), co w efekcie prowadzi do zablokowania stacji, kiedy próbuje wykonać manewry razem z nieodczepionym składem.
Zauważyłem identyczne zachowanie ST45 na innym nieudostępnionym jeszcze scenariuszu na innej scenerii. Problemy ten się pojawił mniej więcej od wrześniowych exe.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #68 dnia: 06 Września 2018, 15:10:50 »
Z tego co widze w kodzie, problem bierze sie z kolejnosci zdarzen -- po dojezdzie do punktu docelowego ST45 otrzymuje komende Shunt 0 0 zanim zarejestrowany zostanie przez nia fakt ukonczenia rozkladu. Komenda generuje polecenie Disconnect i lokomotywa zaczyna je wykonywac, tzn hamuje itp, ale zanim zdazy ukonczyc odczepianie rejestrowany jest fakt wykonania rozkladu jazdy, co powoduje automatycznie przeskok do nastepnego rozkladu na liscie, w tym wypadku z Disconnect->Shunt.

Teoretycznie moge to zalatac dodajac warunek ze w przypadku aktywnej procedury odczepiania przeskok do nastepnej komendy nie powinien miec miejsca (lokomotywa i tak przejdzie do zdefiniowanego przez komende Shunt trybu po zakonczeniu odczepiania) Pytanie do trasopisarzy, czy taka zmiana moze spowodowac rozsypanie sie jakiegos istniejacego scenariusza?

edit: poprawka dodana eksperymentalnie do 18.906
« Ostatnia zmiana: 06 Września 2018, 18:50:42 wysłana przez tmj »

Offline Lokomotywownia

  • Wiadomości: 119
    • Zobacz profil
    • Lokomotywownia
  • Otrzymane polubienia: 14
MaSzyna 18.07 - problemy z instalacją
« Odpowiedź #69 dnia: 14 Września 2018, 21:12:56 »
Cześć. Mam problem z ponowną instalacją MaSzyny wersji 18.07 . Pobieram, rozpakowuję paczkę i instaluję zaznaczając wszystkie okienka ze wszystkimi wersjami i na pasku pokazuje mi się jeden niebieski kwadrat z postępem instalacji i tyle. Wisi mi już prawie godzinę i nic się nie dzieje. Powtarzam to już drugi raz.
Mam W 10, a poprzednie wersję usunąłem z laptopa.
W czym może być problem ?

Offline Cookie

  • Wiadomości: 270
  • Привет! Как дела?
    • Zobacz profil
  • Otrzymane polubienia: 119
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #70 dnia: 15 Września 2018, 02:12:46 »
Godzina to mało. Przy słabym necie może się pobierać całość do nawet 4h
Ta piękna stalowa MaSzyna... Która wozi mnie na wakacje...

Offline lukow_kolej

  • Wiadomości: 32
    • Zobacz profil
  • Otrzymane polubienia: 19
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #71 dnia: 15 Września 2018, 08:24:34 »
Lokomotywa EP05-23 problem z nastawnikiem jazdy, powraca do pozycji zerowej po zadaniu pozycji. Czy tak ma być?

Offline Joachimowicz

  • Zasłużony dla Symulatora
  • Wiadomości: 1630
  • Nazywam się N'Avoie
    • Zobacz profil
  • Otrzymane polubienia: 1763
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #72 dnia: 15 Września 2018, 08:52:49 »
Po zasadzie działania domyślam się, że może to być efekt urealnienia symulatora. Recepta na prowadzenie EP05 jest taka. Używaj myszki, albo dodawaj pozycje trzymając cały czas plus. One będą przeskakiwały, co na pewno usłyszysz. Jeżeli osiągniesz satysfakcjonujący Cię prąd na amperomierzach, to puść plus. Wtedy nastawnik wróci nie do zerowej pozycji, a do aktualnie zadanej. Powrót jest prosty. Trzymasz minus do póki nastawnik nie stanie na zerze i to koniec, możesz puścić minus.
| Z maszyną od 20 Kwietnia 2010! |

Offline lukow_kolej

  • Wiadomości: 32
    • Zobacz profil
  • Otrzymane polubienia: 19
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #73 dnia: 15 Września 2018, 11:30:29 »
Teraz już wszystko rozumiem, dzięki. Spytałem się bo tylko na EP05 tak działa nastawnik.

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10131
    • Zobacz profil
  • Otrzymane polubienia: 2596
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #74 dnia: 15 Września 2018, 13:12:38 »
Na ET40 tak jest od zawsze i nie wiem czy na skodach 181/2 tak nie powinno być. Ktoś musiałby się wypowiedzieć. EU/EP05 miały tak od dawna zrobione u nas, ale komuś się bardzo nie podobało i wywalił im specyficzną obsługę z fizyki.
Ogólnie taka jest specyfika czeskich nastawników. Najwygodniej obsługiwać to myszą. Trzymasz nastawnik na danej pozycji aż wał kułakowy się do niej obróci i dopiero puszczasz klawisz.
Mój kanał youtube

Offline Lokomotywownia

  • Wiadomości: 119
    • Zobacz profil
    • Lokomotywownia
  • Otrzymane polubienia: 14
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #75 dnia: 15 Września 2018, 15:05:22 »
Godzina to mało. Przy słabym necie może się pobierać całość do nawet 4h
Raczej nie jest słaby internet bo mam prawie 250Mb/s pobierania  to coś innego musi być. Tylko co ? Na W 7 chodził bez problemów i się pobierał. Czy to wina W10 ? Na kompie nie ma problemów.  Wstawiam zrzut tak to wygląda.

Offline Kolej w Polsce

  • Deweloper
  • Wiadomości: 434
  • Potrzymaj mi piwo
    • Zobacz profil
    • pornhub.com
  • Otrzymane polubienia: 615
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #76 dnia: 15 Września 2018, 15:08:38 »
Cytuj
Na ET40 tak jest od zawsze i nie wiem czy na skodach 181/2 tak nie powinno być. Ktoś musiałby się wypowiedzieć.
Na kanale tmehatronika jest 182 i jest tak samo z nastawnikiem jak na EP05.
Słupy Robię.
Lista projektów KejWuPe(głównie słupky)

Ugułem śmiszny deweloper XDD

Offline Matson

  • Wiadomości: 193
    • Zobacz profil
  • Otrzymane polubienia: 64
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #77 dnia: 17 Września 2018, 16:31:16 »
Panowie, wczoraj maszyna działała aż miło, dziś nijak nie chce się uruchomić i w logu jest: "Bad init: failed to create glfw window". Jakieś pomysły jak to rozwiązać?

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #78 dnia: 17 Września 2018, 20:28:09 »
Pokaz log.txt bo tak to nawet fusow nie ma zeby z nich powrozyc.

Offline Matson

  • Wiadomości: 193
    • Zobacz profil
  • Otrzymane polubienia: 64
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #79 dnia: 17 Września 2018, 23:13:43 »
Proszę, niestety nic więcej tam nie ma oprócz tego co napisałem. To samo na 17.06

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #80 dnia: 18 Września 2018, 01:02:38 »
Hmm no to faktycznie, problem i to taki dosc dziwny. Zobacz czy cos sie nie poprawi po ponownej instalacji sterownikow do karty graficznej? Nie bardzo wiem co innego mogloby powstrzymac glfw od inicjalizacji.

Offline Matson

  • Wiadomości: 193
    • Zobacz profil
  • Otrzymane polubienia: 64
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #81 dnia: 18 Września 2018, 20:17:46 »
Wyczyszczenie sterowników karty i instalacja na nowo pomogła. Dziwne, coś się musiało wykrzaczyć, może przy aktualizacji Windowsa. Tak czy siak problem rozwiązany.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #82 dnia: 18 Września 2018, 20:19:18 »
Aa to mozliwe, Windows przy aktualizacji lubi wyrzucic sterowniki i wstawic swoje. W kazdym razie jesli juz dziala to dobrze :>

Offline miko22

  • Wiadomości: 613
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 192
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #83 dnia: 20 Września 2018, 21:00:07 »
l053_poranek, misja nr 12 z lokomotywą podmienioną na inną ET41 - scenariusz zablokował się po przyjechaniu do Turowa z opóźnieniem ok. 25 minut. Dalej pod trochę przejechanym na S1 (screen 1.) wjazdowym do Psiego Pola od strony Turowa stoi ROJ 32148. W Psim Polu pod wyjazdowym na S1 w kierunku Swoszowic na torze 2. stoi TBE 321344. Pod wjazdowym na S1 do Swoszowic od strony Psiego Pola stoi RPE 32118. W Swoszowicach pod wyjazdowym na S1 w kierunku Psiego Pola na torze 3. stoi TME 233479, a pod wyjazdowym na S1 w kierunku Krapikowika na torze 2. stoi TMS 323512. Pod wjazdowym do Swoszowic na S1 od strony Krapikowika stoi TKS 224835. Pod przejechanym na S1 (screen 2.) wjazdowym do Krapikowika od strony Swoszowic stoi ROJ 22152. Pod wjazdowym na do Dębicy Osobowej na S1 od strony Krapikowika stoi ROJ 32142 (w Dębicy Towarowej pusto). W Dębicy Osobowej pod wyjazdowym na S1 w kierunku Krapikowika/Dębicy Towarowej na torze 8. stoi TME 232159, a pod wyjazdowym na S2 (screen 3.) w kierunku Krapikowika na torze 2. stoi RPE 23113. SM42-2303 Orion Kolej stoi w Dębicy Osobowej pod tarczą Tm5 na Ms2 jak na screenie 4. (może dobrze, nie wiem). Pod wjazdowym na S1 do Dębicy Osobowej na linii dwutorowej od strony końca scenerii stoi RPE 22167, a za nim już na samym końcu toru w kierunku Dębicy Osobowej RPE 24115. W drugą stronę od Turowa pod wjazdowym na S1 do Pawłonu od strony Rudawy stoi TKS 334939. W Żernikach Małych pod S5 w kierunku Pawłonu z otwartymi drzwiami, stale załączonym sygnałem odjazdu i trochę za W4 (screen 5.) stoi ROJ 33142. Więcej błędów nie znalazłem. Sytuacja trwa już ok. 70 minut. Pod linkiem log (134MB) i errors, exe @tmj 20180919.
http://eu07.pl/userfiles/21606/priv-log_i_errors-l053_poranek.7z

Potrzeba więcej informacji? Wyłączyłem.
« Ostatnia zmiana: 21 Września 2018, 01:47:23 wysłana przez miko22 »

Offline lukow_kolej

  • Wiadomości: 32
    • Zobacz profil
  • Otrzymane polubienia: 19
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #84 dnia: 20 Września 2018, 22:46:00 »
Czy obecna wersja Maszyny jest kompatybilna ze scenerią testową Całkowo v2 z rozszerzeniem do Janiszewa?
Pytam, ponieważ miałem problem z uruchomieniem tej scenerii. Proszę o ewentualne porady.

Offline Transkei

  • Deweloper
  • Wiadomości: 649
    • Zobacz profil
  • Otrzymane polubienia: 882
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #85 dnia: 20 Września 2018, 22:58:33 »
l053_poranek, misja nr 12 z lokomotywą podmienioną na inną ET41 (...)
Cały ten bałagan narobiła EP07 ciągnąca RPE23113 - miała podany wyjazd ale stała, przez co nie mógł wjechać ROJ32142, dalej zaczął czekać ROJ22152, a potem już poszło wszystko lawinowo.
Dlaczego ta EP07 nie ruszyła - trudno powiedzieć. Mam takie dziwne wrażenie, że od jakiegoś exe zdarzają się przypadki, że skład mimo podanego S2 nie chce ruszać. Ponieważ zjawisko występuje rzadko i nieregularnie, to trudno zaobserwować jakieś szczególne okoliczności, odnoszę jednak wrażenie (i niniejszy przypadek to potwierdza), że może to mieć związek z W4 i postojem na pierwszej stacji w rozkładzie.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #86 dnia: 21 Września 2018, 00:05:38 »
Tak na marginesie, uruchomilem ten scenariusz na kiblu 57-837 w nadziei ze uda mi sie wylapac co tam sie potencjalnie dzieje od strony AI, i wyglada na to ze warto dodac pare sekund do opoznienia eventu tor0097_ustaw_60 -- w oryginale jest tam 120 sekund, i to jest o pare sekund za malo dla ai w obecnym ksztalcie; ograniczenia do zera jest zdejmowane zanim AI sie tam zatrzyma, wiec kula sie dalej az pod semafor. Zamienilem eksperymentalnie 120 na 135 i w takiej konfiguracji zatrzymanie i obrot nastepuje ladnie w peronie jak powinno.

edit: udalo sie zlapac 23113 stojaca w Debicy. Stoi tam bo z jakiegos powodu wydaje sie jej ze ma nalozone przez jakis sygnal ograniczenia predkosci do zera. Zobaczymy czy da sie ustalic cos wiecej.
« Ostatnia zmiana: 21 Września 2018, 00:10:36 wysłana przez tmj »

Offline brytan13

  • Wiadomości: 49
  • Zawsze jest dobrze, tak musi być.
    • Zobacz profil
  • Otrzymane polubienia: 8
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #87 dnia: 21 Września 2018, 12:48:15 »
Dzień dobry. Czy to mój zasilacz na suchoty zabolał, czy ja z innej planety? Jazda z prędkością nie przekraczającą 70 (Sandomierz-Dębica), obojętne czy to poranek czy wieczór. Może coś nie wiem bo było ok. Dzięki i przepraszam jak się pomyliłem z działem.
Pozdrawiam,
                   Piotr1szy Nerwowy:):).

Offline AMZ-IZ22

  • Wiadomości: 1
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #88 dnia: 24 Września 2018, 20:29:06 »
Witam wszystkich, mój problem dotyczy wykrzaczania się symulatora niezależnie od mapy jaką wybiorę. Raz przejadę godzinę innym razem 10 minut i trach wywala mnie do pulpitu i pokazuje komunikat, że program maszyna przestał działać.

Załączam plik log z 3 takich przypadków na różnych mapach.

Dodam, że symulator uruchamiam na swoim laptopie Lenowo W520, do którego dokupiłem klawiaturę numeryczną na USB.

Offline tmj

  • Deweloper
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2351
Odp: MaSzyna 18.07 - problemy
« Odpowiedź #89 dnia: 24 Września 2018, 20:55:40 »
Niestety z kartami Quadro symulator ma pewne problemy. Zobacz moze, czy sytuacja nie polepszy sie na aktualnej wersji roboczej: https://ci.appveyor.com/project/Milek7/maszyna-8kwj6/build/artifacts