Autor Wątek:  Linia61_towarowy - brak tekstury  (Przeczytany 1974 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline mendel

  • Wiadomości: 25
    • Zobacz profil
  • Otrzymane polubienia: 2
Linia61_towarowy - brak tekstury
« dnia: 15 Lipca 2018, 16:42:42 »
Cześć.

Długo zastanawiałem się w którym dziale wrzucić ten screen. Jeżeli nie trafiłem - z góry przepraszam i proszę o przeniesienie.

Screen poniżej przedstawia pociąg wjeżdżający na stację Częstochowa Stradom o godzinie 15:14 w scenariuszu linia61_towarowy.
W dwóch wagonach brak tekstury.

Pozdrawiam,
Mendel

Offline tmj

  • Deweloper
  • Wiadomości: 2919
    • Zobacz profil
  • Otrzymane polubienia: 1323
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #1 dnia: 15 Lipca 2018, 17:12:02 »
Bad file: failed do locate texture file "adu_160_1"
Bad file: failed do locate texture file "azdnu_120"
Bad file: failed do locate texture file "111a8"
Wyglada na to, ze niektore wagony maja przypisane tekstury, ktore wylecialy z paczki calosciowej, zostaly przemianowane lub tez ich tam nigdy nie bylo. W katalogu 1xxa_v1:
- zamiast adu_160_1 jest adu_160_n
- zamiast azdnu_120 jest azdnu_120_n
byc moze przez jakas pomylke, lub w ramach niedokonczonych porzadkow?

Offline mendel

  • Wiadomości: 25
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #2 dnia: 15 Lipca 2018, 17:15:08 »
Odpowiadam sam sobie, ale ze względu na to, co wydarzyło się dalej (czyli po tym jak napisałem tego wcześniejszego posta i wznowiłem symulację) wątek należałoby chyba jednak przenieść do pomocy doraźnej.

Po wyjechaniu ze stacji i przejechaniu kilku kilometrów symulator się najpierw zaciął, a po chwili wyłączył. Zdarzyło mi się to pierwszy raz w życiu - na żadnej innej scenerii nigdy nie wystąpiło nic takiego. Oczywiście przejrzałem forum i upewniłem się, że w tle nie miałem odpalonego nic pamięciożernego. Zresztą powtórzyłem symulację dla pewności i wywaliło mnie dokładnie w tym samym miejscu.

Szkoda, bo trasa wyglądała na ciekawą. :-(

Pozdrawiam,
Mendel

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 7496
    • Zobacz profil
  • Otrzymane polubienia: 1069
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #3 dnia: 15 Lipca 2018, 17:20:33 »
Wersja od Ra czy od nas z paczki? Ta od Ra ma składy na paczkę sprzed roku, więc część wagonów może być do podmiany.
W logu na końcu są jakieś przejazdy, ale exe nie powinno już wywalać na brakach dźwięków. Crashdump się nie generuje?
Mój kanał youtube

Offline tmj

  • Deweloper
  • Wiadomości: 2919
    • Zobacz profil
  • Otrzymane polubienia: 1323
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #4 dnia: 15 Lipca 2018, 17:20:55 »
Jesli mozesz, zobacz z ciekawosci czy ten sam problem wystapi na aktualnym exe roboczym, do pobrania z pierwszego postu w tym watku: https://eu07.pl/forum/index.php/topic,28920.0.html

Zobacz tez, czy w katalogu symulatora po wysypie nie pojawil sie plik z "crashdump" w nazwie. Jesli tak, dolacz go do wiadomosci, sa tam potencjalnie przydatne informacje na temat stanu symulacji w momencie wysypu.

Offline mendel

  • Wiadomości: 25
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #5 dnia: 15 Lipca 2018, 17:53:38 »
Wersja od Ra czy od nas z paczki?

Wyłącznie z paczki.
Ja jestem absolutnie początkujący i wszelkie podmiany dla mnie to na razie zbyt wysokie loty.
Paczka: MaSzyna 18.06.
Środowisko: laptop Dell LATITUDE 3550, Intel(R) Core(TM) i7-550U CPU @ 2,40GHz, Windows 10 Professional 64bit.

Jesli mozesz, zobacz z ciekawosci czy ten sam problem wystapi na aktualnym exe roboczym, (...)

Oczywiście, że mogę. Zaraz dam znać.

Zobacz tez, czy w katalogu symulatora po wysypie nie pojawil sie plik z "crashdump" w nazwie. Jesli tak, dolacz go do wiadomosci, sa tam potencjalnie przydatne informacje na temat stanu symulacji w momencie wysypu.

Dzięki za tę informację. Pojawiły się. Wrzucam pliki z obu wysypów.

Pozdrawiam,
Mendel
« Ostatnia zmiana: 15 Lipca 2018, 17:56:06 wysłana przez mendel »

Offline Stele

  • Wydział Repozytorium
  • Administrator
  • Wiadomości: 7496
    • Zobacz profil
  • Otrzymane polubienia: 1069
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #6 dnia: 15 Lipca 2018, 17:59:34 »
Ten skład nie ma wagonów wymienionych u ciebie w logu jako braki. Plik był edytowany przy okazji wywalania tekstur 31.05.2017. Jesteś pewien, że nie wgrywałeś wersji Ra po braku wjazdu na Jawornicę w którymś z innych scenariuszy na l61? Może ludzi mieszam. :P
Mój kanał youtube

Offline tmj

  • Deweloper
  • Wiadomości: 2919
    • Zobacz profil
  • Otrzymane polubienia: 1323
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #7 dnia: 15 Lipca 2018, 18:10:55 »
Jesli dobrze widze, to oba pliki crashdump sa do wersji exe z paczki. Aby uruchomic zamiast tego exe testowe trzeba je wybrac z listy po prawej stronie w okienku Rainsteda. Lista bedzie widoczna gdy na zakladce "Ustawienia" zostanie ustawiony "Tryb Pracy" Rainsteda "normalny" lub wyzszy.

Offline mendel

  • Wiadomości: 25
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #8 dnia: 15 Lipca 2018, 18:30:33 »
Cześć.

Ten skład nie ma wagonów wymienionych u ciebie w logu jako braki.

Braki w teksturach wagonów były w pociągu prowadzonym przez AI, nie przeze mnie.

Jesteś pewien, że nie wgrywałeś wersji Ra po braku wjazdu na Jawornicę w którymś z innych scenariuszy na l61?

Jestem absolutnie pewien, że nic nie wgrywałem. Choćby dlatego, że nie umiem. :-)

Jesli dobrze widze, to oba pliki crashdump sa do wersji exe z paczki.

Dobrze widzisz. Po prostu wrzuciłem pliki z dwóch poprzednich zawieszeń uznając, że może coś pomogą. :-)
Do testów na nowym EXE przystąpiłem przed chwilą.

Aby uruchomic zamiast tego exe testowe trzeba je wybrac z listy po prawej stronie w okienku Rainsteda.

Tego wszystkiego nie wiedziałem, więc poradziłem sobie inaczej.
Ściągnąłem plik eu07-x64_180715.rar ze wskazanego wątku, rozpakowałem go i podmieniłem plik EXE w katalogu MaSzyny poprzez zmianę nazw eu07.exe -> eu07.exe.OLD i eu07-x64_180715.exe -> eu07.exe. Operacja zakończyła się sukcesem, symulacja działała na nowym EXE. Swoją drogą mam mieszane uczucia co do zmiany, że dźwięki normalnie chodzą w czasie pauzy. Czasami pauzuję grę aby coś załatwić przez telefon i wolałbym wtedy aby było cicho. Ale to dygresja.

Sama symulacja niestety wywaliła się znowu ale tym razem NIE powstał plik crashdump. Log.txt i errors.txt załączam.

Pozdrawiam,
Mendel

Offline tmj

  • Deweloper
  • Wiadomości: 2919
    • Zobacz profil
  • Otrzymane polubienia: 1323
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #9 dnia: 15 Lipca 2018, 18:46:39 »
Critical error, memory allocation failure: bad allocation
Wyglada na to ze w tym konkretnym przypadku przyczyna wysypu byl brak wolnej pamieci by pomiescic wszystkie dane.

edit: ten brak pamieci to raczej nie wina ograniczenia sprzetu, a exe z jakiegos powodu zglaszajacego bezsensowne zapotrzebowanie. Trzeba bedzie sie temu przyjrzec.
« Ostatnia zmiana: 15 Lipca 2018, 19:11:21 wysłana przez tmj »

Offline mendel

  • Wiadomości: 25
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #10 dnia: 15 Lipca 2018, 19:42:27 »
Cześć.

ten brak pamieci to raczej nie wina ograniczenia sprzetu, a exe z jakiegos powodu zglaszajacego bezsensowne zapotrzebowanie.

Trochę mi ulżyło. :-)
Dzięki za informację.

Pozdrawiam,
Mendel

Offline tmj

  • Deweloper
  • Wiadomości: 2919
    • Zobacz profil
  • Otrzymane polubienia: 1323
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #11 dnia: 16 Lipca 2018, 02:10:13 »
Poczawszy od wersji 18.716 (do pobrania z podanego wczesniej watku) problem powinien byc ogarniety.

Offline Milek7

  • Administrator ds. Technicznych
  • Wiadomości: 809
    • Zobacz profil
  • Otrzymane polubienia: 391
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #12 dnia: 16 Lipca 2018, 19:46:02 »
> Po prostu wrzuciłem pliki z dwóch poprzednich zawieszeń uznając, że może coś pomogą. :-)
Tak, pomagają :) Tylko dumpy z moich exe (też paczkowych) to do mnie. ale tmj już naprawił buga

>Swoją drogą mam mieszane uczucia co do zmiany, że dźwięki normalnie chodzą w czasie pauzy.
Nic się nie zmieniło, tylko to jest w moich exe (i implementacją openalsoft, ale ta jest dołączana do paczki)

Offline mendel

  • Wiadomości: 25
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Linia61_towarowy2 - brak tekstury
« Odpowiedź #13 dnia: 17 Lipca 2018, 13:46:27 »
Cześć.

Poczawszy od wersji 18.716 (do pobrania z podanego wczesniej watku) problem powinien byc ogarniety.

Niestety nie jest. :-(
Zmieniło się o tyle, że teraz program się nie wyłącza, ale zawiesza (trzeba go ubić z poziomu systemu).
Ale następuje to idealnie w tym samym miejscu co zawsze.

Pliki log.txt i errors.txt oczywiście załączam. Crashdump nie powstał.

Pozdrawiam,
Mendel

Offline tmj

  • Deweloper
  • Wiadomości: 2919
    • Zobacz profil
  • Otrzymane polubienia: 1323
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #14 dnia: 17 Lipca 2018, 13:49:00 »
Starting MaSzyna rail vehicle simulator (release: M7 30.06.2018/2, based on tmj 293787c)

Uruchomiles starsze exe z paczki calosciowej a nie wersje robocza z usunietym bledem :>

Offline mendel

  • Wiadomości: 25
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #15 dnia: 17 Lipca 2018, 14:14:48 »
Uruchomiles starsze exe z paczki calosciowej a nie wersje robocza z usunietym bledem :>

Dałbym sobie rękę uciąć, że wybrałem w Rainstedzie nowe exe.
I bym teraz nie miał ręki... :-)

OK. Wieczorem sprawdzę to starą metodą (czyli chowając wszystkie inne exe w katalogu MaSzyna), tak aby mieć pewność, że pracuję na nowym i dam znać.
Przepraszam za zawracanie głowy.

Pozdrawiam,
Mendel

Offline mendel

  • Wiadomości: 25
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Linia61_towarowy - brak tekstury
« Odpowiedź #16 dnia: 17 Lipca 2018, 14:59:05 »
Dobra, nie wytrzymałem do wieczora i testowałem w biurze. :-)
Jest OK. Przejechałem.
Dzięki.
M.