Autor Wątek:  Exe - konwersja na C++  (Przeczytany 988736 razy)

0 użytkowników i 3 Gości przegląda ten wątek.

Offline AtapiCl

  • Zasłużony dla Symulatora
  • Wiadomości: 4426
    • Zobacz profil
    • O warszawskiej części linii kolejowej nr 7 Warszawa – Lublin i nie tylko ;)
  • Otrzymane polubienia: 212
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2220 dnia: 29 Kwietnia 2017, 23:37:02 »
Znaczy no to jest proces uruchamiania się na nowo. Załóżmy, że ktoś celowo chciałby zobaczyć co się stanie gdy spadnie ciśnienie np... Zobaczy, że wyłączy mu się przetwornica i przez to nie załączy też sprężarki. Chciałby wrócić jednak do normalnej symulacji i pytam jakie ma opcje wtedy :P

Offline CX MANIAK

  • Wiadomości: 241
    • Zobacz profil
  • Otrzymane polubienia: 41
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2221 dnia: 30 Kwietnia 2017, 00:21:31 »
Witam.
 Albo ja coś sknociłem, albo na najnowszej wersji exe Tmj, w ET41 nie działa prawidłowo zawór rozrządczy hamulca. Do bodaj piątej pozycji kranu brak ciśnienia w cylindrach hamulcowych. Rośnie dopiero po daniu w nagłe. Zaraz sprawdzę inne loki.
« Ostatnia zmiana: 30 Kwietnia 2017, 00:22:47 wysłana przez CX MANIAK »

Offline miko22

  • Wiadomości: 616
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 196
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2222 dnia: 30 Kwietnia 2017, 00:24:45 »
Edit: Przy okazji znalazłem błąd z hamulcami niewystępujący na exe borlandowym. Kiedy uruchamia się jakikolwiek pojazd bez powietrza (dopisek ".BQ" do numeru sprzęgu), przestają w nim działać hamulce, tzn. cylindry hamulcowe nie napełniają się przy spadku ciśnienia w przewodzie głównym. Dodatkowo po zahamowaniu lokomotywy hamulcem pomocniczym słychać jakieś syczenie, które ustaje dopiero po ruszeniu z miejsca.
Powodem błędu z hamulcami jest prawdopodobnie samoczynnie załączający się przy starcie symulacji odluźniacz, który przez cały czas spuszcza powietrze z cylindrów. Wskazuje też na to samoczynne napełnianie przewodu głównego po przestawieniu kranu głównego w pozycję jazdy lub napełnienia, także wtedy, gdy ciśnienie w przewodzie głównym jest mniejsze niż 0,28MPa - normalnie trzeba w takiej sytuacji użyć właśnie odluźniacza. Dopiero po naciśnięciu [Num4] (odblokowaniu odluźniacza) hamulce działają poprawnie. Jeśli już, to pojazd powinien się uruchamiać z zerowym ciśnieniem w cylindrach, ale nie z zablokowanym w stanie załączonym odluźniaczem.
Ostatnio (nie pamięta od której wersji) coś syczy po wczytaniu scenerii, myślałem że to AI, bo często w debugmode odpalam.
Widać przy zwykłym uruchamianiu z powietrzem na starcie jest ten sam błąd. Ostatnimi czasy uruchamiam tylko bez powietrza, więc sam nie wykryłem.
« Ostatnia zmiana: 30 Kwietnia 2017, 00:25:59 wysłana przez miko22 »

Offline CX MANIAK

  • Wiadomości: 241
    • Zobacz profil
  • Otrzymane polubienia: 41
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2223 dnia: 30 Kwietnia 2017, 00:34:21 »
 Jak na mój gust to nie to. Odluźniacz działa normalnie. Na EP07 hamulce też opornie reagują. Dopiero gdy ciśnienie spadnie do ok 0,4 atm w PG, zaczyna rosnąć ciśnienie w cylindrach hamulcowych lokomotywy. Czy tak powinno być?

Offline miko22

  • Wiadomości: 616
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 196
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2224 dnia: 30 Kwietnia 2017, 00:55:29 »
Nie potwierdzam. U mnie przy normalnym starcie (nie bez powietrza) wszystko działa prawidłowo. Sprawdziłem EP07-424 i ET41-001 (załączniki).

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2225 dnia: 30 Kwietnia 2017, 01:31:29 »
Znaczy no to jest proces uruchamiania się na nowo. Załóżmy, że ktoś celowo chciałby zobaczyć co się stanie gdy spadnie ciśnienie np... Zobaczy, że wyłączy mu się przetwornica i przez to nie załączy też sprężarki. Chciałby wrócić jednak do normalnej symulacji i pytam jakie ma opcje wtedy :P
No jak sie strasznie uprze to moze posadzic sobie kota na przycisku od sprezarki pantografow i ona powoli bo powoli, ale ostatecznie da rade napelnic. Ja tutaj zakladam ze ktos, kto nie wie co sie stanie zrobi rownie wielkie oczy jak przeczyta np. "ctrl+alt+del: zwarcie pwr" w dokumentacji, wiec umieszczenie takiej opcji akurat takiej osobie specjalnie nie pomoze ;> (z doswiadczenia pisze, bo do tej pory nie wiem co to wlasciwie znaczy pwr i awr, nie mowiac o szczegolach dzialania)

Niemniej zrobic mozna, dlatego zapytalem czy wyzerowanie flagi 'przetwornica zablokowana' co pozwoli ja w takiej sytuacji uruchomic przy nizszym cisnieniu odwzorowalo by w dostatecznym stopniu funkcje tego zwarcia, czy trzeba by kombinowac bardziej?

edit:
Witam.
 Albo ja coś sknociłem, albo na najnowszej wersji exe Tmj, w ET41 nie działa prawidłowo zawór rozrządczy hamulca. Do bodaj piątej pozycji kranu brak ciśnienia w cylindrach hamulcowych. Rośnie dopiero po daniu w nagłe. Zaraz sprawdzę inne loki.
U siebie tego nie widze -- mam sklad 30 wagonow towarowych, start normalnie napelniony, dalem mu chwile na zluzowanie hamulcow, rozpedzilem do 40 km/h i po ustawieniu na hamowanie wstepne num8 zaczal sie normalnie napelniac, jak w zalaczniku.
« Ostatnia zmiana: 30 Kwietnia 2017, 01:44:45 wysłana przez tmj »

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5925
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 443
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2226 dnia: 30 Kwietnia 2017, 12:51:32 »
Chciałbym, aby ktoś też to sprawdził. Całkowo 2, scenariusz SU45-022. Po manewrach czekam na przyprowadzony skład, dostaje ms2, więc jadę i dopinam się do składu. Dostaje rozkład i na minutę przed odjazdem wciskam shift+2. kierpoć wydaje rozkaz odjazdu i... no możemy jechać, ale mam wrażenie że AI nie potrafi odhamować składu jeśli podepniemy się przewodem hamulcowym i jednocześnie przewodem zasilającym (klikamy na insert 3x). Lokomotywa co prawda rusza, ale wygląda, że AI nie potrafi do końca odhamować składu. AI zwiększa prąd aż do wywalenia nadmiarowego, załącza i znów tak samo.

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2227 dnia: 30 Kwietnia 2017, 16:52:30 »
Nie moge sprawdzic bo mi tarcza nie daje sygnalu jazdy ;/ Do AI nie zagladalem, ale z tego co pamietam to chyba nie probuje ruszyc z miejsca dopoki cisnienie w hamulcach calego skladu nie zejdzie ponizej 0.4

edit:
a propos dziwnego zachowania w ukladzie hamulcowym.
@youBy znalazlem w UpdatePiprePressure() cos takiego:
        if( ( BrakeHandle == FV4a )
         && ( ( PipePress < 2.75 )
           && ( ( Hamulec->GetStatus() & b_rls ) == 0 ) )
         && ( BrakeSubsystem == ss_LSt )
         && ( TrainType != dt_EZT ) ) {
            temp = PipePress + 0.00001;
        }
        else {
            temp = ScndPipePress;
        }
W praktyce oznacza to, ze na niektorych lokomotywach jesli cisnienie w przewodzie hamulcowym jest ponizej 2.75 to nalezy wcisnac i trzymac odluzniacz dopoki nie nabije powyzej tej wartosci, bo inaczej przewod w ogole sie nie napelni, bez wzgledu na cisnienie w zbiorniku glownym/przewodzie zasilajacym. Czy to jest odwzorowanie jakiegos rzeczywistego mechanizmu, czy cos jest tutaj nie tak? o.O
« Ostatnia zmiana: 30 Kwietnia 2017, 18:23:26 wysłana przez tmj »

Offline miko22

  • Wiadomości: 616
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 196
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2228 dnia: 30 Kwietnia 2017, 18:53:12 »
W praktyce oznacza to, ze na niektorych lokomotywach jesli cisnienie w przewodzie hamulcowym jest ponizej 2.75 to nalezy wcisnac i trzymac odluzniacz dopoki nie nabije powyzej tej wartosci, bo inaczej przewod w ogole sie nie napelni, bez wzgledu na cisnienie w zbiorniku glownym/przewodzie zasilajacym. Czy to jest odwzorowanie jakiegos rzeczywistego mechanizmu, czy cos jest tutaj nie tak? o.O
Tak, w rzeczywistości jest coś takiego jak zawór odcinający, który właśnie uniemożliwia samoczynne napełnienie przewodu hamulcowego przez kran (nawet w pozycji napełnienia), jeśli ciśnienie w przewodzie hamulcowym spadnie poniżej 0,28MPa. Chodzi o to, aby przy samoczynnym hamowaniu nagłym wywołanym przez zadziałanie czuwaka, SHP lub radio-stopu, kran nie pompował powietrza w przewód hamulcowy, który w takiej sytuacji jest połączony innym elektrozaworem z atmosferą i aby nie opóźniał tym hamowania w sytuacji niebezpiecznej. Żeby ponownie napełnić przewód hamulcowy, trzeba ustawić kran najlepiej w pozycję napełnienia i przytrzymać wciśnięty przycisk odluźniacza, który ponownie zasili wspomniany zawór odcinający umożliwiając napełnienie przewodu hamulcowego. Przycisk odluźniacza trzeba trzymać wciśnięty dotąd, aż ciśnienie w przewodzie hamulcowym wzrośnie powyżej 0,39MPa, co spowoduje zamknięcie styku wyłącznika ciśnieniowego czuwaka, który zbocznikuje styki przycisku odluźniacza i zawór odcinający pozostanie zasilony do następnego spadku ciśnienia w przewodzie hamulcowym poniżej 0,28MPa.
Problem z hamulcami jest natomiast taki, że przy nastawie hamulca "BQ" (start bez powietrza w ZG), lokomotywy startują z zablokowanym w stanie załączonym odluźniaczem, który bez przerwy spuszcza powietrze z cylindrów do momentu jego odblokowania przez wciśnięcie [Num4] i wtedy już hamulce działają poprawnie. Drugi efekt tego błędu jest taki, że nie ma sposobu działania opisanego powyżej, ponieważ przycisk odluźniacza jest jakby cały czas wciśnięty i przewód hamulcowy nawet z zerowego ciśnienia sam napełnia się po przestawieniu kranu w pozycję jazdy czy napełnienia.
Do tego z hamulcami jest jeszcze inny błąd "od zawsze". Użycie odluźniacza nie powinno powodować problemów z przyhamowaniem przy poślizgu i napełnianiem cylindrów przy normalnym hamowaniu przez spuszczanie powietrza z przewodu hamulcowego. Chodzi o to, że teraz kiedy użyje się odluźniacza, to przez jakiś czas po tym (już po puszczeniu jego przycisku) cylindry hamulcowe wcale lub bardzo opornie napełniają się podczas hamowania kranem głównym czy też podczas próby przyhamowania przeciwpoślizgowego.

Offline MichałŁ

  • Wiadomości: 1179
    • Zobacz profil
  • Otrzymane polubienia: 37
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2229 dnia: 30 Kwietnia 2017, 19:00:28 »
Cytuj
Chodzi o to, że teraz kiedy użyje się odluźniacza, to przez jakiś czas po tym (już po puszczeniu jego przycisku) cylindry hamulcowe wcale lub bardzo opornie napełniają się podczas hamowania kranem głównym czy też podczas próby przyhamowania przeciwpoślizgowego.
A dzieje się tak dlatego, że maszynowy przeciwpoślizg jest zasilany ze zbiornika sterującego. W rzeczywistości jest zasilany ze zbiornika o stałym ciśnieniu 5 bar. Dlatego kiedy wyluzujemy lokomotywę czyli obniżymy ciśnienie w zbiorniku sterującym to nie ma wystarczającego ciśnienia do wysterowania hamulca przeciwpoślizgowego.

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2230 dnia: 30 Kwietnia 2017, 19:10:05 »
Problem z hamulcami jest natomiast taki, że przy nastawie hamulca "BQ" (start bez powietrza w ZG), lokomotywy startują z zablokowanym w stanie załączonym odluźniaczem, który bez przerwy spuszcza powietrze z cylindrów do momentu jego odblokowania przez wciśnięcie [Num4] i wtedy już hamulce działają poprawnie. Drugi efekt tego błędu jest taki, że nie ma sposobu działania opisanego powyżej, ponieważ przycisk odluźniacza jest jakby cały czas wciśnięty i przewód hamulcowy nawet z zerowego ciśnienia sam napełnia się po przestawieniu kranu w pozycję jazdy czy napełnienia.
No wlasnie ja ten efekt zauwazylem dopiero po usunieciu automatycznego zalaczenia rozluzniacza przy wpisie BQ, bo mi sie przewod przestal napelniac :>

Co do tego drugiegu bledu to tutaj pewnie musialby sie przyjrzec fachowiec, ja tam predzej cos zepsuje niz naprawie...

edit: aha, wiec zeby to naprawic trzeba by dodac do system dodatkowy zbiornik, ktory sie tym zajmuje?

Offline youBy

  • Deweloper
  • Wiadomości: 6163
  • Co tam?
    • Zobacz profil
    • Automat Weryfikujący Regulację i Lambdę
  • Otrzymane polubienia: 865
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2231 dnia: 30 Kwietnia 2017, 19:58:36 »
a propos dziwnego zachowania w ukladzie hamulcowym.
@youBy znalazlem w UpdatePiprePressure() cos takiego:

W praktyce oznacza to, ze na niektorych lokomotywach jesli cisnienie w przewodzie hamulcowym jest ponizej 2.75 to nalezy wcisnac i trzymac odluzniacz dopoki nie nabije powyzej tej wartosci, bo inaczej przewod w ogole sie nie napelni, bez wzgledu na cisnienie w zbiorniku glownym/przewodzie zasilajacym. Czy to jest odwzorowanie jakiegos rzeczywistego mechanizmu, czy cos jest tutaj nie tak? o.O
Tak ma być – znaczy prawie. W rzeczywistości jest wyłącznik ciśnieniowy zasilania zaworu maszynisty (nie wiem, czy on też jednocześnie nie odcina zasilania styczników liniowych). Wyłącza się on poniżej 2,8 bar w PG (zawór nie ma zasilania), załącza się on powyżej 4,6 bar (zawór działa normalnie). Z racji różnych takich innych powodów pascalowych została zrobiona wersja bez histerezy. Trzeba tam dodać: zmienną bool (stan wyłącznika) oraz dwa ciśnienia wczytywane z fiza (BPPOn i BPPOff). Po ustawieniu absurdalnych wartości od razu uzyska się możliwość symlacji braku takiego wyłącznika.
Podobnie powinno być z wyłącznikiem ciśnieniowym na cylindrze – flaga + 2 wartości progowe. Obecnie działa to tak, że rozłącza zawsze powyżej 2 bar, a styczniki da się załączyć przy wejściu na 1 pozycję poniżej 1 bar. Zamiast tego powinno to być oparte na fladze.

Kompletnie z innej beczki, czy ktos z majacych do czynienia z kodem orientuje sie, jak wlasciwie sa zorganizowane HVCouplers ?
Mniej więcej – HVCouplers[sprzęg][parametr]. Sprzęg to numer sprzęgu, parametr=0 oznacza prąd, parametr=1 oznacza napięcie. ZTCP to napięcia są przesyłane wzdłuż składu "na krzyż" — napięcie odczytane z sąsiada 0 jest podawane na sprzęg 1.

Cytuj
Chodzi o to, że teraz kiedy użyje się odluźniacza, to przez jakiś czas po tym (już po puszczeniu jego przycisku) cylindry hamulcowe wcale lub bardzo opornie napełniają się podczas hamowania kranem głównym czy też podczas próby przyhamowania przeciwpoślizgowego.
A dzieje się tak dlatego, że maszynowy przeciwpoślizg jest zasilany ze zbiornika sterującego. W rzeczywistości jest zasilany ze zbiornika o stałym ciśnieniu 5 bar. Dlatego kiedy wyluzujemy lokomotywę czyli obniżymy ciśnienie w zbiorniku sterującym to nie ma wystarczającego ciśnienia do wysterowania hamulca przeciwpoślizgowego.
Nieprawda — maszynowy przeciwpoślizg jest zasilany ze zbiornika pomocniczego, a sam sygnał sterujący chyba z niczego. Sęk w tym, że odluźniacz odluźnia zbiornik sterujący do atmosfery zamiast wyrównać go z komorą wstępną zaworu rozrządczego. Stąd też na głównym przyrządzie rozrządczym pojawia się siła skierowana w dół, której sterowanie przyhamowaniem przeciwpoślizgowym nie jest w stanie przezwyciężyć. Teoretycznie powinno wystarczyć w kodzie (sorki, że wyjadę jeszcze z Pascalem) w funkcji TLSt.GetPF zrobić taki manewr (odkomentowanie dV1 i implsres, zmiana BCP na VVP):
if(BrakeStatus and b_rls=b_rls)then
   if(CVP<1*0)then
     BrakeStatus:=BrakeStatus and 247
   else
    begin           //008
     dV:=PF1(CVP,VVP,0.024)*dt;
     CntrlRes.Flow(+dV);
     dV1:=+dV; //minus potem jest
     ImplsRes.Flow(-dV1);
    end;
tylko miałem kiedyś wrażenie, że coś tu jest jeszcze nie tak :(
Xoov
Powyższy post wyraża jedynie opinię autora w chwili publikacji. Autor zastrzega sobie prawo do zmiany poglądów bez podawania przyczyny, jak również informowania o tym.

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5925
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 443
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2232 dnia: 30 Kwietnia 2017, 20:08:01 »
Nie moge sprawdzic bo mi tarcza nie daje sygnalu jazdy ;/ Do AI nie zagladalem, ale z tego co pamietam to chyba nie probuje ruszyc z miejsca dopoki cisnienie w hamulcach calego skladu nie zejdzie ponizej 0.4
No niby nie powinna ruszyć, ale macha kołem aż do puszczenia wyłącznika szybkiego i powtarza to wielokrotnie, bez wyraźnego wzrostu prędkości. Spróbowałem pociągnąć sam, efekt jakbym ciągnął wór kartofli po ziemi. Pozostaje spróbować jazdy tylko z jednym przewodem powietrznym.

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2610
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2233 dnia: 30 Kwietnia 2017, 20:20:23 »
W rzeczywistości jest wyłącznik ciśnieniowy zasilania zaworu maszynisty (nie wiem, czy on też jednocześnie nie odcina zasilania styczników liniowych).
Tu by się coś przydało. Przy testowaniu wagonów wyszło, że przy pociągnięciu awaryjnego w wagonie, ai próbuje ciągnąć aż mu nadmiarowy wywali, a może i luzować, opóźniając zatrzymanie.
Mój kanał youtube

Offline miko22

  • Wiadomości: 616
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 196
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2234 dnia: 30 Kwietnia 2017, 20:25:39 »
Tak ma być – znaczy prawie. W rzeczywistości jest wyłącznik ciśnieniowy zasilania zaworu maszynisty (nie wiem, czy on też jednocześnie nie odcina zasilania styczników liniowych). Wyłącza się on poniżej 2,8 bar w PG (zawór nie ma zasilania), załącza się on powyżej 4,6 bar (zawór działa normalnie).
Wyłącznik, o którym piszesz (przynajmniej w EU07 i pochodnych) nazywa się wyłącznikiem ciśnieniowym czuwaka. Powinien załączać się przy ciśnieniu powyżej 3,9bar i tak, powinien też wyłączać styczniki liniowe w momencie rozłączenia styku poniżej 2,8bar - zgłoszenie jest w Bugtrackerze:
Cytat: Stele/miko22 link=issue=276.com915#com915 date=1476608869
- brak odwzorowania wyłącznika ciśnieniowego czuwaka, który powinien wyłączać styczniki liniowe, gdy ciśnienie w przewodzie głównym spadnie poniżej 2,8bar (to samo dla EU/EP07/08 i być może innych);
Jako ostatnie na liście: http://eu07.pl/forum/index.php?issue=276.0
Edit: Trochę więcej informacji do powyższego linku jest tutaj: http://eu07.pl/forum/index.php/topic,28316.msg427825.html#msg427825 Dopiero następnego dnia Stele utworzył zgłoszenie w Bugtrackerze na podstawie mojego postu.
« Ostatnia zmiana: 30 Kwietnia 2017, 20:52:48 wysłana przez miko22 »

Offline MichałŁ

  • Wiadomości: 1179
    • Zobacz profil
  • Otrzymane polubienia: 37
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2235 dnia: 30 Kwietnia 2017, 22:09:55 »
Cytuj
Nieprawda — maszynowy przeciwpoślizg jest zasilany ze zbiornika pomocniczego, a sam sygnał sterujący chyba z niczego.
A no to też wiele wyjaśnia.

Jeszcze wykryłem taki błąd podczas używania syreny zawór wydaje dźwięk hebelka. w rzeczywistości takie coś nie występuje.

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2610
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2236 dnia: 30 Kwietnia 2017, 22:57:20 »
MK1991 chwalił się kompletem dźwięków przełączników wszelakich do ET22, tak by motywować do dodania dedykowanych dźwięków do każdego z przełączników.
----------
Pojawiły się w błędach wpisy:
Scale of 0.0 defined for sub-model "pedaly" in 3d model "dynamic\pkp\ep05_v2\05]kabina_a.e3d". Forcing scale of 1.0 to prevent division by 0Dla sand_bt: pedaly mov 0 0 0 Czyli przełącznika-widmo. Do którego parametru się to odnosi? Da się zrobić jeszcze animację o zerowym zakresie?
« Ostatnia zmiana: 01 Maja 2017, 14:16:50 wysłana przez Stele »
Mój kanał youtube

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2237 dnia: 01 Maja 2017, 14:54:53 »
Skala to pierwszy z trzech podawanych parametrow liczbowych. Technicznie rzecz biorac tam nigdy nie bylo animacji o zerowym zakresie -- podanie skali 0 powodowalo "wyliczenie" wartosci nieokreslonej co mialo efekt uboczny kompletnego rozsadzenia przelacznika od srodka. Jesli faktycznie jest zapotrzebowanie na animacje ktora nic nie animuje, moge dodac cos w stylu typu animacji "none" ktora nie robi nic (ale nie psuje kalkulacji stanu przelacznika) z tym, ze nie wiem czy ma to specjalnie sens -- rozumiem ze to jest uzywane jako prowizorka by 'na szybko' dodac przycisk, bez ustawienia mu prawidlowej animacji ktora powinien miec?

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2610
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2238 dnia: 01 Maja 2017, 14:56:29 »
Dokładnie. Można tam różnie dobrze dać jakiś mikroprzesunięcie w sumie.

I mamy wysyp. Drawinowo170417, en57akł.
« Ostatnia zmiana: 01 Maja 2017, 16:25:27 wysłana przez Stele »
Mój kanał youtube

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2239 dnia: 01 Maja 2017, 16:36:25 »
Wysypalo sie gdzies w sterowniku graficznym ATI, i to tak brzydko ze nie ma zadnej informacji z ktorego miejsca w samym exe :<

A z innej beczki, drobne uaktualnienie:

- eksperymentalne, pojazdy z wpisami .BQ lub innymi wymuszajacymi oproznienie ukladu hamulcowego nie maja na starcie automatycznie zalacznonego odluzniacza

- poprawiona kalkulacja pradow i napiec z podlaczonych kabli WN, bo tak jak podejrzewalem, przy okazji naprawiania takze tutaj napsulem :d

- eksperymentalne, dodana poprawka od @youBy dla interakcji miedzy odluzniaczem i pozostalymi elementami ukladu hamulcowego

- wielkosc wycieku powietrza ze zbiornika pantografow zalezy od panujacego w nim cisnienia; w rezultacie napelnienie zbiornika do wyzszych wartosci moze potrwac nieco dluzej niz poprzednio
« Ostatnia zmiana: 01 Maja 2017, 16:59:11 wysłana przez tmj »

Offline miko22

  • Wiadomości: 616
  • Powoli wracam z "promocją"...
    • Zobacz profil
    • Nasze-Symulatory.pl
  • Otrzymane polubienia: 196
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2240 dnia: 01 Maja 2017, 17:33:23 »
- eksperymentalne, pojazdy z wpisami .BQ lub innymi wymuszajacymi oproznienie ukladu hamulcowego nie maja na starcie automatycznie zalacznonego odluzniacza
- wielkosc wycieku powietrza ze zbiornika pantografow zalezy od panujacego w nim cisnienia; w rezultacie napelnienie zbiornika do wyzszych wartosci moze potrwac nieco dluzej niz poprzednio
Działa bardzo dobrze :)
- eksperymentalne, dodana poprawka od @youBy dla interakcji miedzy odluzniaczem i pozostalymi elementami ukladu hamulcowego
A to bardzo namieszało... Chyba zrobiło się jakieś połączenie z przewodem głównym. Odhamuj skład, zahamuj na [Num2], a później poluzuj na [Num8] albo odhamuj na [NumDel] i trzymaj wciśnięty odluźniacz - wskazówka manometru cylindrów leci na 0,7MPa :O
« Ostatnia zmiana: 01 Maja 2017, 17:43:05 wysłana przez miko22 »

Offline Wiggle

  • Deweloper
  • Wiadomości: 477
    • Zobacz profil
  • Otrzymane polubienia: 141
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2241 dnia: 01 Maja 2017, 19:00:24 »
EN57 teraz bezpośrednio po starcie mi hamuje, testowane na td (ale nie startuje w miejscu eu07 tylko napompowany na torze obok).
Maszynista Instruktor
POLREGIO Zakład Wielkopolski

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2242 dnia: 01 Maja 2017, 19:17:53 »
Bede mogl to sprawdzic jesli mi podasz lopatologicznie co trzeba wpisac w td zeby wystartowac "na torze obok"  Sprobowalem postawic sklad na tor_st1 (co prawda oprozniony, i napelniony recznie) i jezdzi normalnie, bez hamowania.

Offline Wiggle

  • Deweloper
  • Wiadomości: 477
    • Zobacz profil
  • Otrzymane polubienia: 141
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2243 dnia: 01 Maja 2017, 19:54:30 »
Łap mój plik td.scn
Myślałem, że to się stało, bo przypadkowo nacisnąłem num 4 ale jednak nie.
Maszynista Instruktor
POLREGIO Zakład Wielkopolski

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5925
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 443
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2244 dnia: 01 Maja 2017, 20:15:24 »
Jeśli chodzi o SU45, to
Nie moge sprawdzic bo mi tarcza nie daje sygnalu jazdy ;/ Do AI nie zagladalem, ale z tego co pamietam to chyba nie probuje ruszyc z miejsca dopoki cisnienie w hamulcach calego skladu nie zejdzie ponizej 0.4
aby nie szarpać się z tm21 odpal to:
calkowo_v2_osobA_jar.scnTrzeba dojechać w perony, stanąć przed W4 i włączyć AI. Jednak nie ma znaczenia czy łączymy jednym, czy dwoma wężami powietrznymi. Im więcej wagonów tym większe wariactwa wyczynia AI.
Na Całkowie 2 mam niestety od diabła wysypów, o ile na Kaliskiej jestem w stanie zawsze przejechać obie misje oficjalnie dostępne, to na nowym Całkowie mało kiedy udaje się dojechać do końca. Można by to ostatecznie rozwiązać na końcu prac... Tylko co jak się nie da? Po za tym testowanie określonych zachowań w środku jakiejś scenerii jest stresujące: czy nie wywali exeka wcześniej.  Jak daleko są prace stabilizujące wysypy, dla mnie to teraz priorytet?
« Ostatnia zmiana: 01 Maja 2017, 20:16:39 wysłana przez Krzysiek626 »

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2245 dnia: 01 Maja 2017, 21:36:21 »
Czy w tym scenariuszu na calkowo 2 musze cos dodatkowo kombinowac? Bo uruchomilem z domyslnym pociagiem, poczekalem na sygnal manewrowy, wlaczylem AI i ona sie elegancko dokulala do peronow, a o wlasciwej godzinie odjechala sobie jak trzeba. Tak samo regio z EU07 ktory stal tam zaparkowany i odjechal pare minut wczesniej, takze bez szarpania ani zadnych dziwnych wyczynow?

Co do wysypow trudno powiedziec, nie znajac przyczyn -- te, o ktorych wiem (z generowaniem geometrii skrzyzowan itp) przytrafiaja sie na poczatku scenariusza a nie w trakcie. W trakcie przytrafiaja sie bledy skanowania, ale te z kolei ciezko wylapac. Dobrze byloby, gdyby ktos mogl sprawdzic wersje z poprawkami @firleju, czy tam takich wysypow nie ma. Dodatkowo na calkowie sa chyba jakies dziwne konstrukcje, przy wlaczonym debug mode w logu pojawia sie masowo cos takiego:
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
eu07-133 dociskanie...
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
0! Coupler warning on cal_most05:0 - cal_most02:1 connected to cal_most04:1
1! Coupler warning on cal_most05:0 - cal_most02:1 connected to cal_most04:1
eu07-133 dociskanie...
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
0! Coupler warning on cal_most05:0 - cal_most02:1 connected to cal_most04:1
1! Coupler warning on cal_most05:0 - cal_most02:1 connected to cal_most04:1
0! Coupler warning on cal_most05:0 - cal_most02:1 connected to cal_most04:1
1! Coupler warning on cal_most05:0 - cal_most02:1 connected to cal_most04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most05:1 - cal_most02:1 connected to cal_most04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
eu07-133 dociskanie...
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
0! Coupler warning on cal_most05:0 - cal_most02:1 connected to cal_most04:1
1! Coupler warning on cal_most05:0 - cal_most02:1 connected to cal_most04:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
1! Coupler warning on jan_wylotowka06:0 - jan_wylotowka05:0 connected to jan_wylotowka04:1
1! Coupler warning on cal_most01:0 - cal_most05:1 connected to cal_most02:1
I diabli wiedza co to ma byc, albo nawet gdzie tego szukac na mapie -- ktos uzywa lokomotywy zeby skladac z kawalkow most? Co by to nie bylo, symulacji raczej sie to nie podoba ;/

Offline Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 5925
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 443
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2246 dnia: 01 Maja 2017, 21:45:40 »
Nie drażni Ciebie to machanie kołem do 2kA i zjeżdżanie do zera? Sprawdzę jutro na borlandowym exe. Proponuje, poczekać na odjazd z peronów. Także dołącz jeśli znajdziesz czas  jeszcze ze 4 wagoniki. Ten pospieszny jest ciężki.Co do EU07, to nie mam zastrzeżeń. Nie wiem skąd wziąć wersję z poprawkami @firleju, chętnie bym pojeździł na tej wersji. Przy lampkach, luzowaniu i syczeniu nie jestem w stanie pomóc.

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10133
    • Zobacz profil
  • Otrzymane polubienia: 2610
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2247 dnia: 01 Maja 2017, 21:55:11 »
Auta nie mają sprzęgu i gdy się zderzają to w logu mamy takie coś. Zawsze tak było. Nie wiem czy w czymś to szkodzi. Poprawki hamulców i skanowania powinny tu częściowo pomóc, bo by się nie zderzały.
Mój kanał youtube

Offline Niebugoclaw

  • Wiadomości: 1222
    • Zobacz profil
  • Otrzymane polubienia: 10
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2248 dnia: 01 Maja 2017, 23:05:32 »
Przepraszam, jeżeli problem był już opisany na jednej z 75 stron, ale nie mam czasu, żeby każdą przejrzeć. Czy ktoś jeszcze spotkał się na wersji 64 bitowej z problemem ze smugami świateł? Mianowicie po załączeniu w porze nocnej reflektorów, oświetla się cała sceneria łącznie z kabiną, a nie tylko smuga przed lokomotywą.

Offline tmj

  • Zasłużony dla Symulatora
  • Wiadomości: 3808
    • Zobacz profil
  • Otrzymane polubienia: 2349
Odp: Odp: Exe - konwersja na C++
« Odpowiedź #2249 dnia: 01 Maja 2017, 23:08:05 »
Nie drażni Ciebie to machanie kołem do 2kA i zjeżdżanie do zera? Sprawdzę jutro na borlandowym exe. Proponuje, poczekać na odjazd z peronów. Także dołącz jeśli znajdziesz czas  jeszcze ze 4 wagoniki.
No rzucanie kolem w te i we wte bylo w exe "od zawsze" bo tak jest AI napisana. Na Borlandowym jest to samo i ja tego kijem nawet nie ruszalem, bo dopoki jezdzi i zatrzumje sie mniej wiecej jak trzeba to sa inne rzeczy ktore sa w gorszym stanie. Z tego co napisales poczatkowo to myslalem ze moze te ostatnie zmiany w hamulcach itp cos tam popsuly w takim stopniu ze AI przestalo jezdzic... ale doczepilem do tej SU dodatkowe wagoniki, spialem wszystko podwojnymi wezami i jeszcze dalem ogrzewanie i przejscia, i ona z tym jezdzi normalnie, tzn tak samo idiotycznie jak zawsze, ale jezdzi.

Przepraszam, jeżeli problem był już opisany na jednej z 75 stron, ale nie mam czasu, żeby każdą przejrzeć. Czy ktoś jeszcze spotkał się na wersji 64 bitowej z problemem ze smugami świateł? Mianowicie po załączeniu w porze nocnej reflektorów, oświetla się cała sceneria łącznie z kabiną, a nie tylko smuga przed lokomotywą.
Raczej sie z tym nie spotkalem; czy to jest na wersji "zwyklej' c++ czy na wersji ng++ z shaderami, od milka? I na jakiejs konkretnej scenerii i/lub ustawieniach, czy wszedzie? log.txt moglby moze troche pomoc, o ile to nie problem.