Autor Wątek:  'Bad token' podczas dodawania obiektu do scenerii  (Przeczytany 7331 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Hubertnator23

  • Wiadomości: 644
  • Specjalista ds. kiszenia nieukończonych dodatków
    • Zobacz profil
  • Otrzymane polubienia: 400
'Bad token' podczas dodawania obiektu do scenerii
« dnia: 04 Kwietnia 2020, 16:02:36 »
Dzień Dobry,

Ostatnio chciałem dodać obiekt do scenerii 'td' koło przejazdu kolejowego przed dodaniem do testów. Niestety, obiekt się nie pokazuje na scenerii, a w logu wyskakiwał błąd 'bad token'. Chciałbym wiedzieć co to znaczy 'bad token' i co jest nie tak - model, tekstura czy coś innego.
« Ostatnia zmiana: 04 Kwietnia 2020, 16:18:22 wysłana przez Hubertnator23 »

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10131
    • Zobacz profil
  • Otrzymane polubienia: 2601
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #1 dnia: 04 Kwietnia 2020, 16:08:15 »
Podajesz mu parametr tekstur wymiennych oddzielony spacjami, przez co rozdziela go na kilka tokenów, wychodząc za zakres składi node model i się sypie. Powinno być:
node -1 0 hz10 model 1180 1.65 1147 -60 przejazdy/sygnalizator_hz10.t3d przejazdy/hz10_sygnalizator.dds|przejazdy/hz10_daszek.dds|przejazdy/hz10_komora.dds endmodelPo drugie ten model nie ma tekstur wymiennych. Wszystkie są na sztywno zdefiniowane w pliku modelu. Więc całość ma brzmieć:
node -1 0 hz10 model 1180 1.65 1147 -60 przejazdy/sygnalizator_hz10.t3d none endmodelPo trzecie nie robimy na teksturach dds tylko tga. Ddsy to skompresowana wersja w paczce użytkowej.
Mój kanał youtube

Offline Hubertnator23

  • Wiadomości: 644
  • Specjalista ds. kiszenia nieukończonych dodatków
    • Zobacz profil
  • Otrzymane polubienia: 400
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #2 dnia: 04 Kwietnia 2020, 17:35:05 »
Dzięki! Teraz model się wczytuję, tylko że tekstura nie odpowiednia. Jak to rozwiązać?

Limit wagi grafiki to 250kB. Proszę zapisywać w odpowiednio skompresowanym jpg. @Stele


(Poprawione)
« Ostatnia zmiana: 04 Kwietnia 2020, 19:40:42 wysłana przez Hubertnator23 »

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10131
    • Zobacz profil
  • Otrzymane polubienia: 2601
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #3 dnia: 04 Kwietnia 2020, 17:50:24 »
Ale przecież to jest tekstura jakiegoś izolatora sieci trakcyjnej a nie twojego sygnalizatora. W modelu podpięta jest dobra. Pokaż aktualny log, bo pewnie dalej masz coś posypane ze składnią i się texture id w pamięci rozjeżdża.
Co do modelu, to jeszcze wiele mu brakuje do zgodności ze standardami, ale nie wiem czy już wypisywać, by nie zasypać krytyką, gdy tylko próbujesz cokolwiek wstawić w scenę. Może najpierw sam przeanalizuj wytyczne dla twórców i zastanów się czego nie spełniasz.
Mój kanał youtube

Offline Hubertnator23

  • Wiadomości: 644
  • Specjalista ds. kiszenia nieukończonych dodatków
    • Zobacz profil
  • Otrzymane polubienia: 400
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #4 dnia: 04 Kwietnia 2020, 21:05:21 »
Cytuj
Co do modelu, to jeszcze wiele mu brakuje do zgodności ze standardami

Rozumiem że:
  • tekstury nie są w .tga (już naprawione)
  • nie respektowanie hierarchii obiektów (mam trzy obiekty a nie jeden z trzema subobiektami)
  • maszt niedorobiony (w blenderze mam prowizorkę)
  • Nakładające się płaszczyzny (daszek i sygnalizator)

Zmieniłem tekstury z .dds do .tga, i się problem z teksurą izolatora trakcji rozwiązał się! Pewnie coś z eksportowaniem modelu lub wczytywaniu tekstury. Jedyny problem jaki teraz mam jest z daszkiem. Nie jest widoczny pod niektórymi kątami. Wina modelu, czy dodawanie obiektu do scenerii?
« Ostatnia zmiana: 04 Kwietnia 2020, 21:06:25 wysłana przez Hubertnator23 »

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10131
    • Zobacz profil
  • Otrzymane polubienia: 2601
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #5 dnia: 04 Kwietnia 2020, 21:11:32 »
A ma dwustronną geometrię? Maszyna renderuje geometrię tylko od strony wektora normalnego płaszczyzny określanego kierunkowością wierzchołków trójkąta. Musisz w blenderze nadać grubość daszkowi. Nie dawaj klona z odbitymi normalnymi w tym samym miejscu, tylko daj solidify na minimum 2mm, wywalając ściankę wnikającą w korpus. Nakładające się ścianki, nawet o przeciwnych wektorach normalnych, rozwalą się przy imporcie do każdego edytora 3d przez brak indeksowania wierzchołków w t3d.

Co do uwag, to jeszcze pivot w środek nogi i wymnożyć transform obiektu. Oraz podział logiczny na obiekty. Trzeba ci obudowy, lampki zgaszonej, lampki zapalonej i punktu świetlnego podpiętego pod lampkę zapaloną. Teraz masz korpus, daszek i nogę, które powinieneś scalić do kupy.
Mój kanał youtube

Offline Hubertnator23

  • Wiadomości: 644
  • Specjalista ds. kiszenia nieukończonych dodatków
    • Zobacz profil
  • Otrzymane polubienia: 400
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #6 dnia: 05 Kwietnia 2020, 09:09:46 »
Jeszcze sprawdziłem loga, w nim pokazuje się coś takiego: Bad model: transformation matrix for sub-model "sygnalizator" imposes geometry scaling (factors: 0.40, 0.20, 0.90). Co to oznacza?

Offline matek123

  • Moderator
  • Wiadomości: 5582
    • Zobacz profil
  • Otrzymane polubienia: 1763
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #7 dnia: 05 Kwietnia 2020, 10:11:22 »
W przypadku statycznych obiektów niegroźne, ale warto zresetować skalowanie modelu. Żeby w macierzy transform nie było skalowania.
Poszukuję zdjęć na tekstury pociągów sieciowych. Szczególnie platform z pomostami.

Offline Miłosz Dorsz

  • Moderator
  • Wiadomości: 1171
    • Zobacz profil
  • Otrzymane polubienia: 3004
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #8 dnia: 05 Kwietnia 2020, 11:08:31 »
Najpierw jeszcze przeskaluj to do rzeczywistych wymiarów, potem zresetuj skalowanie w programie 3d. Widać że teraz sygnalizator jest stanowczo za duży.
Aktualne projekty: KLIK

Offline Hubertnator23

  • Wiadomości: 644
  • Specjalista ds. kiszenia nieukończonych dodatków
    • Zobacz profil
  • Otrzymane polubienia: 400
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #9 dnia: 09 Kwietnia 2020, 15:15:26 »
Pytanie - jak dodać jeden obiekt z sub-obiektami w blenderze?
« Ostatnia zmiana: 09 Kwietnia 2020, 15:20:28 wysłana przez Hubertnator23 »

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10131
    • Zobacz profil
  • Otrzymane polubienia: 2601
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #10 dnia: 09 Kwietnia 2020, 15:17:59 »
Tworzysz w edytorze 3d drzewko hierarchiczne obiektów. Przeciągasz w outlinerze z którymś tam klawiszem funkcyjnym, tym co tooltip mówi "set parent".
Mój kanał youtube

Offline Balaclava

  • Deweloper
  • Wiadomości: 917
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 662
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #11 dnia: 09 Kwietnia 2020, 16:43:31 »
Można trzeba w outlinerze przeciągnąć obiekt który chcemy uczynić dzieckiem i upuścić go na rodzica trzymając Shift

Offline Hubertnator23

  • Wiadomości: 644
  • Specjalista ds. kiszenia nieukończonych dodatków
    • Zobacz profil
  • Otrzymane polubienia: 400
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #12 dnia: 10 Kwietnia 2020, 12:05:00 »
Jak zrobić animację ostrzegania przed pociągiem? Mam jeden model (sygnalizator) i cztery sub-modele (daszek, stars w którym jest lampka, lamp-on i lamp-off)

Offline Stele

  • Zasłużony dla Symulatora
  • Wiadomości: 10131
    • Zobacz profil
  • Otrzymane polubienia: 2601
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #13 dnia: 10 Kwietnia 2020, 12:18:20 »
Daszek zespawaj z korpusem. Nie ma sensu tego dzielić. Stars zamień na spot light podpięty pod lamp_on.
Sterownie robisz zdarzeniami sterującymi lampką w pliku include. Zobacz sobie jakąś obecną sygnalizację przejazdową i zrób analogicznie.
Mój kanał youtube

Offline Hubertnator23

  • Wiadomości: 644
  • Specjalista ds. kiszenia nieukończonych dodatków
    • Zobacz profil
  • Otrzymane polubienia: 400
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #14 dnia: 13 Kwietnia 2020, 09:50:03 »
Kolejna rzecz - jest dużo wariacji sygnalizatorów HZ-10/HZ-11. Jest HZ-10 z daszkiem klasycznym, daszkiem typu "pazur" i bez daszku. Jeszcze bardziej się dokopałem, i okazuje się że sygnalizator HZ-10 jest zawsze bez krzyża i sygnału akustycznego.
HZ-11 występuje w 5 odmianach: z pojedynczym krzyżem św. Andrzeja, z podwójnym krzyżem, z dzwonem, z dzwonem + pojedynczy krzyż i z dzwonem + podwójny krzyż.

Mam zrobić 5-10 modeli tych sygnalizatorów które korzystają z jednej tekstury, czy dwa (HZ-10 i HZ-11) z doczepkami?

Offline matek123

  • Moderator
  • Wiadomości: 5582
    • Zobacz profil
  • Otrzymane polubienia: 1763
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #15 dnia: 13 Kwietnia 2020, 09:55:02 »
Dwa modele. Doczepki w osobnych modelach.  A połączenie sygnalizatorów z doczepkami z poziomu plików .inc.
Poszukuję zdjęć na tekstury pociągów sieciowych. Szczególnie platform z pomostami.

Offline Hubertnator23

  • Wiadomości: 644
  • Specjalista ds. kiszenia nieukończonych dodatków
    • Zobacz profil
  • Otrzymane polubienia: 400
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #16 dnia: 15 Kwietnia 2020, 13:16:50 »
Czy jest możliwość posiadania dwóch materiałów na jednym obiekcie? W Blenderze można, a w exe wybiera jeden na cały obiekt.

Offline DieselPower

  • Deweloper
  • Wiadomości: 1903
    • Zobacz profil
  • Otrzymane polubienia: 3465
Odp: 'Bad token' podczas dodawania obiektu do scenerii
« Odpowiedź #17 dnia: 15 Kwietnia 2020, 13:22:54 »
Jeden obiekt to jedna tekstura. Zostaje albo przemapowanie i scalenie w jedną teksturę, albo podział na dwa osobne obiekty z własną teksturą.