Autor Wątek:  Quark - problemy różne  (Przeczytany 14940 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Quark - problemy różne
« dnia: 11 Lutego 2014, 20:59:34 »
Z tego co kojarzę, to na rozkładzie jazdy (F3) i na zegarze (F1) wyświetlane informacje powinny się aktualizować w miarę mijanych przystanków. Dojechałem sobie z WK do Koniewic i niestety wygląda to dalej tak jak zaraz po odpaleniu scenerii - czyli najbliższy odjazd Wielki Kac 5:02 (screenshoty). Bug w exe, bug w scenerii czy PEBKAC?
« Ostatnia zmiana: 14 Lutego 2014, 22:13:54 wysłana przez muri »

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6284
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 300
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #1 dnia: 11 Lutego 2014, 21:21:22 »
Wjechałeś zgodnie z godziną podaną w rozkładzie? Na wersji 424 można jeszcze dwukrotnie użyć [F2], wtedy pokazuje się tabelka skanowania. Na wcześniejszych nie da się jej odczytać.
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline Benek

  • Moderator
  • Wiadomości: 4504
  • fb.com/benek.maszyna
    • Zobacz profil
    • Moja strona o MaSzynie
  • Otrzymane polubienia: 17
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #2 dnia: 11 Lutego 2014, 21:24:06 »
Ja miałem to samo, ale na wersji z repo.

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #3 dnia: 11 Lutego 2014, 21:26:38 »
Hm. Zgodnie z rozkładem to chyba nie, bo jak widać rozkładowo powinienem być w koniewidach o 05:28, a jest 05:21 i stoję na oporowym :P Ale to jakaś kiszka jest, przecież jak stuka 05:02 (odjazd z WK), no to chyba pod F1 powinienem widzieć ... -> Pole 05:08, i powinien zniknąć jeden wiersz pod F3?

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6284
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 300
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #4 dnia: 11 Lutego 2014, 21:31:04 »
Hm, to muszę sprawdzić, czy zalicza pierwszą stację, jak się stoi dalej niż 20m. Bo przynajmniej AI musi podjechać na mniej niż 20m do W4, żeby zaliczyć przystanek. Jeśli stajesz dalej od W4, to może nie zaliczać.
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #5 dnia: 11 Lutego 2014, 21:32:36 »
I z tzw. innej beczki: Zepchnąłem skład na żeberko, odpiąłem się, kibelek do Skwarek sobie odjechał, a ja dalej na żeberku czekam na MS2. W logu widzę że odpalił się event EVENT LAUNCHED: koniewice-manewr2 by ep07-1038i to by było na tyle. problem chyba jest gdzieś tutaj://manewry: wypchanie skladu z toru 2 na tor postojowy, powrot na tor 1, przejazd za glowice, wjazd na tor 3.
//event koniewice-manewr1 multiple 120.0 none koniec2p_ms2 end6+ end101- end102+ koniewice_1_update_1 endevent
event koniewice_1_update_1 updatevalues 0 koniewice_1 * 1 * endevent
event koniewice-manewr2 multiple 70.0 koniewice_1 koniec2p_s1 koniewice_odepnij end6+ koniewice_1_update_2 condition memcompare * 1 * endevent
event koniewice_1_update_2 updatevalues 0 koniewice_1 * 2 * endevent
//Ra: odczepienie lokomotywy na postojowym
event koniewice_odepnij updatevalues 0 koniec_tm4_sem_mem Shunt 0 0 endevent //komenda odpinania
event koniec_tm4_sem_mem:sent multiple 10.0 none koniec_tm4_ms2 endevent //manewry po komendzie
Z tego co rozumiem, MS2 na mojej tarczy jest zapalane podczas zmiany wartości w komórce pamięci koniec_tm4_sem_mem ? No to chyba nic takiego się nie dzieje, bo nie mam w logu wywołania komendy koniec_tm4_sem_mem:sent.



  Dodano: 11 Lutego 2014, 21:37:55
Hm, po zastanowieniu się dochodzę do wniosku, że to zdarzenie jednak się nie wykonało. Tam jest "condition memcompare" w warunku, A event ustawiający potrzebną wartość w komórce (koniewice-manewr1) jest zakomentowany. Tak jest celowo? Widze że event o takiej nazwie nie występuje już nigdzie w torach, więc nawet jakby nie był zakomentowany to nigdy by się nie wywołał. Pewnie zamiast tego miało być wrzucone jakieś isolated:free/occupied?
« Ostatnia zmiana: 11 Lutego 2014, 21:43:45 wysłana przez muri »

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6284
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 300
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #6 dnia: 11 Lutego 2014, 21:45:16 »
Cóż, niestety jak na razie to jest koniec akcji, ponieważ manewry do wagonów trzeba by wykonywać z wyjechaniem do W5, co wynika z bezsensownego układu torowego. Z tego powodu nie chciało mi się dokańczać manewrów. Ale ponieważ co jakiś czas ktoś o to pyta, to się jeszcze zastanowię. Wolałbym najpierw poprawić tory, a potem organizować ruch. A póki co poprawianie reszty Quarka nie jest priorytetem, przynajmniej w porównaniu do dołączenia Tarniowa.

Odnośnie eventów, to koniec_tm4_sem_mem:sent powinno się wykonać po odebraniu komendy (odpięcia) przez lokomotywę. OIDP to się kiedyś odpinało, ale ostatnia wersja Quarka, jaką obecnie mam, działa już zupełnie inaczej. Chyba ją będę musiał niedługo udostępnić, bo ta z paczki jest już mocno nieświeża.
« Ostatnia zmiana: 11 Lutego 2014, 22:38:08 wysłana przez Ra »
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #7 dnia: 11 Lutego 2014, 21:52:12 »
Odnośnie eventów, to koniec_tm4_sem_mem:send powinno się wykonać po odebraniu komendy (odpięcia) przez lokomotywę. OIDP to się kiedyś odpinało, ale ostatnia wersja Quarka, jaką obecnie mam, działa już zupełnie inaczej. Chyba ją będę musiał niedługo udostępnić, bo ta z paczki jest już mocno nieświeża.
Czyli w momencie wykonania updatevalues  na komórce koniec_tm4_sem_mem ? :send i :sent znaczą coś innego (pewnie nie i to tylko literówka)? Hehe, to by był strzał w stopę...
Hm, to muszę sprawdzić, czy zalicza pierwszą stację, jak się stoi dalej niż 20m. Bo przynajmniej AI musi podjechać na mniej niż 20m do W4, żeby zaliczyć przystanek. Jeśli stajesz dalej od W4, to może nie zaliczać.
Czyli po podpięciu się do wagonów w WK, powinienem podjechać na <20m od końca peronu, i wtedy po zatrzymaniu się powinno mi "odfajkować" ten W4 ?

  Dodano: 11 Lutego 2014, 22:18:26
Spróbowałem - zostało po staremu (screen). Stałem pod samym W4, i nic. Ruszyłem sobie i byłem już w rozjazdach - przypadkowo wcisnąłem "Q" - i wtedy rozkład "zaskoczył" - przełączyło się na kolejną stację. Tak jakby tylko AI miało moc "odfajkowywania" pozycji z rozkładu

  Dodano: 11 Lutego 2014, 22:29:14
Ale kolejne pozycje już nie wskakiwały. Ani jak mijałem dany punkt sam, ani jak na moment mijania włączałem AI. Chociaż żeby dana pozycja została "zdjęta" z rozkładu, to musiałbym się zatrzymać na odp. W4? Przecież nie będę stawał pospiesznym na przystanku w "Polu"...
« Ostatnia zmiana: 11 Lutego 2014, 22:29:14 wysłana przez muri »

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6284
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 300
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #8 dnia: 12 Lutego 2014, 02:42:20 »
No cóż, widzę że AI dostaje rozkaz podłączenia się do składu, a ponieważ samo go nie wykonuje ani nie rozpoznaje wykonania przez użytkownika, to taki stan (Connect) zostaje na dalszą jazdę i przeszkadza. Będzie trzeba w kolejnych wersjach coś z tym zrobić. Co ciekawe, ten błąd wydaje się istnieć od ponad roku, a jakoś nikt go wcześniej nie zauważył. Jedyna metoda "przejścia" tego, to włączyć AI po podjechaniu do składu i pozwolić mu się samoczynnie podłączyć, co powinno skutkować przejściem na Obey_train (stan widać po przyciśnięciu [F2]).
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline Benek

  • Moderator
  • Wiadomości: 4504
  • fb.com/benek.maszyna
    • Zobacz profil
    • Moja strona o MaSzynie
  • Otrzymane polubienia: 17
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #9 dnia: 12 Lutego 2014, 09:29:03 »
Co ciekawe, ten błąd wydaje się istnieć od ponad roku, a jakoś nikt go wcześniej nie zauważył.
Zapewne z następujących powodów:
  • Nie da się łatwo zmienić oświetlenia w scenerii, więc mało kto na niej jeździ (świadczy też o tym mała ilość screenów w Galerii);
  • Jeśli już ktoś jeździ, to nie wie, że rozkład powinien się przewijać, bo na innych scenariuszach nie było takich dobrodziejstw do tej pory.
Ja ten scenariusz z repo odpaliłem po raz pierwszy dwa dni temu. Co więcej, ponieważ nie mogłem się doczekać Ms2 na tarczy, to podjechałem pod zwrotnicę, prawie na nią wjeżdżając. Sądziłem, że to jest powód, tzn. że wyjechałem już poza odcinek z sem_info od tarczy.

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #10 dnia: 12 Lutego 2014, 10:53:55 »
Heh, no ta noc tam jest trochę "odstraszająca" - dopiero później jak się rozwidni, to robi się lepiej (chociaż zostaje puste niebieskie niebo - dobrze byłoby wzbogacić ten mechanizm movelight o jakąś podmianę tekstury nieba).
W sumie to też miałem problem z MS1 spod szopy. Za pierwszym razem jak stałem na PK i czekałem - to spaliniak wjechał , odpiął się od wagonów, a ja nie dostawałem MS2. Wychodzi na to, że trzeba stać pod tarczą, zanim ten pociąg z Drożdżowni wjedzie na stację. Jadąc spod szopy odpalają się eventy:
EVENT LAUNCHED: sz_postojowy:free by ep07-1038
(...)
EVENT LAUNCHED: sz_dojazd:busy by ep07-1038
Ale one tylko ustawiają wartość w odp. komórkach pamięci. Problem w tym, że nie mogę znaleźć gdzie wartości z tych komórkek są wykorzystywane? Tego miało dotyczyć moje kolejne pytanie: jak tam działają te eventy?
« Ostatnia zmiana: 12 Lutego 2014, 10:55:36 wysłana przez muri »

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6284
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 300
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #11 dnia: 12 Lutego 2014, 17:04:08 »
Ja nikomu nie ograniczam możliwości eksperymentowania z teksturami nieba. Jeśli w nocy widać gwiazdy, to rano raczej nie będzie chmur.

Pierwsza tarcza dla AI znajduje się w okolicy PK, jadąc ręcznie można ją przejechać w stanie Ms1 i nie powinno to mieć negatywnych skutków. Aczkolwiek coś by się przydało z tym zrobić. Tarcza ta puszcza po odczepieniu się SU45. Następnie ustawia się przebieg na głowicy, a druga tarcza puszcza po odebraniu przez EU07 komendy podłączenia się. Sprawdzę to jeszcze.

Na pewno trzeba będzie dopracować współpracę obiektu zarządzającego składem z użytkownikiem, ponieważ jak nie uruchomiłem sprężarki, to mi lokomotywa została w stanie Prepare_engine, podczas gdy ja mogłem już jechać. Do poprawki jest również podświetlenie, które można załączyć bez baterii...
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #12 dnia: 12 Lutego 2014, 19:26:34 »
No tak... nie wpadłem na to żeby zajrzeć pod ziemię :)

  Dodano: 14 Lutego 2014, 21:00:08
W skwarkach są złe modele użyte dla tarcz manewrowych (screen). No chyba że takie też mogą być, ale to bardziej wygląda jak semafory karzełkowe.

  Dodano: 14 Lutego 2014, 21:06:40
A jadąc towarowym rozkład przeskoczył mi na kolejną pozycję nie przy ruszaniu, tylko jak przejechałem na trasie przez przystanek osobowy.
« Ostatnia zmiana: 14 Lutego 2014, 21:06:40 wysłana przez muri »

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6284
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 300
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #13 dnia: 14 Lutego 2014, 21:39:19 »
W skwarkach są złe modele użyte dla tarcz manewrowych (screen).
Zasadniczo są to tarcze zaporowe. Ich użycie częściowo wynika z tego, że AI się wybudzają w trybie pociągowym i zwykła Tm by ich nie powstrzymała przed wjechaniem na głowicę. Można by zmodyfikować Tm, żeby podawało SetVelocity 0 0, powinno być też już możliwe wybudzanie AI z trybem manewrowym. Jednak kiedyś działało to tylko z pociągowym, dlatego są sygnalizatory z czerwonym.
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
AI vs łamanie pantografów
« Odpowiedź #14 dnia: 14 Lutego 2014, 22:13:28 »
Ciekawa (przynajmniej dla mnie) sprawa z AI: AI oczywiście łamie patyki tak samo jak i ja (chociaż ja już opuszczam przed łukami :) ). Zauważyłem, że przed WK toczyła się kolejka składów, które miały połamane po dwa patyki. Wniosek chyba jest taki, że po złamaniu jednego patyka AI kontynuuje jazdę na drugim. Ale trafiłem pacjenta (zał) który miał złamany tylko jeden patyk - tak jakby drugiego nigdy nie podniósł. No chyba że opuścił... Jak to wytłumaczyć?
« Ostatnia zmiana: 14 Lutego 2014, 22:14:47 wysłana przez muri »

Offline Sawi

  • Zasłużony dla Symulatora
  • Wiadomości: 9217
  • O.M.D - Electricity, O.M.D - Enola Gay. 01.09.2012
    • Zobacz profil
  • Otrzymane polubienia: 742
Odp: Quark - problemy różne
« Odpowiedź #15 dnia: 14 Lutego 2014, 22:16:24 »
Bo zazwyczaj się jeździ na tylnym odbieraku.
Życie jest bardzo kruche i w najmniej oczekiwanym momencie tracisz bliskich. Nie widzisz kogoś lata i nagle już tej osoby nie ma :(. Jedynie co tobie zostaje, to wspomnienia http://www.youtube.com/watch?v=Rk_sAHh9s08 "Co mnie nie zabije, to mnie wzmocni".

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: Quark - problemy różne
« Odpowiedź #16 dnia: 14 Lutego 2014, 22:36:22 »
Tyle to ja wiem. Tylko że większość AI na jadących z naprzeciwka miało połamane po obydwa patyki. A na dwu przecież nie jechali. Wniosek: połamali jeden (pewnie najpierw tylni), podnieśli drugi - no i jego też połamali. A ten nie podniósł drugiego - przed nim jedzie EN57 (tej samej relacji Kn - WK), który ma połamane oba.

  Dodano: 14 Lutego 2014, 22:57:38
Przejechałem trasę Skwarki - Dejawy.  Po połamaniu pierwszego patyka, wszystkie łuki jechałem już z opuszczonym pozostałym. Niestety, manewrów w DK oraz pociągu powrotnego już nie przejadę, bo na wjeździe do DK połamał się drugi patyk.  Zrobiłem zestawienie błędów w sieci na tym odcinku.

  Dodano: 14 Lutego 2014, 23:07:31
Sprawa łamania patyków przez AI nie daje mi spokoju. Widziałem stojące na szlaku / turlające się bez prądu AI z połamanymi dwoma patykami (przytaczany już przeze mnie EN 57 do którego screen wrzucałem wcześniej), oraz AI które mimo połamanych obu patyków działa (słychać przetwornicę), i jedzie (w sensie rusza, rozpędza się i wogóle). Why leo ?
« Ostatnia zmiana: 14 Lutego 2014, 23:08:19 wysłana przez muri »

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6284
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 300
Odp: Quark - problemy różne
« Odpowiedź #17 dnia: 14 Lutego 2014, 23:16:07 »
Kurde, przejrzę pliki i udostępnię Quarka z poprawioną siecią, bo niepotrzebnie się męczysz z przestarzałą wersją...
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: Quark - problemy różne
« Odpowiedź #18 dnia: 14 Lutego 2014, 23:20:32 »
Heh, jak masz to chyba dobrze by było.

  Dodano: 16 Lutego 2014, 21:11:28
Mam problem z manewrami w Dejawach - Kopalni (misja towarowy Sk -> DK (manewry) DK -> Sk). Po wyjechaniu na tor szlakowy od WK i minięciu tarczy manewrowej Tm6 nic się dalej nie dzieje. Z tego co widziałem, dalszy ciąg manewrów jest uzależniony od eventu:event dejawy_kopalnia_tm6_sem_mem:sent multiple 0 none dej_tor7<W5pd1 dej_tor7_loop dej_tor7_wyjazd endevent //jak odbierze komendę (jeszcze musi zwolnić głowicę, żeby Ms2 dostać), ale zdarzenie to nie wykonuje się. Zdarzenie które powinno je wywołać (jak rozumiem jest to getvalues na komórce dejawy_kopalnia_tm6_sem_mem - czyli dejawy_kopalnia_tm6_sem_info) jest przypisane do toru (lokalizacja w załączniku):
node -1 0 t11641 track normal 10.0 1.435 0.25 25.0 20 0 flat vis
 rail_screw_used1 4 tpbps-new2 0.2 0.5 1.1
-2239.2 0.200012 7383.58  0.0  //point 1
0.0 0.0 -16.7813  //control vector 1
0.000244141 0.0 16.7813 //control vector 2
-2239.2 0.200012 7333.24  3.0  //point2
0
//event2 dejawy_kopalnia_tm6_sem_info
//event2 dejawy7-manewr4
event1 dejawy_kopalnia_tm6_sem_info
isolated dej_W5pd1 endtrack
Zdarzenie to niestety nie wywołuje się. Próbowałem najeżdżać na ten tor z obu stron, ale nic się nie dzieje. (w logu nie ma wywołania dejawy_kopalnia_tm6_sem_info).
Do DK przyjechałem trochę spóźniony (nieplanowany postój po drodze) - w czasie gdy oblatywałem wagony i wyjeżdżałem pod tarczę na torze od WK, na bocznicy manewrował spaliniak ze świeżo załadowanymi wagonami z kopalni. Jechał z nimi na tor wyciągowy, a potem na tor manewrowy równoległy do stacyjnych. Wydaje mi się, że ja nie dostaję tego Ms2, bo wtedy kiedy powinienem je dostać - on jeszcze przejeżdżał przez zwrotnicę 8, która należy (moim zdaniem niepotrzebnie) do odcinka izolowanego "pd1". Chodzi o tor w drugim załączniku.
Ogólnie to jakieś dziwne jest. Tak jakby mój lok nie widział tej tarczy - załączniki 3 i 4... Nie rozumiem dlaczego na liście zeskanowanych eventów ma tylko semafor który mijałem zjeżdżając z toru 7, a nie widzi Tm zaraz przed swoim nosem?

  Dodano: 16 Lutego 2014, 21:24:44
Aha i jeszcze: trafiłem taki przypadek jak na screenie5 (wjazd Sk->WK): szlaban był podniesiony, a autobus stał. Obserwowałem ten przejazd i okazało się, że światła migają na czerwono. Po zjechaniu pociągu z przejazdu szlabany "przeskoczyły" w pozycję zamkniętą, po czym zaczęły się otwierać. Tak jakby exe renderowało modele w stanie "zasadniczym", nie zważając na to że stan modelu mógł się zmienić.
« Ostatnia zmiana: 16 Lutego 2014, 22:03:52 wysłana przez muri »

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6284
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 300
Odp: Quark - problemy różne
« Odpowiedź #19 dnia: 16 Lutego 2014, 21:51:49 »
Zdarzenie to niestety nie wywołuje się. Próbowałem najeżdżać na ten tor z obu stron, ale nic się nie dzieje. (w logu nie ma wywołania dejawy_kopalnia_tm6_sem_info).
To jest event skanowany i nie wykonuje się przez kolejkę. Dokładniej, działa to w ten sposób, że w Tm6 umieszczana jest komenda podczepiania dla AI i ustawienie drogi uruchamia się dopiero po odebraniu tej komendy. Oczywiście wcześniej głowica musi być wolna, czyli SM31 musi z niej zjechać.

Jechał z nimi na tor wyciągowy, a potem na tor manewrowy równoległy do stacyjnych. Wydaje mi się, że ja nie dostaję tego Ms2, bo wtedy kiedy powinienem je dostać - on jeszcze przejeżdżał przez zwrotnicę 8, która należy (moim zdaniem niepotrzebnie) do odcinka izolowanego "pd1".
Zgodzę się, że niepotrzebnie, ale w zasadzie tam cały układ torowy jest do wywalania (bo tor wyciągowy jest za krótki i wjechać z niego można tylko na skrajny tor stacji, jakby chcieć formować skład węglarek na jakimkolwiek innym, to trzeba wyjeżdżać do W5 na tory główne). Poprawki tam trzeba zacząć od przełożenia torów i pewnie to zrobię, jak nie będę już miał nic pilniejszego.

Ogólnie to jakieś dziwne jest. Tak jakby mój lok nie widział tej tarczy - załączniki 3 i 4... Nie rozumiem dlaczego na liście zeskanowanych eventów ma tylko semafor który mijałem zjeżdżając z toru 7, a nie widzi Tm zaraz przed swoim nosem?
Został w stanie Disconnect, czyli znów jest problem pomiędzy obiektem zarządzającym (poniekąd AI) oraz działaniami użytkownika. Poprawkę na łączenie zrobiłem, a na rozłączanie jeszcze nie. Będę musiał to poćwiczyć przy okazji.

Aha i jeszcze: trafiłem taki przypadek jak na screenie5 (wjazd Sk->WK): szlaban był podniesiony, a autobus stał. Obserwowałem ten przejazd i okazało się, że światła migają na czerwono. Po zjechaniu pociągu z przejazdu szlabany "przeskoczyły" w pozycję zamkniętą, po czym zaczęły się otwierać. Tak jakby exe renderowało modele w stanie "zasadniczym", nie zważając na to że stan modelu mógł się zmienić.
No niestety, z animacjami tak może być, bo są przeliczane tylko podczas wyświetlania. Należało by chyba, przynajmniej raz na sekundę, aktualizować animacje w modelach, które wyświetlane nie są. Ostatnio sprawdzałem jak SU45 się chowa do szopy, to tam drzwi się zaczęły otwierać dopiero jak się pojawiłem z kamerą. Kiedyś jeszcze było tak, że po umieszczeniu kamery w nowym miejscu nagle przypominało się zwrotnicom, że się mają przestawić, ale to już zdążyłem poprawić. Podobny efekt jest z dźwiękami – gdy pierwszy raz przestawisz kamerę w okolice Dejaw (zanim tam dojedziesz), to usłyszysz uruchamianie SM31, mimo iż już dawno jedzie z wagonami.
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: Quark - problemy różne
« Odpowiedź #20 dnia: 17 Lutego 2014, 10:00:48 »
Ale ogólnie to kozak... Jak już zrozumiem te eventy w Quarku, to spróbuję wdrożyć coś a'la automatyczne funkcjonowanie stacji w DK - czyli: manewrówka ładuje wagony, potem je odstawia na wolny tor stacyjny, jak na innym stacyjnym są puste to je zabiera do napełniania (że jest możliwość ładowania to wiem, ale czy jest możliwość sprawdzenia ładunku?), a w międzyczasie liniowa zabiera pełne wagony do elektrowni. I tak w kółko. No ale na razie to plan - zobaczymy co z tego wyjdzie.
Na wiki jest chyba jakiś błąd w adresach stron, bo na http://rainsted.com/pl/Symulator/MaSzyna/Eventy jest opis wpisów sprzęgów i hamulców. A miałem nadzieję znaleźć tam jakiś opis tych wszystkich nowych "ficzerów" jak eventy :sent, :free, :busy itp...
« Ostatnia zmiana: 17 Lutego 2014, 10:02:32 wysłana przez muri »

Offline Sawi

  • Zasłużony dla Symulatora
  • Wiadomości: 9217
  • O.M.D - Electricity, O.M.D - Enola Gay. 01.09.2012
    • Zobacz profil
  • Otrzymane polubienia: 742
Odp: Quark - problemy różne
« Odpowiedź #21 dnia: 17 Lutego 2014, 10:47:03 »
Opis zdarzeń masz po części w wątku szkoły eventowej. Dokładnie od tego miejsca http://eu07.pl/forum/index.php/topic,18634.msg328584.html#msg328584
« Ostatnia zmiana: 17 Lutego 2014, 10:49:13 wysłana przez Sawi »
Życie jest bardzo kruche i w najmniej oczekiwanym momencie tracisz bliskich. Nie widzisz kogoś lata i nagle już tej osoby nie ma :(. Jedynie co tobie zostaje, to wspomnienia http://www.youtube.com/watch?v=Rk_sAHh9s08 "Co mnie nie zabije, to mnie wzmocni".

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: Quark - problemy różne
« Odpowiedź #22 dnia: 17 Lutego 2014, 12:38:10 »
Super, dzięki. Ale i tak jestem zdania, że dokumentacja powinna wisieć na stronie z dokumentacją, a nie być porozrzucana w kilku wątkach na forum.
« Ostatnia zmiana: 17 Lutego 2014, 13:05:14 wysłana przez muri »

Offline Benek

  • Moderator
  • Wiadomości: 4504
  • fb.com/benek.maszyna
    • Zobacz profil
    • Moja strona o MaSzynie
  • Otrzymane polubienia: 17
Odp: Quark - problemy różne
« Odpowiedź #23 dnia: 17 Lutego 2014, 12:41:38 »
Stwórz ją najpierw, to wrzucimy na stronę główną, bo póki co nikt nie zrobił tego porządnie od A do Z.

Offline muri

  • Wiadomości: 627
    • Zobacz profil
  • Otrzymane polubienia: 5
Odp: Quark - problemy różne
« Odpowiedź #24 dnia: 17 Lutego 2014, 13:04:54 »
Zaczątek chyba miał być na tej stronie na wiki której adres już podałem - spróbuję to jakoś skompilować...

Offline Tomnord15

  • Wiadomości: 603
  • Fan ET21
    • Zobacz profil
  • Otrzymane polubienia: 25
Odp: EP07-1038 @ Quark - problem z rozkładem
« Odpowiedź #25 dnia: 18 Lutego 2014, 20:29:49 »
Hm. Zgodnie z rozkładem to chyba nie, bo jak widać rozkładowo powinienem być w koniewidach o 05:28, a jest 05:21 i stoję na oporowym :P Ale to jakaś kiszka jest, przecież jak stuka 05:02 (odjazd z WK), no to chyba pod F1 powinienem widzieć ... -> Pole 05:08, i powinien zniknąć jeden wiersz pod F3?
Sprawdziłem to na exe z paczki 08.13. Jest tak, jeśli przyjedziesz przed czasem na stację to nie zliczy, a jeśli przyjedziesz punktualnie lub się spóźnisz z wjazdem na stację to zliczy.
T.N

Offline selsyn

  • Wiadomości: 253
    • Zobacz profil
  • Otrzymane polubienia: 1
Odp: Quark - problemy różne
« Odpowiedź #26 dnia: 23 Lutego 2014, 01:13:04 »
Cytuj
Z tego co kojarzę, to na rozkładzie jazdy (F3) i na zegarze (F1) wyświetlane informacje powinny się aktualizować w miarę mijanych przystanków.
U mnie wogóle to się nie wyświetla, na najnowszym exe i na oryginalnym również nie. Po wciśnięciu F3 są tylko same kreseczki, po wciśnięciu F2 ukazuje się napis "skanowanie tabeli" ale nic się nie dzieje. Można by to jakoś usprawnić we własnym zakresie żeby pokazywało? Na co należy zwrócić uwagę, gdzie szukać? Drugie pytanie, jak można zwiększyć jasność świecenia kontrolek w kabinie? Jaki parametr i gdzie przestawić? Dziękuję życzliwym za odpowiedź.
« Ostatnia zmiana: 23 Lutego 2014, 01:33:12 wysłana przez selsyn »

Offline marczi-arczi

  • Wiadomości: 65
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Quark - problemy różne
« Odpowiedź #27 dnia: 23 Lutego 2014, 12:34:09 »
Drugie pytanie, jak można zwiększyć jasność świecenia kontrolek w kabinie? Jaki parametr i gdzie przestawić? Dziękuję życzliwym za odpowiedź.

Za jasność i kolor świecenia kontrolek w kabinie odpowiadają niniejsze parametry:

Ambient: 155.5 155.5 155.5
Diffuse: 253.0 255.0 255.0
Specular: 229.5 229.5 229.5