Autor Wątek:  Program wykonał nieprawidłową operację....  (Przeczytany 3616 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Anonymous

  • Gość
Program wykonał nieprawidłową operację....
« dnia: 12 Stycznia 2005, 11:15:18 »
Witam!
Niestety po formacie dysku nie moge ponownie uruchomić symulatora (wcześniej działał z maxymalnymi ustawieniami). (Mam Win98se) Podczas uruchamiania wyświetla błąd:

"EU07 spowodował wyjątek 10H w module NVOPENGL.DLL przy 01cf:695fd494.
Rejestry:
EAX=00000000 CS=01cf EIP=695fd494 EFLGS=00010256
EBX=005fc900 SS=01d7 ESP=007cf8cc EBP=005fc900
ECX=00000010 DS=01d7 ESI=0064d978 FS=19b7
EDX=ffff0000 ES=01d7 EDI=00000000 GS=19ae
Bajtów w CS:EIP:
dd d8 d9 6c 24 08 59 c3 cc cc cc cc 53 8b 5c 24
Stos:
00001e72 695fd4cc 3f801272 00001272 0060d260 0060d264 00000000 695e136c 005fc900 0064d978 695aea34 00602e68 005fc900 007cfbe0 00000000 0060d230 "

Próbowałem zmieniać wszystkie ustawienia na minimum ( w pliku eu07.ini) i dalej to samo. Dodam, że występuje to zarówno przy uruchamianiu z wieszsza poleceń jak i z programu start.exe Sterowniki od karty graficznej (Ge Force 2 MX 400 / 64MB) mam najnowsze, DirectX też,. Włączyłem mu logowanie uruchamiania i oto co otrzymałem:

Starting MaSzyna rail vehicle simulator.
Compilation 080604v02
Renderer:
GeForce2 MX/PCI/SSE/3DNOW!
Vendor:
NVIDIA Corporation
OpenGl Version::
1.5.2
Supported Extensions:
GL_ARB_imaging GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_register_combiners GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod GL_SUN_slice_accum GL_WIN_swap_hint WGL_EXT_swap_control
glClearColor (FogColor[0], FogColor[1], FogColor[2], 0.0);
glFogfv(GL_FOG_COLOR, FogColor);
glClearDepth(1.0f);  
glEnable(GL_TEXTURE_2D);
glShadeModel(GL_SMOOTH);
glEnable(GL_DEPTH_TEST);
glEnable(GL_ALPHA_TEST);
glAlphaFunc(GL_GREATER,0.5);
glDepthFunc(GL_LEQUAL);
glDisable(GL_BLEND);
glHint(GL_PERSPECTIVE_CORRECTION_HINT, GL_NICEST);
glPolygonMode(GL_FRONT, GL_FILL);
glFrontFace(GL_CCW);
glEnable(GL_CULL_FACE);   
glLineWidth(1.0f);
glPointSize(2.0f);
glLightModelfv(GL_LIGHT_MODEL_AMBIENT,ambientLight);
glLightfv(GL_LIGHT0,GL_DIFFUSE,diffuseLight);
glLightfv(GL_LIGHT0,GL_SPECULAR,specularLight);
glLightfv(GL_LIGHT0,GL_POSITION,lightPos);
glEnable(GL_LIGHT0);
glEnable(GL_COLOR_MATERIAL);
glColorMaterial(GL_FRONT, GL_AMBIENT_AND_DIFFUSE);
glMaterialfv( GL_FRONT, GL_AMBIENT_AND_DIFFUSE, whiteLight );
glEnable(GL_LIGHTING);
glFogi(GL_FOG_MODE, GL_LINEAR);
glFogfv(GL_FOG_COLOR, FogColor);
glFogf(GL_FOG_START, 1000.0f);
glFogf(GL_FOG_END, 2000.0f);
glEnable(GL_FOG);
Font init
Font init OK
Sound Init
Loading - texture: textures\logo.bmp
OK


Dziękuję za wszelkie odpowiedzi,
pozdrawiam,
Adam Pyka

Offline Mutopompka

  • Wiadomości: 1155
  • Na IRC-u SPRĘŻAREK vel. tyqtyqtyq
    • Zobacz profil
  • Otrzymane polubienia: 1
Program wykonał nieprawidłową operację....
« Odpowiedź #1 dnia: 12 Stycznia 2005, 14:28:45 »
Więc tak. Co do błędów w symku i win98SE. Błąd ten występuje wtedy, gdy sterownik OpenGL karty graficznej jest nowszy niż zainplementowana obsługa OpenGL-a w Symulatorze! Podejrzewam, że Pan zainstalował sterowniki w wersji 66.93 i stąd ten problem, ponieważ ta wersja sterowników posiada obsługę OpenGL w wersji właśnie 1.5.2 a ona właśnie się "gryzie" z Symulatorem.

Rozwiązanie problemu jest przeinstalowanie sterowników do karty graficznej o numerze np. 53.04 lub 45.23 gdyż w tych sterownikach jest obsługa OpenGL w wersji 1.4 i symulator będzie działał poprawnie.

Tutaj ma pan linki do sterowników OMEGADRIVERS (na którycg zresztą sam jadę: http://ftp://download.guide3d.ru/omega/nvidia/nvidia_w9x_omega_14523.exe (link działa) lub te oficjalne ze stajni nVidii (wersja 53.04): http://www.sirius.pl/get.php?id=73

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1699
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 133
Program wykonał nieprawidłową operację....
« Odpowiedź #2 dnia: 13 Stycznia 2005, 14:28:40 »
Ja miałem ten sam problem i to na Windowsie 2000 Professional. Gdzieś nawet jest ten wątek... więc  nie tylko na Win98 tak się dzieje...
Przepraszam za OT:
Przedwczoraj padł mi dysk. Na szczęście zdążyłem zrobić backup'y. Musiałem zrobić partyję na 11 GB uszkodzonych. Próbowałem Linuksa zainstaloiwać, ale nie działała mi mysz. Wymieniłem z bratem dysk i chciałem zainstalować XP, nie dało się. To samo z Winem 2k Pro. Aktualnie siedze na Win98 SE. Dopiero co się "przeprowadziłem", więc prace nad trakcją do Transylwanii są wstrzymane...