Autor Wątek:  Problem przy odnawianiu scenerii-symulator się nie włącza.  (Przeczytany 10398 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Problem przy odnawianiu scenerii-symulator się nie włącza.
« dnia: 07 Września 2013, 12:11:20 »
Witam. Postanowiłem w związku z projektem 750mm spróbować stworzyć jakąś scenerię pod ten rozstaw. W starym downloadzie mieliśmy ładną trasę ZL-SB, którą próbuję odświeżyć i przystosować do obecnej paczki. Pozmieniałem wszystkie rozszerzenia tekstur z .bmp na .dds, wstawiam normalnotorowego loka w scenerię (bo nie mam wąskotorowych) włączam symulator i... wywala błąd. W załączniku log i errors.txt. Mam nadzieję, że pomożecie mi z tym problemem i uda mi się tą scenerię dokończyć (tworzę ją w gmax).

Popraw nazwę tematu. Jest błąd.
Benek
« Ostatnia zmiana: 07 Września 2013, 14:37:41 wysłana przez KrzysztofGliwice »
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender

Offline Sawi

  • Zasłużony dla Symulatora
  • Wiadomości: 9224
  • O.M.D - Electricity, O.M.D - Enola Gay. 01.09.2012
    • Zobacz profil
  • Otrzymane polubienia: 743
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #1 dnia: 07 Września 2013, 12:13:38 »
Rozszerzeń jawnych należy się pozbyć, a nie je zamieniać. Poza tym musisz się pozbyć duplikatów.
« Ostatnia zmiana: 07 Września 2013, 12:17:33 wysłana przez Sawi »
Życie jest bardzo kruche i w najmniej oczekiwanym momencie tracisz bliskich. Nie widzisz kogoś lata i nagle już tej osoby nie ma :(. Jedynie co tobie zostaje, to wspomnienia http://www.youtube.com/watch?v=Rk_sAHh9s08 "Co mnie nie zabije, to mnie wzmocni".

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #2 dnia: 07 Września 2013, 12:16:41 »
Pozbyłem się.
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6306
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 336
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #3 dnia: 07 Września 2013, 12:16:56 »
Normalnotorowy nie pojedzie, będzie od razu wykolejony. Jak poszukasz, to znajdziesz Lxd2 i nawet skrypt instalacyjny do Rainsted. Wygląda na to, że zbyt wiele zwrotnic ma tę samą nazwę.
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #4 dnia: 07 Września 2013, 12:18:32 »
Wiem że nie pojedzie, chciałem tylko odpalić scenerię i zobaczyć ja wygląda.
« Ostatnia zmiana: 07 Września 2013, 12:21:30 wysłana przez KrzysztofGliwice »
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6306
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 336
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #5 dnia: 07 Września 2013, 12:20:49 »
Symulator najczęściej wywala się na braku dźwięków. Możesz jeszcze uruchomić w trybie bez taboru:EU07.EXE -s sceneria.scn -v ghostview
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #6 dnia: 07 Września 2013, 12:26:32 »
Na ghostview odpaliło, tylko że wypluło mi "scene parse error near node"
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender

Offline Sawi

  • Zasłużony dla Symulatora
  • Wiadomości: 9224
  • O.M.D - Electricity, O.M.D - Enola Gay. 01.09.2012
    • Zobacz profil
  • Otrzymane polubienia: 743
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #7 dnia: 07 Września 2013, 12:32:52 »
Zarzuć plikiem scn oraz errors.txt.
Życie jest bardzo kruche i w najmniej oczekiwanym momencie tracisz bliskich. Nie widzisz kogoś lata i nagle już tej osoby nie ma :(. Jedynie co tobie zostaje, to wspomnienia http://www.youtube.com/watch?v=Rk_sAHh9s08 "Co mnie nie zabije, to mnie wzmocni".

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6306
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 336
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #8 dnia: 07 Września 2013, 12:34:14 »
Błędy składni powinien Ci Rainsted pokazać, ewentualnie jak wczytasz wszystkie include.
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #9 dnia: 07 Września 2013, 12:38:16 »
Pliki dla @Sawiego
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender

Offline Sawi

  • Zasłużony dla Symulatora
  • Wiadomości: 9224
  • O.M.D - Electricity, O.M.D - Enola Gay. 01.09.2012
    • Zobacz profil
  • Otrzymane polubienia: 743
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #10 dnia: 07 Września 2013, 12:47:03 »
Dzięki. Zamień nazwę folderu głównego z Lxd2.v01 na lxd2_v1. Następnie wpis na:
node -1 0 Lxd2 dynamic PKP\lxd2_v1 lxd2 Lxd2 0.0 headdriver 3 0 enddynamic
endtrainset
Obstawiam również, że brakuje Tobie pliku fiz. Więc skopiuj sobie stamtąd chk i zamień nazwę kopii na lxd2.fiz, to powinno pomóc.
« Ostatnia zmiana: 07 Września 2013, 12:49:31 wysłana przez Sawi »
Życie jest bardzo kruche i w najmniej oczekiwanym momencie tracisz bliskich. Nie widzisz kogoś lata i nagle już tej osoby nie ma :(. Jedynie co tobie zostaje, to wspomnienia http://www.youtube.com/watch?v=Rk_sAHh9s08 "Co mnie nie zabije, to mnie wzmocni".

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #11 dnia: 07 Września 2013, 12:53:13 »
Zrobiłem jak trzeba, nie uruchamia się. Log:
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender

Offline Sawi

  • Zasłużony dla Symulatora
  • Wiadomości: 9224
  • O.M.D - Electricity, O.M.D - Enola Gay. 01.09.2012
    • Zobacz profil
  • Otrzymane polubienia: 743
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #12 dnia: 07 Września 2013, 13:03:07 »
Wywala nadal duplikaty i brak tekstury sprzęgu. Otwórz plik LXd2.t3d i zamień w notatniku .bmp na puste pole, oraz .tga również.
Życie jest bardzo kruche i w najmniej oczekiwanym momencie tracisz bliskich. Nie widzisz kogoś lata i nagle już tej osoby nie ma :(. Jedynie co tobie zostaje, to wspomnienia http://www.youtube.com/watch?v=Rk_sAHh9s08 "Co mnie nie zabije, to mnie wzmocni".

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #13 dnia: 07 Września 2013, 13:08:19 »
Wywala duplikaty eventów, nie znalazłem w pliku scenerii żadnych wpisów eventów.
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender

Offline youBy

  • Deweloper
  • Wiadomości: 6163
  • Co tam?
    • Zobacz profil
    • Automat Weryfikujący Regulację i Lambdę
  • Otrzymane polubienia: 865
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #14 dnia: 07 Września 2013, 13:14:24 »
Za to możesz znaleźć ince (np. od wskaźnika W4), które mają nadaną nazwę none.
Xoov
Powyższy post wyraża jedynie opinię autora w chwili publikacji. Autor zastrzega sobie prawo do zmiany poglądów bez podawania przyczyny, jak również informowania o tym.

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #15 dnia: 07 Września 2013, 13:37:08 »
Dzieki youBy, problem zniknął. Zniknęło tylko generowanie się errors.txt, nadal się nie włącza, niezależnie od tego jaki pojazd wstawię...
« Ostatnia zmiana: 07 Września 2013, 13:46:33 wysłana przez KrzysztofGliwice »
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender

Offline Sawi

  • Zasłużony dla Symulatora
  • Wiadomości: 9224
  • O.M.D - Electricity, O.M.D - Enola Gay. 01.09.2012
    • Zobacz profil
  • Otrzymane polubienia: 743
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #16 dnia: 07 Września 2013, 14:09:22 »
Upewnij się czy na pewno posiadasz wszystkie potrzebne pliki.
Życie jest bardzo kruche i w najmniej oczekiwanym momencie tracisz bliskich. Nie widzisz kogoś lata i nagle już tej osoby nie ma :(. Jedynie co tobie zostaje, to wspomnienia http://www.youtube.com/watch?v=Rk_sAHh9s08 "Co mnie nie zabije, to mnie wzmocni".

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Odp: Przoblem przy odnawianiu scenerii.
« Odpowiedź #17 dnia: 07 Września 2013, 14:13:08 »
Rainsted pokazuje, że wszystko jest.
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender

Offline Sawi

  • Zasłużony dla Symulatora
  • Wiadomości: 9224
  • O.M.D - Electricity, O.M.D - Enola Gay. 01.09.2012
    • Zobacz profil
  • Otrzymane polubienia: 743
Odp: Przoblem przy odnawianiu scenerii-symulator się nie włącza.
« Odpowiedź #18 dnia: 07 Września 2013, 14:20:10 »
Chyba znalazłem przyczynę. Przez przypadek zaremowałeś główny wpis inc.
//include wask_1/wask_1.inc endOdremuj i powinno hulać.
Życie jest bardzo kruche i w najmniej oczekiwanym momencie tracisz bliskich. Nie widzisz kogoś lata i nagle już tej osoby nie ma :(. Jedynie co tobie zostaje, to wspomnienia http://www.youtube.com/watch?v=Rk_sAHh9s08 "Co mnie nie zabije, to mnie wzmocni".

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Odp: Przoblem przy odnawianiu scenerii-symulator się nie włącza.
« Odpowiedź #19 dnia: 07 Września 2013, 14:20:54 »
Tekst z tego pliku przeniosłem do głównego pliku .scn
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender

Offline Sawi

  • Zasłużony dla Symulatora
  • Wiadomości: 9224
  • O.M.D - Electricity, O.M.D - Enola Gay. 01.09.2012
    • Zobacz profil
  • Otrzymane polubienia: 743
Odp: Przoblem przy odnawianiu scenerii-symulator się nie włącza.
« Odpowiedź #20 dnia: 07 Września 2013, 14:24:00 »
Pokaż mi całość.
Życie jest bardzo kruche i w najmniej oczekiwanym momencie tracisz bliskich. Nie widzisz kogoś lata i nagle już tej osoby nie ma :(. Jedynie co tobie zostaje, to wspomnienia http://www.youtube.com/watch?v=Rk_sAHh9s08 "Co mnie nie zabije, to mnie wzmocni".

Offline Balaclava

  • Zasłużony dla Symulatora
  • Wiadomości: 937
  • vel. krzysiuup
    • Zobacz profil
  • Otrzymane polubienia: 726
Odp: Przoblem przy odnawianiu scenerii-symulator się nie włącza.
« Odpowiedź #21 dnia: 07 Września 2013, 14:25:35 »
Proszę. Próbowałem otworzyć scenerię w jEt ale wywal błąd w linijce 152, sprawdzałem ją i nic nie znalazłem, co by mogło spowodować ten błąd...

  Dodano: 07 Września 2013, 18:49:26
Dobra, chyba wiem o co chodzi. Przez przypadek usunąłem wczoraj stery do karty dźwiękowej, żadna sceneria się nie włącza.
« Ostatnia zmiana: 07 Września 2013, 18:49:26 wysłana przez KrzysztofGliwice »
Dokumentacja dla przyszłych pokoleń deweloperów:
MaSzynowa Wiki
Narzędzia deweloperskie - Blender