Ankieta

Czy weźmiesz udział w testach?

Tak
24 (70.6%)
Nie
10 (29.4%)

Głosów w sumie: 34

Autor Wątek:  Testy ruchu AI  (Przeczytany 3429 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6321
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 353
Testy ruchu AI
« dnia: 08 Lipca 2011, 17:37:36 »
Ostatnio znalazłem i usunąłem pewne błędy w ruchu AI, związane z funkcjonowaniem sprzęgów wirtualnych. Nie wiem jednak, czy są to wszystkie błędy, czy są jeszcze jakieś. Dlatego potrzebna będzie większa pomoc użytkowników MaSzyny w zakresie testów. Testowanie nie wymaga znajomości wpisów, konstrukcji scenerii czy taboru, wymaga natomiast czasu oraz znajomości scenerii oraz scenariuszy, w tym również ze starszych paczek (2004 i 2006).

Uwaga! Oprócz ruchu AI są zmienione są również inne drobne rzeczy i być może coś się nie będzie wyświetlać prawidłowo. Niemniej jednak można na to nie zwracać uwagi, gdyż najistotniejszą kwestią jest urywanie składów oraz reakcja AI na skład jadący z naprzeciwka po tym samym torze.

W przypadku wykrycia nieprawidłowej sytuacji należy ją opisać, podając nazwę paczki, nazwę scenerii, nazwę prowadzonego składu (ewentualnie wpisy składów, jeżeli zostały podmienione) oraz miejsce, w którym awaria nastąpiła, najlepiej z obrazkiem przedstawiającym. Należy również uruchomić kilka razy tę samą scenerię z identycznymi warunkami, aby sprawdzić, czy sytuacja się powtórzy. Najbardziej wartościowe są te sytuacje, które można powtórzyć.

Na koniec jeszcze jedna uwaga. Osoby nie zainteresowane testowaniem nie powinny używać tego EXE, ponieważ może ono powodować problemy, do których pomoc nie będzie udzielana. EXE będzie wstępnie przetestowane przez Betatesterów na okoliczność łatwych do zauważenia błędów.
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6321
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 353
Odp: Testy ruchu AI
« Odpowiedź #1 dnia: 11 Lipca 2011, 19:01:34 »
W załączniku zamieszczam EXE do przetestowania. W archiwum znajduje się też plik tekstowy z opisem wprowadzonych zmian. Tak jak napisałem, najważniejszą rzeczą do sprawdzenia jest zachowanie składów prowadzonych przez komputer. Zauważone błędy proszę opisywać w tym wątku.

Przy wyświetlaniu VBO (na kartach Intel albo po ręcznym włączeniu usevbo yes w pliku eu07.ini - ale wcale nie trzeba tego włączać) animacje mogą być nieprawidłowe - znikają wskazówki z mierników w niektórych lokomotywach, zwrotniki przekręcają się wokół niewłaściwej osi, zapory na przejazdach mają za nisko oś obrotu itp. Są to błędy znane i na razie nie będą poprawione. Wynikają one z przygotowań do zapisu modeli w plikach binarnych.


W wersji 178 jest drobna zmiana: [F2] jest w stanie pokazać parametry dowolnego pojazdu, do którego się zbliżymy z kamerą.

EU07_178.7z (243.52 kB - pobrany 19 razy.)
« Ostatnia zmiana: 26 Lipca 2011, 03:02:49 wysłana przez Ra »
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline Paczkuś

  • Wiadomości: 433
  • Mój nick się odmienia przez przypadki.
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Testy ruchu AI
« Odpowiedź #2 dnia: 11 Lipca 2011, 21:26:25 »
Przy radiostopie jest jest problem z odhamowaniem składów. Ja sam też nie mogę normalnie odhamować , ani w ogóle ruszyć(3xEN57).
Solo oración!

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6321
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 353
Odp: Testy ruchu AI
« Odpowiedź #3 dnia: 11 Lipca 2011, 21:32:21 »
Tak, trzeba trochę poruszać kranem. Czy AI potrafi odhamować, tego nie wiem, być może nie. Niestety jest to kolejna rzecz, której się nie da zrobić w prosty sposób.
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni

Offline Ra

  • Zasłużony dla Symulatora
  • Wiadomości: 6321
  • Ostatni gasi światło...
    • Zobacz profil
    • Instalator+Starter+Edytor
  • Otrzymane polubienia: 353
Odp: Testy ruchu AI
« Odpowiedź #4 dnia: 26 Lipca 2011, 03:07:30 »
Ponieważ nikt nie zgłosił, że cokolwiek w temacie AI testował, zamykam ten temat. Tym bardziej, że jeden błąd w sprzęgach AI znalazłem sam i już go poprawiłem. Wystarczyło odpalić Calkowo-Orlen, gdzie pojawiały się błędy sprzęgów, a SU45 podłączała się przodem do przedostatniego wagonu w swoim składzie.
¯\_( ͡° ͜ʖ ͡°)_/¯ Ra

Polecam: kręgarz Wojciech Walczak, projekt masarni