Autor Wątek:  Problem z pasażererem...  (Przeczytany 9328 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1686
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 108
Problem z pasażererem...
« dnia: 21 Lipca 2004, 18:23:51 »
Nie mogę jechać jako pasażer. Kopiuje wpis z Quarka przerabiam (bo mam teksturkę własną Bdnu) że zamiast Bd, ma być Bdnu katalogo. Gdy stoje bez lokomotywy wnętrze włącza się normalnie. Ustawiam lokomotywe EP09 kierowaną przez kompa i nic. Próbuje na każdej scenerii prucz Quarka (P3 633Mhz :)), a chcę jechać na koltomowie. Wpis wygląda tak:
node -1 0 505120-00256-1 dynamic PKP\Bdun Bdu-1 111a 0.0 passenger 0 5 Passengers enddynamic (to wagon),
a cały skład tak:
node -1 0 SU46-010 dynamic PKP\SU46 SU46-022 303Ddumb 0.0 headdriver 3 0 enddynamic
node -1 0 505120-00256-1 dynamic PKP\Bdun Bdu-1 111a 0.0 passenger 0 5 Passengers enddynamic
node -1 0 505120-00256-2 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00256-3 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00256-5 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00255-6 dynamic PKP\Wars none wars 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00351-7 dynamic PKP\Adu none 112a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00351-8 dynamic PKP\Adu none 112a 0.0 nobody 3 30 Passengers enddynamic
endtrainset
. Proszę o pomoc w tejże sprawie :)

Offline hejnal

  • ZbanowanyZbanowany
  • Wiadomości: 967
    • Zobacz profil
  • Otrzymane polubienia: 3
Re: Problem z pasażererem...
« Odpowiedź #1 dnia: 21 Lipca 2004, 22:11:35 »
Cytat: "vampirek1"
node -1 0 505120-00256-1 dynamic PKP\Bdun Bdu-1 111a 0.0 passenger 0 5 Passengers enddynamic (to wagon),
a cały skład tak:
[code]node -1 0 SU46-010 dynamic PKP\SU46 SU46-022 303Ddumb 0.0 headdriver 3 0 enddynamic
node -1 0 505120-00256-1 dynamic PKP\Bdun Bdu-1 111a 0.0 passenger 0 5 Passengers enddynamic
node -1 0 505120-00256-2 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00256-3 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00256-5 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00255-6 dynamic PKP\Wars none wars 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00351-7 dynamic PKP\Adu none 112a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00351-8 dynamic PKP\Adu none 112a 0.0 nobody 3 30 Passengers enddynamic
endtrainset. Proszę o pomoc w tejże sprawie :)


Dlaczego dałeś mu sprzęg 0 czyli brak sprzęgu?

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1686
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 108
Problem z pasażererem...
« Odpowiedź #2 dnia: 22 Lipca 2004, 13:47:22 »
Ale ten wpis jest skopiowany z Quarka, i jest tylko zmieniony katalog. A ile ma być?? Nie wiem może przez to właśnie sięwykrzacza EU?? Nie wiem :(

Offline Marcin Czapnik (Techniks)

  • Wiadomości: 126
    • Zobacz profil
    • http://marcinc.rail.pl/galeria
  • Otrzymane polubienia: 0
Problem z pasażererem...
« Odpowiedź #3 dnia: 22 Lipca 2004, 13:52:07 »
Cytat: "vampirek1"
Ale ten wpis jest skopiowany z Quarka, i jest tylko zmieniony katalog. A ile ma być?? Nie wiem może przez to właśnie sięwykrzacza EU?? Nie wiem :(

Zamiast zera ma być 3. Zero jest w quarku dlatego, że wagon z pasażerem jest na końcu.
pozdrawiam
Marcin Czapnik

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1686
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 108
Problem z pasażererem...
« Odpowiedź #4 dnia: 22 Lipca 2004, 13:56:20 »
Cytat: "Marcin Czapnik (Techniks)"
Zamiast zera ma być 3. Zero jest w quarku dlatego, że wagon z pasażerem jest na końcu.

A ma to związek z tym że mi nie działa?? :)

Offline hejnal

  • ZbanowanyZbanowany
  • Wiadomości: 967
    • Zobacz profil
  • Otrzymane polubienia: 3
Problem z pasażererem...
« Odpowiedź #5 dnia: 22 Lipca 2004, 13:59:26 »
0-to brak sprzęgu
1-to hak
2-sprzęg hamulcowy
3-to 1+2 ;)
4-to sterowanie wielokrotne
7-to 4+3

Powinno być albo tak:
node -1 0 SU46-010 dynamic PKP\SU46 SU46-022 303Ddumb 0.0 headdriver 3 0 enddynamic
node -1 0 505120-00256-1 dynamic PKP\Bdun Bdu-1 111a 0.0 passenger 3 5 Passengers enddynamic
node -1 0 505120-00256-2 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00256-3 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 30 Passengers enddynamic

Albo tak:
node -1 0 SU46-010 dynamic PKP\SU46 SU46-022 303Ddumb 0.0 headdriver 3 0 enddynamic
node -1 0 505120-00256-1 dynamic PKP\Bdun Bdu-1 111a 0.0 passenger 3 5 Passengers enddynamic
node -1 0 505120-00256-2 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00256-3 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 30 Passengers enddynamic
node -1 0 505120-00256-1 dynamic PKP\Bdun Bdu-1 111a 0.0 passenger 0 5 Passengers enddynamic

w ostatnim wagonie możesz dać sprzęg 0
Ale nie wiem czy twój problem jest związany z tym.

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1686
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 108
Problem z pasażererem...
« Odpowiedź #6 dnia: 22 Lipca 2004, 14:07:11 »
OK. Dzienks za to, właśnie idę sprawdzić czy działa. Może problem będzie rozwiązany? Mam nadzieje.

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1686
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 108
Problem z pasażererem...
« Odpowiedź #7 dnia: 22 Lipca 2004, 14:13:16 »
No i lipa :(. Nie działa. Aha i jeszcze jedno (może uznacie mnie za idiote) zapomniałem (serio) napisać że wywala błąd "Player train init failed." Więc co jest grane, bo już zgłupieje z tym! PLZ dajcie odp!

Offline hejnal

  • ZbanowanyZbanowany
  • Wiadomości: 967
    • Zobacz profil
  • Otrzymane polubienia: 3
Problem z pasażererem...
« Odpowiedź #8 dnia: 22 Lipca 2004, 14:29:11 »
U mnie daje ten sam błąd. Którą wersje masz? spróbuj potestować na wersji 220703.

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1686
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 108
Problem z pasażererem...
« Odpowiedź #9 dnia: 22 Lipca 2004, 14:42:48 »
Starszą wersje powiadasz?? Spróbuje. Posiadam wersję 220204 spatchowana na 220604 :).Spróbuje na 220703.

P.S.: Czemu patche i wersje wydawane były zawsze w 22 dniu miesiąca?? :)

Offline hejnal

  • ZbanowanyZbanowany
  • Wiadomości: 967
    • Zobacz profil
  • Otrzymane polubienia: 3
Problem z pasażererem...
« Odpowiedź #10 dnia: 22 Lipca 2004, 15:07:30 »
Cytat: "vampirek1"
Starszą wersje powiadasz??


Posiadam wszystkie wersje jakie zostały upublicznione. Od pierwszej do ostatniej.

Cytat: "vampirek1"
P.S.: Czemu patche i wersje wydawane były zawsze w 22 dniu miesiąca?? :)


Bo to pechowa data ;)

Na wersji 220703 "pasażer" działa bez zażutu. Tylko z trasy koltoma usuń bagażowy lub zainstaluj wszystkie patche do 220703.

Na wersji 220204 i w góre na żadnej trasie "pasażer" nie działa. Coś sie znim popsuło w drodze ewolucji, a ponieważ nikt tym nie jeździł to nikt błędu nie zgłaszał. Chyba że coś na forum przeoczyłem.

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1686
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 108
Problem z pasażererem...
« Odpowiedź #11 dnia: 22 Lipca 2004, 15:40:13 »
Próbowałem na 220703 i też nie działa, no i dlaczego? Czy to naprawde takie głupie?? Aha mam pytanie na trasie Quarka jest wpis gdzie jedzie się w Bd, ale prowadzi SU. Czy ktoś mógłby to sprawdzić czy działa??

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1686
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 108
Problem z pasażererem...
« Odpowiedź #12 dnia: 22 Lipca 2004, 15:50:17 »
Przetestowalem na Quarku i też nie działa HELP!!

Offline mw158979

  • Wiadomości: 209
    • Zobacz profil
  • Otrzymane polubienia: 1
Problem z pasażererem...
« Odpowiedź #13 dnia: 22 Lipca 2004, 16:15:44 »
Cytat: "hejnal"

0-to brak sprzęgu
1-to hak
2-sprzęg hamulcowy
3-to 1+2 ;)
4-to sterowanie wielokrotne
7-to 4+3


Przy okazji apeluje do devsow o nieuzywanie szyfrow. 100 razy czytelniejsze beda stale tekstowe SPRZEG_BRAK, SPRZEG_HAK, ...
http://www.marchewa.alleluja.pl

GUI edytora scenerii (nebula) -

Offline Tomi

  • Wiadomości: 194
    • Zobacz profil
  • Otrzymane polubienia: 0
Problem z pasażererem...
« Odpowiedź #14 dnia: 07 Października 2004, 22:57:38 »
Cytuj
Na wersji 220204 i w góre na żadnej trasie "pasażer" nie działa

Zarowno w wersji 160704 jak i 220204+patch pasazer, czyli wczesniejszy bd.bat dziala.
Machajka tez, bo OIDP ktos kiedys pisal ze nie dziala.
Pozdro z Wielkiego Kacka
Tomek

Offline jaras

  • Wiadomości: 224
    • Zobacz profil
  • Otrzymane polubienia: 12
Problem z pasażererem...
« Odpowiedź #15 dnia: 08 Października 2004, 23:56:52 »
Witajcie.

Ja w zasadzie mam z tym problem od samego początku. Najpierw uruchomiłem MaSzynę tak, jak była ona dostępna po zwykłym ściągnięciu (a zatem w jej pierwotnej wersji). Potem stopniowo dodawałem różne łaty i poprawki, uwzględniając oczywiście różne wpisy tu i ówdzie w plikach ze scenami lub innych. Ściągnąłem chyba wszystko co było można ze strony MaSzyny. Wymienionego w tym topicu problemu jednak nie udało mi się rozwiązać.

Cytat: "vampirek1"
(...)wywala błąd "Player train init failed."

U mnie komunikat jest ten sam, lecz sceneria się uruchamia, pociąg sterowany przez AI sam jedzie, zatrzymuje się na przystankach, lecz jadę nie w wagonie, ale w lokomotywie, która nie ma po prostu kabiny i całego nadwozia - cały pociąg więc składa się z wagonów ciągniętych przez podwozie lokomotywy. Ja mogę się tylko obracać myszą, nawet tryb flymode nie działa - klawisz F4 powoduje tylko wyśrodkowanie obróconej myszą pozycji obserwatora.

Próbowałem (bo myślałem, że cały sęk tam tkwi) poprawiać pliki dynamic.dat oraz quarkmc28.scm, zaglądać do plików .mmd i .t3d (nie bardzo zajarzyłem składnię wewnątrz nich), lecz do niczego nie doszedłem.

Screen z tej mojej "lokomotywy" SU46 jest dostępny tutaj.

Pozdrawiam Was serdecznie.
Jarosław Krasuski (@ jaras)

Doc: tutaj.
No cóż... trzeba się powoli zbierać do odejścia z tego forum - nic tu po mnie.

hunter

  • Gość
Problem z pasażererem...
« Odpowiedź #16 dnia: 09 Października 2004, 12:26:37 »
Witam.

Powiadacie, że Wam tryb pasażera nie działa??
Tutaj grubo się mylicie. Jak odpalacie przez loadera, to nie ma się czego dziwić.

To nie jest wina wersji symka.

Do Vampirka, żeby mu działało:

Stwórz sobie plik: koltomowo-pasażer.bat
Napisz w nim taki ciąg:

eu07.exe -s koltomowo.scn -v 505120-00256-1

Teraz będzie ci działało na PEWNO. Jak by coś, to pisz.
Pozdrawiam.

Offline Tomi

  • Wiadomości: 194
    • Zobacz profil
  • Otrzymane polubienia: 0
Problem z pasażererem...
« Odpowiedź #17 dnia: 09 Października 2004, 14:06:04 »
Cytat: "jarzec"
[ciach]

Spróbuj np. tak:
otwierasz notatnikiem plik z definicją składów *.scn, np quarkmce.scn. Przypatrz się gdzie są definicje wagonów w składach. Pojedynczy wagon, jak zapewne wiesz, ma przykładwy wpis:
node -1 0 505120-00256-3 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 20 passengers enddynamic
Teraz wybierz jakim wagonem chcesz podróżować. Zmień jego wpis na np. taki:

node -1 0 bdu dynamic PKP\Bd Bdu-0.tga 111a 0.0 passenger 3 10 passengers enddynamic

gdzie bdu to przykładowa nazwa wagonu, którym będziesz jechał. (Nie polecam używania nazwy typu "505120-00256-3", bo się tam łatwo pomylić) Tą samą nazwę (w tym przypadku "bdu") wpisz w pliku eu07.ini jako pojazd do prowadzenia i zadeklaruj nazwę scenerii. Plik eu07.ini będzie miał więc początek (sceneria quarkmce i wagon o nazwie bdu):
// ustawienia (w nawiasie wartosci default)

sceneryfile quarkmce.scn // domyslny plik ze sceneria, chyba ze w linii komend bedzie: -s filename
humanctrlvehicle bdu // domyslny pojazd sterowany przez gracza, chyba ze w linii komend bedzie: -v vehiclename

Program odpal plikiem eu07.exe a nie start.exe!

Sorry za łopatologicznie tłumaczenie, ale może przyda się to także innym.

Powodzenia.
Pozdro z Wielkiego Kacka
Tomek

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1686
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 108
Problem z pasażererem...
« Odpowiedź #18 dnia: 10 Października 2004, 20:07:40 »
Chłopaki jesteście wielcy wszystko działa cacy jak być powinno. Jeszcze raz wielkie dzięki.

Offline jaras

  • Wiadomości: 224
    • Zobacz profil
  • Otrzymane polubienia: 12
Problem z pasażererem...
« Odpowiedź #19 dnia: 10 Października 2004, 23:28:44 »
Witajcie!

Hehe! Faktycznie! Działa! :-)

Wystarczyło tylko zrobić sobie plik BAT o następującej treści:eu07.exe -s quarkmcebt.scn -v 505120-00256-1dla następującego wpisu w scenerii:node -1 0 505120-00256-1 dynamic PKP\Bd Bdu-0.tga 111a 0.0 passenger 0 5 Passengers enddynamic

Po dłuższym zastanowieniu się, myślę, że było to winą programu start.exe, który "czytając" plik ze scenerią po prostu bierze pierwszy pojazd, w którym jest inny wpis niż nobody. Przed wagonem, którym jedziemy jako pasażer jest przecież lokomotywa, a w niej... wpis headdriver. Z kolei dla lokomotywy nie może być nobody, bo pociąg nie będzie wcale prowadzony przez AI.

Dla przykładu, u mnie w pliku ze scenerią jest taki wpis://osobowy Skwarki->Koniewice (dolna trasa niezelektryfikowana)
trainset MM1301 start1p 0 0
//$o tym pociagiem mozna jechac tylko jako pasażer
node -1 0 SU46-010 dynamic PKP\SU46 SU46-010 303Ddumb 0.0 headdriver 3 0 enddynamic
node -1 0 505120-00256-5 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 10 Passengers enddynamic
node -1 0 505120-00256-3 dynamic PKP\Bd Bdu-0.tga 111a 0.0 nobody 3 10 Passengers enddynamic
node -1 0 505120-00256-1 dynamic PKP\Bd Bdu-0.tga 111a 0.0 passenger 0 5 Passengers enddynamic
endtrainset
Zatem nic dziwnego, że przy uruchomieniu symulatora programem start.exe, jedziemy "w lokomotywie". Wszak ona pierwsza ma przecież wpis inny, niż nobody!

Ot, sprawa prosta ;-). Dzięki @ Tomi! Wiesz... może nie uważam się za jakiegoś tam durnia, ale takie łopatologiczne tłumaczenie jest czasami najlepsze ;-).
Cytat: "Tomi"
Program odpal plikiem eu07.exe a nie start.exe!
To jest bardzo cenna uwaga.

Jednak nie ma tak w życiu różowo, jak by się chciało...

Pojechałem sobie tym pociągiem, kręciłem się troszkę po wagonie (Home i End), czasami włączałem sobie flymode (F4), aż tu nagle... wywałka symulatora. Najpierw pokazał się ten komunikat:

a potem (standardowy - dobrze znany ;-) ten:

Nie mam pojęcia, czym one zostały spowodowane, bo nic nie "zawiniłem". Wtedy akurat czaiłem się gdzieś przy torze czekając na mój pociąg, bo chciałem sobie zrobić jakiegoś screena. No, to zrobiłem screena, tylko, że komunikatów błędów ;-). No tak, zawiniłem... powinienem przecież usiąść wygodnie na swoim siedzeniu i rozkoszować się widokami zza okna, a nie łazić po pociągu lub latać, niczym duch, po planszy :-))).

Ale to już i tak dobrze, że choć trochę sobie pojeździłem jako pasażer :-).

Dziękuję za pomoc i pozdrawiam Was serdecznie.
Jarosław Krasuski (@ jaras)

Doc: tutaj.
No cóż... trzeba się powoli zbierać do odejścia z tego forum - nic tu po mnie.

Offline hejnal

  • ZbanowanyZbanowany
  • Wiadomości: 967
    • Zobacz profil
  • Otrzymane polubienia: 3
Problem z pasażererem...
« Odpowiedź #20 dnia: 11 Października 2004, 10:49:08 »
W starych wersjach zanim pojawił się start.exe robiłem sobie skład z dwoma lokami ze sterowaniem ukrotnionym i wsiadałem do drógiej a pierwszą prowadził AI. Była niezła zabawa jak się utrudniało życie AI przejmując kontorole nad pociągiem z drógiej lokomotywy :D. Wersja ze start,exe mi to uniemożliwiła bo zawsze startowałem w pierwszym loku. Teraz jak jak już wiem że to nie wina wersji tylko start.exe mam prośbę do Pita:
Czy mógłbyś zrobić tak żeby się dało wybrać nie tylko skład i trase ale także odpowiedniego loka lub wagon w składzie? Chodzi mi o to że jak się dycyduje na jazde jako pasażer to chce sobie wybrać wagon w którym był jechał, lub mając dwa loki w składzie to wybierałbym czy chce jechać pierwszą czy drógą. Oczywiście w przypadku osobówek cały skład by się wtedy składał z loka i "pasażerów".

Offline Cesky Kretek

  • Zasłużony dla Symulatora
  • Wiadomości: 1686
  • Trust no one.
    • Zobacz profil
  • Otrzymane polubienia: 108
Problem z pasażererem...
« Odpowiedź #21 dnia: 14 Października 2004, 13:14:59 »
Nie chce zakładać nowego tematu, więc podepnę się tutaj. Czytając "scenery.doc" zauważyłem wpis
headdriver
passenger
conductor
nobody.
Czy to oznacza że można jeździć jako konduktor? Jak to wpisuje to pisze że "Unknown DriveType description: conductor". Próbuje w Bd i EN57 i nic.

Offline TruckeR

  • Wiadomości: 309
    • Zobacz profil
  • Otrzymane polubienia: 0
Problem z pasażererem...
« Odpowiedź #22 dnia: 21 Października 2004, 18:44:32 »
A u mnie wagon zadziałał, jak ustawiłem go na sam początek składu. Vyło to trochę głupie, bo na samym przedzie był jeden wgon BDU, potem lok, potem 3 inne wagony BDU :P Ale dałem loka manewrowego, dałęm 2 wagony na przód i loka na koniec. I było fajnie.
Pozdrawiam serdecznie!