Autor Wątek:  Eventy  (Przeczytany 7189 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Eventy
« dnia: 27 Grudnia 2008, 16:37:44 »
Witam.

Przepraszam jeśli taki sam temat już był zakładany, ale nie mogę go znaleźć.
A więc. Mam problem z eventami. W KAŻDEJ scenerii brakuje po kilka eventów.
Chodzą mi tylko Moczniki i Bochnia. W innych wywalają eventy przy wczytywaniu.
Gdy kliknę enter, gra się wyłącza. *.exe mam z DizelPacka.
Powiedzcie mi, dlaczego się tak dzieje?

Offline pol102

  • Wiadomości: 959
  • Geoinformatyk kolejowy
    • Zobacz profil
  • Otrzymane polubienia: 35
Odp: Eventy
« Odpowiedź #1 dnia: 27 Grudnia 2008, 16:46:07 »
Za tą grę @Winger cię niechybnie udusi :)

Może brakować inców, które były w jakiejś inne trasie, whatever. Log pokaż.

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #2 dnia: 28 Grudnia 2008, 00:26:21 »
Oj @Winger sam mi kazał założyć nowy temat ;)

Kolego, ja nie mam w głównym folderze z MaSzyną loga ;/ Nie wiem co jest ;/
Może po prostu ta moja MaSzyna jest rąbnięta?

Offline Marcin1992

  • Wiadomości: 327
  • Nokia Modder
    • Zobacz profil
    • Modyfikacje telefonów Nokia - www.NokiaHacking.pl
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #3 dnia: 28 Grudnia 2008, 00:27:53 »
W opcjach startera zaznaczasz: Zapisywanie log.txt
Odpalasz symulator, czekasz na błędy eventów i przesyłasz nam treść tego pliku.

Offline Winger

  • Administrator
  • Wiadomości: 1466
    • Zobacz profil
    • http://www.winger.eu07.pl
  • Otrzymane polubienia: 25
Odp: Eventy
« Odpowiedź #4 dnia: 28 Grudnia 2008, 12:25:35 »
Oj @Winger sam mi kazał założyć nowy temat ;)

Ale kazałem opisać problem szczegółowo, tak, by inni zrozumieli :)

Kolego, ja nie mam w głównym folderze z MaSzyną loga ;/ Nie wiem co jest ;/

Plik log.txt, jak nie masz to włącz logowanie tak jak to Marcin1992 opisał.

Może po prostu ta moja MaSzyna jest rąbnięta?

Możliwe, problem na pewno nie istniał od początku, musiał sie pojawic po tym gdy dodałeś coś do MaSzyny. Spróbuj z oryginalną paczką całościową, sprawdź czy działa poprawnie, następnie zacznij dodawać dodatki i po każdym sprawdzać ponownie czy wszystko działa jak trzeba. To standardowe kroki rozwiązywania problemów.
Pozdrawiam,
Winger

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #5 dnia: 28 Grudnia 2008, 13:30:42 »
Loading - texture: textures\plants/#sosna2.tga
OK
Loading - texture: textures\plants/#sosna3.tga
OK
Loading - texture: textures\plants/#swierk1.tga
OK
Loading - texture: textures\plants/#swierksrebrny1.tga
OK
Loading - texture: textures\plants/#topola1.tga
OK
InitNormals
InitNormals OK
InitTracks
Event1 "markowo_grn_e12_sem_info" does not exist
Event1 "markowo_grn_e12_sem_info" does not exist
Event1 "markowo_grn_e12_s1" does not exist

Ten log jest z Krzyżowej2

Panowie. Dziś spróbowałem naciskać enter z włączonym zapisywaniem loga i linia546 odpaliła O_O
Zdziwiłem się, ale niestety, wszystkie semafory świeciły tym samym kolorem od rozpoczęcia służby (mojej) do końca. Czyli jeśli semafor na początku gry (po załadowaniu programu) świecił na czerwono, to nigdy nie zmienił sie na zielony kolor i odwrotnie.

Przepraszam @Wingerze, ale myślałem, że szczegółowo opisałem problem. Spróbuję od początku do maszyny zainstalować tylko linię546 i zobaczymy czy wyskoczą błędy eventów ;)

PS. Nie przeszkadzało mi w linii546 to, że nie było semaforów (nie działały), bo znam tą trasę bardzo dobrze, aczkolwiek gdybym jechał na innej scenerii mógłbym się wpakować na pociąg z nad przeciwka ;)

« Ostatnia zmiana: 28 Grudnia 2008, 13:41:41 wysłana przez Gagar007 »

Offline Marcin1992

  • Wiadomości: 327
  • Nokia Modder
    • Zobacz profil
    • Modyfikacje telefonów Nokia - www.NokiaHacking.pl
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #6 dnia: 28 Grudnia 2008, 13:32:02 »
Brakuje Ci inc'ów od semaforów.

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #7 dnia: 28 Grudnia 2008, 13:39:16 »
Słuszna uwaga kolego, ale mam odnośnik do semaforów:

node -1 0 5051-503320-2 dynamic PKP\eaos eaos3 eaos 0.0 nobody 0 50 coal enddynamic
endtrainset

include krzyzowa2/sc2_składy_ET22-804.scm end

A gdzie tu masz odnośnik do semafora?
Wpis wagonu towarowego i plik ze składami.
Logika, logika...

Quark-t
« Ostatnia zmiana: 28 Grudnia 2008, 16:44:18 wysłana przez Quark-t »

Offline Marcin1992

  • Wiadomości: 327
  • Nokia Modder
    • Zobacz profil
    • Modyfikacje telefonów Nokia - www.NokiaHacking.pl
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #8 dnia: 28 Grudnia 2008, 13:45:39 »
Znalazłem coś ciekawego w pliku sc2.scm w katalogu scenery/krzyzowa2

Cytuj
node 1000 0 Markowo_Grn_tor3 track normal 100.0 1.435 0.25 25.0 20 0 Flat vis
 Rail_screw_used1 4 TpBpS-new2.tex 0.2 0.5 1.1
4327.15 12.3403 2709.59  0.0  //point 1
-4.5415 0.0 33.0225  //control vector 1
4.5415 0.0 -33.0225  //control vector 2
4313.53 12.3403 2808.66  0.0  //point 2
0
event1 Markowo_Grn_E12_sem_info
endtrack

Czy ten event ma tak wyglądać? Jest to jeden z tych, które się Gagarowi wysypują.

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #9 dnia: 28 Grudnia 2008, 14:13:15 »
No ja mam wszystko identycznie

Cytuj
4327.15 12.3403 2709.59  0.0  //point 1
-4.5415 0.0 33.0225  //control vector 1
4.5415 0.0 -33.0225  //control vector 2
4313.53 12.3403 2808.66  0.0  //point 2
0
event1 Markowo_Grn_E12_sem_info
endtrack

node 1000 0 Markowo_Grn_tor3 track normal 100.0 1.435 0.25 25.0 20 0 Flat vis
 Rail_screw_used1 4 TpBpS-new2.tex 0.2 0.5 1.1
4313.53 12.3403 2808.66  0.0  //point 1
-4.5415 0.0 33.0225  //control vector 1
4.54102 0.0 -33.0225  //control vector 2
4299.91 12.3403 2907.73  0.0  //point 2

Offline AtapiCl

  • Zasłużony dla Symulatora
  • Wiadomości: 4426
    • Zobacz profil
    • O warszawskiej części linii kolejowej nr 7 Warszawa – Lublin i nie tylko ;)
  • Otrzymane polubienia: 212
Odp: Eventy
« Odpowiedź #10 dnia: 28 Grudnia 2008, 14:21:10 »
Jej... Zacznijcie kombinować włączając przy tym myślenie ;]

Wpisz w szukajkę w pliku tym 'Markowo_Grn_E12'. Wyskoczą eventy takie jak podaliście. Wyskoczy też gdzieś na końcu wpis semafora:

include;SS4zcpb-zY.inc;Markowo_Grn_E12;4333.28;12.145;2680.96;-8.2;E12;;end
SS4zcpb-zY.inc - masz kolego taki plik w katalogu /scenery/?

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #11 dnia: 28 Grudnia 2008, 14:51:50 »
Nie mam ;/

Mam SS4cpbPW24.inc itp., ale nie mam SS4zcpb-zY.inc ;/

Offline AtapiCl

  • Zasłużony dla Symulatora
  • Wiadomości: 4426
    • Zobacz profil
    • O warszawskiej części linii kolejowej nr 7 Warszawa – Lublin i nie tylko ;)
  • Otrzymane polubienia: 212
Odp: Eventy
« Odpowiedź #12 dnia: 28 Grudnia 2008, 15:20:29 »

Offline Winger

  • Administrator
  • Wiadomości: 1466
    • Zobacz profil
    • http://www.winger.eu07.pl
  • Otrzymane polubienia: 25
Odp: Eventy
« Odpowiedź #13 dnia: 28 Grudnia 2008, 16:12:36 »
Przy okazji, to jest symulator a nie gra. Radzę na przyszłość pilnować się z tym.
Pozdrawiam,
Winger

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #14 dnia: 28 Grudnia 2008, 17:04:10 »
Dobrze @Winger.

A więc po dodaniu tego http://eu07.pl/userfiles/2193/priv-SS4zcpb-zY.zip nie wyskakują już błędy eventów, lecz teraz symulator się ładuje i w pewnym momencie się wyłącza.
« Ostatnia zmiana: 28 Grudnia 2008, 17:06:23 wysłana przez Gagar007 »

Offline Marcin1992

  • Wiadomości: 327
  • Nokia Modder
    • Zobacz profil
    • Modyfikacje telefonów Nokia - www.NokiaHacking.pl
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #15 dnia: 28 Grudnia 2008, 17:05:43 »
Pokaż końcówkę loga.

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #16 dnia: 28 Grudnia 2008, 17:10:05 »
Cytuj
InitNormals
InitNormals OK
InitTracks
InitTracks OK
InitEvents
InitEvents OK
InitLaunchers
InitLaunchers OK
InitGlobalTime
InitGlobalTime OK
Loading - texture: dynamic\pkp\et22\et22-804z.bmp
Failed

Ehhh... Albo mi się wydaje albo tylko textura ET22 jest zła.


Offline AtapiCl

  • Zasłużony dla Symulatora
  • Wiadomości: 4426
    • Zobacz profil
    • O warszawskiej części linii kolejowej nr 7 Warszawa – Lublin i nie tylko ;)
  • Otrzymane polubienia: 212
Odp: Eventy
« Odpowiedź #17 dnia: 28 Grudnia 2008, 17:24:56 »
Symek się nie wysypuje na braku tekstury (prócz jednego wyjątku, ale to nie w taborze). O ile wiem, to Krzyżowa 2 korzystała z 201E packa... I pewnie Ty tej paczki nie masz.

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #18 dnia: 28 Grudnia 2008, 17:38:07 »
Mam 201E pack. Wszystko jest już ok, Wpisy są ok wszystko jest ok. Textury też zmieniłem i są ok. Teraz sie log urywa i nie ma nic dalej. Przyczyna 201E Packu?

Offline AtapiCl

  • Zasłużony dla Symulatora
  • Wiadomości: 4426
    • Zobacz profil
    • O warszawskiej części linii kolejowej nr 7 Warszawa – Lublin i nie tylko ;)
  • Otrzymane polubienia: 212
Odp: Eventy
« Odpowiedź #19 dnia: 28 Grudnia 2008, 17:54:45 »
A masz starter Ra? On Ci pokaże jakiego taboru nie posiadasz...

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #20 dnia: 28 Grudnia 2008, 18:26:16 »
Nie posiadam tego starteru. Gdzie go znajdę?

Offline mariusz glogau

  • ZbanowanyZbanowany
  • Wiadomości: 139
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #21 dnia: 28 Grudnia 2008, 18:26:51 »
Nie posiadam tego starteru. Gdzie go znajdę?
Tu znajdziesz starter.

EDIT: Tyle tematów było w tej sprawie poruszanych.
« Ostatnia zmiana: 28 Grudnia 2008, 18:29:07 wysłana przez mariusz glogau »

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #22 dnia: 28 Grudnia 2008, 18:32:16 »
Cytat: mariusz
Tyle tematów było w tej sprawie poruszanych.

Ale żaden nie był taki jak mój tzn. ja nie znalazłem takiego, który do końca wyjaśnił sprawę.

Offline AtapiCl

  • Zasłużony dla Symulatora
  • Wiadomości: 4426
    • Zobacz profil
    • O warszawskiej części linii kolejowej nr 7 Warszawa – Lublin i nie tylko ;)
  • Otrzymane polubienia: 212
Odp: Eventy
« Odpowiedź #23 dnia: 28 Grudnia 2008, 18:37:50 »
Pobędziesz trochę na tym forum, pokombinujesz ze sceneriami, pobawisz się. Po pewnym czasie zrozumiesz, czemu one były takie, jak Twój...

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #24 dnia: 28 Grudnia 2008, 20:00:01 »
No i nic. Pozamieniałem składy i to samo ;/

Offline AtapiCl

  • Zasłużony dla Symulatora
  • Wiadomości: 4426
    • Zobacz profil
    • O warszawskiej części linii kolejowej nr 7 Warszawa – Lublin i nie tylko ;)
  • Otrzymane polubienia: 212
Odp: Eventy
« Odpowiedź #25 dnia: 28 Grudnia 2008, 20:13:48 »
include krzyzowa2/sc2_składy_ET22-804.scm end
W pliku /scenery/krzyzowa2/sc2_składy_ET22-804.scm też pozamieniałeś?

No i sama informacja, że się wyłącza mało nam mówi. Bo może się wyłączać i wcześniej wyświetlić okienko z błędem jak w przypadku eventów.
« Ostatnia zmiana: 28 Grudnia 2008, 20:16:25 wysłana przez ZiomalCl »

Offline Gagar007

  • Wiadomości: 13
    • Zobacz profil
  • Otrzymane polubienia: 0
Odp: Eventy
« Odpowiedź #26 dnia: 28 Grudnia 2008, 20:41:43 »
Nic nie zmieniałem w scenery/krzyżowa/składy_Et22.
Wyłącza się bez żadnego komunikatu. Po prostu się ładuje, ładuje i się wyłącza.