Jeszcze jeden symulatorek

Kategoria: Od drezyny do TGV.

Wersja archiwalna tematu "Jeszcze jeden symulatorek" z grupy pl.misc.kolej

Dodano 18.01.2017 r.:

Uwaga! Przeniesienie na serwer www.eu07.pl, aby nie zginęło w czeluściach Internetu - @macius5991.
Temat dostępny pod adresem eu07.pl/jeszczejedensymulatorek.
Inna kopia: http://maxwap.pl/l/59/jeszcze,jeden,symulatorek.php.



Marcin
2 Sie 2001, 17:21
Jeśli jeszcze nie znudziły się Wam symulatory to zapraszam do
przetestowania mojego symulatorka. Planuje zrobić z tego
symulator lokomotywy EU07, lecz chwilowo brak wiedzy powoduje że jest
to symulator karykatury EU07. Uprzedzam jedynie że do gry
potrzebna jest karta graficzna zgodna z OpenGlem (na pewno działa z
gForcem i
rivą m64) i mocniejszy sprzęt (celeron powinien wystarczyć).
Jeśli się sypie albo bredzi coś o brakujących plikach (nie
powinien, testowany na czystym W98) to prosze o wiadomość.

Pozdrawiam

Marcin Woźniak
www.eu07.prv.pl

EN57
2 Sie 2001, 17:47

Użytkownik Marcin <mdon@poczta.onet.plw wiadomości do grup
dyskusyjnych napisał:9kcg8s$3h@news.tpi.pl...

Ja testowalem na PIII 550 Mhz, 128 MB RAM, Riva TNT2 32MB i wyciaga ok 36
fps, a max nawet ok 42. Nie jest zle, zwlaszcza, ze jeszcze przed
optymalizacja. Ogolnie zapowiada sie dobrze.

Pozdrawiam!

madcap
3 Sie 2001, 07:26

"Marcin" <mdon@poczta.onet.plwrote:
Jeśli jeszcze nie znudziły się Wam symulatory


O ile kolega mysli o symulatorach jazdy lokiem to trudno aby sie znudziły,
bo było ich wszystkich z 2
(Mechanik + MSTSym.)  :-)

potrzebna jest karta graficzna zgodna z OpenGlem


Mój sprzęt : Duron 800MHz, 256MB RAM i nieszczęsna karta Savage4 8MB. Z
jednymi grami grafika pływa (Quake 3), z innymi (Unreal Tournament) pod
OpenGL dzieja ie kosmiczne rzeczy. Twój symulator należy niestety do drugiej
grupy... Nie było tak źle jak z UT, ale miałem tylko 2 fps... Może wiesz coś
więcej o tej karcie?

Jeśli się sypie albo bredzi coś o brakujących plikach


pod Windows XP zażądał dll - a, tego z katalogu system. po przegraniu
uruchomił się bez trudu. Pod Windows Millenium niczego nie żądał tylko się
po chwili wypieprzył ( 2x error in <unknowni raz error in kernel32)

Cóż kilka moich luźnych uwag:

1. pomijając że skacze u mnie jak nie przymierzając Quake na 386, to grafika
jest rewelacyjna,
2. proponuję (może już o tym myślałeś) narysować w kabinie parę przyrządów
pokładowych, szczególnie tych w polu widzenia mechanika (lampka czuwaka,
voltomierze, amperomierze, manometry, oczywiście prędkościomierz) oraz tych
kosmicznych grzejników do szyb na 3kV,
3. skoro już można obracać głową, to można by chyba umożliwić rzut okiem na
pulpit, na te wszystkie przełączniki,
4. wskazówki techniczne - cóż, nie jestem zbyt kompetentny ale nikt sie nie
pokwapił...
a) pozycji steru jest w EU07 jest trochę więcej niż 10, proponuję więc
sterowanie sekwencyjne(np + -), należy też pamiętać że wybrana pozycja
"łapie" po chwili od jej wybrania, do tego mamy jeszcze możliwość
niezależnego osłabienia wzbudzenia silników, ciężkie zadanie przed Tobą 8)
b) posiadam, zdaje się książkę "El. pojazdy trakcyjne EU 06/07", ale
udostępnienie raczej nie wchodzi w grę (książka leży w Zduńskiej Woli (i
jest potrzebna tatuśkowi (mechanik)), a ja leżę w Gdańsku :-). Mógłbym
jednak małe conieco skserować, zeskanować i wysłać Ci na maila (gdybym go
znał),
c) parametry jazdy - wielka niewiadoma. Pzeglądałem kiedyś ww. książkę, ale
nie znalazłem informacji o przyspieszeniach/ opóźnieniach itp.
kapitalistycznych osiągach. EU07 może rozwinąć 2050 KW mocy a waży 80 ton,
więc możnaby obliczyć czas od zera do setki 8)))). A tak poważnie, to
najlepszym źródłem informacji będą koledzy z grupy, którzy pewnie znają
chociaż przybliżone osiągi sprzętu.
d) z tego co słyszałem, to EU07 ma cienkie hamulce (w porównaniu np do
byka). Informacja może się przydać, gdybyś chciał umożliwić obsługę kilku
loków,
5. przypomniało im się jeszcze, że można dodać więcej dzwięków (sprężarka,
przetwornica, ster), poza tym te które są nie bardzo mi się podobają - ten
świst... Ogólnie to wydaje mi się, że w EU07 nie jest tak głośno und. ważne!
nie słychaćprawie w ogóle dźwięków z zewnątrz (ex. gwizdek kierpocia), chyba
że okna są otwarte (a i tak słychać głównie przetwornice).
6. jeszcze o dźwięku - przy ruszaniu lok. charakterystycznie wyje
wentylatorami oporów rozruchowych, tym wyraźniej to słychać im mocniej
mechanik wykorzystuje opory (w praktyce - im cięższy pociąg).
7. wpływ liczby wagonów a nawet ilości ludzi w wagonach ma BARDZO duży wpływ
na zachowanie lokomotywy (tzn. inaczej się rusza z jednym wagonem pocztowym
a inaczej z rzeźnią Karkonosze.

to by było chyba wszystko, jeśli koledzy z grupy nie zj^#!^&%#  mnie z
pisanie rzeczy oczywistych/nieprawdziwych i jeśli coś cię jeszcze
zainteresuje to pytaj: mad@ogrody.nsm.pl

to były moje 0,03 PLN w sprawie nowego, obiecującego symulatora dla MK :-).
Ponieważ piszę na grupę pierwszy raz, to wypadałoby napisać coś o sobie:
-student Telekomuny (w Gdańsku)
-średniozaangażowany MK z okolic Gdańska/Karsznic (studia/chata)
-kiedyś jeszcze bawiłem sie kolejkami PIKO, nawet zacząłem budować makietę
ale te dzisiejsze ceny...

to chyba tyle, pozdrawiam.

sakorius
3 Sie 2001, 08:10
Witam

Ja uruchomiłem na Celeronie 400 z Rivą TNT2 Vantą 16MB i 64MB RAM i miełem 25
fps, to wystarczy żeby sobie pojeździć. Dobra grafika, cieszy mnie również to,
że inne pociągi jeżdżą (druga EU07 przejeżdżająca pod wiaduktem), a nie stoią
jak w Mechaniku.

Pozdrawiam
Sławek Wieczorek
(Sakorius)

Marcin Woźniak
3 Sie 2001, 11:36

"madcap" <mad@ogrody.nsm.plwrote:
Nie było tak źle jak z UT, ale miałem tylko 2 fps... Może wiesz coś
więcej o tej karcie?


Niestety nie mam dostępu do takiej karty, więc nie mogę
sprawdzić. Proponuję abyś powywalał wszystkie objekty z pliku
scene1.scn, nie wolno tylko ruszyć ostatniego:

node spline trainpatch
..
endspline

i wtedy zobacz jak ci będzie działał (powinieneś widzieć
jedynie kabine). Jeśli FPS się poprawi to po trochu dodawaj pozostałe
objekty. Być może jest to wina któreś funkcji OpenGla której
savage nie obsługuje (może to być np kanał alpha). Jeśli w ten
sposób odkryjesz co tak spowalnia program to daj znać.

Cóż kilka moich luźnych uwag:
..
Mógłbym jednak małe conieco skserować, zeskanować i wysłać Ci na maila (gdybym go
znał),


Byłbym bardzo wdzięczny za skany z co ważniejszymi informacjami.
Mój adres przecież znasz ;)

"Marcin" <mdon@poczta.onet.plwrote:


Dziękuje za wszystkie uwagi, z każdą z nich w zupełności się
zgadzam. W miarę zdobywania materiałów (zdjęcia kabiny,
odpowiednie dzwięki) będę sukcesywnie poprawiał błędy.

Ponieważ piszę na grupę pierwszy raz, to wypadałoby napisać coś o sobie:


Dobrze że mi przypomniałeś, to też są moje pierwsze posty, a
zapomniałem się przedstawić - żul ze mnie straszliwy :(

Naprawiam mój błąd:

Mieszkam w Toruniu, studiuje informatykę w Warszawie (zaocznie).
Moją sympatie do kolei rozbudził "Mechanik", na którego
natknąłem się jakiś rok temu szperając w sieci.

Pozdrawiam

EN57
3 Sie 2001, 12:51

Użytkownik <sakor@poczta.onet.plw wiadomości do grup dyskusyjnych
napisał:23b9.00000000.3b6a9@newsgate.onet.pl...

Dobra grafika, cieszy mnie również to,
że inne pociągi jeżdżą (druga EU07 przejeżdżająca pod wiaduktem), a nie
stoią
jak w Mechaniku.


1) Gdzie jest tam ta druga EU07??? Specjalnie dwa razy przejechałem tą
trasę, zatrzymywałem się i nic.

2) Podobno od czasu ostatniej aktualizacji w Mechaniku jest już możliwośc
zobaczenia pociągu w ruchu (są już takie moduły, ja osobiście jszcze jednak
żadnego nie spotkałem).

Pozdrawiam!

Marek P.
3 Sie 2001, 13:00

1) Gdzie jest tam ta druga EU07??? Specjalnie dwa razy przejechałem tą
trasę, zatrzymywałem się i nic.


Rusza od razu na maxa (0), a gdy zblizasz sie do gorki zwolnij do 40, a ja
zobaczysz :-))

2) Podobno od czasu ostatniej aktualizacji w Mechaniku jest już możliwośc
zobaczenia pociągu w ruchu (są już takie moduły, ja osobiście jszcze
jednak
żadnego nie spotkałem).


Ja z tym spotkalem sie juz kilkanascie razy. Calkiem realistycznie to
wyglada

Pzdr
Marek Pawlukowicz / mpa@kki.net.pl , mpa@wp.pl
... czyli kolega znad morza.

EN57
3 Sie 2001, 13:29

Użytkownik Marek P. <mpa@wp.plw wiadomości do grup dyskusyjnych
napisał:9kel84$j6@news.tpi.pl...

| 1) Gdzie jest tam ta druga EU07??? Specjalnie dwa razy przejechałem tą
| trasę, zatrzymywałem się i nic.

Rusza od razu na maxa (0), a gdy zblizasz sie do gorki zwolnij do 40, a
ja
zobaczysz :-))


Rzeczywiscie, dzieki :))

Pozdrawiam!

madcap
3 Sie 2001, 13:52

"Marcin Woźniak" <mdon@poczta.onet.plwrote :

Proponuję abyś powywalał wszystkie objekty z pliku
scene1.scn, nie wolno tylko ruszyć ostatniego:


Tak zrobiłem, niestety nie pomogło, maksymalnie wyciągnąłem 9 fps i to przy
uruchomieniu w okienku w trybie 16 bit koloru w 800x600 (na mniej nie
pozwala Windows XP). Niestety, studiuję telekomunikację, ale spec. Technika
Mikrofalowa i na komputerach się nie znam. Tak czy siak jak twoja gra
wyjdzie, to na 100% kupię sobie TNT2 alibo i Geforca 8)).

Byłbym bardzo wdzięczny za skany z co ważniejszymi informacjami.


Postaram się więc coś podrzucić, jednak to będzie nieregularna sprawa bo
więcej teraz będę siedział w Zduńskiej Woli, poza tym muszę nauczyć się
wpierw dołączać grafikę do maili (patrz niżej)

Mój adres przecież znasz ;)


Sorry :-))))))))) , to był mój pierwszy mail W OGÓLE, a internet podłączyli
mi dopiero w środę...

Pozdrawiam,
Arkadiusz Kosecki

Stefan
3 Sie 2001, 16:49

Witam

Ja uruchomiłem na Celeronie 400 z Rivą TNT2 Vantą 16MB i 64MB RAM i miełem
25
fps, to wystarczy żeby sobie pojeździć. Dobra grafika, cieszy mnie również
to,
że inne pociągi jeżdżą (druga EU07 przejeżdżająca pod wiaduktem), a nie
stoią
jak w Mechaniku.

Pozdrawiam
Sławek Wieczorek
(Sakorius)


Mój komp to PIII500 i grafika All in Wonder 32 mb Windows Millenium
wyciągnął 50-53fps
Rozwijaj dalej bo to jest fajne.
Mechanika zostawia daleko w tyle
Stefan

loksim4
4 Sie 2001, 05:10
hej
grafika super, 50 klatek, po prostu cudo
boje sie pomyslec, jak to bedzie wygladalo za kilka miesiecy (albo bedzie mialo
wszystko, albo na pewnej stronie pojawi sie napis:
"W zwiążku z tym proszę o wyrozumiałość, jeśli chodzi o aktualizacje programu.
Czeka nas jeszcze wiele pracy przy nowej wersji (wiele elementów jest pisanych
od nowa)."
z mojej strony tylko jedna uwaga: wiem, ze nie wypada tego robic, ale jak sie
wychodzi z kabiny w trakcie jazdy, tzn. przed dojechaniem do konca ?

pozdrowka
loksim

feleck
4 Sie 2001, 06:42
<loks@poczta.onet.plwrote in
news:667f.00000001.3b6bbbbd@newsgate.onet.pl:

z mojej strony tylko jedna uwaga: wiem, ze nie wypada tego robic, ale
jak sie wychodzi z kabiny w trakcie jazdy, tzn. przed dojechaniem do
konca ?


klawisz z literka "q" o ile sie nie myle.
W helpie chyba tak bylo napisane.

Pozdrawiam, Feleck

loksim4
4 Sie 2001, 14:55

klawisz z literka "q" o ile sie nie myle.
W helpie chyba tak bylo napisane.


tak, wiem, napisalem niedokladnie
chodzilo mi nie o calkowite wyjscie z programu, tylko cos jakby wyjscie z
konkretnej jazdy
po prostu laduje mi sie toto dosc dlugo i w tej chwili nie ma chyba takiej
mozliwosci, zeby byc w programie, a nie miec uruchomionej symulacji

pozdrowka
loksim

Krzysztof Dobrzański
4 Sie 2001, 16:04

Jeśli jeszcze nie znudziły się Wam symulatory to zapraszam do
przetestowania mojego symulatorka. Planuje zrobić z tego
symulator lokomotywy EU07, lecz chwilowo brak wiedzy powoduje że jest
to symulator karykatury EU07. Uprzedzam jedynie że do gry
potrzebna jest karta graficzna zgodna z OpenGlem (na pewno działa z


Ja mam Windows Me, PIII 600, 256MB RAM, Riva TNT2 32MB, CD-ROM 48x i wyciąga
20 -29 fps. Po pewnym czasie, za wiaduktem, jak skończy się las program
zawiesił się i tylko Alt+F4 pomogło. Za drugim razem już się nie wieszał.
Rozglądanie się po kabinie jest genialne!

Marcin Woźniak
4 Sie 2001, 16:40

<loks@poczta.onet.plwrote:
tak, wiem, napisalem niedokladnie
chodzilo mi nie o calkowite wyjscie z programu, tylko cos jakby wyjscie z
konkretnej jazdy


niestety czegos takiego nie ma, wprowadze do pozniejszych wersji
po prostu laduje mi sie toto dosc dlugo


niedopracowany parser oraz sortowanie objektów przy ładowaniu
sceny, postaram sie usprawnic

madcap
4 Sie 2001, 17:19
Nikt tego nie napisał, bo dla wszystkich tutaj to jest oczywiste :-) , ale i
w mechaniku i EU07 wysięgniki słupów trakcyjnych są jednakowej długości a
powinny być chyba na przemian dłuższy - któtszy (przynajmniej na prostych).
W obu symulatorkach nie ma też sieci trakcyjnej. Nie znam sie na
programowaniu, może to trudno zrobić?

Pozdrawiam

Marcin Woźniak
4 Sie 2001, 17:33

"madcap" <mad@ogrody.nsm.plwrote:
Nikt tego nie napisał, bo dla wszystkich tutaj to jest oczywiste :-) , ale i
w mechaniku i EU07 wysięgniki słupów trakcyjnych są jednakowej długości a
powinny być chyba na przemian dłuższy - któtszy (przynajmniej na prostych).


Bo wykozystalem slupy z mechanika.
W obu symulatorkach nie ma też sieci trakcyjnej. Nie znam sie na
programowaniu, może to trudno zrobić?


Jesli chodzi o siec to w formacie opisu trasy nie ma jeszcze
latwego sposobu na umieszczenie jej wzdluz krzywej tak jak
slupow, a recznie nie chcialo mi sie wklepywac, bo to strasznie
zmudne zadanie szczegolnie na zakretach.

madcap
4 Sie 2001, 17:56

"Marcin Woźniak" <mdon@poczta.onet.plnapisał był:

 Jesli chodzi o siec to w formacie opisu trasy nie ma jeszcze

latwego sposobu na umieszczenie jej wzdluz krzywej tak jak
slupow, a recznie nie chcialo mi sie wklepywac, bo to strasznie
zmudne zadanie szczegolnie na zakretach.


hmm, troche mnie uspokoiło, ale czy to znaczy, że sieci w ogóle nie będzie?

gretz

Marcin Woźniak
4 Sie 2001, 18:37

"madcap" <mad@ogrody.nsm.plwrote:

hmm, troche mnie uspokoiło, ale czy to znaczy, że sieci w ogóle nie będzie?


siec bedzie mozna zrobic, ale jeszcze nie wiem czy lepiej aby
byla to tekstura z namalowanymi kablami (jak slupy) czy tez zwykle kreski

Artur Kopacz
5 Sie 2001, 17:04

Marcin napisał(a) w wiadomości: <9kcg8s$3h@news.tpi.pl...

Jeśli jeszcze nie znudziły się Wam symulatory to zapraszam do
przetestowania mojego symulatorka. Planuje zrobić z tego
symulator lokomotywy EU07, lecz chwilowo brak wiedzy powoduje że jest
to symulator karykatury EU07. Uprzedzam jedynie że do gry
potrzebna jest karta graficzna zgodna z OpenGlem (na pewno działa z
gForcem i
rivą m64) i mocniejszy sprzęt (celeron powinien wystarczyć).
Jeśli się sypie albo bredzi coś o brakujących plikach (nie
powinien, testowany na czystym W98) to prosze o wiadomość.


Sam się zdziwiłem, ale u mnie na 486-133MHz z S3 VIRGE
na PCI uruchomiło się. Tzn. wyświetlił się obraz szlaku z semaforem
i jak się coś naciśnie to po ok. minucie coś się zmienia.
FPS to klatki na sekundę? U mnie to wynosi 0,05.
Mimo to jestem pod wrażeniem. To może być dobry symulator.
Najtrudniejsza część - engine 3D - jest zrobiona.
Łatwiej programiście zrozumieć działanie lokomotywy EU07,
niż znawcę lokomotyw nauczyć programować w OpenGL.
Sama dynamika ruchu była bardzo dobrze zrobiona w Railsimie
- choć uproszczona, bez szczegółów typu bocznikowanie itp.

Przy okazji: Gdybym kiedyś ulepszał sprzęt to czy do tego
symulatora jest ważniejszy procesor czy dobra
karta z akceleratorem?

pozdrawiam
Kopacz

madcap
5 Sie 2001, 17:16

"Artur Kopacz" <kopac@polbox.combył uprzejmy napisać:

Najtrudniejsza część - engine 3D - jest zrobiona.
Łatwiej programiście zrozumieć działanie lokomotywy EU07,
niż znawcę lokomotyw nauczyć programować w OpenGL.


Kurde, to wlasnie chcialem powiedziec w licznych listach, a kolega w trzech
zdaniach. Łoś jestem, ale moze jeszcze nie fioletowy.

Przy okazji: Gdybym kiedyś ulepszał sprzęt to czy do tego
symulatora jest ważniejszy procesor czy dobra
karta z akceleratorem?


Niech sie wypowie Marcin, ale jedno ci powiem: nie kupuj karty Savage4.

Pozdrawiam

Arkadiusz Kosecki
mad@ogrody.nsm.pl

Marcin Woźniak
6 Sie 2001, 14:13

"Artur Kopacz" <kopac@polbox.comwrote:
Sam się zdziwiłem, ale u mnie na 486-133MHz z S3 VIRGE
na PCI uruchomiło się. Tzn. wyświetlił się obraz szlaku z semaforem


hehe, znaczy sie ze lepiej miec karte ktora nie obsluguje
OpenGla wogole niz z obsluga czesciowa :)

Przy okazji: Gdybym kiedyś ulepszał sprzęt to czy do tego
symulatora jest ważniejszy procesor czy dobra
karta z akceleratorem?


Dobra karta na agp (najpewniejsze jast cos nvidii np riva tnt i
wyzej) jest niezbedna, ale jesli chodzi o procesor to ponizej
celerona tez lepiej nie schodzic.

pozdrawiam
Marcin

Darkman
16 Sie 2001, 04:41

"Marcin Woźniak" <mdon@poczta.onet.plwrote :
| Proponuję abyś powywalał wszystkie objekty z pliku
| scene1.scn, nie wolno tylko ruszyć ostatniego:
Tak zrobiłem, niestety nie pomogło, maksymalnie wyciągnąłem 9 fps i to
przy
uruchomieniu w okienku w trybie 16 bit koloru w 800x600 (na mniej nie
pozwala Windows XP). Niestety, studiuję telekomunikację, ale spec.
Technika
Mikrofalowa i na komputerach się nie znam. Tak czy siak jak twoja gra
wyjdzie, to na 100% kupię sobie TNT2 alibo i Geforca 8)).


To błąd, że w 16bitowym kolorze uruchamiałeś! Kilka funkcji OpenGLa jest
obsługiwanych tylko w 32bitowym kolorze przez sprzęt, więc w 16 bitach jest
emulowanych programowo. Być może nie zostały one użyte, ale warto
sprawdzić...

| Byłbym bardzo wdzięczny za skany z co ważniejszymi informacjami.

Postaram się więc coś podrzucić, jednak to będzie nieregularna sprawa bo
więcej teraz będę siedział w Zduńskiej Woli, poza tym muszę nauczyć się
wpierw dołączać grafikę do maili (patrz niżej)

| Mój adres przecież znasz ;)

Sorry :-))))))))) , to był mój pierwszy mail W OGÓLE, a internet
podłączyli
mi dopiero w środę...

Pozdrawiam,
Arkadiusz Kosecki




Podobne tematy:
Symulator
Symulatory
Symulator nastawni - Kolejarz
Symulatory ;)
Symulator
Symulatory
Symulator Pijaka