Autor Wątek: Exe - konwersja na C++  (Przeczytany 61059 razy)

0 użytkowników i 2 Gości przegląda ten wątek.

Online Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 4961
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 110
Odp: Exe - konwersja na C++
« Odpowiedź #1500 dnia: 20 Marca 2017, 21:12:52 »
Potwierdzam błąd zgłoszony przez:
A jak się ma sprawa z EZT, bo wcalę nie mogę uruchomić kibelków. Załączam baterię, pantografy w górę, potem rozrząd i klapa, nie pokazuje w rozrządczym napięcia sieci wcale mimo że pantografy mam podniesione. Najnowsza wersja exe. Czy może ja robię coś źle? W logu czysto za to załączam errors.
AI potrafi ruszyć tylko tego kibla z miejsca. Nie mamy możliwości załączenia WS klawiszem M. Nawet po odpięciu AI mimo że kibel jedzie, nie mamy możliwości wpływu na jego sterowanie.

Offline Wiggle

  • Wydział Paczek Całościowych
  • Wiadomości: 194
    • Zobacz profil
  • Otrzymane polubienia: 4
Odp: Exe - konwersja na C++
« Odpowiedź #1501 dnia: 20 Marca 2017, 21:14:10 »
Ja już pisałem co zrobiłem wtedy i pomogło i działa jak trzeba, ale no trzeba zobaczyć co się stało.
"Standardowa edukacja zapewni Ci przeżycie. Samokształcenie - fortunę." - Jim Rohn

Online Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 4961
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 110
Odp: Exe - konwersja na C++
« Odpowiedź #1502 dnia: 20 Marca 2017, 21:30:00 »
Ten wpis działał:node -1 0 EN57-2040ra dynamic pkp\en57-2000_v1 en57-2040_ra 6ba 0 headdriver 55 0 enddynamic
node -1 0 EN57-2040s dynamic pkp\en57-2000_v1 en57-2040_s 6bs 0 nobody 55 0 enddynamic
node -1 0 EN57-2040rb dynamic pkp\en57-2000_v1 en57-2040_rb 6bb 0 nobody 0 0 enddynamic
i przestał.node -1 0 EN57-1542ra dynamic pkp\en57_v1 en57-1542ra 6baii 0 headdriver 55 0 enddynamic
node -1 0 EN57-1542s dynamic pkp\en57_v1 en57-1542s 6bsii 0 nobody 55 0 enddynamic
node -1 0 EN57-1542rb dynamic pkp\en57_v1 en57-1542rb 6bbii 0 nobody 55 0 enddynamic
, ten też przestał. Sprawdzane na paczce tej postawionej 3 tygodnie temu i tej postawionej dzisiaj. Nie ma możliwości awarii plików t3d bo ich nie mam.

ED:
node -1 0 EN57-1542ra dynamic pkp\en57_v1 en57-1542ra 6baii 0 headdriver 183 0 enddynamic
node -1 0 EN57-1542s dynamic pkp\en57_v1 en57-1542s 6bsii 0 nobody 183 0 enddynamic
node -1 0 EN57-1542rb dynamic pkp\en57_v1 en57-1542rb 6bbii 0 nobody 0 0 enddynamic
Nic z tego, taki wpis też nie działa
Mamy uruchomienie baterii, narotnik, zbijamy czuwak i podnosimy patyki. Brak napięcia nie ma WSa. Zapuszczamy AI i ono odjeżdża...
Załącznik, brak napięcia po podniesieniu patyków.

ED:2
Ostatnia wersja exe z prawidłowym uruchamianiem kibli, jest z 20170315
« Ostatnia zmiana: 20 Marca 2017, 22:11:31 wysłana przez Krzysiek626 »

Offline tmj

  • Deweloper
  • Wiadomości: 544
    • Zobacz profil
  • Otrzymane polubienia: 144
Odp: Exe - konwersja na C++
« Odpowiedź #1503 dnia: 20 Marca 2017, 22:10:41 »
Dane pokazywane w trybie debug zmienily sie troche, pokazuje on parametry najblizszego pojazdu/czlonu. Przejdz sie w strone czesci z patykami, i powinien pokazac napiecie na podniesionym pantografie (raportowanie stanu I jest na ten moment zakrzaczone)

Postawilem sobie ten zestaw ktory zglaszasz na TD, a takze pare innych i jeszcze ED72 dla pewnosci, i u mnie wszyskie chodza. Wskaznik WN w kabinie pokazuje poprawnie po podniesieniu pantografu, silniki i kompresor zalaczaja sie poprawnie, i wszystkie EZT jezdza normalnie. Instalowaliscie sobie jakies unoffy dla EZT albo cos? :x

Z innej beczki, dopisalem brakujacy kawalek podlaczania z powrotem VBO, powinno byc teraz kompletne (chociaz ciagle na byle jak)

Przyjrzalem sie tez programatorom, i wyszlo ze gryzly sie z czyms dziwnym co stary kod wyprawial w EZT -- pierwszy czlon nie byl skonfigurowany by kontrolowac wlasne swiatla, tylko swiatla modulu silnikowego, ktory swiatel w ogole nie ma. Nie wiem czy to jakas prehistoryczna zaszlosc, ale nie wyglada na to, by usuniecie powodowalo jakies efekty uboczne, wiec teraz czlony EZT sa pod tym wzgledem traktowane jak wszystko inne, i programator dziala na nich poprawnie.

« Ostatnia zmiana: 20 Marca 2017, 22:12:33 wysłana przez tmj »

Online Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 4961
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 110
Odp: Exe - konwersja na C++
« Odpowiedź #1504 dnia: 20 Marca 2017, 22:14:35 »
Ostatnia wersja exe z prawidłowym uruchamianiem kibli, jest z 20170315. Od 16 mam źle.
ED:
Potwierdzam, że w trybie normalnym można uruchomić kibla, jest napięcie i pojechać. Tym niemniej chcieli byśmy jeździć tym w debug mode też. Gdyby to było tylko zakrzaczone UI, ale nie reaguje na sterowanie.
PS: Nie zauważyłem napięcia sieci w UI w trybie normalnym - potwierdzenie podniesienia patyka, ale to przy okazji. Cały czas jeździłem na Quarku i w piątek przestałem i masz...
« Ostatnia zmiana: 20 Marca 2017, 22:29:27 wysłana przez Krzysiek626 »

Offline tmj

  • Deweloper
  • Wiadomości: 544
    • Zobacz profil
  • Otrzymane polubienia: 144
Odp: Exe - konwersja na C++
« Odpowiedź #1505 dnia: 20 Marca 2017, 22:40:36 »
Nie obserwuje u siebie zadnej roznicy dzialania w trybie debug -- po wylaczeniu automatu moge uruchamic kibla bez zadnych problemow, i jezdzi on tak samo jak w trybie normalnym. Sprawdzilem dla pewnosci z livetraction w obu opcjach, ale jest tak samo.

Jesli nie moge u siebie zreprodukowac bledu, to raczej nie jestem w stanie go tez usunac. Czy te klopoty sa na jakims konkretnym scenariuszu, czy wszedzie? Czy to jest standardowa paczka calosciowa + patch, czy cos bylo modyfikowane?


Offline Wiggle

  • Wydział Paczek Całościowych
  • Wiadomości: 194
    • Zobacz profil
  • Otrzymane polubienia: 4
Odp: Exe - konwersja na C++
« Odpowiedź #1506 dnia: 20 Marca 2017, 22:43:24 »
Super! Dzięki za rozwiązanie tego problemu z programatorem! :D
"Standardowa edukacja zapewni Ci przeżycie. Samokształcenie - fortunę." - Jim Rohn

Offline Stele

  • Wydział Paczek Całościowych
  • Administrator
  • Wiadomości: 3871
    • Zobacz profil
  • Otrzymane polubienia: 69
Odp: Exe - konwersja na C++
« Odpowiedź #1507 dnia: 20 Marca 2017, 22:50:21 »
Klopik odpala w debugu bez problemu. Asynchroniczny również. Programator mu działa jak należy. Przy okazji wyszło dziwactwo z hamulcem w członie rb. W ra ma wartości rzędu setek, w s wyzerowane a w rb...
Bądź na bieżąco z paczką całościową. Codzienne patche różnicowe prosto z repozytorium deweloperów: http://eu07.pl/daily/
Dokumentacja symulatora: http://wiki.awril.pl
Mój kanał youtube

Offline Lorem

  • Wiadomości: 127
    • Zobacz profil
  • Otrzymane polubienia: 1
Odp: Exe - konwersja na C++
« Odpowiedź #1508 dnia: 20 Marca 2017, 22:51:54 »
Potiwerdzam problemy z debugmode, ale tylko jeśli uruchamia się symulator z tą opcją włączoną w Rainsted/ini. Jeśli uruchomić w trybie normalnym i potem włączyć debug Shift+Ctrl+F12, to wszystko zdaje się działać dobrze.
Przy debugmode włączonym od startu inaczej też działa załączanie baterii (test SHP wyłącza się sam po ok. sekundzie, lub dużo krócej w przypadku kibla), kamera startuje w innym miejscu, sieć trakcyjna jest jasnozielona, w przypadku kibli nie działa sterowanie drzwiami... nie wiem, co z tego jest zamierzone.
A może by tak własny pulpit...

Offline Stele

  • Wydział Paczek Całościowych
  • Administrator
  • Wiadomości: 3871
    • Zobacz profil
  • Otrzymane polubienia: 69
Odp: Exe - konwersja na C++
« Odpowiedź #1509 dnia: 20 Marca 2017, 22:54:31 »
Nic takiego nie mam. Przypominam, że w debugu włącza się na starcie AI i trzeba je wyłączyć albo będzie nam "pomagać".
Bądź na bieżąco z paczką całościową. Codzienne patche różnicowe prosto z repozytorium deweloperów: http://eu07.pl/daily/
Dokumentacja symulatora: http://wiki.awril.pl
Mój kanał youtube

Offline Lorem

  • Wiadomości: 127
    • Zobacz profil
  • Otrzymane polubienia: 1
Odp: Exe - konwersja na C++
« Odpowiedź #1510 dnia: 20 Marca 2017, 22:59:13 »
w debugu włącza się na starcie AI
Po wyłączeniu AI wcześniej wspomnianych "nieprawidłowości" nie stwierdza się.
A może by tak własny pulpit...

Online Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 4961
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 110
Odp: Exe - konwersja na C++
« Odpowiedź #1511 dnia: 20 Marca 2017, 23:01:35 »
No to mamy chorobę dwubiegunową. Mnie to przypominasz? Wiem że trzeba odłączyć AI, ale nawet jak nam pomoże wystartować to i tak po jego wyłączeniu nie mamy sterowania. Ustawiam tryb debug w Rainsted bo mi bliżej niż do edycji ini i powinno działać jak dawnie. Przełom jest jak pisałem między 15 a 16 dniem marca. Jest ewidentnie inne działanie trybu debug mode w kiblach. Skoro ten tryb, jest to powinien działać tak jak normal, z wyłączeniem fizyki wykolejeń.
ED:
Postawiłem tego kibla na td, bo szybciej wczytuje. Po pierwsze w członie s mam napięcie i mogę załączyć wsa, wracam do ra i nie ma napięcia, nie ma jazdy. Po drugie, nie sądzicie, że od piątku zapomniałem jak się uruchamia kibla... Po trzecie potrafię go uruchomić w trybie normalnym. Po czwarte od szesnastego jest wyraźna zmiana zachowania procedury uruchamiania. Po piąte, jeśli nawet Ai uruchomi kibla i pojedzie za nas, to po przejęciu jednostki powinna być podatna na nasze zabiegi, a nie jest. Po szóste, wygląda na to, że AI siedzi w członie S, bo nie mając napięcia w członie Ra nie mogło by jechać. Po siódme nie mam więcej argumentów.
Wyłączenie AI w pierwszej sekundzie nic nie zmienia.
« Ostatnia zmiana: 20 Marca 2017, 23:23:36 wysłana przez Krzysiek626 »

Offline CX MANIAK

  • Wiadomości: 65
    • Zobacz profil
  • Otrzymane polubienia: 8
Odp: Exe - konwersja na C++
« Odpowiedź #1512 dnia: 20 Marca 2017, 23:17:46 »
Witam.
 U mnie również kibelki na najnowszej kompilacji exe C++ 32 bit, działają normalnie w obu trybach. Udaje się uruchomić, jechać, hamować. Drzwi otwierają się również. Sprawdzałem na TD ze składem 2 xEN57 w ukrotnieniu. 
Pozdrawiam.

Offline tmj

  • Deweloper
  • Wiadomości: 544
    • Zobacz profil
  • Otrzymane polubienia: 144
Odp: Exe - konwersja na C++
« Odpowiedź #1513 dnia: 20 Marca 2017, 23:32:00 »
Po pierwsze w członie s mam napięcie i mogę załączyć wsa, wracam do ra i nie ma napięcia, nie ma jazdy.
Zaraz zaraz, wyjasnijmy sobie cos. Po pierwsze, po co wychodzisz z ra zeby zalaczyc WS? Przelacznik jest w ra, i dziala "zdalnie" stamtad, tak dlugo jak podniesiony jest patyk. Po drugie, jak stwierdzasz brak napiecia w ra? Jesli na podstawie danych wyswietlanych przez UI, to na to nie patrz, bo tam podany jest stan tego konkretnego modulu w ktorym siedzisz, a napiecie "jest" w segmencie silnikowym, i stan tego napiecia pokazany na wskazniku na pulpicie, ponizej kontrolki czuwaka.

(nawiasem mowiac, AI nie siedzi w czlonie silnikowym tylko w sterujacym, tak jak i "ludzki" maszynista, na poziomie kodu jest z maszynista dosc wymienne)

Klopik odpala w debugu bez problemu. Asynchroniczny również. Programator mu działa jak należy. Przy okazji wyszło dziwactwo z hamulcem w członie rb. W ra ma wartości rzędu setek, w s wyzerowane a w rb...
Trudno powiedziec co tam sie dzieje, to moga byc dziwne wartosci w .fiz/mmd rozwalajace kalkulacje, albo brak inicjalizacji, albo cokolwiek innego. Raczej tego nie sprawdze jesli do tego potrzebne jest ganianie za jakimis prywatnymi unoffami, az tyle wolnego czasu to ja nie mam ;x
« Ostatnia zmiana: 20 Marca 2017, 23:52:57 wysłana przez tmj »

Online Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 4961
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 110
Odp: Exe - konwersja na C++
« Odpowiedź #1514 dnia: 20 Marca 2017, 23:56:01 »
Napisałeś że UI pokazuje prawidłowe napięcie w silnikowym to poszedłem sprawdzić. Taka ciekawość, a jak zobaczyłem że jest to, z ciekawości wcisnąłem shift+M. To była czysta ciekawość i nic więcej. WS załączył się, także nastawnik kierunku, nie próbowałem odjechać.

W członie Ra nie pokazuje mi napięcia na UI, ale jeśli nawet pokazuje mi na voltomierzu, to WSa i tak załączyć nie mogę. nie ma WSa nie ma jazdy. Następnie odpalam na 170315 i mam wszystko jak poprzednio. Pewnie sam bym się wypruł wcześniej z tym, ale zająłem się wyświetlaniem u Atapiego a i niedziela też była do odpoczynku. To przegapiłem zmianę.
Najważniejsze, uruchomiłem kibla na Quarku i TD w trybie debug mode. Dziękuję za cierpliwość. Co do zmiany między 15 a 16 dniem marca, to prosiłbym ciebie @tmj, o sprawdzenie skąd się wzięły te różnice. Między postawieniem patyka do sieci i wciśnięciem WSa mija jakiś czas gdzie zapalają się lampki. Po za tym mam wrażenie że przejęcie kibla po AI jest teraz problematyczne. Ale to jeszcze powałkuję. Dzięki za cierpliwość.

Offline tmj

  • Deweloper
  • Wiadomości: 544
    • Zobacz profil
  • Otrzymane polubienia: 144
Odp: Exe - konwersja na C++
« Odpowiedź #1515 dnia: 21 Marca 2017, 00:04:55 »
Co do zmiany między 15 a 16 dniem marca, to prosiłbym ciebie @tmj, o sprawdzenie skąd się wzięły te różnice. Między postawieniem patyka do sieci i wciśnięciem WSa mija jakiś czas gdzie zapalają się lampki.
Sek w tym ze przegladajac pobieznie, tam nie bylo specjalnie zmian, ktore moglyby miec tego typu efekt. Co do pauzy, nie wiem czy warto wspomniec, ale zwroc uwage ze po nacisnieciu shift + O podniesienie pantografu trwa dobrych kilka sekund, i proby wlaczania WS w tym czasie sa skazane na niepowodzenie. Dopiero gdy patyk sie podniesie (widac kiedy, bo budzi sie wtedy woltomierz WN na pulpicie) mozna zalaczyc WS, i to na EN57 nie zajmuje dlugo, jakies 0.5 sek. A potem juz idzie normalnie, przetwornica, sprezarka itp.

Offline Lorem

  • Wiadomości: 127
    • Zobacz profil
  • Otrzymane polubienia: 1
Odp: Exe - konwersja na C++
« Odpowiedź #1516 dnia: 21 Marca 2017, 00:07:15 »
Mnie to przypominasz? Wiem że trzeba odłączyć AI
Myślę, że mnie. Bo faktycznie, wcześniej zgłoszone przeze mnie problemy były wyłącznie wynikiem tego, że z moimi działaniami intereferowało AI, o którego wyłączeniu nie pamiętałem.

Tak czy inaczej, na ostatnim exe wersja 64bit i świeżej, dzisiaj postawionej paczce użytkowej (e3d/dds) z patchem i zainstalowaną większością oficjalnych dodatków, nie mam żadnych problemów z obsługą EZT (poza ED72, która musi mieć podniesiony pantograf od strony obsadzonej kabiny, ale na Borlandowym exe też tak jest, z tego co teraz widzę). Niezależnie od tego, czy włączam z debugmode, czy bez, czy skład uruchamia AI, czy ja, czy przeujmujemy od siebie nawzajem sterowanie, wszystko działa. Także problem nie jest uniwersalny. Chyba że dotyczy jakiegoś konkretnego mmd, ale sprawdzałem składy podane w tym poście i było ok.

(Co zabawne, z członu S też da się przeprowadzić niemal cały rozruch.)
« Ostatnia zmiana: 21 Marca 2017, 00:12:47 wysłana przez Lorem »
A może by tak własny pulpit...

Offline Stele

  • Wydział Paczek Całościowych
  • Administrator
  • Wiadomości: 3871
    • Zobacz profil
  • Otrzymane polubienia: 69
Odp: Exe - konwersja na C++
« Odpowiedź #1517 dnia: 21 Marca 2017, 00:09:43 »
Trudno powiedziec co tam sie dzieje, to moga byc dziwne wartosci w .fiz/mmd rozwalajace kalkulacje, albo brak inicjalizacji, albo cokolwiek innego. Raczej tego nie sprawdze jesli do tego potrzebne jest ganianie za jakimis prywatnymi unoffami, az tyle wolnego czasu to ja nie mam ;x
Spoko, do tego i tak yB musiałby siąść, bo mam wrażenie, że hamulec nieco świruje. Dęba staje, poślizgi łapie. Musi to obejrzeć ktoś, mający ideę jak być powinno.

W ED72 trzeba ustawić sprzęg szyny WN między członami silnikowymi. We wszystkich ezt mających silniki w członach bez aktywnego pantografu trzeba tak czynić.
Bądź na bieżąco z paczką całościową. Codzienne patche różnicowe prosto z repozytorium deweloperów: http://eu07.pl/daily/
Dokumentacja symulatora: http://wiki.awril.pl
Mój kanał youtube

Online Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 4961
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 110
Odp: Exe - konwersja na C++
« Odpowiedź #1518 dnia: 21 Marca 2017, 00:18:42 »
Co do pauzy, nie wiem czy warto wspomniec, ale zwroc uwage ze po nacisnieciu shift + O podniesienie pantografu trwa dobrych kilka sekund, i proby wlaczania WS w tym czasie sa skazane na niepowodzenie.
Wytłumaczę się jak pierwszoklasista, Czekam aż woltomierz pokażę napięcie WN, dopiero włączam WS. Zresztą ta uwaga jest mało istotna, w końcu napięci jest i WS się włączy. Czekam też na uruchomienie sprężarki po przetwornicy w siódemce, bo tak trzeba.
Może zmęczony jestem, i ta różnica zrobiła wielkie zamieszanie. Jeszcze raz przepraszam za zamieszanie, dzięki za cierpliwość. Przejąłem pojazd od AI prawidłowo. 
ed2
To jeszcze dopowiem, że na exe 64 jest podobnie jak na 32. Stabilność jest duża, tylko to nieszczęsne kiblowate. Załącznik, uruchomione  i pojechane.
« Ostatnia zmiana: 21 Marca 2017, 00:50:31 wysłana przez Krzysiek626 »

Offline CX MANIAK

  • Wiadomości: 65
    • Zobacz profil
  • Otrzymane polubienia: 8
Odp: Exe - konwersja na C++
« Odpowiedź #1519 dnia: 21 Marca 2017, 08:40:18 »
Spoko, do tego i tak yB musiałby siąść, bo mam wrażenie, że hamulec nieco świruje. Dęba staje, poślizgi łapie. Musi to obejrzeć ktoś, mający ideę jak być powinno.
Witam.
  Co do hamulca, to gdy ciśnienie w cylindrach oscyluje w okolicach ok 0,4 MPa wpada rzeczywiście w poślizg, ale jest on dziwny gdyż skład zachowuje się jakby szyny były posmarowane smarem. Prędkość spada bardzo powoli, a klop sunie jak po lodzie. Dodatkowo, gdy mamy podczas hamowania nastawnik na pozycji jazdy, to w czlonie S koła obracają się jak oszalałe, jakby hamulec w nim nie działał. W Ra i Rb są przecież w tym czasie zablokowane zestawy. Ale generalnie tak jak pisałem wcześniej jechać kiblem można.
« Ostatnia zmiana: 21 Marca 2017, 21:24:02 wysłana przez CX MANIAK »

Offline tmj

  • Deweloper
  • Wiadomości: 544
    • Zobacz profil
  • Otrzymane polubienia: 144
Odp: Exe - konwersja na C++
« Odpowiedź #1520 dnia: 21 Marca 2017, 12:19:39 »
Tak z ciekawosci, zobacz jakie sa wpisy masy i ladunku tego kibla dla poszczegolnych czlonow (zwlaszcza b) bo te gigantyczne liczby na zdjeciu Steele znikad sie nie wziely.

Offline kacper52115

  • Wiadomości: 54
    • Zobacz profil
  • Otrzymane polubienia: 2
Odp: Exe - konwersja na C++
« Odpowiedź #1521 dnia: 21 Marca 2017, 14:57:22 »
Witam. Mam taki problem. Gdy chcę odpalić na nowym exe to pokazuję się ekran ładowania a następnie mnie wywala. Co może być problemem? W załączniku plik log.
Mój kanał na youtube: https://www.youtube.com/channel/UC4V4hAD-shLwJ9NTiNrTrKQ
Zapraszam również na mojego fotobloga:
kacpermichalski.flog.pl

Offline tmj

  • Deweloper
  • Wiadomości: 544
    • Zobacz profil
  • Otrzymane polubienia: 144
Odp: Exe - konwersja na C++
« Odpowiedź #1522 dnia: 21 Marca 2017, 15:04:12 »
Wyglada na to, ze wylatuje przy starcie Pythona. Czy to jest wersja x86, czy x64? x64 wymaga w katalogu symulatora folderu python64 ktory jest wlaczony do paczki bibliotek do pobrania z http://eu07.pl/userfiles/24014/bugs-eu07cplusplus64_libraries.rar

(nawiasem mowiac, ten log jest chyba z troche starszej wersji exe. Jesli to nie problem, testuj raczej na wersji najnowszej, do pobrania z zalacznika w http://eu07.pl/forum/index.php/topic,28920.msg445222.html#msg445222
« Ostatnia zmiana: 21 Marca 2017, 15:49:33 wysłana przez tmj »

Offline firleju

  • Deweloper
  • Wiadomości: 1389
  • bawię się (w) exe...
    • Zobacz profil
  • Otrzymane polubienia: 66
Odp: Exe - konwersja na C++
« Odpowiedź #1523 dnia: 22 Marca 2017, 09:21:09 »
Ja powoli walczę z tabelką. Tylko tak wrzucam narazie info, że w temacie się coś dzieje. Choć czasami mnie bierze jak widzę jak to jest skomplikowane.
Skrypty do Blendera dostępne tutaj
W miarę aktualne wiki EXE wiki.eu07.es

Offline tmj

  • Deweloper
  • Wiadomości: 544
    • Zobacz profil
  • Otrzymane polubienia: 144
Odp: Exe - konwersja na C++
« Odpowiedź #1524 dnia: 22 Marca 2017, 11:20:54 »
To moze szybciej by wyszlo od razu przeprojektowac jak zorganizowane sa tory zastapic eventy czyms normalnym, skoro i tak trzeba to zrobic ;)

Offline firleju

  • Deweloper
  • Wiadomości: 1389
  • bawię się (w) exe...
    • Zobacz profil
  • Otrzymane polubienia: 66
Odp: Exe - konwersja na C++
« Odpowiedź #1525 dnia: 22 Marca 2017, 13:07:45 »
Ja to już rozdzielam w tej chwili tak, żeby dało się to zrobić. Bardziej chodzi o to jak potem dane z tabelki są używane dalej (na co sposób przekazywania danych do tabelki nie ma wpływu).
Powiem, że troszkę utrudnia mi pracę fakt, że w którymś commicie usunąłeś projekt ale zostawiłeś solucję.
Skrypty do Blendera dostępne tutaj
W miarę aktualne wiki EXE wiki.eu07.es

Offline tmj

  • Deweloper
  • Wiadomości: 544
    • Zobacz profil
  • Otrzymane polubienia: 144
Odp: Exe - konwersja na C++
« Odpowiedź #1526 dnia: 22 Marca 2017, 14:47:14 »
Sorry, projekt wycialem zeby nie bylo bezustannego nadpisywania go sobie nawzajem przy commitach :) dolaczam biezaca wersje, jesli sie do czegos przyda.

Offline firleju

  • Deweloper
  • Wiadomości: 1389
  • bawię się (w) exe...
    • Zobacz profil
  • Otrzymane polubienia: 66
Odp: Exe - konwersja na C++
« Odpowiedź #1527 dnia: 22 Marca 2017, 19:45:47 »
Ja tam już mam na stałe wrzucone w stasha i on sobie nadpisuje tylko zmiany w katalogach do których buduje. No i wersję kompilatora.
Skrypty do Blendera dostępne tutaj
W miarę aktualne wiki EXE wiki.eu07.es

Offline tmj

  • Deweloper
  • Wiadomości: 544
    • Zobacz profil
  • Otrzymane polubienia: 144
Odp: Exe - konwersja na C++
« Odpowiedź #1528 dnia: 22 Marca 2017, 21:39:40 »
Przy okazji grzebania w kodzie rzucil mi sie w oczy komentarz przy swiatlach punktowych...
// dorobić aureolę!
No to dorobilem. Efekt nawet ok, ale ze kalkulacje robione byly z wykorzystaniem glGet() to wydajnosc na wiekszych stacjach spadla o jakies 25% co, biorac pod uwage ze efekt nie jest az tak dobry, bylo zdecydowanie zbyt wysoka cena. Podpialem wiec skonczone "wirtualne matryce" dla openGL, zeby sie pozbyc odwolan do glGet() i teraz zamiast spadku o 25% mamy jakas ~10% poprawe wydajnosci (bo odciazylo to tez stary kod rysujacy punkty swietle) przy wlaczonych aureolach. Efektow ubocznych byc nie powinno, ale wiadomo jak to jest w praktyce :s

tl,dr: powinno byc troche szybciej, i troche ladniej.

(aureole uzywaja tekstury nazwanej lightglare i umieszczonej w katalogu textures/fx Na ta chwile exe nie pozwala definiowac tekstur dla swiatel punktowych, ani wymiarow aureoli, kiedys moze sie to zmieni)

edit:
aha, aureole uzywaja definicji koloru swiatla punktowego, w rezultacie swiatla semaforow zrobily sie bardziej zolte niz pomaranczowe, bo taki jest kolor zdefiniowany dla punktow w tych komorach. Ktos sie bedzie musial poswiecic i je wreszcie poporawiac :d
« Ostatnia zmiana: 22 Marca 2017, 21:53:57 wysłana przez tmj »

Online Krzysiek626

  • Zasłużony dla Symulatora
  • Wiadomości: 4961
  • EXIT
    • Zobacz profil
    • Krzysiek626
  • Otrzymane polubienia: 110
Odp: Exe - konwersja na C++
« Odpowiedź #1529 dnia: 22 Marca 2017, 22:59:42 »
Na TD mam taki widok, na Kaliskiej i Bałtyku jest ładnie. Widoczność tej zjawy zależy od kąta patrzenia. W każdym razie z kabiny widać. Na razie taki efekt jest tylko na TD, jeśli gdzieś jeszcze znajdę, dopiszę.

 

Maszyna - Symulator PojazdĂłw Szynowych